00:00:44 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:00:44 <zodbot> Meeting started Thu Nov  5 00:00:44 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:01:18 <Sparks> #topic Roll Call
00:01:20 * Sparks 
00:01:26 * jjmcd .
00:01:26 * rudi is here
00:03:02 <jjmcd> Wow ... where are all the troublemakers and ne'er do wells?
00:03:44 <Sparks> jjmcd: That's just what I was thinking
00:04:04 <jjmcd> prolly missed the time change
00:04:26 <Sparks> jjmcd: Yeah, it's going to be a little annoying for a couple of weeks
00:04:41 <Sparks> Okay, let's get started as we have a lot to cover...
00:04:50 <Sparks> #topic Old Business
00:04:51 <jjmcd> Well, MITN moved to 6 on account of conditions so no conflict there
00:05:02 <Sparks> Sparks to follow up with quaid to check on courtesy note to previous contributors
00:05:17 <Sparks> ^^^ done and I'll follow up on this during the CC discussion
00:05:29 <Sparks> #topic Release Announcement
00:05:39 <Sparks> To be ready no later than November 10.
00:06:05 <Sparks> We need to get with Marketting on this and make sure that everyone is on the same page.
00:06:26 <jjmcd> who is mktg contact?
00:06:32 <Sparks> Can I get a volunteer to work with Marketting to make sure everything good?
00:06:43 <Sparks> jjmcd: I think mchua_afk
00:06:50 <Sparks> But I don't know
00:07:23 <Sparks> Anyone?
00:07:52 * jjmcd is concerned about zero day RN issues overlapping with reporting time of month which is normally bad
00:08:07 <Sparks> Ya
00:08:17 <Sparks> Okay, I'll put the word out on the list.
00:08:32 <Sparks> #action Follow up with mktg on the Release Announcement.
00:08:49 <Sparks> #topic Guide Status - Release Notes
00:08:56 <Sparks> jjmcd: What's the latest?
00:09:05 <jjmcd> Let me relate what went on
00:09:09 <jjmcd> it was a disaster
00:09:24 <jjmcd> Asyou know our schedule had us building the rpm a week after it was needed
00:09:45 <jjmcd> When I first tried to build it, I had a terrible time with the omfs, not sure why
00:10:04 <jjmcd> even now, there is a lot of weirdness about bits of the omfs being translated and others not
00:10:25 <jjmcd> haven't yet sorted out what is causing that -- right now there appears to be no pattern
00:10:58 <jjmcd> Once I got the omfs to work, yelp would crash 2-5 minutes after opening the rn's whether you were looking around or not
00:11:30 <jjmcd> Eventually concluded yelp has some sort of size limitation, so I replaced the tables with a link to docs.fp.o
00:11:51 <jjmcd> Also, stupid publican doesn't make the index for xml, just says "index belongs here" essentially
00:12:18 <jjmcd> and at one point, all the xml's had a note saying they were empty.  Don't know where that came from or why it went away
00:12:54 <jjmcd> Anyway, eventually got the help to work, but when you go to about-fedora directly from the menu, as opposed to from help, it isn't formatted properly
00:13:30 <jjmcd> Interestingly, the publican produced xml is kind of screwed up, but help seems to deal with it.  Fixing the screw ups, tho, doesn't change anything
00:14:01 <jjmcd> Anyway, as you know, we encountered pub 1.0 on koji, so we worked around it by runing publican outside of rpmbuild
00:14:26 <jjmcd> We will need to do that for zero day, too.  Really not much of a problem except when you discover it an hour before you need the rpm!
00:14:36 <jjmcd> So, that;s where we are.  Any questions?
00:14:59 <Sparks> So many with so little time.
00:15:15 <jjmcd> that was last night!
00:15:30 <Sparks> But the package got built in koji and we lived happily ever after... until zero day... right?
00:15:36 <jjmcd> right
00:15:48 <jjmcd> Not everything we wanted
00:16:14 <jjmcd> tables are linked to instead of there, a-f from menu screwy, and help titles partly translated
00:16:22 <Sparks> Okay, but everything is on target for the release day, correct?
00:16:28 <jjmcd> correct
00:16:34 <Sparks> Okay... moving on!  :)
00:16:36 <jjmcd> We will fiz what we can on zero day
00:16:51 <jjmcd> But we won't try the make inside rombuild until next rel
00:17:02 <Sparks> #topic Guide Status - Installation Guide
00:17:29 <Sparks> rudi: I guess you are up.  Is the Installation Guide ready for prime time?
00:17:51 <rudi> Good to go
00:18:13 <Sparks> Excellent.
00:18:25 <Sparks> #topic Guide Status - Installation Quick Start Guide
00:18:33 <Sparks> jjmcd: And I'm guessing this is ready as well?
00:18:38 <Sparks> rudi: And I'm guessing this is ready as well?
00:18:55 * jjmcd has no idea about iqsg
00:18:55 <rudi> Yep :)
00:19:15 <Sparks> #topic Guide Status - Deployment Guide
00:19:38 <Sparks> I don't think the lead is on tonight for the Deployment Guide.
00:19:49 <Sparks> Is that up on docs.fp.o?
00:19:59 <rudi> Yeah -- it's up there
00:20:27 <Sparks> Yeah, just checked.  In English...
00:20:34 <jjmcd> rudi, were you going to have the redirect pages ready for release?
00:20:51 <rudi> jjmcd -- yeah, I will
00:21:06 <Sparks> #topic Guide Status - User Guide
00:21:07 <rudi> I started that last week and ended up toasting my entire local copy of the site ;)
00:21:15 <Sparks> rudi: Yikes!
00:21:23 <jjmcd> don't you just love that
00:21:26 <Sparks> danielsmw: You here tonight?
00:22:08 <Sparks> Hmmm... Well I see it on the docs.fp.o for F12...
00:22:12 <rudi> Yeah -- I got bit because I forgot that different docs have entirely different directory structures :)
00:22:12 <Sparks> I'll take that as a good sign.
00:22:26 <Sparks> rudi: We need to remedy that.
00:22:43 <jjmcd> We need to be sure we don't do that on zikula
00:22:47 <Sparks> yes
00:22:54 <Sparks> #topic Guide Status -
00:22:57 <jjmcd> Fixing it in cvs will be a major pita
00:23:00 <Sparks> #topic Guide Status - SELinux User Guide
00:23:15 <Sparks> radsy: What say you on your SELinux guide(s)?
00:23:16 <rudi> jjmcd -- yeah; I am *not* going to volunteer for that job :)
00:23:44 <radsy> Sparks, services guide didn't get an update for f12
00:23:54 <Sparks> radsy: Did it need an update?
00:24:05 <radsy> no, it's all still accurate/recent
00:24:11 <Sparks> I'm good with that.
00:24:29 <Sparks> rudi: Can you make sure that the F12 docs include radsy's guides on SELinux?
00:24:36 <radsy> i've been doing the wireless guide, and might be branching into desktop documentation, so i'm likely to be in and out a bit.
00:24:57 <Sparks> radsy: No problem.  Just let us know where we can help!
00:25:10 <Sparks> #topic Guide Status - Security Guide
00:25:31 <rudi> Sparks -- will do
00:25:33 <Sparks> Very little changed from F11 to F12 in this guide.  I have started working on improvements for F13, though.
00:25:37 <Sparks> rudi: Thank you
00:25:50 <Sparks> #topic Guide Status - Virtualization Guide
00:26:00 <Sparks> Tsagadai: You here tonight?
00:26:20 <Tsagadai> sure am
00:26:34 <Sparks> Tsagadai: Got an update on your Virtualization Guide?
00:26:42 <Tsagadai> I've been preoccupied with the RHEV release :)
00:27:02 <Tsagadai> but, there are a lot of updates coming very shortly (hopefully this week)
00:27:22 <Sparks> Tsagadai: But it's ready for F12, correct?
00:27:34 <Tsagadai> ready in a sense
00:27:50 <Sparks> Well okay then!  :)
00:28:24 <Sparks> Tsagadai: Thanks for the update.  Let us know if any assistance is needed.
00:28:42 <Sparks> #topic Guide Status - Fedora Live Images
00:28:51 <Sparks> I see this is on the website...
00:28:55 <Sparks> rudi: Is this yours?
00:29:09 <rudi> Not officially, no
00:29:21 <rudi> But since no-one else was tending it, I've been looking after it :)
00:29:21 <Sparks> rudi: Are any of them officially yours?  :)
00:29:32 <rudi> lolz IG and IQSG :)
00:29:48 <Sparks> rudi: Ya...  Another one of those that is on my rescue list.  Thanks for picking it up.
00:30:01 <Sparks> rudi: So it's out there for F12 so that's good
00:30:06 <rudi> And yes, it's ready to go :)
00:30:15 <Sparks> Excellent!
00:30:23 <Sparks> #topic Guide Status - Making Fedora Discs
00:30:31 <Sparks> rudi: And this one is also ready to go!
00:30:36 <rudi> Yeah
00:30:44 <Sparks> Excellent.
00:30:57 <Sparks> #topic Guide Status - Accessibility Guide
00:31:03 <Sparks> And this is one that I picked up...
00:31:26 <Sparks> It needs work.  It was very well written years ago but some of the information is dated and there are new solutions available now.
00:31:54 <Sparks> So I've been working on a reorganization with the help of rudi fact checking the existing information.
00:32:16 <Sparks> I don't think it will be ready before F12 but it will be available somewhere between F12 and F13 for sure.
00:32:31 <Sparks> #topic Guide Status - Overall Picture
00:33:03 <Sparks> I just want to take a second and say thank you to everyone that contributed to the many guides we have.
00:33:25 <Sparks> Without the Accessibility Guide, we will have nine guides going to "press" for F12!
00:33:30 <Sparks> That is outstanding!
00:33:49 <jjmcd> We should have a Docs press release alongside the F12 press release
00:34:00 <Sparks> We should!
00:34:04 <quaid> +1
00:34:18 <Sparks> I'll have to go back in my notes but I think we shipped maybe five guides last release.
00:34:19 <jjmcd> hey! there is life in kalifornia
00:34:27 * quaid blames tardiness on daylight savings
00:34:29 * ianweller is here
00:34:52 <Sparks> #topic New Guides
00:35:01 <Sparks> radsy: You want to talk about your new projects?
00:36:38 <rudi> radsy is AFK
00:36:42 <Sparks> Okay
00:36:58 <Sparks> Well, I'll let him tell the tale.
00:37:46 <Sparks> Anything else guide-related?
00:38:20 <Sparks> #topic Status on CMS (Zikula)
00:38:29 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:39:20 <Sparks> I think danielsmw finished packaging one of the editors.
00:39:42 <Sparks> Does anyone else have any other items on this?
00:40:20 <Sparks> Okay, moving on!
00:40:27 <Sparks> #topic Status on CC license rollout.
00:40:41 <Sparks> #link https://fedoraproject.org/wiki/License_changeover_schedule
00:41:02 <Sparks> So I think we are ready to officially announce the change to CC-BY-SA!
00:42:16 <Sparks> ianweller: You gonna do the announcement?
00:42:51 <ianweller> suuuuuuure
00:43:13 <ianweller> Sparks: everything's done?
00:43:28 <Sparks> ianweller: AFAIK
00:43:34 <radsy> back
00:43:42 <Sparks> quaid: Any other obsticles that you know of?
00:43:42 <ianweller> front
00:43:50 <quaid> nope
00:43:52 <jjmcd> right
00:43:55 <quaid> all clear!
00:44:00 <Sparks> Guides have been regenerated... wiki has been changed
00:44:14 <jjmcd> Guides now all in rpm as well?
00:44:29 <Sparks> I think spot has given us the go ahead.
00:44:41 * quaid . o O { The final pieces of The Master Plan are coming together! }
00:44:41 <ianweller> i'll make the announcement after the meeting then
00:44:47 <ianweller> lemee go double check where it is
00:44:48 <quaid> oops, did I think that outloud?
00:44:50 <Sparks> jjmcd: The only guides in RPM are f-r-n and the Security Guide and I did the Security Guide the other day
00:44:54 <ianweller> https://fedoraproject.org/wiki/User:Ianweller/Creative_Commons_press_release ?
00:45:17 <ianweller> anybody have any qualms about what we're sending out
00:45:50 <Sparks> #link https://fedoraproject.org/wiki/User:Ianweller/Creative_Commons_press_release
00:45:55 <jjmcd> oh my gosh!  You're going to send out THAT?
00:46:16 <Sparks> jjmcd: Yeah, except we are going to put your name on it.
00:46:24 <jjmcd> oh, ok
00:46:40 <Sparks> ianweller: Do we (you) need to talk with the CC folks directly about this so they can do something if they wish?
00:46:57 <ianweller> lovin the we (you)
00:47:04 <ianweller> Sparks: i'll ping mlinksvayer
00:47:08 <Sparks> ianweller: You are my resident CC guy
00:47:13 <Sparks> ianweller: Cool
00:47:17 * Sparks is excited!
00:47:24 <ianweller> and he *just* quit IRC
00:47:26 <ianweller> lulz
00:47:26 <quaid> did that go through
00:47:42 <quaid> the *new" press release mojo of f-marketing-l?
00:47:54 * quaid mixes his ASCII markup
00:48:05 <ianweller> quaid: yeah mchua_afk looked at it
00:48:17 <Sparks> So I'll mark 8 complete
00:48:19 <ianweller> snazzed it up
00:49:52 <ianweller> oh
00:49:53 <Sparks> So is everyone a go for the license change?  Any issues we haven't thought of?
00:50:13 <ianweller> also note that mlinksva offered to provide a quote for the press release (i just reread the email he sent me a few months back)
00:50:21 <ianweller> if we wanna do that?
00:50:24 <jjmcd> I only changed the omf's for those languages we are shipping
00:50:27 <quaid> +1
00:50:27 <Sparks> ianweller: Sure if you want.
00:50:42 <ianweller> we'll do that, and then push the PR through all the relevant tubez
00:50:51 <jjmcd> There may be other omf footprints hidden in f-r-n, about-fedora and others
00:51:00 <jjmcd> errr OPL footprints
00:51:28 <Sparks> jjmcd: Okay.  I'm sure we'll need to shake out a few here and there.
00:51:33 <jjmcd> yeah
00:51:40 <jjmcd> I was surprised to find that there last night
00:52:03 <quaid> yeah, it's not going to kill us
00:52:15 <quaid> if we have to take some bug reports and fix some packages after release
00:52:21 <quaid> the intention is clear and our there, that counts a lot
00:52:25 <jjmcd> You only find it if you go rummaging around in /usr/share/gnome as far as I can tell
00:53:27 <Sparks> Okay, anything else on this topic?
00:53:53 <Sparks> #action ianweller to get a quote from mlinksva (CC) to include in the press release
00:54:10 <Sparks> #action ianweller to ship the press release to all the necessary tubez
00:54:22 <Sparks> ianweller: When do you think this will occur?
00:54:27 <ianweller> "soon"
00:54:36 <ianweller> announcement tonight, maybe a quote back from mlinksva by tomorrow
00:54:37 <Sparks> Before the end of the year?
00:54:37 <ianweller> who knows
00:54:44 <ianweller> then i'll ask mel about pushing through tubez
00:54:45 <Sparks> Okay.  :)
00:54:56 <Sparks> Does RH handle that?
00:54:56 <ianweller> hehe hopefully before january ;)
00:54:59 <ianweller> i dunno.
00:55:05 <quaid> yeah, we can ask for an RHT hand-off
00:55:10 <ianweller> i really have no clue, and i'm hoping mchua_afk does ;)
00:55:11 <quaid> there is the business wire stuff
00:55:15 <quaid> and the press.redhat.com
00:55:18 <ianweller> and/or coordinate it
00:55:23 <Sparks> cool.
00:55:26 <quaid> yeah, she does; there is likely an SOP on it somewhere
00:55:52 <Sparks> #action ianweller to coordinate with mchua_afk on the press release
00:55:57 <Sparks> Okay, anything else?
00:56:40 <Sparks> #topic New Guides
00:56:55 <Sparks> Going back to this topic because I'm excited by some of radsy's work
00:57:02 <Sparks> radsy: Tell us about your new projects
00:57:04 <Sparks> please
00:57:21 <radsy> ok
00:57:33 <radsy> I've been silently working on a wireless guide: http://sradvan.fedorapeople.org/Wireless_Guide/en-US/html-single/
00:57:52 <radsy> mainly a high-level overview of 802.11 stuff, but other mobile tech (ev-do, hsdpa etc.) will end up in there
00:58:29 <radsy> started as a side project really but has gained a bit of attention here, which could lead me to doing desktop/network docs, especially emerging desktop tech
00:58:45 <radsy> but we're still in talks to find out priorities/agendas, etc.
00:58:46 <radsy> that's all
00:59:07 <Sparks> I've read the WG and it's cool.
00:59:20 <Sparks> radsy: Is the guide hosted on fhosted.o?
00:59:26 <radsy> Sparks, not as yet
00:59:42 <Sparks> radsy: Okay.  Do you need a BZ component for handling tickets?
01:00:04 <radsy> once i'm a bit happier with it, yes I will
01:00:23 <Sparks> radsy: Okay, just let me know and we'll get you setup.
01:00:23 <radsy> no rush straight away however
01:00:26 <radsy> ok
01:00:35 <Sparks> Anyone have any questions?
01:01:08 <Sparks> Okay, thanks radsy!
01:01:29 <Sparks> #topic Outstanding BZ Tickets
01:01:42 <Sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW
01:01:56 <Sparks> There are currently 9 new bugs that have not been assigned.
01:02:17 <Sparks> Please visit the link above and see if you can handle one (or more) of these tickets, please.
01:02:59 <Sparks> #topic All other business
01:03:06 <Sparks> Okay, does anyone have anything else?
01:03:43 <Sparks> Anyone?
01:03:45 <Sparks> Anything?
01:04:47 <Sparks> Okay, then we'll go ahead and close down tonight.
01:04:51 <Sparks> Thanks everyone for coming!
01:04:57 <Sparks> Keep up the excellent work!
01:05:01 <Sparks> #endmeeting