16:00:09 <jlaska> #startmeeting Fedora QA Meeting
16:00:09 <zodbot_> Meeting started Mon Nov  9 16:00:09 2009 UTC.  The chair is jlaska. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:25 <jlaska> #topic gathering mass
16:02:58 <jlaska> this will be a quick meeting :)
16:04:21 * kparal present
16:04:26 <jlaska> kparal: howdy
16:04:38 <jlaska> who else we got lurking ... wwoods, adamw
16:04:45 <adamw> yo
16:04:48 <jlaska> Oxf13 and I are also in another meeting at the moment
16:04:48 <adamw> (dawg)
16:05:27 <jlaska> we can spend today just making sure we've got people working the open issues
16:05:32 <jlaska> https://www.redhat.com/archives/fedora-test-list/2009-November/msg00409.html
16:05:48 * wwoods is all up ins
16:08:13 <jlaska> #topic Previous meeting follow-up - https://fedoraproject.org/wiki/QA/Meetings/20091102#Action_items
16:08:39 <jlaska> We've got a carry-over action item from Viking-Ice ... I don't think we had a chance to check-in on this last week
16:08:43 <jlaska> Viking-Ice investigating creating a test case for bug#530452 ... and adding to F12 install matrix
16:08:44 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=530452 high, low, ---, jmccann, CLOSED RAWHIDE, Gnome sets the keyboard layout to USA after every log in
16:08:53 <jlaska> Viking-Ice: any updates or issues you had on this?
16:09:30 <jlaska> we can move back to this when Viking-Ice returns
16:09:42 <adamw> i'm pretty sure that one got fixed.
16:09:58 <jlaska> oh cool, I'd love a test case for this one
16:10:19 <wwoods> rebooting to test fix for bug 524808 (my machine is affected)
16:10:20 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=524808 high, high, ---, chrisw, MODIFIED, swiotlb should be enabled when VT-d setup fails
16:10:27 <jlaska> wwoods: roger
16:10:50 <jlaska> adamw: Viking-Ice: if anyone has a link for the test case .. we can add to the minutes and check-in w/ Liam on adding to the install test plan
16:10:53 <jlaska> okay next up ...
16:10:56 <jlaska> *  jlaska to check-in with anaconda-devel team for status on any issues they are monitoring for the wednesday RC compose
16:11:13 <jlaska> I checked in w/ denise and clumens privately last week, and adamw did the same on irc
16:11:32 <adamw> there were no anaconda blockers left, and we fixed the anaconda blocker that wasn't left yesterday =)
16:11:40 * jlaska does a dance
16:12:06 <mether> adamw, did you manage to track down the KDE related issues that some people reported?
16:12:15 <adamw> mether: it's an NVIDIA driver issue only
16:12:28 * Viking-Ice no new input from me been busy @ work
16:12:29 <mether> the proprietary driver?
16:12:29 <adamw> mether: the only guy claiming to see it still on nouveau still had desktop effects enabled from his NVIDIA session
16:12:31 <adamw> yes
16:12:32 <adamw> nouveau works
16:12:34 <mether> ok
16:12:48 <adamw> airlied has forwarded the patch that causes all the excitement to NVIDIA so they can fix their driver, we can't do much else
16:13:01 <mether> what about https://bugzilla.redhat.com/show_bug.cgi?id=504826
16:13:03 <buggbot> Bug 504826: medium, low, ---, skvidal, ASSIGNED, preupgrade and /boot on raid
16:13:15 <adamw> well, i've made a scratch build of xorg-x11-server without the patch for those who really need it, it's in the bug report
16:13:19 <mether> ah wait
16:13:21 <mether> wrong bug
16:13:22 <skvidal> mether: can anaconda boot on raid?
16:13:47 <mether> someone filed a recent preupgrade/anaconda bug
16:13:50 <mether> that sounded serious
16:13:52 <mether> let me look
16:14:19 <skvidal> https://bugzilla.redhat.com/show_bug.cgi?id=533545
16:14:20 <buggbot> Bug 533545: urgent, low, ---, skvidal, NEW, Fedora 11 preupgrade to F12/rawhide destroys grub on raid
16:14:21 <skvidal> that one
16:14:26 <mether> yep
16:14:55 <skvidal> I can't find any thing that replicates it
16:15:19 <skvidal> s/thing/way/
16:15:53 <mether> ok
16:16:08 <mether> is there a rc5?
16:16:23 <adamw> no
16:16:25 <adamw> rc4 is it
16:16:48 <mether> we are going ahead with it
16:16:50 <mether> thats the final?
16:16:54 <adamw> no
16:16:57 <adamw> it's what we've got so far
16:16:58 <jlaska> #chair adamw
16:16:58 <zodbot_> Current chairs: adamw jlaska
16:17:00 <adamw> if we go ahead, rc4 is it
16:17:05 <mether> adamw, ah ok
16:17:06 <adamw> if rc4 isn't good enough, we're going to slip
16:17:12 <jlaska> #topic RC4 test update
16:17:28 <jlaska> sorry, sounds like we are already there now ... just changing the topic to fit
16:18:15 <kparal> what's the difference between go/no-go meeting and rc readiness meeting?
16:19:32 <jlaska> kparal: good question ...
16:19:36 <adamw> one has more g's, the other has more r's
16:19:40 <jlaska> heh
16:19:56 <jlaska> the go/no_go is historically engineering coming to agreement on releasing
16:20:05 <jlaska> the readiness meeting is for the entire fedora project
16:20:16 <jlaska> docs, marketing, infrastructure etc...
16:20:25 <kparal> i see
16:22:35 <Oxf13> readiness assumes we're going, and we're just making sure all groups are up to speed with what's goign to happen on release day
16:22:53 <Oxf13> go/no-go is whether or not we have a software set that is ready to be released.
16:24:13 <jlaska> sorry gang, I'm jumping between 2 meetings
16:24:18 <adamw> skvidal: 533545 - i haven't seen any reproducers either afaict
16:24:20 <jlaska> and adamw is also chasing down some recent bugs
16:24:24 <adamw> as you can see I asked liam to see if he could reproduce
16:25:16 <jlaska> do we want to spend time in the meeting walking through recent blocker list activities
16:25:24 <jlaska> or are folks comfortable breaking and working the issues offline?
16:25:28 <jlaska> https://bugzilla.redhat.com/showdependencytree.cgi?id=473303&hide_resolved=1
16:25:32 <jlaska> ^^^ F12Blocker list
16:26:58 <jlaska> okay ... that seems like a resounding ... let's work it offline :)
16:27:31 <kparal> :)
16:27:43 <adamw> if no-one wants to do state of play on the blockers that's ok by me
16:28:28 <jlaska> alright, let's keep working those issues in #fedora-qa
16:28:43 <jlaska> for the record, the issues I'm seeing now are ...
16:28:48 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533879
16:28:49 <buggbot> Bug 533879: medium, low, ---, ajax, NEW, X fails when using vesa driver
16:28:54 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533817
16:28:55 <buggbot> Bug 533817: medium, low, ---, anaconda-maint-list, NEW, Fedora 12 RC.4 DVD image fails to boot with isolinux: disk error on x86_64
16:29:04 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533739
16:29:05 <buggbot> Bug 533739: urgent, low, ---, katzj, NEW, Partial initialization of Intel BIOS RAID arrays by the live CD could lead to data corruption
16:29:09 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533621
16:29:10 <buggbot> Bug 533621: high, low, ---, rvykydal, ASSIGNED, Can't Boot After F12 b2 DVD Upgrade on sytem with RAID1 /boot
16:29:19 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533545
16:29:20 <buggbot> Bug 533545: urgent, low, ---, anaconda-maint-list, NEW, Fedora 11 preupgrade to F12/rawhide destroys grub on raid
16:29:31 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=533392
16:29:33 <buggbot> Bug 533392: medium, low, ---, notting, ASSIGNED, dracut-network not included in F-12-RC1 DVD install
16:29:51 <jlaska> https://bugzilla.redhat.com/show_bug.cgi?id=524808
16:29:52 <buggbot> Bug 524808: high, high, ---, chrisw, MODIFIED, swiotlb should be enabled when VT-d setup fails
16:30:02 <jlaska> alright, enough spam from me
16:30:12 <jlaska> wwoods: kparal: you guys have time for a quick update on autoqa?
16:30:19 <jlaska> #topic AutoQA Update
16:30:32 <wwoods> sure, uh
16:31:00 * wwoods tries desperately to remember what it was he was doing last week though the Monday brain gof
16:31:03 <wwoods> gof? fog
16:31:19 <jlaska> https://fedoraproject.org/wiki/QA/Meetings/20091102#AutoQA_update
16:31:19 <Oxf13> I thought youwere going for brain golf
16:31:21 <jlaska> wwoods: heh :)
16:31:25 <Oxf13> chip and put
16:31:35 <kparal> i have added a check to rpmguard to warn user if too old rpmdiff is installed
16:31:57 <wwoods> ah, right - so the python library is all ready to be merged but I want to test it out first and make sure we're not breaking anything
16:32:26 <wwoods> the koji watcher is also (theoretically) functional
16:32:52 <wwoods> and the autoqa.koji_utils library has a couple of nice little things in it for setting up post-build tests
16:33:14 <wwoods> e.g. nvr_to_urls(), which takes the NVR given by the watcher and returns a list of URLs for all the packages for that build
16:33:35 <jlaska> interesting, I might like that for daily use :)
16:33:36 <wwoods> as a proof-of-concept I added a really simplistic rpmlint post-koji-build test
16:34:01 <wwoods> jlaska: you want koji download-build
16:34:09 <jlaska> yeah
16:34:41 <wwoods> so anyway, we've got all this code refactoring, a new hook, a new watcher, and a new test for that hook
16:34:53 <wwoods> I'm dubbing the whole thing autoqa 0.3
16:35:10 <jlaska> cool, I think atodorov was also trying to build an rpmlint test as well ... I pointed him towards your branch to compare notes
16:35:12 <wwoods> as soon as we can get it on a test system and show that it all works as expected
16:35:19 <wwoods> I'll merge it into the master branch
16:35:30 <kparal> there are also some patches of mine about autoqa waiting for wwoods approval, so he has probably a busy time now :)
16:35:31 <jlaska> wwoods: I've got an autotest-0.11 server up if you'd like to test your latest code
16:36:09 <wwoods> kparal: I haven't seen anything other than [PATCH] fix installation of autoqa python library
16:36:37 <kparal> wwoods: yes, and in the Trac there is a patch to avoid having autotest-server installed
16:36:59 <kparal> when someone wants to try his new test with autoqa and autotest running
16:37:14 <jlaska> kparal: is this the patch that makes it so you don't need autotest-server?
16:37:21 <wwoods> I don't see the point of that patch, since the tests are supposed to be designed to run without autoqa/autotest
16:37:43 <wwoods> there's two situations: 1) run the test on a local system, 2) run it with autoqa and autotest
16:37:53 <wwoods> I don't see the use of adding a third, hybrid possiblity, where you use autoqa but not autotest
16:37:57 <jlaska> kparal: https://fedorahosted.org/autoqa/ticket/52 ?
16:38:04 <wwoods> seems like unnecessary complexity to me
16:38:12 <kparal> jlaska: that's it
16:38:33 <kparal> wwoods: well atodorov said his tests are running just by executing them, but doesn't work with autoqa
16:39:05 <kparal> the wrapper scripts need some testing too
16:39:22 <kparal> but I leave it up to your consideration
16:39:27 <jlaska> I might not fully understand, but I can see it being generally useful to make it easy for folks to have confidence that their tests are properly integrated withint autotest?
16:39:42 <kparal> that was the intention
16:40:01 <kparal> rather autoqa then autotest, but yes
16:40:19 <jlaska> gotcha, that seems like something we should have an answer for
16:40:29 <jlaska> kparal: do you want to re-kick the tires on this thread to autoqa-devel
16:40:36 <jlaska> and perhaps we can move the discussion there?
16:40:48 <kparal> yes, it will be better to move it there
16:40:48 <jlaska> wwoods might have some ideas on a different solution for this
16:41:16 <jlaska> kparal: any other outstanding patches you were looking for guidance on?
16:41:23 <kparal> nope
16:41:45 <jlaska> #action kparal will raise autoqa ticket#52 on autoqa-devel list for further discussion
16:42:14 <jlaska> wwoods: kparal: any other autoqa updates?
16:42:44 * jlaska knows RC4 is occupying much of everyones time
16:42:55 <kparal> yes, all from me
16:43:16 <jlaska> kparal: thanks
16:43:37 <jlaska> alrighty ... let's move on to open discussion
16:43:44 <jlaska> #topic Open discussion - <your topic here>
16:44:04 <jlaska> mclasen replied to the agenda and asked that we think about how to test F-12 day0 updates
16:44:10 <jlaska> https://www.redhat.com/archives/fedora-test-list/2009-November/msg00410.html
16:44:33 <jlaska> I know we're all heads down at the moment, so we can follow-up after the meeting
16:44:46 <jlaska> Oxf13: wwoods: has this been handled in the past in any way?
16:44:57 <kparal> 0-day updates are updates released on the release day?
16:44:57 <Oxf13> not sure about pre-upgrade
16:45:04 <Oxf13> er wait.
16:45:07 <Oxf13> blah.
16:45:17 <jlaska> kparal: you got it ... updates that weren't critical enough to cause a mediakit respin
16:45:21 <jlaska> Oxf13: :)
16:45:27 <Oxf13> last release we opened up the 11 updates(-testing) repos before we launched 11
16:45:32 <Oxf13> we plan to do the same with 12.
16:45:45 <jlaska> so we'll just need folks to yum update to those repos ahead of time ... and report back?
16:45:47 <Oxf13> we already had a successful push of updates, I want to get a few people testing them with manual repo configs
16:45:49 <kparal> I have seen there are already f12 updates repos available
16:46:01 <Oxf13> and then we'll drop the mirror-manager redirect and everybody will have F12 updates to play with, perhaps later today
16:46:53 <jlaska> do we have instructions on how to test that ... or is this just `yum --enablerepo=updates-testing update` ?
16:47:16 <jwb> you have to get around MM at the moment
16:47:41 <Oxf13> you have to work around MM, so you'd have to adjust your baseurl= to point directly to a mirror
16:47:42 <jlaska> jwb: so that's the manual repo change Oxf13 noted I gather
16:47:56 <Oxf13> so this should be undertaken by people who are comfortable changing that, and changing it back
16:48:02 <jlaska> We can certainly blast this out to testers for feedback
16:48:10 <jlaska> would be nice to have a test case that detais the changes needed
16:48:28 <jlaska> I suspect we're just looking for obvious things after the update ... like deps/conflicts and basic functionality
16:48:31 <jlaska> ?
16:49:41 <Oxf13> yeah
16:49:47 <jlaska> #action create a test case to describe the process for testing day-0 updates
16:49:52 <Oxf13> I don't want to turn on repos that will break the world
16:49:59 <jlaska> Oxf13: definitely
16:50:16 <jwb> there will be another push today
16:50:21 <wwoods> probably we can offer a repo file. heck we could put the repo file in a release package and then have the repo disable itself at F12 release. whee.
16:50:25 <jwb> so content will change again at some point
16:50:35 <jlaska> wwoods: yeah
16:50:47 <jlaska> Oxf13: I don't imagine we're going to get much traction on that today to be honest
16:50:48 <Oxf13> jwb: fair enough
16:51:07 <Oxf13> well, I suppose I could just do that here and see what falls over.
16:51:13 <jlaska> I'll be happy to take the action item to create the test and reach out for feedback on the list
16:51:39 <kparal> I have to admin I don't get it. what about just let the updates repository be empty for a few days?
16:52:08 <jlaska> kparal: you mean, why push stuff now?  Why not wait until we're done testing RC4?
16:52:30 <jwb> kparal, too late.  it already has content
16:52:33 <Oxf13> kparal: because a build up of updates has much higher potential to go *boom* when we release them
16:52:46 <Oxf13> as opposed to the standard "trickle" with testing
16:53:03 <kparal> well we can put all the bunch into -testing first?
16:53:36 <Oxf13> kparal: most are in -testing
16:53:57 <Oxf13> kparal: but that's all maintainer driven, we can suggest loudly but outside of revoking every request we can't prevent things from going into -stable
16:54:12 <kparal> alright
16:54:17 <jlaska> ah, so this is just the bodhi updates workflow that maintainers are folllowing
16:54:20 <jlaska> gotcha
16:54:35 <jlaska> okay ... any other topics today
16:54:45 <jlaska> or shall we get back to testing and updating blockers?
16:55:24 <wwoods> by all means, let's get back to the traditional pre-release psychobilly freakout
16:56:10 <jlaska> okay gang ... sorry for the distracted meeting
16:56:16 <jlaska> thanks for joining folks :)
16:56:18 <jlaska> #endmeeting