23:59:54 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:59:54 <zodbot> Meeting started Wed Dec 16 23:59:54 2009 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:59:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:00 <sparks> #chair jjmcd
00:00:00 <zodbot> Current chairs: jjmcd sparks
00:00:10 <sparks> #topic Roll Call
00:00:11 * sparks 
00:00:15 * ianweller 
00:01:33 * bcotton is here
00:01:46 * rudi is here
00:01:56 * jjmcd .
00:03:12 * sparks gives everyone a few more minutes to trickle in
00:03:30 * Tsagadai is here
00:06:02 <sparks> Okay, let's get started
00:06:08 <sparks> #topic Action items from last week's meeting
00:06:19 <sparks> Sparks to send a message to L10N and Logistics about a docs planning meeting for early next week
00:06:31 <sparks> Yeah, that didn't happen.  Still working on it, though.
00:07:10 <sparks> #action sparks to coordinate a meeting between docs, L10N, and others on translation questions and F13 schedule.
00:07:19 <sparks> jjmcd to review poelcat's schedule and come up with a recommendation before the meeting
00:07:36 <jjmcd> done - link in agenda
00:07:36 <sparks> jjmcd: Is your action items waiting on my action item?
00:07:42 <sparks> Oh!
00:07:42 <jjmcd> No
00:07:55 <sparks> #link http://jjmcd.fedorapeople.org/F13-RelNotes-MajorTasks.html
00:07:56 <jjmcd> Mostly I want to focus on getting the core deliverables right
00:08:01 <sparks> Excellent
00:08:17 <sparks> Okay, moving on...
00:08:23 <sparks> #topic Release Notes
00:08:27 <jjmcd> For F12 all the clutter caused us to miss an important detail - the schedule had us building the rpm two weeks after jesse needed it
00:08:39 <sparks> There is a question...  Should L10n merge POs?
00:08:59 <sparks> Yes, the F12 schedule wasn't ideal...
00:09:08 <jjmcd> I am feeling like they ought to be paying the price of not getting the new tfx up
00:09:30 <jjmcd> As long as we are a crutch for them, they really have no reason to get off dead center
00:10:15 <sparks> I'm okay with doing things like RH does them... let the translators do everything
00:10:33 <jjmcd> Now, logistically, this might not be realistic, but I think we should at least make the threat
00:10:48 <rudi> I think it's the right direction to be heading
00:11:25 <sparks> I'm not sure that logistically it's not realistic.  It certainly is possible.  A lot of our business practices would have to change.
00:11:35 <rudi> +1 sparks
00:12:01 <sparks> BUT you wouldn't have things like the French pulling their translations.  If they weren't ready then they wouldn't publish them
00:12:14 <rudi> I don't know whether shifting all the burden for producing and publishing the translated docs can go from Docs -> L10N in the space of one release
00:12:15 <jjmcd> yeah, I mean in principle it seems to make sense, but I got the impression that a lot of their translators had very limited technical capability so it might all fall on glezos
00:12:22 <sparks> rudi: Hell, I've shaken everything else up around here...
00:12:28 <rudi> lolz
00:12:30 <jjmcd> hehe
00:12:57 <rudi> jjmcd -- I think there would be a *lot* of hand-holding to begin with
00:12:58 <sparks> Well... if we are going to rotate our practice around the tool, then the tool better be easy to use.
00:13:11 <sparks> Luckily Publican 1.x isn't difficult
00:13:26 <jjmcd> yeah -- but I think many, maybe even most, actually do the translation in aarghh windows
00:13:30 <sparks> rudi: We could push information into the translators guide
00:13:34 <sparks> which we should do anyway
00:13:43 <rudi> jjmcd -- fortauntely, Publican 1 runs fine on Windows :)
00:13:52 <jjmcd> Oh, is that right!!!
00:13:54 * sparks wouldn't know about that
00:13:55 <jjmcd> holy smokes
00:14:04 <rudi> Mac is coming RSN :)
00:14:45 <jjmcd> that could be a big win then
00:14:49 <rudi> sparks -- yeah; I plan to update parts of the TQSG shortly to cover Publican 1 usage
00:14:58 <jjmcd> If the translators could immediately see their product
00:15:01 <sparks> rudi: +1
00:15:19 <rudi> The problem is still the interoperabilty of Publican and Transifex though
00:15:40 <sparks> well... they should know how to build their documents even if the "owner" is still going to handle the publishing.
00:15:44 <jjmcd> Oh, yeah, so they might have Publican on win, but not msgmerge
00:16:04 <sparks> Well... Transifex needs to be updated... period
00:16:05 <rudi> Actually, the gettext tools are packaged for Windows too
00:16:21 <rudi> And are included in the Publican installer .exe too :)
00:16:34 <jjmcd> Ahhh, now that's a plan
00:16:37 <rudi> But yeah; the Transifex problem is real and growing
00:16:44 <jjmcd> growing?
00:17:15 <rudi> Translators have had multiple issues over the last few weeks with accessing and uploading files
00:17:37 <jjmcd> what has changed?
00:18:08 <rudi> Which has exposed the bigger problem in that the current version is an unmaintained one, and that the Transifex guys don't really have the time to maintain Fedora's instance
00:18:43 <rudi> I think in this case, it was specifically a bug in infra; but it took an enormous amount of time to track down; which caused a lot of grief for L10N
00:19:57 <sparks> Well, the plan to migrate to 0.7 is there
00:20:19 <sparks> Okay, anything else on this topic?
00:20:50 <sparks> #topic Status on CMS (Zikula)
00:21:00 <sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:21:12 <sparks> I wish David was here tonight...
00:21:19 <sparks> mchua_afk: You around?
00:21:36 <sparks> So there are still modules that need to be packaged...
00:21:52 <sparks> and apparently the new version of Zikula has a library that needs to be yanked out and packaged.
00:22:08 <sparks> David is working that part but he needs some help.
00:22:49 <sparks> Anyone want to volunteer to help David with Zikula?
00:23:52 <sparks> I'm also going to need help with Limesurvey.
00:24:19 <sparks> It has several libs in it that I have to pull out.  I've never had to deal with that kind of thing so I'm not sure how to go about doing that.
00:24:44 <sparks> #topic Does yum langpack support help us?
00:24:51 <sparks> #link https://fedoraproject.org/wiki/Features/YumLangpackPlugin
00:25:17 <sparks> jjmcd: Did you add this?
00:25:47 <jjmcd> Sounds like if we package a guide and individual langpack, people can install, say, user-guide and auto get their local lang
00:25:54 <sparks> juhp: You around?
00:25:56 <jjmcd> and they don't need to get them all
00:26:12 <sparks> Sounds cool.
00:26:28 <jjmcd> Doesn't seem to help RN but it does guides
00:26:28 * sparks was hoping Jens was monitoring IRC to talk about this.
00:26:32 <jjmcd> *HOWEVER*
00:26:55 <jjmcd> It looks to me that making the langpack is going to take a bit of head scratching
00:27:07 <jjmcd> At least for html, not so much for yelp
00:27:31 <sparks> rudi: Is Jens in throwing distance?
00:28:22 <sparks> jjmcd: So it would be difficult to get it to work with html but would work with yelp?
00:28:24 <rudi> sparks -- down the hall
00:28:33 <rudi> hang on :)
00:28:35 <sparks> rudi: Didn't know if you could throw something at him.
00:28:35 <jjmcd> Well, that's my read
00:28:49 <jjmcd> Not impossible, but it would take some creativity
00:29:08 <rudi> ping juhp
00:30:19 <sparks> rudi: Oh well...
00:30:29 <jjmcd> I think I could do it but I would hit it with a hell of a big club.  stickster might be a little more elegant about it
00:30:35 <sparks> jjmcd: Well, I'd definitely be interested in how it would all work.
00:30:36 <rudi> Hang on -- I'll try in person :)
00:31:38 <rudi> Sorry -- not at desk
00:31:52 <jjmcd> In yelp 2 you just add the omf, in 3, put the new language in the right place and it all works
00:31:55 <sparks> rudi: That's okay
00:32:12 <jjmcd> In html it would take some editing during install.
00:32:20 <sparks> And 3 is coming out in Sep?
00:33:22 <sparks> shaunm: When is Yelp 3 coming out?
00:33:23 <jjmcd> Well, the Q isn't when it is coming out, it is when will it be packaged
00:33:44 <sparks> jjmcd: Yeah, but as soon as it hits the streets we can start playing
00:33:44 <jjmcd> But it is such a minor diff, the OMF ain't rocket science
00:34:57 <sparks> Okay...
00:35:07 <sparks> Well, this is all very interesting news.
00:35:37 <sparks> Anything else on this topic?
00:35:38 <jjmcd> I think doc langpacks are prolly F14 anyway.  Too risky to try to use them for 13
00:35:58 <sparks> Can Publican make langpacks?
00:36:10 <sparks> or is it just the way they are "titled"?
00:37:23 <jjmcd> Publican can't package except in the trivial case
00:38:52 <jjmcd> but if we have langpack and if they are similar to RHEL maybe we can talk them into it
00:38:54 <sparks> Okay, maybe we can get more details on this later.
00:39:03 <sparks> ya
00:39:17 <sparks> Okay... moving on
00:39:26 <sparks> #topic Guide Status
00:39:38 <sparks> Anyone want to talk about their Guides?
00:40:16 <Tsagadai> I'm making progress
00:40:18 <Tsagadai> :)
00:40:39 <rudi> Tsagadai -- did you see that bug about screenshots? :P
00:40:51 <Tsagadai> I go on leave soon so there won't be any significant progress on that until january
00:41:00 <Tsagadai> but it is planned
00:42:07 <sparks> Anyone else?
00:43:06 * bcotton promises to have some kind of progress to report in the first 2010 meeting
00:43:23 * sparks marks down bcotton's promise
00:43:34 <sparks> #topic New Guides
00:43:39 <sparks> Any new guides coming out?
00:44:45 <sparks> #topic Outstanding BZ Tickets
00:44:55 <sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
00:44:56 <rudi> anross -- did you want to say something about QE and bugzilla?
00:45:05 <sparks> We quite a few open tickets.
00:45:25 <anross> rudi:  didn't have a speech planned ;)
00:45:33 <sparks> If you have tickets assigned to your project please grab them, mark them assigned, and try to work them.
00:45:50 <sparks> At least make sure the person who filed it knows the ticket is being worked.
00:45:52 <anross> but... in general... how do people feel about having someone progress bugs from modified to closed
00:46:09 <anross> 2nd set of eyes
00:46:46 <jjmcd> Well, a number of them are waiting for a push of F11 RN's.  The source has been updated, I don't know the translation status, but mostly waiting for an rpm
00:47:48 <rudi> jjmcd -- and I think one of the blockers for that is working out what to do with the PackageKit warning...
00:47:55 <jjmcd> That's F12
00:48:14 <jjmcd> And actually, I don't think thats a biggie
00:48:30 <jjmcd> more challenging is the CPU one, and I don't want to do the two separately
00:49:06 <jjmcd> THe prob with the CPU one is that I can't figure out how to find an authoratative answer.  We've had several "authorities" with different opinions
00:49:32 <rudi> True
00:49:44 <shaunm> sparks: september, with gnome 3
00:50:01 <jjmcd> I haven't got much evidence to prefer one opinion over another
00:50:24 <shaunm> there will be development releases before then, of course.  but you won't want to target it until you're targetting gnome 3
00:51:00 <sparks> shaunm: cool
00:51:31 <sparks> jjmcd: Maybe just put in the higher of the two CPUs and when the lesser one works then they are still happy
00:51:55 <jjmcd> I may just ask stickster_afk who to ask
00:52:07 <sparks> +1
00:52:23 <jjmcd> If I can catch him on one of those two minute intervals in the AM when he's not _afk
00:52:33 <sparks> jjmcd: There are a lot of RN tickets out there that are still flagged as NEW.
00:52:41 <sparks> good luck
00:52:45 <juhp> sparks: hi
00:52:46 <jjmcd> Oh, I'll look at them
00:53:02 <jjmcd> I thought I had most of the new ones
00:53:02 <sparks> Okay, anything else on the bugs?
00:53:18 <juhp> (ah langpacks)
00:53:27 <jjmcd> Hi Jens
00:53:32 <sparks> juhp: Hi!  We want to know more about the langpack feature you are working on.  Can you wait a sec?
00:54:22 <juhp> yup np
00:54:26 <sparks> Okay...  moving on...
00:54:43 <sparks> #topic Langpack (again)
00:55:02 <sparks> juhp: So can you give us a brief overview of your langpack feature?
00:55:16 <juhp> :)  sorry was in a phone meeting
00:55:45 <juhp> bug 536737
00:55:46 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=536737 medium, medium, ---, panemade, ASSIGNED, Review Request: yum-langpacks - langpacks plugin for yum
00:56:01 <juhp> yeah basically the package is ready to do into f13
00:56:50 <sparks> And what would it do for us?
00:56:51 <juhp> it is a pretty simple yum plugin that allows langpacks for a user's locale etc to be autoinstalled when they install or update a package
00:57:48 <juhp> so i didn't read all the context above but if you have a master package and then translations were "langpacks" they could probably be installed for the user
00:58:11 <jjmcd> OK, dumb question, what makes a langpack?
00:58:14 <sparks> Could this be done in anaconda, too?
00:58:21 <sparks> yeah, and what jjmcd said.
00:58:31 <juhp> yup
00:58:36 <juhp> <jjmcd> Sounds like if we package a guide and individual langpack, people can install, say, user-guide and auto get their local lang
00:58:45 <juhp> sorry yup to ^
00:58:49 <rudi> juhp -- so, for example, if the masterpackage was fedora-release-notes-en-US -- then users could automatically pull in fedora-release-notes-de-DE ?
00:59:04 <juhp> for anaconda - currently it would probably have to go to language support groups
00:59:15 <juhp> I haven't tested anaconda yet but it might work
00:59:47 <jjmcd> presumably, a langpack would have to have some install script to merge it with the installed content
00:59:49 <juhp> rudi: I would prefer fedora-release-notes to fedora-release-notes-en-US
01:00:07 <juhp> jjmcd: merge?
01:00:07 <rudi> OK -- but that's the mechanism :)
01:00:15 <juhp> rudi: yep
01:00:44 <jjmcd> Well, we are talking docs, so we don't have message files laying around, we're not going to translate at run time
01:00:45 <rudi> juhp -- and what specifies something as a master package or a "translation package"? Something in the .spec?
01:00:51 <juhp> rudi: I think fedora-release-notes-en-US would work too so forget my comment above for this discussion anyway :)
01:01:13 <juhp> rudi: currently it is hardcoded in the plugin ;)
01:01:22 <rudi> Awesome :)
01:01:34 <juhp> I am planning to have metadata you can provide later
01:01:42 <juhp> s/have/support/
01:02:33 <juhp> rudi: do yeah for now you could just file a bug and I can add base/langpacks pairs to the list
01:02:39 <juhp> s/do/so
01:02:46 <rudi> Wow!
01:02:57 <rudi> That's a very cool solution :()
01:02:58 <juhp> is it good? :)
01:03:00 <rudi> :) even
01:03:05 <juhp> ok :)
01:03:07 <juhp> thanks
01:03:44 <rudi> We had been idly wishing last week that PackageKit could do something like this :)
01:03:49 <juhp> rudi: you may still need to add them in comps too though for <language>-support groups
01:03:51 <rudi> And Jens makes it happen :)
01:04:02 <sparks> juhp: Can you come back next week and talk more about this?
01:04:08 <juhp> yeah it would have been in f12 if I had been a bit faster...
01:04:13 <juhp> sure
01:04:19 <sparks> cool
01:04:28 <juhp> but next week it should be in rawhide too...
01:04:30 <juhp> by
01:04:52 <juhp> the package is approved but I didn't have time to import it yet :)
01:05:08 <juhp> glad you guys want to use it :)
01:05:29 <sparks> cool!
01:05:43 <juhp> thanks for asking :)
01:06:00 <sparks> Okay, any other questions for Jens while we have him on RH's dime?
01:06:34 <sparks> juhp: Thanks for coming by to chat.
01:06:41 <juhp> pleasure
01:06:45 <sparks> #topic Anything else?
01:06:54 <sparks> Okay, is there anything else anyone wants to talk about?
01:07:41 <jjmcd> Did you see S1775 passed unanimously
01:07:55 <sparks> yes!  :)
01:08:00 <jjmcd> (OT but "anything else ;-))
01:08:27 * sparks already sent it to the packet network
01:08:45 <jjmcd> hehe - I have a cron job does that
01:09:03 <sparks> Okay... anyone?  anything?
01:09:31 <sparks> Well....
01:09:41 <sparks> Thanks everyone for coming out!
01:09:46 <sparks> #endmeeting