21:05:16 <biertie> #startmeeting spins sig
21:05:16 <zodbot> Meeting started Mon Dec 28 21:05:16 2009 UTC.  The chair is biertie. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:05:25 <biertie> #chair nirik brunowolff
21:05:25 <zodbot> Current chairs: biertie brunowolff nirik
21:05:37 <biertie> #topic rollcall
21:05:41 * biertie is here
21:05:46 * brunowolff is here
21:05:46 * nirik is here.
21:05:58 <biertie> #topic agenda
21:06:34 <brunowolff> I have some spin related FYI stuff.
21:06:57 <biertie> I guess we aren't with enough members to discuss the spins for sig?
21:07:30 <nirik> well we could go over them and vote next week?
21:07:37 <brunowolff> I like to have kanarip around for that kind of stuff, since he is our vision person.
21:07:52 <brunowolff> That's a reasonable idea.
21:07:56 <biertie> haha, that's nice -how you put it-
21:08:12 <brunowolff> Especially if there is feedback for the spin owner that can be acted on.
21:09:11 * nirik nods.
21:09:54 * sdziallas hullos
21:10:00 <sdziallas> (sorry for being late9
21:10:02 <nirik> ok, so how about we do brunowolff's lzma first, then each of the ready spins?
21:10:09 <biertie> hmm
21:10:12 * nirik doesn't have anything else off hand for agenda.
21:10:19 <brunowolff> OK.
21:10:52 <brunowolff> I heard back from lougher and he indicated that Morton wanted the lzma patches to sit in linux-next until 2.6.34.
21:11:04 <biertie> #topic lzma
21:11:27 <brunowolff> I haven't seen them show up there yet either, but I am not sure if that is because linux-next is still for 2.6.33 right now.
21:12:02 <brunowolff> I haven't done a lot of squashfs yet, but still want to get a test version of 4.1 working here to see how much it buys us.
21:12:12 <nirik> is there any chance we might get fedora kernel folks to carry them in our kernel?
21:12:21 <nirik> (after testing of course)
21:12:39 <brunowolff> Kyle has given me access to squashfs in devel, but I am supposed to get 4.1 reviewed by him before doing a devel build.
21:13:10 <nirik> sounds good
21:13:21 <brunowolff> I think if the patches actually appear in linux-next and I have some numbers on much live images shrink that look
21:13:36 <brunowolff> good. I will ask Kyle to back port the patches.
21:14:18 <brunowolff> I was looking ahead and I am not sure we will release with 2.6.34. It looks like it won't quite be ready in time.
21:14:47 <brunowolff> Also with the new focus on stability of rawhide, we might be less aggressive in getting a new kernel than we
21:14:51 <brunowolff> have been in the past.
21:15:32 <brunowolff> So the summary is that I still have some justification work to do and that to get it in, the kernel guys will need to make an exception.
21:17:19 <brunowolff> Along with the lzma report I ran across some bugs in livecd and liveusb related tools. I'll just list them here,
21:17:38 <brunowolff> but I don't think we need to do further discussion in the meeting.
21:17:56 <brunowolff> https://bugzilla.redhat.com/show_bug.cgi?id=548149
21:17:57 <buggbot> Bug 548149: medium, low, ---, katzj, NEW, liveusb overlay didn't work on f12
21:18:21 <brunowolff> https://bugzilla.redhat.com/show_bug.cgi?id=538496
21:18:22 <buggbot> Bug 538496: high, low, ---, katzj, MODIFIED, F12 Release - livecd-tools - Unable to Change Root Password
21:18:36 <brunowolff> https://bugzilla.redhat.com/show_bug.cgi?id=546909
21:18:37 <buggbot> Bug 546909: medium, low, ---, kanarip, NEW, The live base ks tries to copy a nonexistant file into the image
21:19:39 <brunowolff> The only other fyi stuff is that getting liveusb devices to work is a lot more of a pain than one would think based on
21:19:52 <brunowolff> how well live cd/dvds work across systems.
21:20:42 <brunowolff> Lot's of per computer bios setup is generally required and it would be nice to have an easy way to make the drives
21:21:03 <brunowolff> work like both superfloppies and hdds at the same time for boot purposes.
21:21:11 <brunowolff> That's it for me.
21:21:15 <nirik> well, dd does that, but you get no persist.
21:22:37 <brunowolff> dd just copies images. You need the right images to make things bootable off both the mbr and a boot partition.
21:22:49 <brunowolff> Some bios' only support one or the other.
21:23:08 <nirik> right, but all the live isos should be hybridisofs
21:23:19 <brunowolff> There is also a xip format that is even more obscure. But I don't think that can even be done properly on the
21:23:32 <brunowolff> larger usb pen drives that are out now.
21:24:58 <nirik> anyhow, shall we move on to the ready for sig spins?
21:25:15 <brunowolff> I tried one of those, and I am not sure if they support both boot alternatives. Also it makes it hard to use the
21:25:19 <brunowolff> whole device.
21:25:27 <brunowolff> Yeah let's move on/
21:25:34 <nirik> yes, it should support both.
21:26:19 <nirik> biertie: you have a list of ready for us spins?
21:27:01 * sdziallas notes that he'll try to have a design suite proposal ready by one of the next meetings, as well as probably something from the Sugar side of things.
21:27:34 <brunowolff> https://fedoraproject.org/wiki/Haskell_Spin
21:27:39 <biertie> https://fedoraproject.org/wiki/Category:Spins_Ready_For_SIG
21:27:43 <brunowolff> https://fedoraproject.org/wiki/Moblin_Spin
21:27:45 <biertie> sorry, I'm on another meeting too
21:27:52 <biertie> #topic haskell spin
21:28:13 <biertie> I just want to say that the wiki for the haskell spin isn't ready yet, but it's 'ok'
21:28:25 <biertie> and I already kicked him out of the spins process for F12
21:28:32 <nirik> it's a very simple ks file.
21:28:33 <brunowolff> These guys don't want an image produced, so the bar should be a little lower.
21:28:48 <biertie> so I don't want to a total asshole :)
21:29:02 <biertie> k k :)
21:29:30 * sdziallas wonders if it would make sense to base it on the fedora-livecd-desktop file, rather than including the whole gnome-desktop group, but doesn't really mind as they don't want an image ;)
21:29:41 <brunowolff> This is probably kind of a kanarip thing as it is questionable whether this is enough to really be worth the trouble.
21:30:54 <brunowolff> It probably should be based on the live desktop rather than adding desktop stuff separately.
21:31:08 <nirik> yeah, I would think that would be more consistent...
21:31:14 <brunowolff> That's extra maintenance outside of the core area of the spin.
21:31:32 <brunowolff> I'd at least like to hear a justification for doing it that way.
21:32:16 <nirik> shall we add that question to the talk page/mail the submitter?
21:32:43 <brunowolff> That seems like it should be on the talk page.
21:33:08 <nirik> ok. can you add it?
21:33:28 <brunowolff> Personally, I'd rather see a more generic developer kickstart, but if he thinks that people are specifically interested
21:33:51 <brunowolff> in Haskell stuff, I don't see a need to require that.
21:34:49 <brunowolff> #action brunowolff will ask haskell spin owner why he isn't using the livecd desktop ks as a base on the talk page.
21:35:02 <nirik> well, there was a developer sig that had a spin a while back, but they seem dormant now.
21:35:36 <nirik> thanks. Shall we move on to the other one?
21:35:41 <biertie> k
21:35:46 <biertie> #topic moblin spin
21:38:12 <sdziallas> can we vote on this one?
21:39:12 * nirik hasnt looked over the ks very much.
21:41:39 <sdziallas> I guess the most significant question is the new mini-base.ks.
21:42:50 <nirik> yeah, the ks here is pretty complex.
21:43:15 <sdziallas> well, from what I understand, it's intended as a slimmed-down version of the fedora-live-base.ks
21:43:17 * nirik isn't sure presto is a good idea. Also, insert my usual rant about ssmtp being used for an MTA
21:43:32 * sdziallas grins ;)
21:43:56 <nirik> also mesa-dri-drivers-experimental is not supposed to be installed by default anywhere I wouldn't think.
21:44:23 <brunowolff> I was just going to ask about that one.
21:44:29 <nirik> also rm -f /boot/initrd* doesn't do anything as we use initramfs now. ;)
21:44:34 <sdziallas> so the moblinNetbook.ks seems to be the spin's kickstart file, and the mini-base.ks could be also used by other spins as a default kickstart (if we approved it, I guess)
21:44:49 <brunowolff> By the time F13 comes out, I would expect the hardware for which this is targeted to be supported.
21:45:49 <sdziallas> I *suppose* it's because Moblin requires OpenGL support to work reasonably well. But I'm not sure.
21:46:23 * sdziallas notes that we're doing rm -f /boot/initrd* in the fedora-live-base.ks, too.
21:47:06 <nirik> that should be fixed there.
21:47:09 <brunowolff> If we allow the mini spin as base for live images, we'll need to update some policy as currently the requirement is
21:47:09 <nirik> too
21:47:21 <brunowolff> base of live-base or live-desktop.
21:47:27 * sdziallas nods.
21:47:57 <brunowolff> Who wants to file that bug?
21:48:04 <nirik> so, I would say we should ask the submitter to say why they need a different base... and perhaps sit down and catalog any other issues we have?
21:48:24 <sdziallas> nirik: I heard it was to save space on netbooks...
21:48:48 <nirik> perhaps we could invite them to discuss on the spins list?
21:48:54 * nirik sees we are running low on time.
21:49:04 <brunowolff> Yes. But I think that a good mini base could be useful for people doing custom spins, so we shouldn't
21:49:20 <brunowolff> discourage them too much.
21:49:43 <sdziallas> well, how about this: we could split the two things, discuss the moblin spin and the mini-base file as two seperate things.
21:49:50 <brunowolff> But it might be better to subtract stuff from live-base.
21:49:54 <nirik> well, it might be usefull for lxde and xfce too... but then why not make the base smaller and larger spins can add to it more?
21:50:24 <brunowolff> There does seem to be two separate things here.
21:50:38 <sdziallas> (that way, we could a quick yay / nay on the spin itself and move the mini-base discussion to the list)
21:51:23 * nirik doesn't feel he's looked over it enough to vote on it today...
21:51:48 <brunowolff> The only objection I have to the moblin ks is that it shouldn't be including mesa-dri-drivers-experimental.
21:52:34 <brunowolff> If that is needed as a temporary measure, there should be a deadline for it to be removed (beta?).
21:53:09 <sdziallas> I think approving it temporarily sounds reasonable, but we can vote on it next week, too.
21:53:27 <sdziallas> it = mesa-dri-drivers-experimental
21:54:28 <brunowolff> #action brunowolff will file a bug report about live-base and initrd cleanup
21:55:31 <brunowolff> There may be some interaction between changes to the mini base ks and the moblin ks. We probably want
21:56:14 <brunowolff> to just say the moblin one seems OK, but we should really figure out mini-base first and then go back to moblin
21:56:29 <brunowolff> after it is adjusted for any changes to mini-base.
21:57:14 <nirik> yeah.
21:57:16 * nirik agrees
22:00:01 * nirik has to run soon
22:01:47 <biertie> end meeting?
22:01:50 <brunowolff> I added a comment about  mesa-dri-drivers-experimental to the moblin discussion page.
22:01:55 <brunowolff> Yeah.
22:01:57 <biertie> k
22:02:01 <biertie> thank you for being here
22:02:09 <biertie> and sorry again that I have to lead another meeting too :(
22:02:15 <biertie> #endmeeting