00:20:05 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:20:05 <zodbot> Meeting started Thu Jan  7 00:20:05 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:20:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:20:06 <rudi> jjmcd, I'd vote +1 to work on KDE, and +1 to move GNOME to HTML
00:20:21 <sparks> #topic Roll Call
00:20:22 * sparks 
00:20:28 <jjmcd> Big change midstream, but it would eliominate a lot of grief
00:20:33 * jjmcd .
00:20:42 <dhillon-v10> *me
00:21:05 <nathant> ***nathant
00:21:34 <sparks> Sorry for being late.  I didn't realize the time!
00:21:56 * rudi is here
00:22:34 <sparks> Okay, let's get started!
00:22:40 <rivanvx> ok
00:22:58 <sparks> #topic F13 Release Schedule
00:23:07 <sparks> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-and-trans-tasks.html
00:23:15 <sparks> poelcat: You around?
00:23:30 <jjmcd> I have a few notes, but unfortunately I referenced line #s in the doc sked, and you pointed to the combined sked
00:23:46 <sparks> Okay, so the URL above is for both the translators and us...
00:23:49 <sparks> jjmcd: Yeah, sorry.
00:23:59 <sparks> I was reviewing everything.
00:24:16 <jjmcd> Yeah, I should have looked first, but I was fixating on making sure we had the right order
00:24:27 <sparks> So what do you have for the docs?
00:24:35 <jjmcd> But most of my catches were nit-picks, the real meat is ok
00:24:52 <jjmcd> Well, the POT generation and html generation really don't match very well
00:25:12 <jjmcd> We have 0 days to do the beta notes when in reality we have weeks
00:25:25 <jjmcd> Theres the docs.fp.o vs fh.o thing still
00:25:45 <sparks> Okay, are you going to put those together and send them to poelcat?>
00:25:49 <jjmcd> And on GA RNs also an unnecessary delay ins tarting
00:25:52 <jjmcd> Yepper
00:26:43 <jjmcd> Plus a few notification I would move from beta to ga
00:26:46 <jjmcd> but same dates
00:26:51 <sparks> Cool
00:27:10 <sparks> Hopefully he can generate the calendar files for me so I won't miss anything.
00:27:29 <jjmcd> He has the sources out there so you can do that easily
00:28:11 <jjmcd> Hey, another country heard from.  Hi Susan
00:28:12 <sparks> ya
00:28:47 <sparks> Okay, anythign else on this topic?
00:28:53 * laubersm sneaks in while listening to a basketball game
00:29:56 <sparks> Okay, moving on
00:30:10 <sparks> #topic Release Notes
00:30:19 <jjmcd> For F12, Release Notes are in XML (Yelp) only.  This means there is no easy way for a KDE user to view them.  We can display HTML notes in any window manager.  However, if we provide XML for Gnome and HTML for KDE, this doubles the size of the package.
00:30:26 <jjmcd> We could provide HTML only (and quite easily), but now Gnome users see a major change mid-stream.
00:30:33 <jjmcd> If we do anything for KDE, we should talk about where to put the docs on the menu.  Talking with rudi before the meeting we may have little choice.
00:31:08 <jjmcd> So basically I'm looking for input.  I'm pretty open for now
00:31:18 * sparks thinks we might have to do release notes for the Release Notes!
00:31:26 <jjmcd> hehe
00:31:38 <sparks> Well... I'm a big advocate for accessibility...
00:31:56 <sparks> but I hadn't thought of the accessibility within different desktops...
00:32:06 <jjmcd> I feel like nothing for KDE (well, they still have online) is a bad deal
00:32:22 <sparks> so it would seem that pushing everything as HTML would be the answer.
00:32:27 <rudi> Thinking about it, maybe a double-sized package might not be a bad idea for the rest of the F12 lifespan?
00:32:28 <laubersm> while I personally use gnome and so "as is" sounds good :)  I agree that KDE users need just as easy access to local RN
00:32:40 <rudi> And look at HTML only for F13?
00:32:48 <sparks> What about XFCE?
00:32:51 <jjmcd> Yeah, I'm kind of leaning that way
00:33:00 <jjmcd> Well, html will work for everyone
00:33:13 <nathant> Xfce Spin doesn't use Yelp
00:33:17 <jjmcd> although I have no clue how to make a menu entry for XFCE
00:33:24 <rudi> That way, nobody gets surprised, and we also get a chance to fine-tune the HTML strategy before F13...
00:33:41 <rudi> Yeah; we need to look at how to integrate with XFCE too
00:33:53 <sparks> nathant: Ya...  Will Xfce handle html?
00:34:00 <jjmcd> Doex XFCE have a .desktop type thingie?
00:34:18 * laubersm loves the technical terms
00:34:24 <nathant> sparks: Yes, Xfce documentation is in html
00:34:45 <nathant> jjmcd: Yes, and menu configuration is fairly easy from the look of it
00:34:58 <jjmcd> Ahh good.  From an rpm?
00:35:50 <nathant> Think so, there's a package called xfce-doc
00:36:01 <jjmcd> nathant, as best I can tell, it is easy to add/replace a file from an rpm. kind of messy to change a file
00:36:40 <jjmcd> OK, so for F12 update, html or both?
00:36:53 <jjmcd> Sounds like we have support for html only for f13
00:37:05 <sparks> jjmcd: Do you have time to generate a HTML-only version for F12 so we can play with it?
00:37:12 <jjmcd> sure
00:37:42 <jjmcd> The f11 update provides html for KDE, but no menu option on Gnome since that is available through yelp
00:38:13 <jjmcd> bu you can always open index.html with htmlview
00:38:26 <sparks> I'm good with aiming F13 towards HTML-only
00:38:37 <nathant> sparks: I second that
00:38:53 <laubersm> count me in for only html in F13
00:39:07 <sparks> Okay...  who can test a package in KDE?
00:39:24 * rudi volunteers
00:39:27 <jjmcd> sparks, I made myself F11 and F12 KDE sticks to test on
00:39:35 <sparks> Cool
00:39:41 <sparks> rudi: You are on for KDE
00:39:44 <dhillon-v10> jjmcd, I can help with testing :)
00:40:02 <sparks> nathant: Can you test in Xfce?
00:40:07 <jjmcd> BTW, a stick is the cat's meow for testing cuz you can save off the overlay file and that makes it easy to start over
00:40:09 <nathant> Sure
00:40:27 <jjmcd> Good deal
00:40:46 <sparks> jjmcd: There you go.
00:40:50 <nathant> I can test in Xfce
00:40:50 <jjmcd> I'll put together an F12 html only with just a few languages so it is small
00:40:59 <sparks> jjmcd: When do you want to do the tests?
00:41:24 <jjmcd> I guess in a few days, my little prog can make the rpm pretty painlessly
00:41:39 <sparks> jjmcd: It might be good to do this on IRC so any issues can be fixed in real time
00:41:43 <jjmcd> I need to do some xfce research
00:41:48 <jjmcd> Yeah, good plan
00:41:58 <sparks> Are we missing any desktops?
00:42:00 <sparks> OLPC?
00:42:12 <sparks> errr... Sugar
00:42:14 <jjmcd> BTW, did you see my note on the list?  The rpm maker sources are on github for the terminally curious
00:42:16 <nathant> sparks: LXDE
00:43:01 <jjmcd> With html, it may only be a matter of providing a handful of menu files
00:43:08 <sparks> #action jjmcd to rebuild F12 Release Notes in HTML-only and test in GNOME, KDE, Xfce, ...
00:43:21 <rudi> Yeah; Sugar and LXDE are the only other two that we offer groupinstalls for
00:43:38 <sparks> Anyone use either of those?
00:44:43 <sparks> I can shoot something out on the Planet to see if we can get some help
00:44:58 <jjmcd> Now there's a good idea
00:45:28 <jjmcd> http://github.com/jjmcd/FedoraDox/tree/master/tools/doc-publican-rpm/
00:45:40 <jjmcd> Allows you to make your own custom set of languages
00:46:06 <sparks> #action sparks to ask on the Planet for assistance on testing LXDE and Sugar
00:46:10 <sparks> Cool
00:46:20 <jjmcd> and there's an rpm at http://github.com/jjmcd/FedoraDox/downloads
00:46:33 <jjmcd> If you just want to recklessly install it withough studying the sources
00:47:34 <sparks> heh
00:47:53 <sparks> Okay, anything else on the Release Notes?
00:48:09 <jjmcd> Oh, F11
00:48:26 <jjmcd> An update has been pushed, should hit the repos in the next day or so
00:48:41 <jjmcd> It fixes some bugs but also adds a menu item for kde
00:48:59 <jjmcd> Testing languages seems a pain in KDE.  Maybe rudi can help here
00:49:08 <rudi> jjmcd -- will do
00:49:13 <jjmcd> There must be an easier way
00:49:39 <jjmcd> That's what I had on RNs
00:49:57 <sparks> Cool
00:50:08 <sparks> Yeah, F11 should be in the wild now
00:50:26 <sparks> Okay, moving on!
00:50:27 <jjmcd> Oh yeah, that RPM makes has man pages, info pages, etc
00:50:42 <sparks> #topic Status on CMS (Zikula)
00:50:52 <sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:50:57 <sparks> ke4qqq: You around?
00:51:40 <sparks> I think Marketing pushed a Fedora skin for Zikula last week
00:51:44 <sparks> so that's exciting.
00:51:47 <jjmcd> cool
00:52:12 <jjmcd> I thought I saw mchua here, perhaps she could brag on it
00:52:29 <sparks> I haven't heard anything else on this in a while.  Hopefully ke4qqq can provide some info on this next week.
00:53:16 <sparks> Okay, moving on..
00:53:30 <sparks> #topic Does yum langpack support help us?
00:53:39 <sparks> #link https://fedoraproject.org/wiki/Features/YumLangpackPlugin
00:53:47 <sparks> jjmcd: Was this of interest?
00:53:49 <jjmcd> I have some concerns on how we might make this work
00:54:02 <sparks> okay
00:54:04 <jjmcd> Well, it would be nice, and easy for yelp, not so much for html tho
00:54:23 <sparks> ya
00:54:35 <sparks> Do we need it for HTML?
00:54:54 <jjmcd> well, yeah, if we are going to do dox in html
00:55:14 <sparks> true
00:55:23 <jjmcd> This would allow us to push selected langs, but for html, I don't know how to make it work
00:55:34 <jjmcd> Not that it can't, but I can't see the way.
00:55:38 <sparks> Why would it be any different?
00:55:50 <jjmcd> Perhaps a long heart to heart with spot or some other expert
00:55:56 <sparks> ya
00:56:00 <jjmcd> Well, yelp has some cool features
00:56:33 <sparks> #action jjmcd and sparks to setup a meeting with spot and others to discuss YumLangpack and HTML
00:56:39 <jjmcd> In particular, you can add a language by adding files.  HTML doesn't know how to select languages by itself, tho.  So you have to MODIFY files which is a lot harder inside rpm
00:57:12 <jjmcd> And even if you can the logic is a lot harder
00:57:20 <sparks> yes
00:57:34 <sparks> maybe the plugin can be smarter than us
00:57:48 <jjmcd> Now you're fantasizing
00:58:12 <jjmcd> Maybe we can teach the browser to translate on the fly
00:58:20 <sparks> well, there's tha
00:58:22 <sparks> that
00:58:36 <jjmcd> Still, it shows promise
00:58:46 <jjmcd> I don't think we can dismiss it out of hand
00:58:52 <sparks> ya
00:59:34 <nathant> But HTML wouldn't need to know how to select languages by itself...
01:00:07 <nathant> You'd generally only need one language, you just need to pick the right one initially
01:00:25 <nathant> Or am I not following the discussion?
01:00:27 <jjmcd> nathant, in Gnome, you select a language on logon, and everything (that is translated) shows up in your selected language
01:00:43 <nathant> Ahh
01:00:47 <nathant> That makes sense now
01:00:49 <jjmcd> In some places (India, Belgium) this is very handy
01:01:09 <jjmcd> In India, the guy down the street probably doesn't speak the same language you do
01:01:22 <jjmcd> Not quite so bad in Belgium
01:01:34 <jjmcd> In Canada, the law requires multilanguage
01:01:50 <dhillon-v10> jjmcd, agreed, I am from India but the differences aren't so much
01:02:14 <jjmcd> dhillon-v10, seems like half the languages we have are Indic languages
01:02:27 <dhillon-v10> jjmcd, really wow :)
01:02:58 <jjmcd> A lot of them I never heard of
01:03:24 <dhillon-v10> jjmcd, okay i could hlep out with translations then yay :)
01:04:16 <jjmcd> They all use weird characters, too.  And different
01:04:30 <sparks> heh
01:05:08 <dhillon-v10> jjmcd, lol
01:05:20 <sparks> Okay... anythign else on this?
01:05:48 <jjmcd> I don't think so.  I'll get with spot
01:06:06 <sparks> cool
01:06:12 <sparks> #topic New Guides
01:06:17 <sparks> Any new guides in the works?
01:06:42 <dhillon-v10> sparks, I want to pick the one on live installer, it currently doesn't have anyone to work on it, can i
01:07:16 <sparks> live installer?
01:07:58 <sparks> Is that not covered in the Installation Guide?
01:08:19 <dhillon-v10> sparks, sorry its the Live Images one :P
01:08:33 <sparks> making a live image?
01:09:05 <dhillon-v10> sparks, not quite sure its the last thing on this page: http://fedoraproject.org/wiki/Docs_Project_meetings#Agenda_for_Next_Meeting
01:09:50 <sparks> Hmm...  not sure what that is.
01:10:07 <dhillon-v10> sparks, yah same here :D
01:10:13 <rudi> That's the live images doc
01:10:42 <rudi> ie - http://docs.fedoraproject.org/readme-live-image/en-US.html
01:10:46 <sparks> rudi: Okay, looks like you are handling that doc, correct?
01:10:48 <dhillon-v10> rudi, thanks :)
01:11:08 <rudi> sparks -- only by virtue of nobody else handling it
01:11:14 <rudi> I'm more than happy to give it away
01:11:22 <jjmcd> AHhh, looks like we have a victim
01:11:27 <dhillon-v10> rudi, can I pick it, I am a new member though
01:11:53 <sparks> dhillon-v10: rudi is an excellent resource
01:11:53 <rudi> dhillon-v10 -- that's no problem, but you might want to discuss any changes on the mailing list first before jumping in :)
01:12:30 <rudi> The only real "trap for new players" is the realization that when we change something in a doc, we create work for 20 or more translation teams
01:12:55 <dhillon-v10> rudi, okay yah I work over at Ubuntu and FreeBSD and it does increase a *lot* of work
01:12:56 <rudi> So we only change stuff in existing docs if we absolutely *have* to (ie, something is out-of-date and factually wrong)
01:13:57 <sparks> Okay, anything else for New Guides?
01:14:15 <nathant> There was a draft Command Line Survival Guide posted to the list today
01:14:43 * sparks hasn't caught up on his email
01:14:45 <jjmcd> That looks like a goody
01:15:00 <rudi> sparks -- power management and resource management guides sometime soon :)
01:15:06 <sparks> cool
01:15:31 <rudi> Will start moving as soon as I finish playing whack-a-mole with the IG :)
01:15:37 <sparks> ya
01:15:44 <nathant> rudi: let me know if you need a paragraph on the new xfce power manager
01:16:04 <rudi> nathant -- Ta! I'll make a note
01:16:53 <nathant> rudi: no problem
01:16:54 * laubersm *should* be available for some proofreading (or more) next week
01:17:29 <sparks> Okay, let's move to the existing guides
01:17:36 <sparks> #topic Guide needs
01:17:52 <jjmcd> that darn peer
01:18:12 * jjmcd still needs to recruit more helpers for the ARG
01:18:12 <sparks> Have we figured out if the new Transifex is up and ready?
01:18:25 <rudi> sparks -- still coming
01:18:32 <sparks> Okay
01:18:32 <rudi> But there's definitely traction there now
01:18:37 <sparks> +1
01:18:57 <sparks> I need some help with documenting PolicyKit in the Security Guide.
01:19:02 <jjmcd> Only about a month until we start sending them publican pots
01:19:02 <nathant> jjmcd: ARG?
01:19:10 <jjmcd> Amateur Radio Guide
01:19:34 <rudi> Independent of that, we should pick a time soon to migrate all existing Guides' POT and PO files to Publican 1 (in the master branches at least)
01:19:57 <sparks> jjmcd: We also need to update the RNs and SG for the PackageKit vulnerability
01:20:04 <jjmcd> Yep
01:20:21 <jjmcd> There are a bunch of updates to F12 rn's I need to do
01:20:21 <sparks> All my guides are in Publican 1, I think.
01:20:24 <rudi> And then co-ordinate with L10N when/if to move the Publican 1 PO files into the current working Transifex branches
01:20:34 <jjmcd> Now that F11 is put to bed, that is the next big thing
01:20:53 <jjmcd> rudi, how much of a pain will that be?
01:21:03 <rudi> Yeah, the PackageKit thing in the RN and the processors list are still blockers for the 0 --> 1 migration
01:21:22 <jjmcd> Also a blocker for me moving my F10 box to F12
01:21:22 <rudi> jjmcd -- not much of a pain at all, actually. It's just picking the right moment.
01:21:41 <rudi> There's a few other blockers in the IG
01:22:01 <rudi> I hope to have those all put to bed in the next few days.
01:22:19 <jjmcd> did you see jsmith's Publican bug?
01:22:26 <sparks> I didn't
01:22:48 <rudi> I think we're in a position now to fix the PackageKit thing in the RN, but what about the processor list?
01:22:58 <rudi> I saw that bug, but haven't tested it yet
01:23:04 <rudi> I should get to that today
01:23:08 <jjmcd> I was trying to reproduce it, but had no joy at all making 1.0 work from scratch.  Fine with an existing doc but not new
01:23:08 <sparks> Well, we can push it separately
01:23:36 <rudi> jjmcd -- that's a bug in 1.0; the issue was fixed in 1.3
01:23:51 <jjmcd> Now that ppl are back to work I should be able to get with notting, but I've been on the phone all week it seems
01:24:08 <jjmcd> rudi, it was 1.3 i was struggling with
01:24:10 <rudi> jjmd -- you can also fix it by removing any empty fields from the publican.cfg file
01:24:24 <jjmcd> ahh, i'll look at that
01:25:01 <jjmcd> It was whining about not finding ___DocName____
01:25:11 <jjmcd> Who knows where all those _ came from
01:26:41 <sparks> Okay, anything else guide-wise?
01:28:26 <sparks> #topic Other business
01:28:32 <sparks> Anyone have anything else?
01:28:42 <jjmcd> Want to mention the yelp meeting
01:30:06 <sparks> Yeah
01:30:23 <jjmcd> The Gnome folks are organizing a meeting on help display in March in Chicago.  They are getting together Gnome, KDE and XFCE folks from Fedora, The Gnome folks are organizing a meeting on help display in March in Chicago.  They are getting together Gnome, KDE and XFCE folks from Fedora, Ubuntu and others to talk about what is needed for help display.
01:30:23 <jjmcd> Ubuntu and others to talk about what is needed for help display.
01:31:18 <jjmcd> They have some thoughts about an improved language for help content, maybe a common help application
01:31:35 <jjmcd> But obviously, their prerspective is from Yelp
01:32:08 <sparks> Yeah...  Looks like some KDE folks have already RSVP'd
01:32:30 <jjmcd> I have a conflict on Saturday, but I think I may prioritize this higher
01:33:03 <jjmcd> Besides, I need an excuse to buy sparks a guinness
01:33:08 <sparks> :)
01:34:00 <jjmcd> Sparks, you are going by train????
01:34:05 <sparks> #action sparks to talk to Max about funding
01:34:14 <sparks> jjmcd: If I go then I will be going by train, yes
01:34:26 <jjmcd> Long ride
01:34:48 <sparks> better than being strip searched at the airport!
01:34:54 <jjmcd> Well, there is that
01:35:08 <sparks> plus I like taking the train!
01:35:09 <jjmcd> It's about 6 hours drive from here, -2 minutes by air
01:35:15 <jjmcd> hehe I can see that
01:36:12 <sparks> Okay, anything else?
01:36:15 <jjmcd> I did some teaching at the Motorola University, so I have some experience with the drive
01:36:38 <sparks> Ya
01:38:27 <sparks> Okay, thanks everyone for coming!
01:38:39 * mchua here now if zikula updates needed *fades back into background until called*
01:38:57 <sparks> mchua: Go for it!
01:39:15 <mchua> I think we may be ready for staging, with hiemanshu's skin package in and working.
01:39:35 <mchua> Trying to find itbegins to sit down and confirm it - so if y'all see him around, ping plz
01:39:47 <mchua> that's it - once we get that, we'll be on staging, and shortly thereafter (we assume) production
01:40:14 <sparks> cool
01:40:26 <sparks> what's missing for us to use it for docs.fp.o?
01:40:37 <mchua> you may want a translations workflow.
01:41:13 <mchua> Other than that, i'm not sure what else you'd need that we don't already have
01:41:32 <mchua> EOF
01:41:32 <sparks> excellent
01:41:44 <sparks> any questions for mchua?
01:42:15 <mchua> for that matter, if you figure out a translations workflow, we'd love to use it too - Marketing hasn't really had any i18n-ness in our formal workflows in the past, so that's something we'd like to learn from you on.
01:42:34 <sparks> will do
01:42:40 * mchua can't think of anything else, is done
01:42:58 <sparks> Okay, thanks mchua for the update
01:43:12 <sparks> And we'll go ahead and close the meeting at this time.
01:43:22 <sparks> Thanks, everyone, for coming!
01:43:28 <sparks> #endmeeting