18:03:37 <Oxf13> #startmeeting Fedora Release Engineering
18:03:37 <zodbot> Meeting started Mon Jan 11 18:03:37 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:03:46 <Oxf13> #meetingname fedora-releng
18:03:46 <zodbot> The meeting name has been set to 'fedora-releng'
18:03:54 <Oxf13> #topic roll call
18:04:19 <Oxf13> ping: notting jwb lmacken wwoods rdieter_work poelcat warren dgilmore spot
18:04:26 <warren> pong
18:04:58 * dgilmore is here
18:05:33 * notting is here
18:05:37 <rdieter_work> here'ish
18:06:17 <Oxf13> wwoods: ping; releng meeting
18:06:39 <jwb> in real-life meeting
18:06:41 <Oxf13> so I want this to be something of a quick meeting, there isn't a lot of new topics
18:07:00 <Oxf13> #topic no frozen rawhide
18:07:02 * wwoods appears in a puff of smoke
18:07:19 <Oxf13> lmacken: notting: progress reports on your end of this project?
18:07:28 <notting> no progress
18:07:58 <Oxf13> I saw a patch dump from lmacken and talk of getting something up to test, not sure how far down that road he got
18:09:04 <Oxf13> #info Bodhi code has been posted for review, a test instance coming soon I hope
18:09:15 <Oxf13> Moving on.
18:09:18 <Oxf13> #topic dist-git
18:09:40 <Oxf13> Still working on fedpkg here, a few more targets got coded last week, more to come this week
18:10:21 <Oxf13> I may also do a module refresh this week to get our git repos setup a bit better to start with and take another stab at filtering out the kernel repo some.
18:11:05 <Oxf13> #info progress on fedpkg, will continue work
18:11:22 <Oxf13> #info may refresh git repos this week
18:11:52 <warren> stabbity stab
18:12:00 <Oxf13> warren: ?
18:12:05 <warren> you said stab
18:12:11 <Oxf13> ah
18:12:23 <Oxf13> #topic fedora-release subpackage proposal
18:12:33 <Oxf13> nirik created a wiki page for this proposal
18:12:43 * nirik looks up.
18:13:01 <nirik> Any further feedback on it?
18:13:03 <Oxf13> https://fedoraproject.org/wiki/Features/RawhideRepoSubpackage
18:13:35 <Oxf13> If we go this route, and it seems there are many who would want to, i do wish to make the rawhide repo still disabled by default, even if it's in its own package
18:13:46 <nirik> I know it adds complexity, but I think it's worth it to reduce the number of people who mess up and install rawhide packages when they shouldn't.
18:14:12 <nirik> yeah, there are some use cases there where people would want to install it, but not enable it.
18:14:25 <nirik> and I agree that enabling rawhide on just a package install is not a good idea.
18:14:27 <Oxf13> nirik: if I make the change, will you help find all the documentation that needs to be changed?
18:14:35 <nirik> sure. Happy to!
18:14:42 <Oxf13> ok.
18:15:10 * nirik tosses it on his todo list.
18:15:21 <Oxf13> #idea Accept nirik's proposal, but keep rawhide disabled by default
18:15:31 <Oxf13> lets put it to a vote.  I'm +1 after seeing the list feedback.
18:15:47 <notting> +1
18:16:11 <warren> +1
18:17:26 <Oxf13> wwoods: what does QA think about this?
18:18:13 <poelcat> +1
18:19:05 <wwoods> well, as long as the procedure for enabling rawhide is clear that's fine
18:19:19 <wwoods> I'm trying to find an explanation of what's supposed to happen at the end of the rawhide cycle
18:19:20 * dgilmore is ok with it
18:19:22 <dgilmore> +!
18:19:33 <nirik> rawhide never ends! ;)
18:19:41 <wwoods> badly phrased
18:19:42 <Oxf13> wwoods: rawhide cycle doesn't end.
18:19:53 <nirik> you mean when the next stable release is branched off.
18:20:18 <wwoods> when the branch happens, some testers will want a way to follow the stable-release branch rather than continuing to follow rawhide
18:20:19 <Oxf13> people who have rawhide enabled, will need to grab the fedora-release from the branch and install it
18:20:28 <warren> I really think people should re-optin to rawhide at the stable branch point
18:20:30 <warren> if they really want rawhide
18:20:33 <wwoods> so QA will need to be able to say "here's what you do"
18:20:52 <wwoods> as long as we can tell testers how to get on and off the rawhide train, I'm totally cool with it
18:20:54 <nirik> what do we currently do?
18:21:06 <nirik> ie, does this change any with a subpackage?
18:21:24 <Oxf13> well I guess that begs the question
18:21:40 <wwoods> it does change. currently, near the end of the rawhide cycle, we push out a new fedora-release package which disables the rawhide repo and enables the stable repos
18:22:00 <Oxf13> nirik: currently when I make a fedora-release package for a new release, say for dist-f13 back when we branched away dist-f12, I set the rawhide repo to enabled, all other repos disabled
18:22:08 <wwoods> so everyone automatically gets shifted to the stable branch
18:22:15 <Oxf13> nirik: so that if you did an install from dist-f13 content, you got put on the rawhide train
18:22:22 <wwoods> (unless they fail to update during the window between that point and the actual re-start of the new rawhide blah blah)
18:22:24 <nirik> right.
18:22:49 * nirik gets confused by 'if you have edited your repo files' here.
18:22:52 <wwoods> anyway, as I said, I don't really care about the implementation, so long as we can tell testers what branches there are and how to switch between them
18:22:55 <Oxf13> then at some point, rawhide would get disabled, and the fedora{-updates} repos were made enabled
18:23:02 <Oxf13> this falls over a bit with no frozen rawhide
18:23:21 <Oxf13> because with no frozen rawhide, once we branch, rawhide != the pending release
18:23:28 <nirik> right.
18:23:31 <Oxf13> so we can't put a yum config in rawhide that will point you to the pending release
18:23:54 <nirik> so, we can't default people to the stable release easily.
18:23:59 <wwoods> right.
18:24:05 <Oxf13> for people that are currently on rawhide, yes
18:24:06 <wwoods> given that the goal of some of this is to get more people using rawhide
18:24:09 <wwoods> that may not be bad.
18:24:12 <Oxf13> people who install alpha will stay on the stable release
18:24:16 <warren> perhaps we might want to rethink this
18:24:19 <Oxf13> (ditto beta, etc...)
18:24:25 <wwoods> people who choose rawhide will stay on rawhide, which is OK if you presume a more stable rawhide
18:24:29 <warren> Might it be better for the user to opt-in to each release?
18:24:35 <Oxf13> warren: this actually doesn't have anything to do with fedora-release-rawhide being a subpackage
18:24:49 <Oxf13> the "problem" exists whether or not it is a subpackage
18:24:52 <warren> ok
18:25:14 * nirik nods.
18:25:17 <wwoods> the only thing this changes is the procedure for switching between branches
18:25:25 <warren> "I opt in to rawhide which happens to be F-13 at the moment.  I don't want to follow F-14 when we branch."
18:25:25 <wwoods> which I would like documented for testers.
18:25:46 <Oxf13> that's less easy now
18:26:06 <Oxf13> although... not impossible.
18:26:12 <nirik> well, we could push one fedora-release to rawhide that switches people to stable.
18:26:17 <nirik> then next day rawhide gets a new one.
18:26:22 <Oxf13> well, impossible without having autosigning in place
18:26:31 <wwoods> except that anyone who doesn't update on *that one day* skips that update
18:26:33 <warren> nirik: that's assuming everyone updates daily
18:26:38 <Oxf13> nirik: that's not really a long enough time
18:26:41 <nirik> yeah, true.
18:26:53 <warren> I'd really prefer that you opt-in to a particular release number and follow that forever.
18:26:58 <wwoods> we currently have a window that's something like.. 1 week? 2 week?
18:27:02 <wwoods> and people still miss it.
18:27:04 <warren> I opt-in to F-13 wherever it comes from.
18:27:15 <Oxf13> warren: easily done if you "opt-in" to the alpha release
18:27:30 <Oxf13> it's only the time prior to alpha that you can get misdirected
18:27:43 <wwoods> so people who don't wanna run rawhide.. shouldn't run rawhide
18:27:48 <wwoods> which seems pretty obvious
18:27:51 <warren> why can't we make the time prior to alpha opt-in to F-13 too?
18:28:06 <wwoods> why can't people just wait for the stupid alpha
18:28:12 <wwoods> or make the switch
18:28:20 <nirik> that would mean freezing rawhide for a week or two to get people to move to stable who want to I guess.
18:28:32 <wwoods> if you can't handle remembering to switch when alpha happens, maybe you shouldn't really be running pre-alpha stuff
18:29:09 <Oxf13> warren: mostly because it would require A) mirrormanager hacks for redirections, and B) all packages gpg signed all the time
18:29:16 <nirik> The same issue could happen there tho right, if you don't switch on the day of the branching of the next stable, you are stuck on rawhide?
18:29:25 <Oxf13> A is easy, we've done it before.  B is harder and going to take some time to get right
18:29:52 <Oxf13> nirik: you may have to yum downgrade the fedora-release package
18:30:02 <Oxf13> to move from rawhide back to the release, but yes
18:30:05 <nirik> and anything rawhide that moved on. ;)
18:30:06 <Oxf13> rawhide will move on
18:30:44 <nirik> anyhow, the subpackage for rawhide doesn't matter much for this issue... it's more to make it harder for people on a stable release to accidentally enable it.
18:31:58 <Oxf13> yep
18:32:14 <Oxf13> #agreed fedora-release-rawhide will be made a subpackage
18:32:23 <nirik> thanks!
18:32:34 <Oxf13> #action Oxf13 will implement the subpackage
18:32:43 <nirik> I look forward to not having to tell end users to re-install as often. ;)
18:32:47 <Oxf13> #action nirik will gather list of documentation that needs to be changed
18:33:42 * lmacken rolls in late
18:33:55 <Oxf13> #topic open floor
18:34:01 <Oxf13> any open topics to discuss?
18:34:07 <lmacken> wrt bodhi no frozen rawhide/crit path
18:34:18 <lmacken> I'm working on some last-minute API tweaks for autoqa, and I hope to have something in staging today or tomorrow
18:34:20 <Oxf13> #topic no frozen rawhide
18:34:36 <Oxf13> #info lmacken hopes to have something staged by tomorrow for testing of bodhi
18:34:41 <Oxf13> lmacken: anything else on that?
18:34:48 <lmacken> nada
18:34:53 <Oxf13> #topic open floor
18:35:16 <Oxf13> if nothing in a couple minutes, I'll close the meeting
18:36:54 <gholms|work> Is this the right place to bring up the review request backlog?
18:39:06 <wwoods> not really.
18:40:29 <Oxf13> #endmeeting