05:02:20 <juhp> #startmeeting I18n
05:02:20 <zodbot> Meeting started Tue Jan 19 05:02:20 2010 UTC.  The chair is juhp. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:02:53 <juhp> welcome to the biweekly i18n meeting
05:03:32 <juhp> anyone here for the meeting? :)
05:04:26 <juhp> hi nkumar
05:04:27 * jds2001 knows nothing about i18n but is here :)
05:04:34 <juhp> :)
05:04:36 * jds2001 didnt want you to feel lonesome :)
05:04:52 <juhp> you can keep us on the straight and narrow :)
05:05:02 <dychen_> hi
05:05:04 <pravins> hi
05:05:09 <tagoh3> hi
05:05:09 <kaio_monolith> hi
05:05:55 <phuang> hi
05:06:10 <juhp> I guess paragan is here too
05:06:25 <juhp> I think that is most of us
05:07:13 <juhp> I had an expression of interest from fangq to talk about 65-nonlatin.conf but not sure if he can be up at midnight... so may need to find another time for that
05:08:39 <juhp> ok
05:08:50 <epico> hi
05:08:58 <paragan> hi
05:08:59 <jni> hi
05:09:00 <juhp> hi epico
05:09:23 <epico> Hi juhp.
05:09:44 <juhp> let's get started
05:10:06 <juhp> apart from fontconfig not too many big topics today
05:11:13 <juhp> yesterday was talking to ankit (l10n) about Language Support Criteria - so just thought maybe it was worth a quick review here while we are gathered
05:11:32 <juhp> #topic LanguageSupportCriteria
05:12:24 <juhp> we have this page https://fedoraproject.org/wiki/I18N/LanguageSupportCriteria which covers the basic requirements or definition of language support
05:12:28 <pravins> its very much following https://fedoraproject.org/wiki/I18N/LanguageSupportCriteria
05:12:37 <juhp> not sure we have reviewed it before
05:13:02 <nkumar> hi
05:14:32 * juhp changes "Entry in comps" to "comps group"
05:15:10 <paragan> ok
05:15:44 <paragan> I guess we have all updated information on that page for Language support criteria
05:16:05 <pravins> hmm, must things are there
05:16:30 <juhp> ok
05:16:36 <juhp> well you guys made it... :)
05:17:56 <juhp> basically looks ok to me
05:18:15 <juhp> Anyway it is good to maintain this page and keep it clean and up to date
05:18:32 <juhp> I see roozbeth also editted a bit last year :)
05:20:18 <paragan> yeah he added orthography section
05:20:53 <paragan> but seems we need his attention more in upstream to add orthography for many new languages.
05:21:27 <juhp> ok
05:21:34 * juhp improved the language a little
05:21:37 <juhp> we better move on
05:23:16 <juhp> #topic 65-nonlatin.conf
05:23:44 <juhp> tagoh3: did you have a chance to look at fangq separate files?
05:23:58 <tagoh> juhp: no, not yet
05:23:59 <juhp> still not convinced we really need fallback upstream
05:24:09 <tagoh> is it on upstream bug right?
05:24:09 <juhp> hmm.. me neither
05:24:13 <juhp> yup
05:24:25 <juhp> tagoh: do you have time this week?
05:24:25 <tagoh> okay. have a look later
05:24:29 <juhp> thanks
05:24:40 <juhp> I will also try to look at them and we can discuss
05:25:02 <tagoh> juhp: dunno. need to work on other tasks a bit. will do my best though
05:25:05 <juhp> and perhaps we can try to talk to fangq too
05:25:11 <juhp> ok
05:25:14 <juhp> nod
05:25:39 <juhp> otherwise we maybe have to drop zenhei as zh default for now...
05:26:05 <juhp> phuang: if you have time perhaps you could look too?
05:26:54 <phuang> ok
05:27:36 * juhp just noticed "fc-list :lang=xx" on I18N/LanguageSupportCriteria
05:27:42 <juhp> phuang: you know the bug?
05:27:57 <phuang> no
05:28:00 <juhp> phuang: do you have time
05:28:01 <juhp> heh
05:30:24 <phuang> Sorry. What's the problem?
05:30:44 <juhp> http://bugs.freedesktop.org/show_bug.cgi?id=20911
05:30:45 <buggbot> Bug 20911: normal, medium, ---, keithp@keithp.com, ASSIGNED, 65-nonlatin should be updated for CJK fonts
05:30:49 <juhp> heh
05:30:58 <juhp> sounds like it will be me anyway ;o)
05:31:28 <juhp> phuang: the one we have been talking about for the last half-year...
05:35:17 <juhp> phuang: current problem that wqy-zenhei overrides vlgothic for japanese on desktop
05:35:55 <phuang> Is there a bug about it?
05:36:22 <juhp> yes
05:37:17 <phuang> Does the problem happen in Japanese locale or English locale?
05:37:35 <juhp> good question - both I guess
05:37:49 <juhp> it is not locale related I guess
05:38:03 <juhp> bug 476459
05:38:04 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=476459 medium, medium, ---, petersen, ASSIGNED, Chinese wqy-zenhei-fonts overrides Japanese default font
05:38:10 <tagoh> juhp: right - just happens when applications requires ja fonts to fontconfig
05:38:18 <juhp> it is now a F13Blocker bug
05:38:22 <juhp> right
05:38:54 <juhp> phuang: we talked about it in the last i18n fonts meeting...
05:39:00 <juhp> and many times before that
05:39:10 <phuang> ok I will check it
05:39:15 <juhp> thanks
05:39:29 <juhp> maybe it is interesting for epico too
05:40:48 <juhp> #action phuang,juhp,tagoh to check fangq's fontconfig proposal
05:41:22 <juhp> when we have some consensus we can put a comment in the bug
05:41:58 <juhp> please let me know what you find - I would very much like to get resolution on this issue soon for f13
05:42:38 <juhp> #topic F13
05:42:59 <juhp> nothing really specific just a checkin on the schedule
05:43:10 <juhp> 2010-01-26	 Feature Submission Deadline
05:43:17 <juhp> 2010-02-09	Feature Freeze
05:43:25 <juhp> 2010-02-16	 Alpha Freeze
05:43:25 <juhp> Software String Freeze
05:43:44 <juhp> well I need to update my YumLangpacksPlugin feature for fesco
05:44:04 <juhp> and QA approached me about a testday for the feature so that would be good
05:44:22 * juhp is still not sure about which comps group it can live in
05:44:30 <juhp> bit relunctant to put it into @base
05:44:34 <juhp> any thoughts?
05:45:00 <juhp> putting one's own packages in comps seems harder...
05:45:14 <juhp> well this one is pretty general anyway
05:45:23 <juhp> jds2001: maybe you have a comment?
05:45:40 <juhp> where yum-langpacks should live in comps?
05:46:09 <jds2001> ahh
05:46:15 <jds2001> lemme read scrollback
05:46:29 <juhp> just started
05:46:31 <juhp> :)
05:46:53 <jds2001> why not put it in @base?
05:46:59 <dychen_> juhp: do we want to new a group says "language support"
05:47:00 <jds2001> you can make it optional
05:47:09 <jds2001> there's already a group for that
05:47:13 <juhp> jds2001: heh lol
05:47:21 <jds2001> contains all the input methods and things
05:47:28 <juhp> well that would work yes
05:47:34 <jds2001> remind me what langpacks does again?
05:47:51 <juhp> jds2001: it pulls in langpacks for openoffice etc for your language
05:48:23 <juhp> and kde et al
05:48:25 <jds2001> ahh, how does it find that out? the system locale?
05:48:36 <juhp> currently by user locale...
05:48:45 <dychen_> jds2001, juhp: Does yum-langpack handle input methods as well?
05:48:46 <juhp> but one can also set it
05:48:54 <juhp> dychen_: hmm
05:49:04 <juhp> dychen_: not yet
05:49:42 <juhp> perhaps I should just drop it into @base and wait for people to scream at me
05:49:49 <juhp> otherwise it will never tested... ;)
05:50:06 <jds2001> is it turned on by default?
05:50:30 <juhp> when installed yes
05:50:40 <juhp> like presto
05:50:45 <jds2001> and you plan on installing it by default?
05:50:54 <jds2001> yeah, and I rpm -e yum-presto :)
05:50:54 <juhp> that is the hard part
05:50:58 <juhp> hehe
05:51:01 <juhp> nod
05:51:04 <jds2001> I have a local mirror, thank you very much :)
05:51:09 <juhp> :)
05:51:31 <juhp> I am trying to make it accessible without being in everyone's face...
05:51:43 <jds2001> yeah, that's hard.
05:51:45 <juhp> so yeah maybe optional or off is enough...
05:52:00 <juhp> or I need a yum flag perhaps
05:52:02 <juhp> right
05:52:02 <jds2001> i say test the hell out of it, and throw it in there.
05:52:10 <juhp> hmm ok :-)
05:52:12 <juhp> worksforme
05:52:32 <jds2001> worst thing that happens is someone removes it.
05:52:34 <juhp> I'll say send all flames to jds2001 ;-P   just kidding
05:52:41 <juhp> :)
05:52:46 <jds2001> but you may also get to be subject to the critpath process :/
05:53:01 <juhp> yeah I don't really need the aggro that goes with that :)
05:53:11 <juhp> nod
05:53:32 <juhp> perhaps I should just enjoy the Test Day and long life :)
05:53:53 <jds2001> i would send out a message on devel and say "yo, im doing this tomorrow unless someone says no" :)
05:54:20 <juhp> when if and who moves yum-presto to @base...
05:54:33 <juhp> jds2001: ok sounds like a plan thanks for that
05:55:22 <juhp> wonder if relnotes have opened yet
05:55:36 <juhp> we probably need some relnotes for f13 anyway
05:55:50 <juhp> like "yum install yum-langpacks" ;o)
05:56:16 <juhp> #topic open
05:56:28 <juhp> anything else before close
05:56:50 <juhp> kaio_strauss: did you have anything you wanted to raise?
05:57:07 <kaio> tables in ibus-table are repacked
05:57:24 <juhp> kaio: what's new with the packaging?
05:57:32 <kaio> on new category way
05:57:52 <kaio> cangjie and its related tables are packed in ibus-table-cangjie
05:58:34 <kaio> there are -latin, -cyrillic, -xingma, -yinma, -cantonese,etc.
05:58:34 <juhp> ok
05:58:55 <kaio> this is for reducing the maint resources I need to spend on that
05:59:16 <juhp> you mean they are all subpackages?
05:59:33 <kaio> they are in separated tarball
05:59:48 <kaio> ibus-table is not same license as the tables
05:59:52 <juhp> I am talking about fedora
06:00:09 <juhp> ah you mean upstream ok
06:00:12 <kaio> since GPLv2 allows me to upgrade to v3, all tables are in GPLv3 now
06:00:26 <juhp> kaio: so how does it affect fedora?
06:00:53 <kaio> juhp☺ which I need a few package reviews
06:01:03 <juhp> ok
06:01:13 <kaio> except -cangjie and -cantonese
06:01:40 <juhp> still unclear how it reduces maintainence but no objections so far
06:02:02 <juhp> perhaps we can share details later
06:02:30 <juhp> less works sounds good anyway :)
06:02:48 <kaio> time are consumed on editing configure.ac and autotool files
06:03:09 <juhp> if noone has anything more to discuss we can finish shortly I think
06:03:20 <kaio> building should be quite same if there is no big rebuild because of big jump from ibus
06:03:39 <juhp> kaio: so less packages??
06:04:16 <kaio> less tarball = less configure.ac, README, AUTHORS, Makefile.am, etc
06:04:26 <juhp> good
06:04:52 <juhp> but you didn't give any numbers or details of that :)
06:04:58 <juhp> thanks anyway
06:05:05 <kaio> table pack around 5 in number is appropriate I feel
06:05:22 <juhp> so only 5 packages now?
06:05:29 <kaio> now is 8
06:06:26 <juhp> ok tell me later :)
06:06:28 <kaio> cangjie, cantonese, cyrillic, latin, xingma, yinma, tv, code, (and extraphrase)
06:06:41 <juhp> aha
06:06:48 <juhp> sounds good then
06:07:09 <juhp> wonder what tv is?
06:07:28 <kaio> tv and latin could be kicked into genetic
06:07:36 <juhp> we're out of time
06:07:41 <kaio> tv = thai + vietnamese
06:07:44 <juhp> I think we better finish off
06:07:49 <juhp> hmm
06:07:54 <juhp> not too obvious
06:08:10 <kaio> you cannot watch tv with ibus obviously :P
06:08:17 <juhp> hehe
06:08:32 <juhp> thanks for the meeting everyone!
06:08:56 <juhp> #endmeeting