18:05:29 <Oxf13> #startmeeting Fedora Release Engineering
18:05:29 <zodbot> Meeting started Mon Jan 25 18:05:29 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:05:34 <Oxf13> #meetingname fedora-releng
18:05:34 <zodbot> The meeting name has been set to 'fedora-releng'
18:05:43 <Oxf13> #topic roll call
18:06:15 <Oxf13> ping: notting poelcat jwb lmacken wwoods rdieter_work spot warren dgilmore
18:06:28 * poelcat here
18:06:37 <wwoods> THUD
18:06:55 <warren> BA BA BA OOO MAU MAU BA BA OOO MA MA MAU
18:08:01 * notting is here
18:08:42 <rdieter> here
18:10:34 <Oxf13> #info members present: poelcat wwoods warren notting rdieter and Oxf13
18:10:53 <Oxf13> #topic Meeting practices
18:10:58 * lmacken here
18:11:12 <Oxf13> #info lmacken also in attendance
18:11:22 <Oxf13> recently there was a discussion about the fesco meeting notes and how they could improve
18:11:48 <Oxf13> one good suggestion was to always have an info line summarizing a topic before moving on to the next, to let readers have some idea of what's going on, so I'm going to try that.
18:11:58 <Oxf13> please help me remember to do such
18:12:09 <rdieter> good idea
18:12:22 * dgilmore is here
18:12:31 <Oxf13> #info dgilmore also in attendance
18:12:49 <Oxf13> #info discussed closing each topic out with info lines before moving on.
18:13:03 <Oxf13> I'd also like to start using tickets for meeting subjects, as I'm terrible at remembering things we're supposed to discuss
18:13:23 <Oxf13> so if any of you have topics you want discussed at a meeting, filing a ticket and using the 'meeting' keyword is a way to get it on the agenda.
18:13:33 <Oxf13> #info use tickets with 'meeting' keyword to get topics on meeting agenda.
18:13:45 <Oxf13> That's all I have for procedural stuff, any comments?
18:14:05 <dgilmore> sounds good
18:14:07 <warren> seems logical
18:14:37 <poelcat> i like it
18:15:21 <Oxf13> alright, lets move on
18:15:30 <Oxf13> #topic Test images for QA
18:15:58 <Oxf13> THere was a ticket to deliver these last week, and I did so.  I ran into a number of problems along the way but this is why we were doing it now, to work out the kinks
18:16:48 <warren> does this mean we're past the "rawhide does not build" problems?
18:16:49 <Oxf13> I delivered the images (basically a pungi compose, minus the Packages/ and {repodata,repoview}/ directories ) to alt.fp.o under the pub/alt/stage/rawhide directory
18:16:55 <Oxf13> warren: yes, we are past that.
18:17:01 <Oxf13> #info got past the rawhide does not build problem
18:17:09 <Oxf13> #info images delivered to alt.fp.o and noted in the ticket
18:17:41 <Oxf13> I talked a bit with QA and we feel that we can use a directory structure that looks kind of like /mnt/koji if we have to deliver multiple images
18:17:51 <Oxf13> rawhide-<date>/<arch>/os
18:18:12 <Oxf13> and then maintain a pair of symlinks.  One symlink would be for the tree currently being tested which will have a watcher script on it for autoqa
18:18:34 <Oxf13> another symlink would be for the "last known good" images which more people could use and we could potentially put them on the mirror system somewhere
18:18:41 <Oxf13> thus far, we haven't had a known good set of images
18:18:46 <poelcat> Oxf13: we should put this in the SOP as part of the process?
18:19:34 <jlaska> Oxf13: so presently, last known good would still point to F-12.
18:19:50 <Oxf13> poelcat: as we figure out if that's what we're going to do, yes
18:20:02 <poelcat> re: https://fedoraproject.org/wiki/Composing_test_images
18:20:33 <Oxf13> yep, I'll be getting to those later
18:20:54 <Oxf13> so I guess
18:21:22 <Oxf13> #proposal Use dated directories for test image delivery, and maintain symlinks to "current images to be tested" and "last known good test images"
18:21:28 <Oxf13> obviously I'm +1
18:21:31 <dgilmore> +1
18:21:36 <lmacken> sounds good, +1
18:21:53 <notting> +1
18:21:56 <rdieter> +1
18:22:32 <Oxf13> alright that's enough to pass.
18:22:51 <Oxf13> #agreed we will use dated directories for test image delivery and maintain symlinks.
18:23:07 <Oxf13> #action Oxf13 will work with poelcat to update the SOP reflecting this
18:23:31 <Oxf13> #action Oxf13 will work with QA team to determine symlink names and set expectations
18:24:06 <Oxf13> any last words on this topic? (which so far has been sufficiently documented for meeting minutes)
18:25:30 <Oxf13> seems not, moving on
18:25:40 <Oxf13> #topic Standard Operating Procedures
18:26:23 <poelcat> want me to drive?
18:26:26 <Oxf13> If you recall last week, we discussed attempting to tackle one SOP a week to further document what it is we do, and to better bring new contributors up to speed (and to protect against raptors)
18:26:41 <Oxf13> oh great, a netsplit.  I hope we didn't lose any of our people.
18:27:03 <Oxf13> I turn the chair over to poelcat
18:27:03 * dgilmore is here still
18:27:26 <poelcat> we worked on #2 and #5 this past week
18:27:31 <poelcat> https://fedoraproject.org/wiki/Release_Engineering_Release_Tickets
18:27:33 <poelcat> for alpha
18:27:44 <poelcat> still needing a little feedback
18:28:00 <poelcat> i think for these to be good and "raptor proof" they need to be clear enough
18:28:11 <poelcat> that someone other than Oxf13 could walk through
18:28:18 <poelcat> the steps and accomplish the task
18:28:35 <poelcat> so two specific urls are
18:28:36 <Oxf13> I agree, but that will be a work in progress, as some of the concepts are pretty deep, like sigul
18:28:48 <poelcat> #info https://fedoraproject.org/wiki/Composing_test_images
18:29:00 <poelcat> #info https://fedoraproject.org/wiki/Create_release_signing_key
18:29:11 <Oxf13> I've got those up on my screen to review today
18:29:21 <Oxf13> review and/or edit
18:29:23 <poelcat> great
18:29:41 <poelcat> should we pick #6 or #7 for our goal for this week?
18:30:04 <poelcat> it would be helpful if other releng-ers look these pages over too
18:30:28 <poelcat> "sign packages for alpha" or "purge orphans" for $100
18:30:33 <Oxf13> jwb could not make today's meeting, but I've asked him to document the steps he uses next time he does a updates push
18:30:44 <poelcat> awesome
18:30:53 <Oxf13> #info jwb is working on documenting the steps for doing a bodhi updates push
18:31:07 <Oxf13> I'm not sure how soon he can have that done, as his day job has been really busy lately, but he is working on it.
18:31:22 <Oxf13> poelcat: since we have an orphan purging coming up soon, I could work on that one
18:31:49 <poelcat> Oxf13: send me the text and I'll put 'wikify' it :)
18:32:10 <Oxf13> #action Oxf13 will work on documenting the steps for purging orphans
18:32:45 <Oxf13> poelcat: it seems to me that by working from the top down, we wind up getting to document as we actually do the task, which has great benefit, but could mean some delay in the later items
18:33:32 <poelcat> true, i just like that it feels like we are building momentum :)
18:33:39 <Oxf13> #action All releng members who perform releng tasks are encouraged to document the steps if no SOP currently exists for your task.
18:33:39 <poelcat> we can skip around too if that helps
18:34:01 <poelcat> #info if you don't have time to format for wiki send to poelcat the wiki-monkey
18:34:03 <Oxf13> #action Oxf13 will review the two pending SOP documents today
18:34:07 <Oxf13> Anything else on this topic?
18:34:17 <poelcat> all good
18:36:00 <warren> is IRC working?
18:36:12 <dgilmore> yes warren
18:36:32 <Oxf13> Ok, I'm out of topics, so #topic open floor
18:36:36 <Oxf13> #topic open floor
18:37:11 <dgilmore> the new /mnt/koji should be delivered on friday
18:37:37 <Oxf13> #topic New /mnt/koji
18:37:46 <dgilmore> some time next week i hope we have it up and running and ready for testing
18:37:47 <Oxf13> #info new /mnt/koji hardware should be delivered on Friday
18:38:06 <dgilmore> I want to test doing multiple mashes and composes on it
18:38:13 <Oxf13> dgilmore: given how much content is on current /mnt/koji and how slow it is, what are your plans to populate the new hardware?
18:38:49 <dgilmore> Oxf13: rsync it during US nights
18:39:13 <Oxf13> dgilmore: US nights is right when we're doing our rawhide composes
18:39:30 <dgilmore> Oxf13: right.  there really is not a good time to do it
18:39:31 <Oxf13> which isn't a huge deal, it'll just slow things down a bit
18:39:34 <Oxf13> indeed
18:39:44 <Oxf13> is there a backup we could restore from to prime the pump as it were?
18:39:53 <dgilmore> but US nights are when people are using it the least
18:40:08 <dgilmore> Oxf13: the last backup is really old
18:40:23 <dgilmore> we have not been able to back it up propperlly
18:40:24 <Oxf13> dgilmore: yeah, but the packages content doesn't really change
18:40:32 <dgilmore> mmcgrath: is working on a new backup solution for it
18:40:46 <dgilmore> Oxf13: the last backup is months old
18:40:50 <dgilmore> like 3 or 4
18:41:16 <Oxf13> well, I trust you here.  I'm looking forward to being able to test it
18:41:38 <Oxf13> although I'm not sure we can generate the same kind of day to day usage without pointing say kojipkgs.fp.o to it once updated
18:41:47 <mmcgrath> dgilmore: the last good backup of nfs1 was from before the move I guess.
18:42:26 <Oxf13> We'll do our best.
18:42:34 <Oxf13> oh, related to this I do have another topic or two
18:42:57 <dgilmore> Oxf13: we cant fully give ita  good hiding.  but we should be able to give it a shot by doing mashing and composing etc
18:43:13 <Oxf13> dgilmore: indeed
18:43:39 <Oxf13> Anything else on this?
18:43:51 <notting> 'hooray'?
18:44:03 <Oxf13> I reserve celebration :/
18:44:26 <dgilmore> nothing else. just wanted to update the status of the new hardware
18:44:31 <Oxf13> ok
18:44:55 <Oxf13> #info Discussed new hardware incoming, and the need to start load testing it hopefully next week or hte week after
18:45:01 <Oxf13> #topic dist-git update
18:45:42 <Oxf13> I did refresh the git repos last week
18:46:02 <Oxf13> and in doing so, I also figured out something that was wrong with git:// cloning and picking up changes that have been pushed since the refresh
18:46:14 <Oxf13> (turns out I was running the git daemon with the wrong group permissions)
18:46:58 <Oxf13> I as also able to successfully trim the kernel.git repo a bit, getting rid of a weird branch that somehow made it onto master (myoung stuff), and also trimmed the changelog entries of spurious (to git) first lines of date, name, n-v-r
18:47:23 <Oxf13> Next time I refresh the repos, the same first line trimming will be performed across all the repos, which will make logs look a bit more informative.
18:48:38 <Oxf13> I've also been trying to work with SmootherFrOgZ to get some contributions applied to the fedpkg program, we just need to meet up on IRC and walk through patch generation/emailing
18:48:55 <Oxf13> #info repos were refreshed, and some trimming was done of kernel.git
18:49:12 <Oxf13> #info SmootherFrOgZ has contributions to give to fedpkg, just have to work out patch submission
18:49:41 <Oxf13> We are getting close to trying actual builds of software, which will require a test koji instance
18:49:53 <Oxf13> one that I can modify to use fedpkg to do the building
18:50:21 * ricky notes that we are in the process of getting public IPs for koji.stg.fp.o
18:50:40 <ricky> So that will hopefluly be ready later today.
18:50:47 <lmacken> ricky: excellent
18:51:05 <Oxf13> dgilmore: do you think we could accomplish multiple goals here, and put koji.stg.fp.o on the new /mnt/koji ?
18:51:20 <Oxf13> that way we can test doing builds from git and composing on new hardware?
18:51:36 <ricky> koji.stg has ro on /mnt/koji at the moment
18:51:51 <Oxf13> k
18:52:31 <Oxf13> #info dist-git project will soon need to test building with Koji in stg
18:52:42 <Oxf13> #info koji.stg.fp.o will be ready soon for public use
18:53:07 <Oxf13> #info We may be able to combine new /mnt/koji hardware testing needs and dist-git building needs into the same testing
18:53:34 <Oxf13> Anything else on dist-git?
18:54:18 <Oxf13> alright, back to open floor
18:54:22 <Oxf13> #topic open floor
18:54:29 <poelcat> how are we feeling about starting NFR in 2 weeks?
18:56:33 <Oxf13> not so good
18:56:37 <Oxf13> #topic No Frozen Rawhide
18:56:45 <Oxf13> notting: lmacken: anything to report on your fronts?
18:57:13 <notting> no
18:57:54 <lmacken> Oxf13: nope, waiting on koji.stg to test pushing
18:58:29 <Oxf13> #info waiting on koji.stg for further testing
18:58:45 <Oxf13> Ok, well I have some hope, but hope and time are dwindling.
18:59:31 <Oxf13> Ok, we're coming up on the hour mark.  Any last minute topics, or I'll close the meeting
19:00:39 <Oxf13> alright
19:00:42 <Oxf13> #endmeeting