15:06:30 <rjune> #startmeeting
15:06:30 <zodbot> Meeting started Tue Feb  9 15:06:30 2010 UTC.  The chair is rjune. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:39 <rjune> #chair tk009 adamw
15:06:40 <zodbot> Current chairs: adamw rjune tk009
15:07:02 <rjune> Good [Morning | Afternoon | Evening] zappers.
15:07:08 <rjune> #topic roll call
15:07:11 <adamw> morning. definitely morning.
15:07:13 <rjune> Who's here
15:07:14 <akiase> evening :)
15:07:19 * akiase is here
15:07:22 <Tech33> here
15:07:28 * iarlyy here = )
15:07:28 * comphappy here
15:07:29 <waltJ> good afternoon.
15:07:32 <iarlyy> hey there
15:07:34 <jfalco> New guy and here :)
15:07:35 <adamw> hi all
15:07:38 <adamw> yaaay
15:07:38 * tk009 is here
15:07:45 <adamw> mcepl: ?
15:07:52 <tk009> hello jfalco and welcome
15:07:58 <jfalco> ty
15:08:05 <mcepl> yes
15:08:13 <mcepl> hi y'all
15:08:13 <adamw> wow, good turnout.
15:08:18 <rjune> great
15:08:28 <rjune> I have to step away for a second, tk009 can you hit the next topic?
15:09:04 <adamw> agenda: http://lists.fedoraproject.org/pipermail/test/2010-February/088365.html
15:09:19 <tk009> #topic [adamw] Orphaned package response update
15:09:35 <adamw> okay, so I actually got un-lazy and did something about this yesterday
15:09:36 <tk009> I already saw this one on the list
15:09:53 <tk009> wording looked fine to me
15:09:58 <adamw> I sent a draft text to the list, and john k kindly corrected my stupidity
15:10:06 <rjune> back
15:10:13 <adamw> was I supposed to be doing anything beyond writing the text block? I forget
15:10:16 <tk009> I didn't even notice that until he mentioned it
15:10:21 <tk009> good catch by him
15:10:29 * cebbert here
15:10:34 <adamw> hi cebbert
15:11:08 <tk009> does anyone want to add anything on this topic?
15:11:08 <adamw> i can talk to mcepl about doing some kind of automated spam on bugs we know are orphan components, I guess?
15:11:33 <tk009> are there that many of them?
15:11:33 <adamw> the draft is http://lists.fedoraproject.org/pipermail/test/2010-February/088369.html , for the record
15:11:45 <adamw> orphans? off the top of my head, I don't know.
15:11:55 <tk009> #link http://lists.fedoraproject.org/pipermail/test/2010-February/088369.html
15:12:25 <tk009> there wernt many before unless something changed, faily easy to go through by hand
15:12:37 <iarlyy> I know orphans packages are removed from development cycle, isnt?
15:13:09 <adamw> yeah, unblocked orphans (ones which aren't dependencies for other packages) get removed
15:13:16 <mcepl> adamw: that's probably not for me ... cannot just mass changing of the query be used?
15:13:16 <tk009> yes there are removed at some point
15:13:17 <iarlyy> why not disabled from bz, because remove them would remove some useful documentation
15:13:50 <adamw> okay then, for now let's just go with adding the text I wrote to our list i guess
15:13:56 <mcepl> adamw: your text looks lovely
15:13:58 <tk009> kk
15:14:01 <adamw> thanks :P
15:14:05 <akiase> +1 :)
15:14:28 <tk009> #topic [adamw] Action item update: Jetpack and stock responces.
15:14:41 <Tech33> this one is mine
15:14:44 * adamw has no idea what the heck this is :)
15:14:49 <adamw> oh good. :)
15:14:53 <tk009> =)
15:15:02 <tk009> fire away Tech33
15:15:32 <Tech33> my issue is that to make a button for all of the stock resp makes too many buttons, so I'm going to try and code a patch to jetpack for mcepl to give me mulltiple row capability in jetpack
15:15:43 <Tech33> I probably just lost most of you with that
15:16:01 <rjune> <magic happens> it works better
15:16:06 <adamw> can we have the Fisher Price version?
15:16:10 <tk009> I cuaght the conversation earlier
15:16:25 <mcepl> I was thinking about the issue of multiple rows, I didn't do it, because I think it could lead to overuse of the buttons, but let's try what you can do.
15:16:27 <Tech33> I'm going to try to craft a new json for new bugzappers, that has all of the stock responces as buttons
15:16:44 <tk009> we have more responces than we have room for buttons, that is the gist yes?
15:16:52 <mcepl> tk009: yes
15:16:57 <Tech33> because there will be too many buttons, we will need two top rows of buttons and two bottom
15:17:00 <Tech33> yes
15:17:03 <mcepl> (well, Tech33 has more answers than I made buttons)
15:17:20 <adamw> isn't there a better interface option than Piles O' Buttons?
15:17:28 <adamw> like, a drop-down or something?
15:17:44 <mcepl> adamw: well, buttons are much faster ... remember, this is designed to be FAST
15:18:06 <adamw> well there's a tipping point where there's so many buttons it no longer is, but I take your point
15:18:13 <mcepl> moreover, you can automaticize location of the button, you cannot automate scrolling in the list
15:18:16 <adamw> (and that tipping point is called 'kde 3' :>)
15:18:27 <mcepl> +1 :D
15:18:44 <tk009> update this one next week?
15:19:02 <adamw> #info tech33 is working on improvements to jetpack to handle lots of stock response buttons
15:19:41 <Tech33> that will do
15:20:14 <tk009> moving on then
15:20:27 <tk009> #topic [adamw] blocker bug review on friday
15:20:36 <mcepl> adamw: http://oreilly.com/news/zenclavier_1299.html (for background)
15:21:02 <adamw> alright! so friday is the second f13 blocker bug review meeting
15:21:31 <adamw> for anyone who doesn't know, that's a meeting where we go through all the bugs listed as blocking the next release (in this case F13 alpha)
15:21:39 <adamw> we make sure they're really blocker bugs and make sure they're being handled properly
15:22:00 <adamw> so first of all, just promoting the meeting - the more people who come along and offer opinions and bring up bugs that haven't been considered, the better
15:22:11 <mcepl> adamw: how many of them are there?
15:22:17 <adamw> at present not a huge amount
15:22:20 <adamw> here's the references:
15:22:26 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=f13alpha
15:22:30 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=f13beta
15:22:32 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=f13blocker
15:22:39 <adamw> those are the alpha, beta and final blocker bugs
15:23:01 <adamw> the second thing is: i wanted to make sure everyone knows about the process
15:23:26 <adamw> if you come across any really serious bugs while zapping, that you think are serious enough they need to be fixed before alpha, beta or final, please add them to the blocker list
15:23:43 <adamw> it's very easy: just put the word 'f13alpha', 'f13beta' or 'f13blocker' in the 'Blocks:' field
15:24:02 <Tech33> question, when you are done
15:24:04 <adamw> even if you're not sure, please do it - that's what the review meetings are for
15:24:07 <adamw> Tech33: shoot
15:24:15 <Tech33> nm, you just answered it :)
15:24:17 <adamw> right
15:24:21 <adamw> always err on the side of adding the bug
15:24:31 <Tech33> commitee to remove, not add
15:24:38 <adamw> we'd far rather have to spend 2 minutes in a blocker meeting taking it off the list, than miss it and have to live with it in the release for months
15:25:07 <adamw> you can use the release criteria as a guide - https://fedoraproject.org/wiki/Fedora_Release_Criteria
15:25:29 <adamw> i did just want to check in briefly with tech33 and mcepl in particular as they do X triage and I've totally not kept up with X bugs this cycle
15:25:39 <adamw> are there any you're particularly worried about?
15:26:06 <Tech33> I scanned through the nv/noveau and didn't see any, or maybe one, but I'm going to ask after about the one
15:26:17 <adamw> awesome
15:26:20 <adamw> how's ati looking mcepl?
15:26:36 <mcepl> adamw: I am fighting hard (against personal issues) to keep up with bugs, but I am mightily slided towards RHEL bugs.
15:26:40 <adamw> alright
15:26:46 <mcepl> fighting with it
15:26:47 <adamw> i'll take a quick look through the list then, take the pressure off you
15:27:09 <akiase> what time is the bug review meeting on friday?
15:27:57 <adamw> good question.
15:28:07 <adamw> hmm, I just noticed I think I put a nonsensical time on the last meeting :)
15:28:18 <adamw> it says '15:00 UTC (11 AM EDT)' but I think that's only valid during daylight savings
15:28:20 <rjune> LOL
15:28:43 <adamw> so let's say 11am eastern time
15:28:44 <rjune> EST is GMT-5
15:28:50 <akiase> ok
15:28:55 <adamw> which is I believe 16:00 UTC, during daylight savings
15:29:03 <adamw> i'll be sure to put a sane time on the next announcement, heh
15:29:08 <tk009> that meeting is always held in the bugzappers channel for those that don't know
15:29:12 <rjune> so 1500 UTC is indeed 1100 EDT.
15:29:16 <rjune> though, it's rather odd.
15:29:40 <adamw> okay. so the time I wrote was true, just not very helpful since we're not in daylight time right now. heh.
15:29:52 <adamw> yes, the meeting happens in -bugzappers
15:30:09 <adamw> which isn't really ideal, but mostly because near release time it can go on for *ages* and we didn't want to block this channel for all that time
15:30:18 <adamw> around alpha, though, it's usually only an hour or so.
15:30:25 <tk009> it really has nt been a problem
15:30:36 <mcepl> (and "ages" could mean almost whole day)
15:30:55 <akiase> ok :)
15:31:01 <adamw> so yeah, please do come along to the meeting - it's interesting to watch even if you don't have anything to add - and add any issues you're worried about to the list
15:31:17 <adamw> even if it turns out not to be a blocker, you don't get docked Fedora Points or anything :)
15:31:46 <tk009> and there are always cookies
15:31:57 <akiase> yay! :)
15:32:17 <tk009> moving on
15:32:24 <tk009> #topic [tk009] Meeting time change update
15:32:44 <tk009> okay i am have major fail on this one so far
15:32:53 * adamw hands tk009 the cookie of failure
15:32:58 <tk009> #link https://fedoraproject.org/wiki/Bugzappers_meeting_matrix
15:33:11 <tk009> the atrix is there I just need to send the email out to test
15:33:17 <tk009> matrix*
15:33:22 <adamw> since we have a lot of people here right now - how is this meeting time for everyone?
15:33:25 <adamw> is it good or awkward?
15:33:27 <tk009> it will go out right after the eeting
15:33:40 <akiase> no problem for me
15:33:40 <rjune> what will we eet?
15:33:49 <tk009> meet*
15:33:56 <tk009> dont hate on my keyboard
15:33:58 <tk009> =P
15:34:11 * Tech33 hands tk a new emmmm
15:34:13 <tk009> this time is getting harder for me
15:34:27 <tk009> 2 hours from now is better for me personallyu
15:34:39 <tk009> 1800 UTC
15:34:41 <rjune> it's rough on my wife too
15:35:00 <tk009> 1700 rather
15:35:03 <adamw> anyone else?
15:35:13 <akiase> doesn't matter for me
15:35:24 <tk009> we didn't change it last time, that may be the case again
15:35:27 <rjune> don't matter to me.
15:35:36 <adamw> alright, let's see what happens with the email
15:36:21 <Tech33> next?
15:36:36 <adamw> #info tk009 about to send out an email about the meeting time change
15:36:44 <tk009> #topic [tcpip4000/tk009] Action item update: Report on inactive members.
15:36:58 <tk009> is tcpip4000 here?
15:37:18 <mcepl> sorry, for being off for a second, but 1800UTC is off limits for me ...
15:37:30 <tk009> 1700 I meant mcepl
15:37:38 <tk009> but nothing may change anyway
15:37:48 <mcepl> that's bad but I will think about it
15:38:14 <tk009> okay so tcpip made an effort to contact all bugzappers and get their status
15:38:15 <adamw> no tcpip4000 i don't think
15:38:46 <tk009> he created a list of what he got for responses
15:38:59 <tk009> it wasn't bad only 23 names
15:39:01 <adamw> nice
15:39:20 <tk009> now that we have this list what should we do with it
15:39:41 <tk009> the list has eail addresses in it so I have not created a link
15:39:56 <tk009> I need to add the nicks
15:40:29 <tk009> now that we know 23 mebers are AWOL do we do anything about it
15:40:44 <tk009> is it our place to do anything?
15:41:05 <Tech33> are any of them listed on the triagers page as being resp for anything?
15:41:12 <tk009> no
15:41:28 <adamw> then there's nothing to do afaik
15:41:28 <Tech33> and everyone who IS listed has responded?
15:41:32 * mcepl would vote for ignoring it .. 23 is not that bad
15:41:35 <Tech33> I agree with adam
15:41:36 <adamw> that's the list of active triagers
15:41:46 <adamw> we initially wanted to do this check just to make sure that list was accurate
15:42:26 <jfalco> wait, 23 active or 23 AWOL?
15:42:33 <tk009> AWOL
15:42:41 <tk009> 56 active
15:42:45 <jfalco> k
15:42:47 <tk009> or that responded
15:43:11 <tk009> okay moving on
15:43:31 <tk009> #topic [tk009] Action item update: Housekeeping procedures for closing
15:43:35 <tk009> tracker bugs and unresolved bugs that remain on the tracker bug(s)
15:44:06 <tk009> this is another fail, I only really knuckled down on this last night
15:44:22 <tk009> I need to contact poelcat and confir what I am going to do
15:44:38 <tk009> but it shouldn't be the problem I thought it first was
15:44:56 <tk009> I will jsut be closing the blockers not the attached bugs
15:45:49 <tk009> there will need to be soething written up on the wiki for this. Once I have the steps down I will post it for review
15:47:20 <tk009> some want to berate me or have something to add on this one?
15:47:25 <tk009> =)
15:47:30 <adamw> #info tk009 working on the tracker bug closing policy, will just need a wiki add
15:47:35 <adamw> nope, sounds fine to me
15:47:42 <akiase> nope :)
15:47:55 <tk009> #topic Open Floor
15:48:00 <tk009> bring what ya got
15:48:25 * adamw doesn't have anything extra
15:48:36 <adamw> are our new members okay with the process so far? unsure about anything?
15:48:59 * jfalco wonders where he is needed most
15:49:11 <rjune> anaconda needs people
15:49:15 <rjune> do you know Python?
15:49:20 <tk009> and C
15:49:29 <tk009> and can do 10+ hours
15:49:32 <tk009> a week
15:49:37 <adamw> yeah, we're kind of at a tricky point where the areas that *really* need help are the most sticky ones
15:49:41 <adamw> anaconda, kernel, xorg a bit
15:49:51 <jfalco> no C, a little Python, and 10 hrs a day sometimes
15:49:55 <adamw> besides those, it's mostly just Pick A Component
15:50:06 <pjones> also you've got to be able to deal with a bunch of egomaniacal assholes ;)
15:50:13 <tk009> lol
15:50:17 <tk009> silly pjones
15:50:30 <jfalco> lol
15:50:41 <mcepl> adamw: I think I don't have prerequisites on xorg bug triage
15:50:48 <adamw> pjones is one of the anaconda guys :)
15:51:00 <adamw> mcepl: sure, but it does require a reasonable amount of...general knowledge i guess i'd say
15:51:07 <mcepl> (I don't care about any programming language, and bug triage as much as you can)
15:51:10 <rjune> pjones, we're not egomaniacl
15:51:18 <pjones> rjune: I meant us!
15:51:18 <akiase> is that list up to date? http://fedoraproject.org/wiki/BugZappers/Components_and_Triagers
15:51:22 <mcepl> yes, willingness to learn and attention to detail, yes
15:51:27 <adamw> akiase: pretty close, yup
15:51:31 <Tech33> akiase: yes
15:51:58 <adamw> jfalco: so yeah if you're willing to dive into Xorg contact mcepl, if you're willing to dive into anaconda let me or pjones or denise know
15:52:17 <pjones> adamw: dcantrell is our leader now.
15:52:28 <adamw> pjones: ah, yeah, I forgot
15:52:41 <adamw> anyway, if you're not sure poke me and I'll poke the appropriate person
15:52:42 <jfalco> adamw: sound good, let me have a look around and I'll get back to you guys
15:52:52 <adamw> jfalco: excellent, i'll check back in with you in a few days
15:52:58 <jfalco> sounds good
15:53:01 <akiase> are  there any other components that you would recommend to a beginner like me? =)
15:53:40 <tk009> akiase is there one that really pisses you off? that is how i pick =)
15:53:57 <adamw> akiase: i can give you general advice - look for a component with an active (ideally friendly :>) maintainer and a reasonably small list of bugs
15:54:03 <adamw> it keeps things manageable when you're starting out
15:54:21 <akiase> ok, thanks for the advices :)
15:54:51 <adamw> anyone know why the 'need help' column is set to 'no' for almost all components?
15:54:55 <akiase> but there are so many components with "No" ?
15:54:56 <adamw> i don't remember it always being that way...
15:55:01 <adamw> yeah i'm wondering about that
15:55:03 <Southern_Gentlem> adamw,  i need to talk to you a couple of minutes after the meeting please
15:55:06 <tk009> I don't know
15:55:14 <adamw> Southern_Gentlem: sure
15:55:33 <tk009> its been like that for a month or so at least
15:55:52 <jfalco> yeah that need help, threw me for a loop, I almost didn't join cause it looked like ya'll had it covered :)
15:56:10 <tk009> we'll have to look in to that
15:56:12 <adamw> yeah
15:56:28 <adamw> #action tk009 and adamw to look into preponderance of 'nos' on the needs help? list
15:56:41 <tk009> kk wrapping it up then for today
15:56:47 <tk009> althing else?
15:56:50 <tk009> anything*
15:56:54 <akiase> nope
15:57:12 <adamw> thanks for coming out everyone!
15:57:13 <tk009> thank you all for coming =) nice turn out
15:57:24 <tk009> I will do the recap
15:57:32 <tk009> #endeeting
15:57:37 <tk009> #endmeeting