21:01:04 <kanarip> #startmeeting Spins SIG
21:01:05 <zodbot> Meeting started Mon Feb 15 21:01:04 2010 UTC.  The chair is kanarip. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:13 <kanarip> #topic Roll Call
21:01:16 * kanarip here
21:01:16 * brunowolff is here
21:01:22 * nirik is sorta around, but working on work stuff too.
21:01:26 <kanarip> biertie, ping
21:01:41 <biertie> right
21:01:47 * biertie is here
21:02:15 <kanarip> alright
21:02:19 <kanarip> i guess maxamillion is here too ;-)
21:02:26 <maxamillion> hi hi
21:02:29 <biertie> no, he's faking
21:02:54 <kanarip> #topic Agenda
21:03:04 <brunowolff> Moblin merge?
21:03:11 <brunowolff> Games spin status
21:03:13 * sdziallas hollers
21:03:15 <brunowolff> lzma update
21:03:20 <sdziallas> mini ks?
21:03:27 * sdziallas shuts up, listens
21:03:47 <kanarip> and Makefile, autofoo
21:04:12 <kanarip> #topic Moblin Merge
21:04:46 <maxamillion> (side note: was that as way out of left field as I thought it was or did someone know something and I'm just out of the loop?)
21:05:15 <brunowolff> I saw it happened and was wondering if it was going to have any significant affect on the spin?
21:05:32 <brunowolff> Do we need to change the name or worry about trademarks again?
21:05:38 <biertie> probably no
21:05:39 <biertie> not
21:05:53 <kanarip> has it been approved by the board carrying the moblin name?
21:05:53 <maxamillion> should we ask legal about it?
21:06:03 <biertie> yes maxamillion
21:06:09 <sdziallas> I haven't talked to Peter for some days lately. Not exactly sure what his plans are...
21:06:11 <biertie> but moblin 2 stays moblin
21:06:42 <biertie> so since meego isn't really released yet, and we don't use it yet
21:06:46 <biertie> I don't think there is a problem
21:07:04 <maxamillion> I suppose we might also want to check and see if there has been any code changes and see if there are more bits that need packaging, or if there is a new build needed, or possibly $other
21:07:20 <maxamillion> well yeah, that's a good point
21:07:29 <biertie> meego will be qt based
21:07:36 <biertie> while moblin is gtk based, right?
21:07:47 <kanarip> afaik, yes
21:07:51 <maxamillion> biertie: yes
21:08:03 <kanarip> but i'm probably the least familiar with moblin/meego here, too ;-)
21:08:04 <maxamillion> so its going to be a complete rewrite or fork
21:08:32 <kanarip> so, this requires no action or intervention then, for Fedora 13?
21:09:21 <biertie> I don't think moblin 2 will change, no
21:09:28 <kanarip> ok
21:09:30 <kanarip> #agreed No action pending on the Moblin Spin (merge)
21:09:31 <biertie> they didn't announced that anyway
21:09:40 <kanarip> #topic Games Spin status
21:09:45 <maxamillion> yeah, I can't see moblin2 changing at all since it is already released
21:09:57 <kanarip> brunowolff, vous avez le donner de la parole
21:10:08 <brunowolff> It's building again and I have been running size tests in the nackground yesterday and today.
21:10:26 <brunowolff> It looks like I will need to drop a big game for F13. Probably alien arena,
21:10:34 <brunowolff> I'll commit something tonight.
21:11:15 <brunowolff> I may put openoffice back to match desktop or I might stick with abiword.
21:11:22 <kanarip> which will probably leave the games spin in very good shape for F13, as far as the size is concerned, no?
21:11:35 <kanarip> dropping a big game like alien arena, that is?
21:11:44 <brunowolff> Yes, alien arena is over 250 mb.
21:12:08 <kanarip> anything more on the games spin?
21:12:21 <brunowolff> Not directly move on to lzma update.
21:12:37 <kanarip> #topic lzma update
21:12:44 <brunowolff> Good news there.
21:12:50 <kanarip> brunowolff, vous avez le donner de la parole (encore) ;-)
21:13:00 <brunowolff> Full details are in https://fedoraproject.org/wiki/Features/LZMA_for_Live_Images
21:13:20 <brunowolff> But in short Lougher added an xz wrapper that works with fedora.
21:13:35 <brunowolff> My test showed a 10% reduction in size of the games spin.
21:13:58 <brunowolff> I am still looking at F14 or an update for F13 not release for this.
21:14:08 <sdziallas> that's sweet! (10 %)
21:14:12 <kanarip> maybe also mention on the LZMA feature page, the current size of the games spin
21:14:39 <kanarip> just to give people an idea of the importance of trimming the squashfs image by 10%
21:15:14 <brunowolff> OK. At the time it was from about 4.3 to 3.9 GB.
21:15:42 <brunowolff> I can use the rough numbers now and fill in some more accurate ones later.
21:16:37 <brunowolff> I need to hear back from Kyle, but squashfs-tools should go into rawhide very shortly after the branch.
21:17:12 <brunowolff> It will be about a month for the 2.6.34 kernel, depending on where fedora kernel development goes.
21:17:37 <brunowolff> They might concentrate on 2.6.33 since that will probably be used for the F13 release.
21:17:51 <kanarip> i think that's the case, yes
21:17:58 <brunowolff> I'll make up an enhancement proposal for livecd-creator.
21:18:11 <kanarip> we encountered some exotic issues with the 2.6.3x series in our respins as well
21:18:24 <brunowolff> Basicly I want the default to be lzma with an option to change it.
21:18:55 <brunowolff> That's the current status.
21:19:00 <kanarip> thanks brunowolff
21:19:10 <nirik> good work on this brunowolff
21:19:20 <kanarip> #topic Mini kickstart
21:19:28 <kanarip> huff, are you around?
21:19:42 * kanarip has not seen the mini ks in spins-kickstart yet
21:20:00 * sdziallas neither, but would love to - is there anything we can do to get this done soon-ish?
21:20:33 <kanarip> yes of course, just include the mini.ks
21:21:19 <sdziallas> as in: take the one from pbrobinson and put it in for now?
21:21:47 <kanarip> sdziallas, yes
21:22:13 <sdziallas> kanarip: awesome, I can take care of this and adjust the spins in question accordingly.
21:22:27 <kanarip> sdziallas, also update the Makefile.am when you do so
21:22:34 <sdziallas> kanarip: actually... I guess we should probably import the moblin spin, too, if we want it for alpha / in time, right?
21:22:42 <sdziallas> kanarip: okay, I'll do that.
21:23:04 <kanarip> sdziallas, yes
21:23:21 <kanarip> #agreed kanarip to update the Makefile.am / configure.ac (done already, pushed)
21:24:02 <kanarip> #agreed sdziallas to pull in the fedora-live-mini.ks and update Makefile.am accordingly, bumping the Z in the X.Y.Z versioning in configure.ac
21:24:24 <kanarip> #agreed sdziallas to pull in the fedora-livecd-moblin.ks as well (again updating the Makefile.am and so forth)
21:24:45 * sdziallas will do so immediately post-meeting.
21:24:50 <kanarip> sdziallas, thanks
21:25:10 <sdziallas> merci ;)
21:25:11 <kanarip> sdziallas, test your changes with a simple "autoreconf -v && ./configure && make rpm"
21:25:32 * kanarip has one more topic
21:25:40 <kanarip> #topic Board SWG: Spins
21:26:04 <huff> kanarip: im here now
21:26:10 * huff reads up
21:26:16 <kanarip> #link http://lists.fedoraproject.org/pipermail/spins/2010-February/000996.html
21:26:30 <kanarip> huff, concerning the mini.ks shuffle/merge
21:27:07 <huff> kanarip: what I would like to see happen is AOS ks becomes mini.ks
21:27:20 <huff> and get modified to make smaller and more generic
21:27:39 <kanarip> sdziallas, is that sustainable for you guys?
21:28:11 <sdziallas> kanarip: well, I'd be happy with it as long as we can get either a mini-x thing on top of it or are allowed to put the required packages into the spins ks.
21:28:30 <sdziallas> kanarip: so generally yes - we'd need to figure out whether the livesys stuff from %post would go, though.
21:28:46 <kanarip> sdziallas, does the aos.ks have sufficient of base.ks's scripting to make sure the spin behaves properly?
21:28:58 <sdziallas> huff: if I understand you correct then this is currently not part of AOS, is it?
21:29:06 <kanarip> sdziallas, that's my point exactly
21:29:07 <huff> not as a livecd
21:29:13 <huff> aos is basicly just a min package set
21:29:38 <kanarip> huff, the need for a mini.ks is the minimal package set + the scripts that set the spin up as a spin
21:30:47 <huff> ok do you want me to add that?
21:31:32 <kanarip> or...
21:31:44 <maxamillion> cwickert: welcome
21:31:49 <cwickert> sorry to be late
21:32:04 <sdziallas> kanarip: we could revive the scriptlet attempts from ~ F9... but it's probably a bit of late notice for that
21:32:08 <kanarip> fedora-live-mini.ks contains the scripts and the fedora-live-aos.ks for the packages
21:32:28 <kanarip> fedora-live-base.ks contains fedora-live-mini.ks (for the scripts and the minimal set of packages) and the extra packages
21:32:45 <kanarip> sdziallas, yeah, either of these changes seem a little late to me anyway
21:33:19 <kanarip> i'd rather make the rigorous changes post-f13
21:33:19 * sdziallas mhms.
21:33:35 <kanarip> or rather, after we branch off master to F-13
21:35:11 <sdziallas> so how do we proceed here? just import the old mini.ks and do minor mods if needed - or put in the aos.ks adding a bunch of stuff to it.
21:35:36 <kanarip> sdziallas, i'd favor pulling in mini.ks and leaving the rest as-is
21:36:07 <kanarip> shall i call a vote?
21:36:51 <sdziallas> sounds good.
21:37:12 <kanarip> vote: pull in mini.ks as-is and use that for soas and moblin (+1) or use the aos ks and copy the scripts from base.ks (+0)
21:37:14 <kanarip> +1
21:37:51 <maxamillion> +1
21:37:56 <biertie> +2
21:38:13 <brunowolff> Weak +1
21:38:27 * nirik is fine with whatever the affected spins want to do... but weak +1 here I guess.
21:38:45 * sdziallas is +1, but would like to see the AOS thing done afterwards.
21:38:59 <huff> I agree with sdziallas
21:39:54 <sdziallas> as in "afterwards" = "make sure we get it done altogether in time" :)
21:40:11 <kanarip> biertie, your vote is invalid
21:40:20 <biertie> ;)
21:40:28 <biertie> I'm fat, so I count for 2
21:40:35 <nirik> perhaps after we branch that could land in the head branch?
21:40:36 <kanarip> but we have sufficient +1's for a majority anyway
21:40:37 <sdziallas> huff: I'd be happy to help with testing / nuking randomly annoying package dependencies, but you guys did already the work and it just needs to be integrated in the repo at some point.
21:41:05 <kanarip> biertie, no you're not fat, and no you do not count for 2 even if you were
21:41:21 <sdziallas> nirik: +1
21:41:22 <biertie> :(
21:41:27 <kanarip> #agreed mini.ks to be pulled in, soas and moblin to use mini.ks
21:41:51 <kanarip> nirik, we can branch for F-14-devel now and make the changes, have them fall back on master post-F-13 release?
21:42:18 <nirik> dunno. whatever works I guess.
21:43:00 <kanarip> well, it'd facilitate the work gets started now, but not interrupt the nightly spins that are composed from master iirc, right?
21:44:00 <nirik> yes.
21:44:40 <kanarip> ok, that's a wrap on the mini.ks then
21:44:55 <kanarip> i'll branch off F-14-devel to facilitate work being done right now
21:45:04 <kanarip> #action kanarip to branch off master to F-14-devel
21:45:29 <kanarip> #topic Board SWG: Fedora Target Audience wrt. Spins (attempt #2)
21:46:12 <kanarip> so, the board apparently really wants this target audience thing to be defined, in terms of what Fedora Project's target audience is, and they're wondering how such target audiences relate to spins
21:46:52 <kanarip> #link http://lists.fedoraproject.org/pipermail/spins/2010-February/000996.html
21:47:10 <brunowolff> I liked the option 2 type solution. I want the board to set a priority for the project to help with resource allocation and to help
21:47:39 * nirik also favors option 2, but hasnt had time to reply to the email yet.
21:47:43 <brunowolff> make design decisions. But I want spins able to target other groups where there isn't an unresolvable conflict.
21:47:47 <maxamillion> I honestly don't see why this questions needs answering, the spins exist because there is a target audience that the desktop spin doesn't satisfy ... its kind of self explanitory
21:48:34 <kanarip> i favor option 3, where each spin defines it's target audience
21:48:44 <nirik> I would hope the Fedora target is either general enough to include all spins audiences, or at least not limiting us to it.
21:49:51 <cwickert> are we to decide about the solutions?
21:49:54 <kanarip> well to me the Fedora target is something completely different then what the board is coming up with anyway
21:50:02 <brunowolff> The issue with 3 is it opens up a can of worms.
21:50:03 <maxamillion> kanarip: I'm with you, I think that's kinda what we are doing now and it seems to be working
21:50:07 <kanarip> cwickert, we're to indicate our most favorable
21:50:10 <maxamillion> brunowolff: how so?
21:50:14 <cwickert> IMO they just asked us for our problems
21:50:36 <cwickert> and IMHO the problems are more serious than all this discussion
21:50:48 <brunowolff> What if you need two different versions of the same program to satisfy the requirements of two spins?
21:51:02 <cwickert> brunowolff, example?
21:51:06 <maxamillion> brunowolff: I don't follow
21:51:25 <nirik> brunowolff: spins work together to either use the same version, or provide parallel installable ones?
21:51:25 <kanarip> brunowolff, technically non-sustainable, because those two versions would not be in Fedora
21:51:29 <brunowolff> I don't think it is likely. But I think that is one of the differences between option 2 and 3.
21:51:57 <cwickert> brunowolff, take a look at ubuntu vs. xubuntu. xubuntu ships a stripped down version of gnome-session because they need it for gdm
21:52:14 <nirik> I really think the conflicts thing is overblown. Sure, there are conflicts between groups... but we are all sane adults, we can try and solve them via techinical means, if not we can always ask fesco/board to decide.
21:52:17 <cwickert> but IMO the problem should not be patched or adressed on a packaging level but upstream
21:52:21 <brunowolff> With 2 spins need to work with in the guidelines. If there is a conflict the target wins.
21:52:36 <maxamillion> nirik: +1
21:52:47 <kanarip> brunowolff, that's not making any sense to me
21:52:56 <brunowolff> With option 3 I think people need to at least be thinking about updated guidelines where there are conflicting packaging
21:53:05 <brunowolff> requirements between different spins.
21:53:05 <cwickert> nirik, +1, I cannot really think of a conflict
21:53:10 <kanarip> brunowolff, there can't be conflicting packaging
21:53:16 <cwickert> I mean: are kde and gnome conflicting?
21:53:20 <kanarip> brunowolff, that's not allowed in fedora
21:53:33 <nirik> ell, there are things like gnome folks moving to polkit, and kde needing PolicyKit still for a cycle...
21:53:34 <maxamillion> no spin is going to fit into the "target" they are basically just formally putting together a plan to say "we endorse the Desktop Spin and the audience they target" ... more or less
21:53:58 <maxamillion> the whole point of the spin is to satisfy an audience not satisfied by the target
21:54:00 <cwickert> nirik, ok, but this can be done within the spin
21:54:07 <brunowolff> I think that is sort of the point of the question. How far are we willing to go to accomadate spins that want to do something different/
21:54:29 <nirik> cwickert: right, I am saying thats an example where there was a conflict and it was solved by allowing kde folks to keep the older interface around until they didn't need it.
21:54:39 <cwickert> IMHO we should make sure that we all build from and upon fedora
21:54:51 <cwickert> if we started like *buntu we are damned
21:55:08 <brunowolff> I think that is more in line with solution 2 than solution 3.
21:55:25 <cwickert> of course there are limitations in the way we customize our spins, but we need to solve this technically
21:55:30 <maxamillion> cwickert: if we were anything like *buntu, I wouldn't be here ... I left that mess a long time ago
21:55:40 <cwickert> maxamillion, +1
21:55:49 <kanarip> can we please cut off the comparisons with *buntu?
21:55:52 <kanarip> you make me feel sick
21:55:55 <maxamillion> kanarip: +1
21:56:00 * maxamillion was just commenting
21:56:05 <kanarip> look
21:56:09 <kanarip> it's all in fedora
21:56:11 <maxamillion> I am however tired of the *buntu comparisons on the whole
21:56:14 <kanarip> there can't be many conflicts
21:56:20 <maxamillion> kanarip: +1
21:56:26 <kanarip> and where there are, the spins sig is not the place to solve those problems
21:56:31 <kanarip> cvs.fedoraproject.org is
21:57:08 <kanarip> now
21:57:11 <cwickert> for example if we want another config or another branding for program foo, then we need to make subpackages. gnome-panel-branding foo and gnome-panel-branding-bar. suse alreay does this and they do it pretty clever
21:57:44 <kanarip> if we let the board define target audiences to create spins for, no matter how broad, how well do you think this addresses spins with a niche target audience such as our current AOS spin?
21:58:03 <kanarip> cwickert, that's Re-Mix, not Spins
21:58:14 <cwickert> kanarip, not necessarily
21:58:26 <cwickert> think of the mini spin that wants another panel layout
21:58:38 <cwickert> this has nothing to do with branding, it's both fedora
21:58:43 <kanarip> if the means and packages are in fedora already, then again the spins sig is not where the battle is fought
21:58:53 <cwickert> right
21:59:25 <brunowolff> I agree with that.
21:59:29 <cwickert> but the spins sig should kick others to acress the technical problems
21:59:43 <cwickert> then we don't need to worry anout conflicts and target audiences
21:59:44 <kanarip> i'm very reluctant to go into the realm of matching target audiences for our spins with target audiences for the project as a whole
21:59:51 <kanarip> hence i'm in favor of option 3
22:00:18 <cwickert> +1
22:00:19 <brunowolff> The email message proposed Spins SIG -> FESCO -> Board, but I think just FESCO -> Board seems more appropriate.
22:00:36 <cwickert> but IMO this is all too theoretical
22:00:44 <nirik> cwickert: +1
22:00:53 <maxamillion> +1
22:01:04 <brunowolff> -1
22:01:42 <cwickert> I mean, if we stick with the "working" target audience, I don't care if the people are working on/with Gnome/KDE/LXDE/whatever
22:01:46 * nirik was +1ing cwickert's saying IMO this is too theoretical, not voting for option 3
22:01:50 <brunowolff> I believe the questions are about how to go about resolving conflicts when they come up.
22:02:17 <cwickert> and if we say we are not for "working" but for "consuming" people, this is nothing we can influence with the spins
22:02:44 <maxamillion> here's a question:
22:02:53 <brunowolff> We can certainly add we aren't seeing unresolveable conflicts now if that is how spin owners are seeing things.
22:02:58 <maxamillion> why are we adding this burocracy(sp?) on top of the way we do things now?
22:03:56 <nirik> FYI, currently we have: "Someone who (1) is voluntarily switching to Linux, (2) is familiar with computers, but is not necessarily a hacker or developer, (3) is likely to collaborate in some fashion when something's wrong with Fedora, and (4) wants to use Fedora for general productivity, either using desktop applications or a Web browser."
22:04:14 <nirik> so, some of the spins don't match that target.
22:04:23 <cwickert> which ones?
22:04:26 <nirik> but I think conflicts are very rare
22:04:32 <brunowolff> I don't see added bureaucracy for the cases where there aren't conflicts, which for most stuff there isn't.
22:04:47 <nirik> say the electronics lab targets developers/hackers?
22:04:52 <kanarip> nirik, AOS Spin
22:05:04 <kanarip> i for one think all of 4 just stink
22:05:10 <maxamillion> nirik: wtf? .... Xfce Spin target audience = users who want to use Xfce ... why do we need the break down about types of users?
22:05:16 <nirik> design-suite doesn't go for 'general productivty' ?
22:06:15 <brunowolff> My view on why we are getting asked is that the Board is looking at a way to resolve conflicts and determine priorities using
22:06:42 <brunowolff> a targert audience and asking us (the Spins SIG) if that is going to cause problems.
22:06:46 <cwickert> maxamillion, I think these definitions are on different levels. active/inactive/working/consuming is on a completely different level than Xfce, KDE, Games, Design etc
22:07:07 <brunowolff> If that's the question, I think the answer is that it isn't going to cause problems.
22:07:20 <cwickert> brunowolff, +1
22:07:38 <cwickert> I think we all can subscribe to the current definition that nirik just quoted
22:07:42 <maxamillion> cwickert: right, but the Xfce, KDE, Games, Design, etc. is the level at which the Spins are sitting, why do we need to be involved in the decisions of the active/inactive/working/consuming/etc. level?
22:08:24 <cwickert> maxamillion, I don't want to get involved. I'm interested in technical problems and solutions but not in hypothetical questions.
22:08:26 * sdziallas sorry, back. kanarip: everything should be in shape now.
22:08:38 <cwickert> that's why I'm in FESCO, not the board
22:08:53 <maxamillion> cwickert: right, but if I understand this correctly ... that's what the Board is asking of us, is it not?
22:08:54 <kanarip> sdziallas, ok
22:08:58 * nirik goes to get more coffee.
22:09:15 <cwickert> maxamillion, yes, but I think I cannot comment on that
22:09:16 <maxamillion> I don't see why any of what the Board is trying to do is our problem or how/why it even effects us?
22:09:30 <cwickert> that's why is skipped the first part in my reply completely
22:09:34 <maxamillion> rgr
22:09:40 * cwickert is working on a reply atm
22:09:50 * maxamillion hates politics
22:10:00 <cwickert> :)
22:11:30 <cwickert> so do we agree to say "not our buisness"?
22:11:50 <cwickert> or should we give a recommendation for something
22:12:00 <maxamillion> +1 at saying "not our business"
22:12:05 * kanarip is working on a reply too
22:12:06 <cwickert> which would preferralby 3 IMHO
22:12:10 <brunowolff> More or less. In addition, I think it is useful for the project to have a target audience.
22:12:21 * maxamillion facepalms
22:12:36 <kanarip> mine will be from an individual perspective, not the Spins SIG representative or anything like that
22:12:57 <kanarip> i feel we would need to reach consensus here first, before we can send out any message on behalf of the Spins SIG
22:12:57 <maxamillion> I'm going to stay out of the rest of this part ... you guys just hash it out and tell me what the result is. I will adjust my actions/activities/involvement accordingly
22:13:12 * cwickert will write from an Xfce/LXDE perspective
22:13:27 <brunowolff> You might also point them to this log as the discussion might be of interest to get a better idea of how we interpreted their questions.
22:13:32 <cwickert> or a "non-gnome" perspective
22:14:30 <brunowolff> For the Spins perspective I can live with whatever. I am here more for techincal than vision reasons and the impact on any
22:14:48 <brunowolff> of the soltuions on the games spin is negligible.
22:15:15 <nirik> I think spins defining their target audience could be nice... if only to help in marketing...
22:15:51 <nirik> but yeah, I don't think we as a sig should reply with anything unless their is some consensus.
22:16:24 <brunowolff> To some extent we do and document it on the summary sections of our spin pages.
22:16:24 <maxamillion> nirik: I think each spin already does
22:16:27 * abadger1999 thinks the Board asked the SPin SIG a bunch of questions that are better targeted at the Spin owners themselves.
22:16:38 <maxamillion> abadger1999: +1
22:16:41 * nirik nods.
22:17:07 <brunowolff> Yeah, the other Kevin probably has a lot different opinions on this than the rest of us.
22:18:51 * nirik thinks we are way over time. ;)
22:19:17 <maxamillion> nirik: +1
22:23:03 <kanarip> #endmeeting