14:06:30 <rdieter> #startmeeting KDE SIG Meeting -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-02-16
14:06:30 <zodbot> Meeting started Tue Feb 16 14:06:30 2010 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:50 <rdieter> #chair Kevin_Kofler than_ jreznik ltinkl SMParrish
14:06:51 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik ltinkl rdieter than_
14:07:00 <rdieter> #topic Init
14:07:06 <rdieter> who's present today?
14:07:11 <Kevin_Kofler> #meetingname kde-sig
14:07:12 <zodbot> The meeting name has been set to 'kde-sig'
14:07:15 <Kevin_Kofler> Present.
14:07:16 * SMParrish here
14:07:17 <svahl> present
14:07:32 * mefoster here
14:07:33 * thomasj here
14:08:00 <jreznik> here
14:08:02 * ltinkl is here
14:08:26 <rdieter> #topic qtwebkit jit/selinux problem: update
14:08:38 <rdieter> any news on the qtwebkit jit/selinux thing ?
14:09:03 * than is present
14:09:46 <Kevin_Kofler> None that I know of.
14:10:02 <Kevin_Kofler> -disable-javascript-jit is the only solution at the moment (and what we're using).
14:10:12 <jreznik> someone should ask probably someone :D
14:10:33 <jreznik> as it affects my package, should be probably me
14:10:35 <Kevin_Kofler> webkitgtk also disables the JS JIT for the same reason.
14:11:43 <rdieter> OK, I'd propose opening a tracker bug, preferably linked with an upstream report.
14:12:13 <rdieter> Bonus points for contacting anyone we know @ qt/nokia to try to get the issue some visibility
14:12:14 <Kevin_Kofler> Tracker bug for WebKit in general, with clones against qt and webkitgtk?
14:12:49 <rdieter> good question, I was thinking more about qt/webkit, as that's what concerns us most, but we could generalize the effort too
14:12:54 <Kevin_Kofler> BTW, as far as Qt is concerned, this now also affects QtScript.
14:13:12 <rdieter> oh ick
14:13:23 <Kevin_Kofler> (But up to 4.5 Qt went along without a JIT for QtScript just fine too.)
14:13:31 <Kevin_Kofler> Really, the JIT is not a required feature.
14:13:38 <Kevin_Kofler> But sure, it'd be nice to have it working.
14:13:46 <jreznik> sounds good to cooperate the effort with gtk guys
14:13:48 <Kevin_Kofler> (better performance)
14:14:24 <Kevin_Kofler> That said, I'd want it enabled on x86_64 too, not sure what the status there is.
14:14:30 <rdieter> jreznik: you willing to take the torch and lead the efforts here?
14:14:49 <jreznik> rdieter: ok
14:14:50 <Kevin_Kofler> As for webkitgtk, it's the same JIT with the same issues, so it'll need the same fix.
14:14:58 <jreznik> yes
14:15:19 * jreznik is addind webkit issue to his todo
14:15:21 <rdieter> #action jreznik to lead efforts to improve webkit jit/selinux situation
14:16:09 <rdieter> thanks.
14:16:21 <rdieter> anything else?  or can we move on ?
14:16:33 <jreznik> move on
14:16:56 <rdieter> #topic #565420: akonadi kcm not shown in systemsettings
14:17:06 <rdieter> .bug 565420
14:17:08 <zodbot> rdieter: Bug 565420 akonadi kcm not shown in systemsettings - https://bugzilla.redhat.com/show_bug.cgi?id=565420
14:17:26 <Kevin_Kofler> So the summary is that svahl noticed this went AWOL and users would no doubt notice it too.
14:17:36 <rdieter> with kdepim-runtime-4.4.0, upstream decided to hide the akonadi-related kcm's...
14:17:46 <Kevin_Kofler> And unlike svahl, the average user is unlikely to figure out the magic "kcmshell4 kcm_akonadi" incantation.
14:18:08 <than> rdieter: is there any reason why upstream want to hide it?
14:18:10 <Kevin_Kofler> Right, upstream decided to hide the stuff. I have a patch to bring them back and I think that's really the right thing to do.
14:18:22 <Kevin_Kofler> than: They think people don't need it. :-/
14:18:23 <rdieter> than: I'm sure they have their reason(s).
14:18:24 <Kevin_Kofler> But it's not true.
14:18:45 <ltinkl> repeating than, was there any reason provided by upstream why they wanted to hide those KCMs?
14:18:48 <Kevin_Kofler> rdieter: "Users should not need it" is the reason given in the commit message, but it's not true, they do need it.
14:18:51 <svahl> it's still available in krunner, but I didnt found it in the menu
14:18:56 <than> Kevin_Kofler: hm, it's not good reason!
14:19:02 <rdieter> Kevin_Kofler wanted to revert the change, which I'm not necessarily against, but I also think before doing so in any release, we should contact them for their justification/rationale for doing so.
14:19:03 <Kevin_Kofler> than: +1
14:19:28 <Kevin_Kofler> KDE is becoming more and more like GNOME. :-(
14:19:31 <ltinkl> unless I see a valid reason, I'm for showing (reenabling) them
14:19:40 <Kevin_Kofler> The option is already under "Advanced user settings".
14:19:45 <SMParrish> I agree with than, I dont like someone else deciding what I do and do not need.  +1 to implement the patch and add it back
14:19:47 <ltinkl> which is ok imho
14:20:22 <Kevin_Kofler> So we have me, than, ltinkl, SMParrish, svahl agreeing that the KCM should be shown, right?
14:20:38 <svahl> +1 here (maybe contact upstream first)
14:21:09 <jreznik> count /me +1!
14:21:10 <Kevin_Kofler> I have a (2-line) patch in Rawhide already, I'll build it for F11/F12 too.
14:22:30 <than> svahl:  yes, we should ask upstream for real reason
14:22:47 <Kevin_Kofler> Who is going to do that?
14:23:04 <jreznik> with prepared use cases why it's needed
14:23:11 <Kevin_Kofler> jreznik: Right.
14:23:14 <Kevin_Kofler> Good point.
14:23:40 <Kevin_Kofler> Do you volunteer? :-)
14:23:40 <than> ltinkl: could you please check with upstream?
14:23:45 <ltinkl> than: ok
14:23:54 <than> ltinkl: great, thanks
14:24:29 <rdieter> #action ltinkl to contactd kdepim upstream about the decision/rationale behind hiding akonadi kcm's
14:24:48 <Kevin_Kofler> But in the meantime we should show it!
14:25:00 <rdieter> Kevin_Kofler: I agree, let's do it
14:25:24 <Kevin_Kofler> #agreed We will show the Akonadi KCM in System Settings in Fedora (at least for now).
14:26:46 <rdieter> that's all we had on the agenda today
14:26:47 <Kevin_Kofler> So, I think we're through with the agenda, right?
14:26:52 <rdieter> #topic Open Discussion
14:26:56 <rdieter> yep
14:26:57 <Kevin_Kofler> FYI: https://fedoraproject.org/wiki/SIGs/KDE/KDE_4.4.0_update_set#proposed_changes_to_pull_in
14:27:21 <Kevin_Kofler> I've collected the changes which missed the current update set (which just got pushed).
14:27:37 <rdieter> the kdelibs/kdepim-runtime stuff is pretty much a no-brainer for inclusion.
14:27:44 <rdieter> how do we want to handle qt-4.6.2 ?
14:27:46 <Kevin_Kofler> I think it's fairly straightforward we want those.
14:28:03 <Kevin_Kofler> I'd include 4.6.2 in the next testing push.
14:28:24 <Kevin_Kofler> Remember how Aaron said 4.6.2 has important fixes we should get out ASAP?
14:28:25 <rdieter> fwiw, qt-4.6.2 is in kde-unstable repo for now.  I'd urge folks to test it.
14:28:53 <jreznik> we probably want it asap
14:29:02 <rdieter> hrm... right.
14:29:17 <rdieter> k, I'll move it to kde-testing for a wider audience.
14:29:27 <rdieter> and we can probably include it in the next updates-testing batch
14:29:42 <Kevin_Kofler> I'm syncing and building kdepim-runtime.
14:29:57 <than> rdieter: we should move 4.6.2 to testing first
14:30:17 <jreznik> yep, testing
14:30:32 <Kevin_Kofler> than: Of course we're going to testing, not stable, there.
14:30:38 <Kevin_Kofler> This is all part of the 4.4.0 update group.
14:32:46 <than> i will prefer, we will move 4.4.0 first in stable without 4.6.2
14:33:49 <than> let it 1 week in testing, if we don't get any bad feedback, we can move 4.6.2 in stable
14:34:24 <jreznik> we still need some more time for 4.4, so why not test it together?
14:34:36 <jreznik> then we will need another testing period
14:34:44 <jreznik> (if we wait)
14:35:26 <Kevin_Kofler> Yeah, KDE 4.4.0 is not ready for stable!
14:35:37 <Kevin_Kofler> We should test them together.
14:35:39 <rdieter> there's pros/cons to each.  How about we see how kde-testing feedback goes over the next few days, and re-evaluate then.
14:35:49 <Kevin_Kofler> KDE upstream (at least aseigo) recommends to ship 4.6.2 over 4.6.1.
14:35:58 <Kevin_Kofler> Many bugfixes there.
14:36:05 <Kevin_Kofler> I think it's a bad idea to push 4.6.1!
14:36:21 <rdieter> I'd lean toward testing kde44/qt-4.6.2 together too
14:36:27 <jreznik> it's better to test with 4.6.2 even it means longer testing period
14:36:28 <Kevin_Kofler> rdieter: I think it'd be better to get it into updates-testing at the same time.
14:36:28 <than> Kevin_Kofler: we care about regessions in 4.6.2
14:36:48 <Kevin_Kofler> than: We also care about regressions in 4.6.1 which 4.6.2 fixes. :-)
14:36:59 <Kevin_Kofler> It's likely these are more.
14:37:09 <Kevin_Kofler> And the best way to find 4.6.2 regressions is to have it in testing.
14:37:27 * thomasj likes the idea 4.4/4.6.2
14:37:28 <Kevin_Kofler> (right now, not after 4.4.0 is stable)
14:37:41 <SMParrish> I agree test them together
14:37:51 <ltinkl> yup, put them together into testing
14:38:30 <rdieter> these concerns are why I was suggesting delaying any 4.6.2 decisions for 2-3 days.  It'll probably be that long before we get another good updates push anyway.
14:39:11 <than> rdieter: i agree with rex
14:40:50 <Kevin_Kofler> I don't think delaying is useful.
14:40:54 <rdieter> I honestly think we'll end up pushing 440/462 together anyway, but this gives us the flexiblity to stay with 461 in the event of any nastiness we find over the next couple of days
14:41:02 <Kevin_Kofler> We want 4.6.2 out, the sooner we get it into the update set, the better.
14:41:04 <thomasj> It doesn't hurt to wait 2-3 days more. But 4.4/4.6.2 testing together, would be nice.
14:41:30 <rdieter> fyi, 462 is in kde-testing now.
14:41:41 * thomasj installing currently
14:41:45 <than> Kevin_Kofler: we can wait 2-3 days :)
14:42:04 <rdieter> speaking of the kde repos, heffer was kind enough to offer a new de-based mirror.
14:42:17 <rdieter> I'll be adding that to the mirror lists soon
14:46:33 <rdieter> looks like things got quiet, are we done for today?
14:47:40 <rdieter> #info will delay decision on what to do with qt-4.6.3 for 2-3 days
14:48:01 <rdieter> #info will have a new de-based mirror for kde repos soon
14:48:17 <rdieter> alright then, thanks everybody.
14:48:19 <rdieter> #endmeeting