21:00:41 <smooge> #startmeeting EPEL
21:00:42 <zodbot> Meeting started Fri Feb 26 21:00:41 2010 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:52 <smooge> hi guys
21:02:18 <smooge> #topic roll call
21:02:21 <stahnma> I think I have a meeting at $DAYJOB
21:02:26 <stahnma> so I guess I am not really here :(
21:02:41 <smooge> it is ok I didn't get an agenda together
21:02:42 * nirik is here.
21:02:52 <smooge> but I am happy to see you able to say hi stahnma
21:03:37 <smooge> #topic call for agenda
21:03:55 <smooge> Hi guys this will be a short meeting. Do people have items they would like to talk about?
21:03:56 <derks> sorry i'm late
21:04:07 <smooge> I have a couple of my own but should be pretty short
21:04:58 <derks> do we want to touch on the FESCo ban on direct stable pushes, or is that strictly a fedora thing?
21:05:03 <nirik> I suppose we could touch again on the incompatible upgrades stuff, as I don't think we have reached a final conculsion on it.
21:05:29 <nirik> derks: a) there has not been a ban. b) it doesn't apply to epel, as we already don't allow direct to stable in epel. ;)
21:05:58 <silug> fwiw, i thought i should let everyone know that i'm slowly working my way out of the pit that is Real Life.  i'm trying to slowly work on my backlog of bugs and stuff...
21:06:06 <derks> right on.  Personally I wouldn't ever push directly to stable anyhow... just saw it was a pretty hot thread on fedora devel
21:06:09 <silug> emphasis on "slowly"
21:06:11 <nirik> hey silug. ;)
21:06:30 <nirik> derks: there is talk about drafting a policy that will change this, but there is not even a draft yet.
21:06:30 <smooge> no problem silug I am making 2 feet forward for every 1.5 back right now myself
21:07:08 <derks> nirik, gotcha
21:09:25 <smooge> #topic RHEL/EPEL conflicts
21:09:49 <smooge> ok seth got me a script to find provide conflicts that I am playing with
21:10:05 <smooge> The first thing was I couldn't find the kvm-qemu-img that was listed in the email last night
21:10:14 <smooge> I am trying to figure out what I missed in my copying
21:12:02 <smooge> hehe yep. I missed the vt tree
21:12:26 <smooge> that would do it. I should be able to have everything done soon so we can get a list of conflicts
21:12:32 <silug> it would be easier if rhel didn't randomly name packages different than fedora.  :)
21:12:40 <smooge> yes it would
21:12:48 <smooge> however, not my department
21:14:12 <nirik> good work on that smooge. Keep us posted on it.
21:15:50 <smooge> it looks like we may have a couple of packages pulled in this release but not a lot.
21:16:43 <smooge> I should have a complete list of things by the end of the weekend
21:17:07 <smooge> next week we can start looking at dealing with conflicts a bit better and hopefully broken deps.
21:17:23 <nirik> yeah.
21:17:30 <smooge> #topic Broken upgrades
21:17:57 <smooge> Ok I should also have a mediawiki spec file for people to look at next week
21:18:11 <nirik> so where did we last leave this?
21:18:20 <derks> is that a mediawikiXY package?
21:18:24 <nirik> allowing updated packages when they are fooN and don't conflict?
21:18:35 <smooge> I am not sure where it left off nirik
21:18:42 <nirik> yeah, me either. ;)
21:19:00 <smooge> I am going to lead with one that basically says mediawiki -> mediawiki15, mediawiki19 will be the new one
21:19:07 <derks> I noticed on one of the epel list threads.... that postgresql84 was *added* in rhel 5.5 ... so, aren't they doing just this same thing?
21:19:19 <smooge> sort of like how RH has done with samba3x and postgres84 packages
21:19:23 <nirik> yeah,
21:19:29 <smooge> me slow type
21:19:54 <nirik> I'd still like to ping the packaging list and see if they want to provide any input before we commit to this route, but I gues I can do that and see what happens.
21:21:16 <smooge> nirik please do
21:21:36 <nirik> ok, can do
21:21:40 <smooge> I figure I can at least have an alternative for people to look at
21:21:49 <smooge> so its not a bunch of hand-waving
21:22:41 <derks> i really think the ability to introduce new(er) branches of packages will be a great improvement
21:22:51 <smooge> what is the commannd to say "nirik said he will do this."
21:23:14 <Froolap> I would really like to see a database where I could select a specific application and get a listing of dependancies as well as the dependancies for all other dependancies.  It would be very helpful for customizing a system for specific applications.
21:23:18 <smooge> #action nirik will email packaging group for ideas on how to do this in the future.
21:23:33 <rsc> right. But you're not #chair
21:23:43 <smooge> I am not?
21:23:43 <rsc> or are you?
21:23:47 <nirik> he should be.
21:23:57 <smooge> zodbot doesn't love me
21:24:13 <nirik> Froolap: this is a Extra packages for enterprise linux (EPEL) meeting. ;) Not a general fedora meeting.
21:24:22 <nirik> it just doesn't say anything. It did it.
21:24:39 <smooge> #topic slipstream (or nirik gets a pony)
21:25:00 <nirik> I think the slipstream idea basically died...
21:25:07 <nirik> I seemed to be the only one who liked it. ;)
21:25:11 <smooge> I liked it
21:25:11 <derks> slipstream?
21:25:28 <smooge> rawhide for epel was my idea for slipstream
21:25:42 <nirik> derks: instead of 'mediawiki15' and 'mediawiki18' in the main/normal repo, we have a 'slipstream' repo
21:25:43 <smooge> but I might had misunderstood nirik
21:25:53 <smooge> ooooh i did misunderstood
21:26:13 <nirik> in that we can ship a newer one that breaks the base repo, because we tell users that it could and not to expect it to work from update to update.
21:26:37 <nirik> so in that repo we only have problem children like mediawiki / moin/ etc.
21:26:43 <derks> ahh... so it'd be like a disabled by default, upgrade at your own risk repo
21:26:57 <nirik> derks: yeah.
21:27:08 <smooge> ah I was seeing it in my head as something different
21:27:11 <derks> but it would maintain the same package name 'mediawiki', 'moin' rather than 'moin19' etc?
21:27:14 <nirik> but that means another 2 repos to deal with from rel-eng side of things.
21:27:24 <nirik> right.
21:27:47 <nirik> and if the current one was broken totally/no longer supported, it would just be removed from the base repo
21:28:28 <Froolap> nirik: I do not wish to distract.  I would like to talk with you for a couple of minutes when this is done if possible.  Thanks.
21:28:36 <smooge> ok I was seeing slipstream as sort of our rawhide and we would freeze stuff in it to epel-testing and then epel-stable. It would mean also setting up updates trees like Fedora has so even more work
21:28:48 <nirik> Froolap: sure, happy to.
21:29:05 <nirik> smooge: ah... I see what you were thinking...
21:29:14 <nirik> I was picturing it as a much smaller scale...
21:29:27 <nirik> and only time things would move from it is major releases...
21:29:48 <nirik> ie, we have mediawiki 1.8 in it now for epel5, then epel6 comes out, we could have that version in the base epel repo there.
21:30:42 <nirik> let me write this all up again in my email to packaging... can cc epel-devel.
21:30:47 <smooge> ok thansk
21:30:56 <smooge> anything else on this for anyone
21:31:13 <derks> nirik, I like the idea... though being that a new rhel release comes around only every many of years...  would it make more sense just to call it 'epel 6 beta'?
21:31:38 <nirik> derks: well, that could be confusing since it's building against/usable in epel5.
21:31:58 <derks> nirik, right...  that's true
21:33:00 <nirik> perhaps we need another round on epel-devel before packaging...
21:33:21 <smooge> yeah.. because I want to get a better idea
21:33:39 <smooge> I have 2 more silly topics and then we can close
21:33:45 <smooge> #topic PPC love
21:33:56 <nirik> also, dgilmore as I recall didn't like the idea due to him doing all the rel-eng. ;) care to chime in denis?
21:34:17 <Southern_Gentlem> sledge hammer??
21:34:33 * nirik waits to hear what ppc love is here. ;)
21:34:47 <smooge> Ok sorry you were talking so I wanted to wairt
21:35:01 <smooge> Ok we have a tree that we don't know much about
21:35:09 <derks> has there been any community request for PPC builds?
21:35:10 <smooge> does anyone here run/test PPC?
21:35:33 <nirik> I have a ppc32 test box, but it's running f12 currently.
21:35:52 <nirik> I haven't ever tested rhel on ppc as I don't have a license for it, and centos does not produce ppc. ;)
21:36:03 <derks> smooge, I have a dual 1.8 PPC mac pro that has been staring at me for over a year... so I suppose I do.
21:36:06 <rsc> I know, that there are people out there using CentOS PPC (some development trees) and EPEL PPC - but for myself I don't use PPC.
21:36:15 <Froolap> I have an ibm p43.  would be nice to get oracle running on.
21:36:25 <rsc> nirik: CentOS would like and need help for PPC, at least I was told this
21:36:26 <smooge> yeah.. centos has not seen a lot of community interest in it (well ok interest in the way of "we will do the work for you kbsingh")
21:36:40 <nirik> rsc: yeah, understandable. I have ENOTIME for such tho. ;(
21:36:52 <rsc> no, the problem at CentOS is, that their core team doesn't really accept contributions....
21:37:28 <smooge> well I know some of them do...
21:38:01 <smooge> when I was there it was mostly people asking for finished builds and no-one saying they would do some themselves
21:38:08 <smooge> but that is neither here nor there :)
21:38:40 <smooge> in the end, we are doing some PPC EPEL builds and I was wondering if we had ideas on how to test/build them better.
21:38:47 <rsc> well, I offered them already multiple times help for building packages etc. But there always was something like "no" but with other words :(
21:39:08 <nirik> I don't know how many/if any consumers we have...
21:39:17 <smooge> me either
21:39:28 <nirik> perhaps we should ask for stats on how many ppc epel mm requests we get?
21:39:55 <smooge> ok will ping mdomsch on that
21:40:22 <nirik> It doesn't really cost us much to build for it now, except in confusion for our maintainers... but when f12 goes eol, fedora probibly won't have any more ppc builders, so we probibly should drop support then too.
21:41:11 <smooge> that was my worry
21:41:27 <derks> we could also poll RHN hosted for a number of PPC subscribers
21:41:29 <smooge> and also dealing with the fact that we haven't helped test stuff
21:41:34 <Froolap> It would be nice if it was well documented when and where support is dropped for those of us with legacy machines that might want to put them into service 10 years from now.
21:42:28 <nirik> Froolap: yeah, a single page for that might be nice... a lookup table.
21:42:38 <smooge> yes. I agree
21:43:00 <smooge> I guess what I am wanting is my own desktop PPC with a power7 chip in it :)
21:43:20 <Froolap> I have exactly that problem currently with a 486 machine I was hoping to install linux on and get wireless networking going on.
21:43:24 <smooge> I am sure they grow on vines in the promised land
21:44:06 <nirik> ok, so gather stats, revisit at a later meeting?
21:44:15 <smooge> nirik, the cost is in lack of testing, amounts of disk space, who is using it
21:44:20 <smooge> nirik, yes I agree
21:44:35 <nirik> well, and the confusion for maintainers, as there is no ppc desktop.
21:44:42 <smooge> #action smooge will get stats from mdomsch. smooge will ping dgilmore on ppc builds after F12
21:44:49 <nirik> rhel only provides server for rhel5 ppc.
21:45:03 <nirik> so you have to exclude things that use/need packages only in desktop
21:45:26 <smooge> nirik, yeah.. its things like that says "lets make Fedora Enterprise Linux just for PPC :)"
21:45:47 <smooge> ok I have one other topic item for us to think about
21:46:06 <smooge> #topic RHEL-4.9 (end of the line bub?)
21:46:42 <smooge> Ok if I am understanding rumours and stories.. RHEL-4.9 will be the last RHEL 4 release with everything else being security/oh-shoot fixes
21:47:14 <smooge> how does this affect things for us if at all?
21:47:18 <derks> should certainly lock epel4 for new packages
21:47:21 <derks> IMO
21:47:32 <rsc> -1
21:47:38 <derks> really?
21:47:57 <smooge> hey mdomsch you around?
21:47:58 <nirik> I'm not sure it should change anything for us... I suppose we could consider locking out new packages, but I see both sides of that.
21:48:03 <rsc> derks: well, I would like to see forward-compat packages added
21:48:08 <mdomsch> smooge, yep
21:48:17 <rsc> derks: something to help people getting away from RHEL 4 and up to RHEL 5.
21:48:21 <derks> rsc, ok... i see you there
21:48:40 <smooge> mdomsch, we were wodnering what our MM numbers were for i386/x86_64/ppc so we could get an idea of usage
21:49:12 <smooge> derks, I just came from a place where 60% of the computers were still RHEL-3 and I was having to rebuild EPEL-4 stuff for them
21:49:48 <nirik> yeah, we have some clients still using 3 in places. ;(
21:50:21 <smooge> I have no idea about absolute numbers, but I do know it was pretty common in server areas back at my other previous job places too
21:50:27 <mdomsch> smooge, http://fedoraproject.org/maps/el5/
21:50:32 <smooge> (heck one was still using RHEL-2 for a lot of stuff.)
21:50:33 <mdomsch> and /el4/
21:50:46 <derks> smooge, yeah we have a lot of RHEL3 here as well.  my stance is...  start migrating customers/boxes before well before EOL time
21:50:51 <mdomsch> shows 55.8k unique IPs for el5 i386, 48.3k unique for x86_64
21:50:57 <rsc> smooge: you know that RHEL2.1 is still inofficially supported? ;-)
21:52:13 <smooge> derks, sure.. but customers never see it that way. Many would prefer to pay more money for people to keep them at something they like than all this PROGRESS stuff
21:52:27 <smooge> mdomsch, cool. thanks. is there a general number mapping too?
21:52:37 <smooge> wow look at Europe. They use PPC there
21:53:00 <mdomsch> ?
21:53:01 <derks> smooge...  i hear that.  up until a year or so ago we had a customer who refused to migrate off his redhat 7.3 box.  really.
21:53:06 <mdomsch> general number mapping ?
21:53:19 <smooge> mdomsch, never mind. I didn't read what was on the pictures
21:53:20 <Froolap> Sometimes it's better to just have something that works, than to upgrade and find out what's broke.
21:53:26 <smooge> mdomsch, I am stoooopid
21:53:50 <smooge> derks, I was tentatively calling that RHEL-2.2 for some people.
21:53:52 <Froolap> Recent example.  firefox decided to upgrade my browser, and now I can't play eucher on yahoo any more.
21:53:54 <jsmith> derks: I used to manage 6500 boxes, and my boss insisted that they stay on RH7.3
21:54:00 <smooge> I know a lot of computers still on RHL-7.3
21:54:07 <Froolap> Good reason not to be on the bleeding edge of upgrades
21:54:09 <Will_tampa> LOL  some times you have no choise... ig the have legacy hardware that you like & an't find support in the upgrades.....
21:54:20 <Will_tampa> ig if
21:54:37 <Will_tampa> I have to learn to type .. again\
21:54:40 <smooge> mdomsch, I didn't know we had ia64 builds or was that just someone rying
21:56:09 <nirik> huh. is that germany with all the el5 ppc?
21:57:25 <smooge> well ok I think we are nearing our end. Thanks mdomsch for the maps. It looks like PPC has less than 0.3% of all downloads
21:57:32 <smooge> nirik, I think so
21:57:58 <smooge> #topic Even More Open Floor
21:58:04 <Will_tampa> that meeting going to be releaced as mp3?
21:58:19 <smooge> no the beat sucks
21:58:20 <mdomsch> smooge, just trying; epel doesn't have ia64
21:58:26 <mdomsch> both of those customers tried though
21:58:34 <derks> So...  any talk about zStream (Extended Update Support) and EPEL?
21:58:39 <smooge> ok.. I guess we need to explore something for them :)
21:58:54 <smooge> derks, not really. we have never set up EPEL to deal with that
21:59:05 <mdomsch> nor should we...
21:59:23 <smooge> it would require a LOT of work as we would need to segregate our builds and stuff. I would do it if you paid us a million dollars (maybe)
21:59:29 <derks> no, i agree.  just wondering if there ever was talks about it.  seems like it would be a nightmare to attempt
21:59:52 <smooge> I think we talked about it once.. laughed ourselves silly and then went back to the meeting :)
22:00:01 <derks> ha
22:00:02 <mdomsch> conceptually, not hard to implement technically.  Process-wise, given our contributors, I wouldn't think so.
22:00:21 <smooge> mdomsch, yeah. I think it would definately be 'paying' work
22:00:29 <mdomsch> z-stream is very much paying work
22:00:58 <mdomsch> it's the part I love most about the paid-for open source support model: the more you pay me, the less changes I'll inflict upon you.
22:01:10 <derks> ha
22:01:11 <derks> yes
22:01:14 <smooge> I had to do something like that for a while with RHEL-3.6. It was a long nightmare since mock etc wasnt available to me
22:01:34 <mdomsch> some might call that protection money
22:01:50 <smooge> yep... its worked for thousands of years
22:01:55 <derks> we are looking at making it available here, and I just can't seem to convince anyone how impossible it would be for me to do
22:02:01 <derks> or manage
22:02:47 <smooge> derks, I was told to keep track of my hours to be billed... if I had been a consultant I would have been able to buy a jet
22:03:05 <smooge> anyway. I think we have covered that. anything else for openfloor
22:03:22 <smooge> if not we meet again in 2 weeks. same epel-channel. same epel-time
22:03:23 <Froolap> yes
22:03:47 <derks> smooge, thanks!
22:04:01 <smooge> #endmeeting