15:04:24 <adamw> #startmeeting BugZappers meeting 2010/03/09
15:04:24 <zodbot> Meeting started Tue Mar  9 15:04:24 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:34 * mcepl is in
15:04:36 <adamw> hello everyone
15:04:41 * Tech33 is here
15:04:41 <adamw> #topic roll call
15:04:42 <Kyril> hi
15:05:04 <daumas> heya adam
15:05:26 <beland> Greetings.
15:05:30 <adamw> hi all
15:05:36 <adamw> glad you could make it beland :)
15:06:05 <adamw> alright, we don't really have much on the agenda today...
15:06:10 <adamw> #topic previous meeting follow-up
15:06:37 <adamw> previous meeting was http://meetbot.fedoraproject.org/fedora-meeting/2010-02-23/fedora-meeting.2010-02-23-15.04.html
15:07:13 <adamw> we had a few action items on there, so let's just check in on 'em
15:07:27 <adamw> mcepl: you got co-ownership of the triage space on fedorahosted, right?
15:08:54 <adamw> well...i'm pretty sure he did =)
15:09:04 <mcepl> adamw: yes
15:09:11 <adamw> ok, great, so that one's done
15:09:20 <adamw> #info mcepl is now an admin of the fedorahosted triage space
15:09:46 <adamw> we had an action item down for tk009 to email comphappy about the statistics stuff
15:09:49 <mcepl> and after prolong hacking session on #fedora-admin (and #trac) I managed to revive XML-RPC access to the Trac on triage project.
15:09:56 <adamw> oh cool!
15:09:59 <adamw> nice stuff.
15:10:08 <mcepl> (Eclipse-mylyn FTW)
15:10:14 <adamw> #info triage trac space is now xml-rpc accessible again
15:11:26 <adamw> ok, on statistics again
15:11:59 <adamw> for the newer members...well, almost everyone...=) there's a group member with the nick 'comphappy' who's been working on and off on a system to give us statistics about triaging
15:12:15 <adamw> just so we can get an idea of how much actual work we're doing, how it changes over time, all that good stuff
15:12:30 <mcepl> and some of us are not holding their breath anymore ... being completely blue
15:12:36 <adamw> it's been kind of a long story though :) we almost had a working system, then changed approach, and stuff.
15:12:57 <adamw> so, though we had an action item down, comphappy actually stopped by the channel shortly after last week's meeting and explained what's up now
15:13:20 <Tech33> mcepl doesn't have enough to do, let him recode it :)
15:13:26 <adamw> he's working with the Fedora Community team to integrate his work there, which makes sense, because Fedora Community is the logical space for this kinda thing
15:13:46 <adamw> #link https://admin.fedoraproject.org/community/
15:13:53 <mcepl> no I mean, great kudos to comphappy for work he did ... I know half of theproblems were not of his making
15:14:26 <adamw> he's been discussing it on infrastructure-list , so you can follow along with progress there (his real name is Brennan Ashton, that's what you'll see on the mails)
15:15:32 <adamw> so, there's some news there. and yeah, we always make a little fun of the project for dragging on so long, but at least brennan is trying, so of course if anyone wants to help him that would be awesome
15:15:54 <adamw> so if you're interested, look for him on irc or drop him an email (his address is in the infrastructure archives)
15:16:25 <adamw> anyone have comments / questions on that?
15:17:32 <daumas> adamw, is there a wiki page or is this project described in some of those mailing lists posts? i'd like to read more about it.
15:17:49 <Tech33> personally I'm of two minds about metrics, they can be useful, they can also be not useful
15:17:53 <adamw> good question...give me a few mins (or anyone else who has links, join in)
15:19:01 <adamw> daumas: http://lists.fedoraproject.org/pipermail/infrastructure/2009-April/006513.html is an outline of the _old_ version of the tool, which was submitted to infrastructure as its own project
15:19:33 <daumas> adamw: thanks
15:19:47 <adamw> daumas: http://lists.fedoraproject.org/pipermail/infrastructure/2010-February/008373.html is the new project brennan's working on, which i believe is kind of a prerequisite for the Ultimate Vision
15:20:15 <adamw> and you can find the actual code for the old version of the tool at https://fedorahosted.org/triage/browser/triageweb
15:20:29 <adamw> (i believe it uses some stuff from 'scripts' in the same root, as well)
15:20:59 <adamw> Tech33: what's your worry about stats?
15:21:22 <Tech33> adamw: not really important, should not have mentioned it
15:21:45 <adamw> Tech33: i was interested =)
15:22:13 <Tech33> well, just a for instance
15:22:46 <Tech33> if my own stats were to be shown, you'd see an over-abundance of closed cantfix, and closed dupes
15:23:12 <Tech33> but without understanding the why, it can be interpreted ... if not wrong, then badly
15:23:48 <adamw> sure, the idea wasn't to act as a sort of Are You A Good Triager, You Naughty Little Monkey tool :)
15:24:29 <adamw> there were going to _be_ stats for individual triagers in there, but it was mostly intended to let us know who was active and who was idle, and as a reference for the triagers themselves, not a stick for the Authorities to use to beat you with
15:26:47 <adamw> okay, couple of other things on the action items...
15:27:10 <adamw> #info comphappy is now working on triage statistics under the Fedora Community umbrella in the infrastructure team, see infrastructure list for details
15:27:22 <mcepl> Tech33: and tool for leadeship of BugZappers (me, adamw, etc.) towards Fedora Project and Red Hat to show that we are actually good for something.
15:27:34 <adamw> so there was an action item for me to work with poelcat and tk009 on the rawhide -> f13 rebase
15:27:37 <adamw> mcepl: exactly!
15:28:08 <adamw> we've made progress with that, we set up the queries and updated the housekeeping page and sent an announce to -devel
15:28:20 <adamw> which got some feedback that we're trying to work through before we actually push the rebase through.
15:28:32 <poelcat> adamw: the rebase is scheduled for today
15:28:40 <adamw> poelcat: are you around? do you know if the rebase actually needs fesco approval, as someone said in the thread?
15:28:48 <adamw> ah, well, you answered my first question already =)
15:28:59 <poelcat> adamw: fesco approved the whole process back in the beginning
15:29:08 <adamw> right, so each specific rebase doesn't need it
15:29:08 <pjones> I wouldn't think there's more approval needed from us
15:29:18 <poelcat> adamw: not at all
15:29:19 <adamw> that's what i figured too, the question in the thread just threw me for a loop
15:29:44 <adamw> are you worried about any of the feedback? there was that thing someone worked up to use the version selected when the bug was filed rather than whatever's on it now
15:29:44 * poelcat is about 800 messages behind on devel list... maybe time to declare bk
15:29:51 <adamw> but i don't see why that would be reliable
15:30:07 <adamw> poelcat: just mark all the ones with 'update' (or 'udpate') in the topic as read, it'll help =)
15:30:43 <mcepl> poelcat: killfile is a necessity (gmane.org and newsreaders opportunity to use it)
15:30:47 <adamw> for reference, the -devel thread is http://lists.fedoraproject.org/pipermail/devel/2010-March/132338.html
15:31:30 <adamw> till's reply talking about FESco is http://lists.fedoraproject.org/pipermail/devel/2010-March/132390.html
15:31:55 <adamw> and his apparently-overengineered alternative list derivation method is http://lists.fedoraproject.org/pipermail/devel/2010-March/132416.html
15:32:15 <poelcat> adamw: the only thing I can think that needs to be modified to match NFR is the timing of the rebase
15:32:18 <poelcat> that is all
15:32:22 <adamw> yeah, me too
15:32:36 <adamw> we've run the rebase multiple times before and it's been fine
15:32:47 <adamw> maybe I should've made that point more clearly in the thread...oh well
15:33:17 <poelcat> all documented here https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Releases
15:33:24 <adamw> summary, the rebase is going to happen today and we're happy with that...sound right?
15:33:40 * jeff_hann too late again :(
15:33:44 <adamw> hi jeff
15:34:00 <jeff_hann> hi everyone
15:34:59 <poelcat> adamw: my only suggestion (if it isn't too late to change things w/ eng-ops)
15:35:13 <poelcat> would be to delay for a few more days
15:35:21 <poelcat> if that gives people more time to make any adjustments they want to
15:36:04 <adamw> poelcat: well, there wasn't a big groundswell of concern, it was just a couple of people responding to the thread
15:36:07 <adamw> so i think it should be fine
15:36:28 <poelcat> okay
15:38:09 <adamw> alrighty, last item we had was for me again, to update the bug lifecycle page to match no frozen rawhide
15:38:24 <adamw> #info f13 bug rebase is going ahead as planned, no problems expected
15:38:58 <adamw> I did update the lifecycle page; it turned out to be unexpectedly tricky
15:39:09 <adamw> #link https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
15:39:36 <adamw> the diff of the change is https://fedoraproject.org/w/index.php?title=BugZappers%2FBugStatusWorkFlow&diff=157433&oldid=155130
15:39:50 <adamw> it'd be great if people could check it and see if a) it looks correct and b) it's not now too flipping confusing
15:40:10 <adamw> because i sorta had to crowbar bits in around the old language, it's probably somewhat uglier now than I would've liked to make it if writing from scratch
15:40:44 <adamw> #info adamw updated the bug workflow page to match up with no frozen rawhide: https://fedoraproject.org/w/index.php?title=BugZappers%2FBugStatusWorkFlow&diff=157433&oldid=155130
15:42:27 <adamw> so, any questions / comments on that?
15:42:47 <beland> Looks OK.
15:42:59 <beland> I did have a question about NFR and [[Releases/Rawhide]]
15:43:43 <adamw> shoot!
15:43:50 <beland> Is http://alt.fedoraproject.org/pub/alt/nightly-composes/ F13 or F14?
15:44:41 <Oxf13> f13
15:45:20 <beland> I thought so from the mailing list conversation...
15:45:24 <beland> When will it change over?
15:45:39 <beland> And is there somewhere to get Live media for F14?
15:46:18 <adamw> nirik maintains those images
15:46:26 <adamw> nirik: ^^^^
15:46:41 <adamw> i don't believe there's F14 images anywhere atm, but i may be wrong
15:47:35 <Southern_Gentlem> beland,  in about 6 months
15:47:54 <adamw> Southern_Gentlem: well, the live images may well switch to being f14 at a different time to the release
15:47:58 <adamw> it's essentially up to nirik
15:48:36 <beland> Are we estimating it will be around a particular milestone?
15:49:22 <adamw> i've no idea =)
15:49:25 <adamw> seems nirik isn't around...
15:49:49 <beland> I suppose the idea here is that the "real" rawhide doesn't need all that much testing compared to the branched/alpha/beta release?
15:50:24 <adamw> well, basically that what people who get the nightly live images probably want, and what we probably want them to test, is f13
15:50:24 <beland> Well I guess the question is whether you can *ever* install Rawhide from a Live image, as the Rawhide page currently claims.
15:50:52 <adamw> well, for a short time, yes: before f13 was branched from rawhide, you could.
15:51:03 <adamw> but obviously the current wording is a bit outdated. there's probably other stuff on the page that may need changing
15:52:14 <adamw> beland: do you want to take an action item to just revise it? we trust your wiki kung fu, i think :)
15:53:12 <beland> I will update the link to the daily live media to correctly describe what's there, but it's difficult to give the reading public a clear explanation when no one really knows what's going on. 8)
15:54:04 <adamw> well, ask nirik about his plans for the live images, and oxf13 for any other questions about the NFR process
15:54:44 <adamw> i'll stick it in there as an action item anyway, if you don't get enough info to do it, no biggie, we'll come back to it later
15:54:57 <adamw> #action beland to try and update the Rawhide wiki page for NFR, with input from nirik and oxf13
15:55:38 <beland> Are their email addresses the same (@fedoraproject.org)?
15:56:11 <adamw> nirik is Kevin Fenzi, from the list (just check your -test archive for his address)
15:56:18 <adamw> oxf13 is Jesse Keating, jkeating at red hat
15:56:26 <beland> Okay, thanks.
15:57:29 <adamw> thanks a lot beland
15:57:34 <adamw> okay, so, that's it for the agenda...
15:57:36 <adamw> #topic open floor
15:57:53 <Tech33> real quick?
15:57:57 <Tech33> or out of time?
15:58:01 <adamw> did anyone have any issues they wanted to bring up? anyone stuck on something, just losing their motivation, aaanything?
15:58:26 <adamw> beland: oh, darn, sorry, I didn't see your reply about Tracking bugs
15:58:30 <adamw> beland: or else i'd have worked that in
15:58:38 <adamw> er, Target bugs
15:58:50 <beland> I knew there was something I was forgetting.
15:58:52 <adamw> shall we put that on next week's agenda?
15:59:11 <beland> Your call.
15:59:37 <adamw> yeah, let's
15:59:44 <adamw> anything aside from that, anyone?
16:00:30 <Tech33> I had one, but don't have time now, I'll make an agenda item for next week
16:00:38 <adamw> okay, sorry to over-run
16:01:02 <adamw> just a reminder, the Agenda Item List is https://fedoraproject.org/wiki/BugZappers:meeting-agenda-list , if there's something you want to discuss at a meeting you can always throw it in there
16:01:07 <adamw> and we'll pull it in for the next meeting's agenda
16:01:19 <adamw> let's wrap this puppy up :) thanks for coming everyone!
16:01:36 <adamw> #endmeeting