23:00:05 <jjmcd> #startmeeting Docs Project Weekly Meeting
23:00:06 <zodbot> Meeting started Wed Mar 17 23:00:05 2010 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:23 <Emad78> hi jjmcd
23:00:32 <jjmcd> #link https://fedoraproject.org/wiki/Docs_Project_meetings
23:00:42 <jjmcd> #topic roll call
23:00:43 <laubersm> .fas laubersm
23:00:44 <zodbot> laubersm: laubersm 'Susan Lauber' <susan@ties.org>
23:00:45 * jjmcd 
23:00:53 <Emad78> me
23:00:57 * ianweller 
23:00:59 * stickster 
23:01:08 * rudi is here
23:01:16 * Emad78 is here
23:01:54 <jjmcd> #topic Follow up on last week's action items
23:02:05 <jjmcd> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-03-11/docs.2010-03-11-00.01.html
23:02:47 <jjmcd> stickster - wiki?
23:02:48 * stickster reports all his action items are finished.
23:03:06 * jjmcd also, and ke4qqq isn't here
23:03:19 <jjmcd> And hi Ben
23:03:21 <stickster> jjmcd: I took care of ke4qqq's for him too :-)
23:03:29 <bcotton> hi jjmcd
23:03:32 <jjmcd> Uitstekend - so all done
23:03:52 <jjmcd> OK this next one should be quick
23:03:56 <jjmcd> #topic Desktop Help Summit
23:04:03 <jjmcd> Any last minute topics for jjmcd to carry to the DHS?
23:04:20 <jjmcd> shaunm, I will identify a conf room and post instructions on the wiki
23:04:38 <jjmcd> #action jjmcd will identify a conf room and post instructions on the Gnome wiki
23:04:57 <jjmcd> anything else on the desktop help summit
23:05:23 <jjmcd> OK, now the big one
23:05:36 <jjmcd> #topic Release Notes
23:05:47 <jjmcd> #link https://fedoraproject.org/wiki/Documentation_Beat_status
23:06:04 * stickster posted a schedule to the list today
23:06:11 * nathant slips in late at the back
23:06:22 <jjmcd> I have identified the beat status and especially beats where new contributors could get involved
23:06:49 <jjmcd> If there is a beat with "opportunity" in bold, it should be relatively easy for a new contributor
23:07:08 <Emad78> I will try to put something in there if I can.
23:07:28 <stickster> We need to start getting content ported pronto. What is our approach going to be for beats where no one is contributing?
23:07:35 <jjmcd> If a beat has possible opportunity, it will take a little more work
23:07:45 <jjmcd> stickster, I've been going after those
23:08:05 <jjmcd> I figure those are probably the topughest
23:08:28 <jjmcd> My strategy is to look at the change table, try to pick heavy hitters, and chase down the upstream release notes
23:08:28 * stickster waits for details
23:08:48 <jjmcd> I can only guess at what is important
23:09:02 <stickster> What is the change table you're referring to? Is that the list of all packages that have changed?
23:09:05 <jjmcd> But in some cases, e.g. Entertainment, I really haven't a clue
23:09:12 <jjmcd> stickster, yes
23:09:23 <jjmcd> there is a link at the bottom of Documentation_Beats
23:09:48 <stickster> I would recommend that in the absence of any other beat content, we stick with what's on the feature list.
23:10:08 <stickster> Those pages should have release notes content or at least a pointer to where we can gather it.
23:10:15 <jjmcd> WHerever there is something on the feature list, the beat is bolded
23:10:29 <jjmcd> new contributors can work off the feature list without a lot of exploration
23:10:38 <stickster> quaid: rudi: Input appreciated too
23:10:42 <jjmcd> ANd the beat page has a link to the feature list
23:11:04 <jjmcd> laubersm, will you be around over the weekend?
23:11:22 <laubersm> I'll be in and out.  I hope to pay attention to the desktop summit irc room
23:11:51 <jjmcd> I'll be off to the summit, but it would be nice if someone could marshall the troups for xml conversion
23:12:09 <jjmcd> I did a couple of easy beats this morning so new contributors have an example
23:12:12 <laubersm> That is this weekend?
23:12:20 <jjmcd> yes
23:12:30 <stickster> jjmcd: Let's start marshalling the troops *now*
23:12:38 <jjmcd> Next couple days I want to focus on getting content into the hard beats
23:12:52 <laubersm> Are we still having a howto after the meeting tonight?
23:13:12 <jjmcd> WOW, I totally forgot about that.  Sounds good to me
23:13:47 <jjmcd> Many, many thanks to rudi for doing the branch and building the empty document BTW, Saved me tons of time
23:14:02 <rudi> NP
23:14:02 <laubersm> I'm already multitasking a bunch of things this weekend - including a 4-5 hour drive on Sunday where I will not be online
23:14:15 <jjmcd> #info rudi is awesome
23:14:49 <jjmcd> I obviously won't be a lot of use from Friday PM until Mon PM except maybe a little monday AM
23:14:52 <laubersm> I can probably help some Friday night and Sat morning
23:14:58 <jjmcd> Great
23:15:06 <jjmcd> Perhaps we can get some folks launched
23:15:07 <stickster> jjmcd: I think that's why I would rather we work on getting beats put into Publican now
23:15:25 <stickster> And make adding content the second priority.
23:15:42 <stickster> If the POT doesn't exist at all translators have nothing to work on.
23:15:48 <rudi> I'll take the installer today -- there are substantial changes in F13
23:15:48 <stickster> We're already late for them
23:15:53 <jjmcd> Good point,
23:16:13 <jjmcd> rudi, outstanding.  I think mether started on that
23:16:19 <rudi> Oh OK
23:16:21 <jjmcd> and there are plenty of feature pages
23:16:51 <jjmcd> rudi got all the more or less boilerplate in there, and there are a few beats done
23:17:16 <jjmcd> OK, well, after the meeting we can get some work done during the howto
23:17:23 <jjmcd> is everyone up for that?
23:17:35 <Emad78> I should be able to do some.
23:17:52 <bcotton> jjmcd: will the howto be sent around? i won't be able to stick around after the meeting, but i'd like to see what i still don't know
23:17:53 <laubersm> I can stick around for a little while
23:18:25 <nathant> i won't be able stick around after the meeting
23:18:34 <nathant> happy to do catch-up reading though!
23:18:39 <jjmcd> Well, I assumed we would do it on #fedora-meeting.  If you leave your IRC client on it can keep a log.  Heck, I guess we could start meetbot
23:19:03 <jjmcd> #action we will use meetbot for tonight's howto and post the log on the list
23:19:16 <nathant> great
23:19:17 <jjmcd> Is that a reasonable approach?
23:19:21 <stickster> yep yep
23:19:33 * bcotton approves
23:20:14 <jjmcd> For any of the new folks, don't be shy about picking up any of the beats
23:20:59 <jjmcd> OK, before we talk about the change tables, anything else release notes related?
23:21:25 <jjmcd> #link https://fedoraproject.org/wiki/User:Jjmcd/Drafts/Fedora_13_tables
23:21:30 <jjmcd> Has everyone seen this?
23:21:41 * Emad78 has
23:22:24 * laubersm likes the idea
23:22:27 <jjmcd> Anyone with plusses/minuses about a separate document?
23:22:42 <bcotton> i think it's a good idea
23:22:50 <Emad78> I totally agree with it also.
23:22:57 <rudi> jjmcd -- as I said on the list -- go for it!
23:22:59 <jjmcd> I'm liking it too, obviously, only problem is we need a new repo, new package, etc. etc. etc.
23:23:15 <jjmcd> But I need to learn to deal with that anyway
23:23:25 <rudi> jjmcd -- yeah, don't sweat that stuff
23:23:41 <jjmcd> THere's awesome infra guys that make stuff happen
23:23:55 * stickster left a comment on title
23:24:23 <jjmcd> OK, so it sounds like we go sith it
23:24:36 <stickster> np here
23:24:43 <stickster> Split == good.
23:24:52 <jjmcd> ianweller - some pages in the wiki have a fedora version macro that says 12, how do we say 13?
23:25:13 <ianweller> we edit [[Template:FedoraVersion]]
23:25:23 <ianweller> er
23:25:27 <ianweller> sorry, mkisread
23:25:28 <ianweller> misread*
23:25:35 <ianweller> {{FedoraVersion|next}}, i believe
23:25:40 <stickster> yup
23:25:43 <ianweller> stickster knows more, he wrote the template ^_^
23:25:47 <jjmcd> Ahhhh, cool
23:25:55 * rudi has just left a different note on the title :)
23:25:59 <jjmcd> OK
23:26:14 <rudi> So are folks here happy if we start removing the tables from the XML of the RN?
23:26:26 <jjmcd> I'd be tickled to death
23:26:30 * stickster has just left a different different note :-)
23:26:54 * jjmcd is glad his server only fetches the mail every 5 minutes
23:27:02 <rudi> lolz
23:27:20 <rudi> jjmcd -- comments are on the Talk page on the wiki, not on the list :S
23:27:28 <jjmcd> So, besides the howto coming up, anything else on release notes?
23:27:33 <jjmcd> Oh good
23:28:20 <jjmcd> #topic Guide Status
23:28:42 <jjmcd> Has everyone updates the schedule
23:28:43 <jjmcd> #link https://fedoraproject.org/wiki/Docs_F13_schedule
23:29:36 <stickster> jjmcd: What is the follow-through plan for the guides with no names beside them?
23:29:40 * jjmcd needs to start IRCing from a faster box
23:29:58 <jjmcd> Most have an owner, Sparks has a list
23:30:08 <jjmcd> but some owners may need relief
23:30:09 <stickster> jjmcd: Is it on the wiki perchance?
23:30:25 <jjmcd> Some are on the meeting page
23:31:08 * jjmcd would offer to email the missing owners, but with heads-down until the rpm wednesday, I'm sure to forget
23:31:24 <rudi> list is here -- https://fedoraproject.org/wiki/Docs_Project_guides_table
23:31:42 <rudi> (needs a little updating)
23:31:48 <jjmcd> Yes, I think that is included on the meeting page
23:31:54 <rudi> Ah sorry :)
23:31:59 <rudi> So it is :)
23:32:30 <rudi> stickster -- I'm standing by to take care of anything not owned
23:32:43 <jjmcd> How about we defer this until next week when the beta rpm is out the door, and who knows, maybe we will have our fearless leader back
23:32:50 <stickster> true true
23:32:55 * stickster defers, first things first
23:32:57 <stickster> rudi: Thanks
23:33:14 <jjmcd> #action Handle missing guide owners at March 24 meeting
23:33:16 * stickster would rather see more shared load there, for sure
23:33:29 <stickster> jjmcd: That's a good time to do it, since SRPM package review is a week afterward
23:33:54 <jjmcd> And after some of the newer contributors have had a chance to play in the release notes they may be up for taking one of those guides under their wing
23:34:42 <jjmcd> Do any of the guide owners here present need any help?  Any issues?
23:35:50 <jjmcd> Anything else on guides?
23:36:07 <stickster> *chirp chirp* :-D
23:36:19 <jjmcd> OK then
23:36:22 <jjmcd> #topic Outstanding BZ Tickets
23:36:27 <laubersm> I'm still waiting on danielsm to send me updates for user guide
23:36:47 <laubersm> that likely won't make it in until F14 anyways but still
23:37:00 <laubersm> last I heard they were on a system at "home" where he would be this week
23:37:13 <jjmcd> Ahhh yes, I recall those comments
23:37:22 <jjmcd> Wasn't he in RDU this week
23:37:36 <jjmcd> OK
23:37:37 <rudi> laubersm -- do you think you'll have the bandwidth to incorporate Murray's notes from the list?
23:37:40 <jjmcd> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
23:38:30 <laubersm> rudi, very likely.  I just checked and I do have that email starred but I have not looked at it yet
23:38:53 * laubersm thinks she should look at the due dates before committing such things...
23:38:58 <rudi> ;)
23:39:23 * jjmcd still wants to know how to incorporate precognition into .procmailrc
23:39:43 <Emad78> I can do Murray's email. I've looked at it and gone through it all.
23:40:03 <laubersm> Emad78, COol!  go for it.
23:40:18 <Emad78> I have it all marked up with all his notes. :)
23:40:32 <jjmcd> Oh way cool
23:40:36 <Emad78> laubersm: I need a bug report right?
23:40:47 <laubersm> Emad78, you have commit access already?  Or should we get that taken care of tonight?
23:40:54 <laubersm> Emad78, no bug necessary
23:41:11 <Emad78> I have access to the User-Guide already for commits.
23:41:13 <laubersm> unless you do not have commit rights and do not want commit rights
23:41:28 <jjmcd> Emad78, the bug is really a communication feature, not a permission thing
23:41:31 <laubersm> Emad78, great - then just fix it :)
23:41:38 <Emad78> Ok, I'm on it.
23:41:46 <jjmcd> Outstanding
23:41:49 <laubersm> Emad78, what jjmcd said - and a tracking option
23:41:50 <stickster> woohoo!
23:42:31 <jjmcd> So, does anyone need any help with bugs?  Any particular issues?
23:43:13 <jjmcd> #info Emad78 showing evidence of awseomeness
23:43:30 * Emad78 is just trying to help out.
23:43:38 <jjmcd> :-))
23:43:50 <jjmcd> anything else on guides/bugs?
23:44:02 <laubersm> rudi, is user guide branched and ready for master to have F13 updates?
23:44:13 * laubersm is too lazy to look at the moment
23:44:27 <rudi> laubersm -- changes go into "master"
23:44:29 * laubersm figures if anyone has done it recently, it was rudi
23:44:38 <rudi> We only branch when we're ready to drop to translation
23:44:54 <rudi> (which then freezes the content in the F13 branch)
23:44:56 <laubersm> got it
23:45:01 <laubersm> thanks
23:45:06 <rudi> The RN is a bit different ;)
23:45:13 <laubersm> Emad78, are you playing with the F13 alpha yet?
23:45:25 <Emad78> laubersm: No I haven't
23:45:37 * laubersm notes that she has mostly worked on release notes so that would explain the confusion
23:45:58 * jjmcd still needs to make an alpha stick
23:46:04 <stickster> rudi: Re: branching and translation
23:46:05 <laubersm> Emad78, because it is also past time to be looking for things to update for F13 in there as well.
23:46:41 <stickster> rudi: Are we going to have the opportunity to do another update before the final translation period, as noted in the email I sent to the Docs list earlier? Was that schedule sane?
23:46:41 <Emad78> laubersm: Ok I can get it and try to get something out of it.
23:47:08 <laubersm> Leave any details like screen shots and menu names for a while - they may still change again - but anything major like "default app"
23:47:30 <rudi> stickster -- with the RN, we were able to do so in the past, and your advice re string changes was succinct and on the money :)
23:47:32 <laubersm> or this no longer exists now type things can be done now
23:47:36 <Emad78> laubersm: Got it. I'll see what I can find.
23:47:41 <jjmcd> There were some default changes I think
23:47:59 <rudi> For the guides, once they're branched, we need to ask for exceptions from L10N to make changes in (say) the F13 branch
23:48:41 <stickster> rudi: Okeydoke -- thanks for the head check :-)
23:48:51 <laubersm> Emad78, like empathy as the new gnome IM default instead of pidgen - unless you do preupgrade like I did and it leaves pidgen...
23:48:55 <rudi> The real risk (which we've encountered in the past) is that once we change something in a branch, the big, well-staffed teams can accommodate it, but it places a much larger burden on the smaller (one-person!) teams
23:49:26 <stickster> laubersm: Emad78: Yeah, really the good thing to do is install F13 Alpha + updates to a VM and write based on what you see there
23:49:27 <Emad78> laubersm: Ok I see, well I'll get the Alpha and check it out.
23:49:36 <stickster> agreed
23:49:48 <stickster> rudi: Right.
23:50:17 <stickster> rudi: One thing we have on our side is an updates flow for the pending release
23:50:27 <Emad78> stickster: Is this always the DVD or just the Live CD???
23:50:36 <rudi> Yep; as long as we're *adding* stuff we're OK
23:50:49 <rudi> (for the RN!)
23:50:58 <stickster> rudi: *nod
23:51:09 <stickster> We should be careful not to tinker with changes too much in the existing strings
23:51:43 <rudi> Yeah; that's something for new folks here to keep in mind
23:51:55 <jjmcd> For the new folks, making unnecessary changes adds to the translation work
23:52:14 <rudi> So, for example, if something's not actually *wrong* in an existing guide, avoid changing it
23:52:22 <jjmcd> Obviously you want to fix something that is just plain wrong, but minor cosmetic changes, no
23:52:39 * Emad78 copies that.
23:53:14 <stickster> quaid: Do we currently have a working python-mwlib? I know about the dep problem, fixing it with a new update.
23:53:26 <stickster> quaid: Can we effectively pull down a page though?
23:54:38 <stickster> #info If something's not actually *wrong* in an existing piece of text, don't change it after we send to translators.
23:54:50 * stickster reminds that we should be using meetbot to keep notes for us ;-)
23:55:12 <jjmcd> OK, move on?
23:55:14 <stickster> IRC is tough enough already because it only catches people who are here -- we need the records on the list for people not here
23:55:24 <jjmcd> #topic All other business
23:55:34 <jjmcd> Hey David --- evenin'
23:55:40 <stickster> jjmcd: Are we copacetic with trading off meeting chairing?
23:55:44 <ke4qqq> hi jjmcd
23:56:01 <jjmcd> Sounds good to me
23:56:06 <stickster> k
23:56:09 <stickster> #agreed stickster will chair next meeting on 2010-03-24
23:56:14 <jjmcd> I'll be fried next week anyway, after the rpm!
23:56:22 <jjmcd> Anything else to come before this august assembly?
23:56:36 * stickster has nothing further but can help for a couple hours tonight with porting assuming our tool works
23:56:59 <stickster> jjmcd: Are you going to let the translators know when we'll have POT to them?
23:57:05 <stickster> Do we have an ETA for that?
23:57:27 <jjmcd> Don't have an ETA yet, but I am thinking we could be a long way along in 24 hours
23:57:44 <stickster> jjmcd: Let's commit to something
23:58:07 <stickster> Can we try for 11:00pm Eastern tomorrow night? That would be... er
23:58:16 <stickster> 2010-03-19 UTC 0300
23:58:33 <jjmcd> Sounds about right
23:58:37 <stickster> i.e. set a goal, then achieve it
23:58:39 <stickster> k
23:58:46 * stickster hopes zodbot is listening to him
23:59:02 <jjmcd> #action Have POTs ready 0300Z Friday morning
23:59:10 <rudi> worksforme
23:59:15 <stickster> jjmcd: need a person for that #action I think
23:59:18 <stickster> #undo
23:59:24 <jjmcd> rudi - you will deal with the mechanics?
23:59:24 <stickster> yeah, zoddie's ignoring me :-)
23:59:36 * jjmcd is suspicious of undo
23:59:40 <jjmcd> #undo
23:59:40 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2843bad0>
23:59:56 <rudi> jjmcd -- yep, I'll do the plumbing
00:00:07 <jjmcd> #action Have POTs ready 0300Z Friday morning - jjmcd get conversion done, rudi will do the plumbing
00:00:36 <jjmcd> OK, we are out of clock.  Anything else?
00:00:57 <jjmcd> Then we go to #fedora-docs for howto
00:01:10 <jjmcd> 10
00:01:16 <jjmcd> 5
00:01:21 <jjmcd> 4
00:01:35 <jjmcd> 3 seconds are too fast, these are lazy seconds
00:01:38 <jjmcd> 2
00:01:46 <jjmcd> 1
00:01:55 <jjmcd> THanks everyone
00:01:59 <jjmcd> #endmeeting