15:00:38 <adamw> #startmeeting Bugzappers meeting 2010-03-23
15:00:39 <zodbot> Meeting started Tue Mar 23 15:00:38 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:46 <adamw> #topic roll call
15:00:51 <adamw> morning, everyone - who's around?
15:00:55 * Tech33 is here
15:00:59 <bertux> I'm aroung as promised
15:01:17 <bertux> It's my first bugzappers meeting
15:01:28 <adamw> hiya bertux
15:01:40 <adamw> mcep: beland: ping
15:01:50 <bertux> thank you to welcome me :)
15:02:26 <bertux> I'm mentored as a future french Fedora ambassador
15:02:29 <adamw> awesome
15:02:59 <bertux> and I've already been sponsored as a french Fedora translator
15:03:07 <adamw> good stuff
15:03:08 <beland> Greetings
15:03:09 <bertux> but what i prefer is testing :)
15:03:13 <adamw> have you been able to get anywhere with bugzapping yet?
15:03:38 <bertux> I've managed to install F13 with BTRFS root filesystem on LVM
15:04:09 <bertux> I've managed to create and delete manually BTRFS snapshots before and after yum updates
15:04:38 <adamw> interesting
15:04:55 * waltJ is late but here
15:05:14 <bertux> but i haven't well understood how is organized the bugzapper process
15:05:17 <adamw> hi walt
15:05:33 <adamw> bertux: have you read the wiki instructions?
15:05:42 <bertux> not completly
15:06:19 <adamw> bertux: well, they're designed to get you started in the process - it's probably best to start at https://fedoraproject.org/wiki/BugZappers/Joining
15:07:04 <adamw> if you have questions after that, please ask on the list or on IRC
15:07:07 <adamw> hi iarlyy
15:07:55 <etank> im here but very green at bug zapping
15:07:58 <adamw> hiya
15:08:06 <adamw> don't worry, everyone starts that way =)
15:08:33 <adamw> are any of our more experienced members interested in doing any mentoring for new members at present btw? seems like we have a few new people in the room
15:08:59 * mcepl is here, sorry too late
15:09:12 <adamw> hi mcepl
15:09:23 <adamw> don't worry, we've just been chatting with some of the newer members
15:09:33 <adamw> say hi to etank and bertux
15:09:37 <Tech33> well...heh...I'm looking for a replacement :)
15:10:02 <adamw> Tech33: ah, been short on time lately?
15:10:13 <mcepl> etank, bertux: hi
15:10:14 <Tech33> unfortunately, yes
15:10:51 <adamw> Tech33: well, sorry to hear - thanks for all your work so far
15:10:58 <adamw> Tech33: what components are you looking for someone to take over?
15:12:28 <Tech33> mozilla/firefox
15:12:54 <bertux> thank you for the link :)
15:13:26 <adamw> bertux: no problem
15:13:41 <adamw> so is anyone interested in helping out with mozilla/firefox triage?
15:13:43 <Tech33> welcome bertux and etank
15:13:53 <etank> thanks
15:13:54 <adamw> tech33 and mcepl could probably help to get started
15:14:41 <mcepl> yes, of course, with the greatest pleasure
15:15:33 <adamw> #info tech33 is looking for someone to take over his mozilla/firefox zapping duties
15:15:40 <adamw> (that's just for the meeting logs)
15:15:44 <Tech33> understand
15:15:44 <beland> Out of curiosity, what's up with the popular Firefox crashers?
15:16:05 <etank> beland: do you mean the crashes on 64bit systems?
15:16:50 <beland> Bugs 543165 and 538207.
15:17:00 <adamw> i think beland means the couple of firefox bugs which have hundreds of duplicate reports and comments
15:17:12 <etank> yeah those are the ones (543165 at least)
15:17:21 <adamw> they're both crashes-on-close i believe
15:17:38 <iarlyy> ops, now here
15:17:42 <iarlyy> hi all
15:18:14 <adamw> hi iarlyy
15:19:20 <beland> Someone was going to speak to Firefox developers about them.
15:19:28 <adamw> well, if anyone does feel like giving tech33 a hand, please contact him on IRC or email or post to the list. tech33 = Chris Campbell, btw.
15:19:39 <adamw> beland: I think it was matej?
15:19:39 <Tech33> yep yep
15:22:20 <adamw> mcepl: did you get in touch with the firefox devs?
15:24:36 <mcepl> adamw: yes, I did, no guarantees about outcome, but they certainly know about the issue
15:24:45 <adamw> mcepl: okay, great. thanks
15:25:00 <adamw> so, anyway...we don't have anything on the agenda today so i'm just kinda letting it roll
15:25:42 <mcepl> all of them are doing large projects in the upstream code, so the time for Fedora bugfixing is limited
15:26:02 <adamw> oh, i was supposed to write a proposal to drop the Target tracker bugs after last week's meeting, haven't done it yet, sorry. i may in fact use an alternative proposal from oxf13 that we use them to track bugs we'll accept fixes for through release freezes
15:26:55 <beland> I wonder if any F13 users are experiencing either of those crashes.
15:26:59 <bertux> how can we help with Firefox bugs triage ?
15:27:26 <adamw> bertux: well, by doing some of it :) if you talk to mcepl and tech33 after the meeting, in #fedora-bugzappers or by email, they can give you some guidance
15:27:31 <etank> beland: im not but my F13 install is 32bit :/
15:27:59 <adamw> beland: i'm not either, but I didn't in f12.
15:28:04 <etank> i dont have a 64bit test box around
15:28:07 <bertux> adamw: ok i've bookmarked this channel too
15:28:15 <etank> adamw: the bug seems kind of hit or miss
15:28:33 <etank> im was wondering if it had to do with video drivers somehow
15:28:37 <adamw> etank: yeah, that's why we wanted someone to talk to the devs, just to see if we can get better reads on those bugs
15:28:37 <beland> I don't think they are 64-bit exclusive crashes; I experience one of them on my 32-bit machine.
15:28:57 <adamw> etank: they're obviously hitting multiple people, but we don't know exactly what it is. it could well be related to some popular extension
15:29:08 <etank> true
15:29:28 <mcepl> adamw: oh lovely, did anybody asked all affected to run firefox in safe mode?
15:29:32 <mcepl> shoot
15:29:33 <bertux> my firefox on f13 32 bits have only crashed one time if i remember well
15:30:04 <adamw> mcepl: I dunno, I haven't read through the bugs carefully yet
15:30:08 <bertux> yes i suppose most firefox bugs are due to extensions
15:30:54 <mcepl> adamw: me neither, I am afraid
15:31:26 <bertux> so, should i i submit a bug for the btrfs features missing by default ?
15:31:55 <adamw> bertux: you say there's a build in koji which works? which one is it exactly? link
15:31:56 <beland> It also affects Thunderbird.
15:31:57 <Tech33> have a meeting at work, sorry, I'll be back in an hour or so, I'll read the minutes
15:32:00 <bertux> i don't know how to be sure the bug isn't reported yet
15:32:45 <bertux> the build version i've downloaded from koji is -11 at the end of the name
15:33:19 <bertux> and the latest i've seen in the testing repo was named -9 at the end 
15:33:32 <bertux> i'm searching for precise links
15:34:15 <adamw> bertux: this one? http://koji.fedoraproject.org/koji/buildinfo?buildID=161415
15:34:28 <bertux> but the most surprising problems is that the btrfstools are not installed by default if you choose btrfs as filesystem :(
15:34:59 <bertux> adamw: yes this one
15:35:03 <adamw> okay, so the -11 build just got pushed to F13 stable today
15:35:13 <adamw> so you don't need to report bugs about anything that's working in -11
15:35:16 <adamw> here's how I found that out:
15:35:25 <bertux> cool :)
15:35:32 <adamw> first I noticed that the koji page lists it with the tag 'dist-f13', which indicates it's in the f13 stable repos
15:35:48 <bertux> but what about the rpm not being installed by default ?
15:35:57 <adamw> so i confirmed that by going to Bodhi - http://bodhi.fedoraproject.org/ - and searching for btrfs-progs
15:35:59 <adamw> that found this page:
15:36:03 <adamw> https://admin.fedoraproject.org/updates/btrfs-progs-0.19-11.fc13
15:36:19 <adamw> where you can see the comment from 'bodhi', dated today, which says 'This update has been pushed to stable'
15:36:39 <adamw> okay, for the package not being installed by default, you should file a bug, i believe against anaconda
15:37:58 <bertux> but i should search first if it's not already reported to avoid duplicate
15:38:11 <adamw> yes
15:38:18 <adamw> you can use the bugzilla search interface
15:38:33 <adamw> or a quick way to do it is to go to http://bugz.fedoraproject.org/anaconda
15:38:48 <adamw> you can always use that URL format - http://bugz.fedoraproject.org/(srcpackagename)
15:39:00 <adamw> that gives you a quick list of all open bugs on the package
15:39:15 <adamw> it's not actually very useful for anaconda as there's so many, but for a smaller package it's easy and quick to just eyeball that list
15:39:37 <adamw> searching that list for 'btr' gives no result, so i'd *guess* it hasn't been filed, but you might want to do a more comprehensive search first.
15:41:03 <adamw> hi robatino btw :)
15:41:56 <mcepl> adamw: against component "distribution", I believe
15:42:16 <adamw> mcepl: you think? i'm not quite sure. as I figure it, it'd need a hook in anaconda to know what fs you're installing onto
15:42:23 <adamw> mcepl: so it's not just a case of adding it to comps
15:42:45 <adamw> afaict the only sensible way to have it install only if you're installing a btrfs partition is to have anaconda do it...
15:42:48 <mcepl> not sure, but BTRFS is not much supported at all
15:43:03 <mcepl> so if you want to use, you have to be a tough guy
15:43:24 <adamw> mcepl: sure, but that doesn't mean you can't file bugs to make the implementation better.
15:43:39 <mcepl> of course, go ahead
15:44:00 <mcepl> not sure, where is the public IRC channel
15:44:25 <adamw> for btrfs? dunno
15:44:33 <adamw> for anaconda, #anaconda =)
15:45:22 <mcepl> yeah, #btrfs here has 91 users
15:45:31 <mcepl> I thought so
15:45:33 <pjones> of course, if the problem is that a package isn't installed by default, anaconda is not the right place.
15:46:30 <pjones> (and we do install btrfs-progs if you create a btrfs fs during installation.)
15:47:24 <adamw> pjones: bertux says he didn't get btrfs-progs in that situation
15:48:00 <bertux> pjones: yes that's what i've seen
15:48:21 <pjones> I'm very skeptical about that.  The code is shared with many other scenarios that we'd also see breaking.  I'd also expect to see, for example, no e2fsprogs on ext* filesystems if that were the case.
15:48:43 <bertux> but i've only tested the alpha version
15:48:50 <bertux> not with the latest version
15:49:07 <adamw> i can try and test it in a vm with tc1, if I remember.
15:49:21 <pjones> e95be86c        (David Lehman   2009-02-23 11:45:41 -0600       1079)    _packages = ["btrfs-progs"]
15:49:31 * Oxf13 looks at topic, still in roll call?
15:49:56 <adamw> Oxf13: i got lazy with the topics =)
15:50:02 <adamw> #topic general shootin' the breeze
15:50:37 <adamw> #action adamw to test btrfs-progs installation when creating a btrfs partition in installer
15:50:38 * etank has got to run. see you all in zappers later
15:50:42 <adamw> etank: thanks for coming!
15:50:54 <adamw> bertux: did you actually create a btrfs partition during install, or install onto a pre-existing one?
15:51:17 <bertux> i've planned to reinstall using TC1
15:52:44 <adamw> bertux: okay, it'd be good to know your results with that then
15:53:15 <adamw> on the topic of TC1 - for anyone who's unaware, Fedora 13 Beta TC1 came out yesterday, and QA group testing is underway, see https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test and https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
15:53:22 <bertux> yes i think i've just asked anaconda to reformat the existing partition
15:54:31 <adamw> bertux: well, if it happens again, let us know and keep a note of exactly the partition process you used
15:55:10 <bertux> adamw: do you think i should delete the partition and let anaconda create it ?
15:55:52 <adamw> bertux: that may change the behaviour, I guess, but i think you should do it however you initially *wanted* to do it, because obviously we'd want that process to work :)
15:56:02 <adamw> working around a bug doesn't help it get fixed
15:56:51 <adamw> alright, we're up near an hour now
15:56:56 <adamw> does anyone have any topics to bring up?
15:56:58 <adamw> #topic open floor
15:56:59 <bertux> so just asking anaconda to format it should be enough in the right process ?
15:57:15 <adamw> bertux: yeah, if you ask it to format a partition to btrfs it ought to install the tools, that makes sense to me.
15:57:33 <bertux> that makes sense to me too
15:58:06 <bertux> creating a filesystem doesn't mean creating a partition
15:58:36 <bertux> but i suppose reporting bugs about TC0 is not usefull anymore
15:58:49 <pjones> the code that's there is only tied to making the filesystem and mounting existing filesystems; it has nothing to do with the partition itself.
15:59:03 <pjones> bertux: well, tbf, this code hasn't changed in 13 months.
15:59:26 <adamw> pjones: so basically any situation where you involve btrfs in the installation in any way, you should get the tools
15:59:37 <pjones> adamw: that's how I read it, yeah
15:59:41 <adamw> ok
15:59:50 <adamw> well bertux will try again and i'll also test it if i get time
15:59:52 <bertux> pjones: i'm sure the tools was not installed because the binaries was not present
16:00:08 <pjones> bertux: so the question is - exactly what did you do?
16:00:20 * waltJ has got to jump on the train. see ya.
16:00:24 <adamw> cya walt
16:00:29 <adamw> we're coming up on end-of-meeting time
16:00:34 <pjones> indeed.
16:00:49 <adamw> bertux/pjones, please do discuss further in #anaconda or #fedora-bugzappers though :) and we'll try to figure out what happened in that situation
16:00:57 <adamw> thanks for coming, everyone
16:00:59 <bertux> i've checked the box named Format in the window about my existing LVM logical volume for /
16:01:41 <pjones> and it's set to btrfs in that dialog?
16:01:59 <adamw> #endmeeting