15:00:40 <quaid> #startmeeting
15:00:41 <zodbot> Meeting started Wed Mar 31 15:00:40 2010 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:10 <quaid> #topic Fedora Summer Coding - https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda - intro & roll call
15:02:33 <quaid> ok, despite throwing the agenda and stuff together late last night ...
15:03:17 <quaid> was finishing another project, so now I have most of my time to devote to Fedora Summer codin
15:04:00 * quaid waits a few more minutes to gives folks a chance to be here
15:04:47 * pwbarnes is ready.
15:05:05 * jreznik is ready, pinging rvokal
15:05:06 <dash123> meet started?
15:07:04 <pwbarnes> dash123: Started, but on hold to give everyone a chance to show up.
15:07:36 <dash123> ok
15:07:59 <quaid> #topic Fedora Summer Coding - https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda - Status on $whatever
15:08:30 <quaid> I did some updates and am about 1/2 way done with this set of pages:
15:08:44 <quaid> #link https://fedoraproject.org/wiki/Category:Summer_Coding_2010
15:09:15 <quaid> in particular, I worked from the [[GSoC 2010 plan]] to create the [[Summer Coding 2010 plan]], but it needs more thinking
15:09:41 <quaid> the hard target is that there are a number of different messages for different audiences
15:10:14 <quaid> I'll be working on those today and pushing the results back to the list.
15:11:14 * quaid gets the minutes from last week ..
15:12:31 <quaid> #link
15:12:33 <quaid> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-03-24/fedora-meeting.2010-03-24-15.02.html
15:13:07 * Southern_Gentlem hopes quaid gets this complete brain dump so next year only minir chances are needed
15:13:29 <quaid> Southern_Gentlem: yep
15:13:34 <jreznik> quaid: "a number of different messages for different audiences" means people responsible for fsoc, mentors, students etc? ;-)
15:13:42 <quaid> yep
15:14:07 <quaid> audiences I see are: students, mentors, sponsoring organizations, upstreams and sub-projects
15:14:30 <quaid> jreznik: have you been able to talk with folks about Brno ideas?
15:15:33 <jreznik> quaid: yes, rvokal is here - he likes the idea
15:16:00 <jreznik> we mentioned it on university last week, I met few people intersted in fsco
15:16:03 <jreznik> fsoc
15:16:07 <quaid> fsc?
15:16:24 <quaid> AAE! (acronyms are evil!)
15:16:32 <jreznik> yes, no sco ;-)
15:16:53 <quaid> what are some questions you all have or might have that you think your universities need to know?
15:16:58 <quaid> scheduling is one of them
15:17:04 <quaid> what our plan is in working with uni
15:17:29 <pilhuhn> level of needed expertise may be another one
15:18:36 <quaid> yes, plus, "What level of student do you want us to work with? beginner, intermediate, advanced?
15:19:28 <jreznik> quaid: I think we should have more levels - as we have now - bachelors/masters (not sure about right english terminology ;-)
15:20:03 <quaid> jreznik: yep, or we say "undergraduate and graduate" for the same thing
15:20:28 * jreznik thought that ;-)
15:20:53 <quaid> ok, I'll be working on the message for those different audiences today
15:21:05 <quaid> if anyone is around and wants to work on it, or review, etc., #fedora-summer-coding
15:21:27 <quaid> #action finish [[Summer Coding 2010 plan]]
15:21:39 <quaid> #action use [[Summer Coding 2010 plan]] to populate [[Summer Coding 2010]]
15:23:06 <quaid> mchua: let me know if there is anything more we can provide and under what timeline for discussions with Olin
15:23:13 <pwbarnes> At some point, we probably need to hit all of our communication channels with a status announcement and give some direction for those who are interested in participating.  Right now, there is some disjoint between the messages delivered to each channel.  People exclusively watching summer-coding do not have the same information as those watching redhat-summer or redhat-summer-mentors, for example.
15:23:32 <quaid> yes, that's imperative for this week
15:23:54 <quaid> there is a lot of GSoC stuff going on and we need to be clear what we are doing, yes
15:24:20 <quaid> I'll make sure to use those channels, but they are a bit out of band, especially now.
15:24:57 <quaid> ok, carrying a few others over from last week
15:25:09 <quaid> #action quaid working on updating wiki pages by 31 Mar
15:25:16 <pwbarnes> If you want to prepare a status announcement, I will work on pointing all channels to it and getting everyone talking through the same channels.
15:25:23 <quaid> #action need to set deadline for school participation
15:25:27 <pilhuhn> I saw JRuby doing their summer of code - perhaps also something for use to look at
15:25:28 <quaid> pwbarnes: ok, thx
15:25:41 <quaid> pilhuhn: do you have a link for that?
15:25:53 <pilhuhn> let me check
15:25:58 <quaid> #action need to set specific list of what a school needs to decide/figure out before deadline
15:26:11 <dash123> pilhun did you mean http://rubysoc.org/
15:26:30 <quaid> wow
15:26:53 <pilhuhn> dash123: yes
15:27:08 <quaid> that's useful
15:27:23 <quaid> #link http://rubysoc.org
15:27:33 <pilhuhn> Ah, that is Rsoc -- I saw that on jruby related messages - but those guys seem to work nicely together
15:27:49 <quaid> anyone interested in researching what they are doing and cross-comparing it?
15:28:10 <quaid> cross-comparing with what we are in the midst of doing, that is ...
15:28:18 <pilhuhn> I'd do, but /me is offline the next 2 weeks
15:28:22 <dash123> joomla guys are also cooking up something http://groups.google.com/group/joomla-student-outreach-program
15:28:54 <quaid> #link http://groups.google.com/group/joomla-student-outreach-program
15:29:06 <quaid> that's cool, people are getting the idea all over
15:30:13 <quaid> #action $someone to cross-compare rubysoc.org with Fedora Summer Coding
15:31:08 <quaid> anything more here?
15:32:23 <quaid> https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda - OpenHatch.org
15:32:46 <quaid> mchua and I have had separate discussions with Open Hatch
15:33:02 * jreznik is trying to find out how does OpenHatch work
15:33:04 <quaid> I'm looking for them as a possible way to organize small to large ieas
15:33:38 <quaid> jreznik: one way is, they have modules for a project bug tracker, and pulls in specially tagged bugs, e.g. "easyfix"
15:34:15 <quaid> the idea of the project aiui is to be a central location for people looking to get involved and for projects to post small to large needs.
15:34:38 <quaid> so the bug capture stuff is interesting, but not as much as we need.
15:35:08 <quaid> but I heard about plans/work to add a "missions" tool that lets projects do several things:
15:35:42 <quaid> level 1 - small research and get-to-know items -- download this and compile it to see how it feels; read these 5 wiki pages; etc.
15:36:16 <quaid> level 2 - small project work so the student and projects can learn about each other -- fix a minor bug; document something; do a test day; test a bug fix; etc.
15:36:40 <quaid> level 3 - sets of small projects or singular larger projects -- these are more like the traditional GSoC work.
15:37:10 <quaid> I thought it mapped pretty well to a nice process -- let students explore around with level 1 and 2 so they can fit a sub-project they fit with and are interested in
15:37:28 <quaid> and by the time we get to level 3, the sub-projects and the students know each other, etc.
15:37:45 <quaid> ok, so when is this stuff coming?  May perhaps
15:38:03 <quaid> so we'll need to do good old wiki-page-full-of-ideas for the sub-projects to post to.
15:39:04 <quaid> #action finish messaging and get the word out to sub-projects/mentors to compile ideas in [[Summer Coding ideas for 2010]]
15:39:54 <pwbarnes> The procrastinators will be defining their summer plans in May, so we will have to have at least our basic framework ready by then, or we will miss the window for this summer.
15:40:03 <quaid> right
15:40:15 <quaid> my feeling is one that we are already behind
15:40:30 <pwbarnes> I have that same feeling.
15:40:30 <quaid> so I have mid-April as the latest
15:40:46 <quaid> I'm going to try to increase the work I do via mailing list
15:40:58 <quaid> because I'm feeling a bit like I'm just grasping and not being focused.
15:41:11 <quaid> which brings me to ...
15:41:19 <quaid> #topic Task organization
15:41:30 <pilhuhn> Ok, I have to dro poff -- sorry
15:41:34 <quaid> k
15:41:47 <quaid> I don't normally like to load a new project with e.g. Trac, but ...
15:42:13 <quaid> if this does take off, and even with how complex it is already, we need to have actual task tracking.
15:42:36 <quaid> so I'm going to request fedorahoste.org/summer-coding and start to load it as a task tracker for the whole summer
15:42:53 <quaid> anything on that or ...
15:42:56 <quaid> any other topic?
15:43:36 <jreznik> sounds good to have trac instance
15:45:44 <quaid> ok, I'm done with agenda items ... and am happy to finish early and keep on working on this stuff ...
15:45:56 <quaid> any other topics/questions/discussion?
15:49:40 <quaid> ok, closing down ...
15:49:49 <quaid> #endmeeting