15:00:31 <adamw> #startmeeting BugZappers meeting 2010-04-06
15:00:32 <zodbot> Meeting started Tue Apr  6 15:00:31 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:46 <adamw> #topic gathering
15:00:53 <adamw> morning, everyone. who's here?
15:01:35 * etank is
15:02:03 <adamw> hi rjune
15:02:09 <adamw> hi iarlyy
15:02:10 <iarlyy> hi guys
15:02:12 <rjune> hello adamw
15:02:18 <iarlyy> hey adamw = )
15:02:20 <rjune> I heard there was beer
15:02:35 <SMParrish_mobile> Sortof here
15:03:03 * mcepl is
15:03:06 <adamw> rjune: i don't know what irresponsible jerk would have started THAT kind of crazy rumour
15:03:25 <mcepl> an interesting idea ;)
15:03:47 * adamw waits a bit in case tech33 is coming
15:04:45 <adamw> ah well, we'll save his item till he gets here.
15:04:57 <adamw> #topic last meeting follow-up
15:05:18 <adamw> #url http://meetbot.fedoraproject.org/fedora-meeting/2010-03-30/fedora-meeting.2010-03-30-15.00.html
15:05:20 <adamw> ah, hey tech33
15:05:21 <Tech33> sorry, got sidetracked
15:05:24 <adamw> just doing previous meeting recap
15:05:26 <Tech33> hi, I'm here
15:05:32 <adamw> hi bertie! welcome
15:05:43 <bertie_wooster> hi
15:05:55 <adamw> bertie_wooster: we should have some time at the end of the meeting to get you started (bertie's a new volunteer, everyone)
15:06:06 <bertie_wooster> ok
15:06:12 <bertie_wooster> i wait here
15:06:16 <adamw> okay, so, we had a few follow-ups last week
15:06:22 <mcepl> bertie_wooster: welcome!!!
15:06:30 * adamw tech33 to look into running a test class (adamw, 15:19:23)
15:06:37 <adamw> Tech33: any progress there?
15:06:47 <adamw> (that was about running classes for starter bugzappers)
15:06:57 <Tech33> no progress to report, I'll try to do better by next week
15:07:45 <adamw> alrighty
15:07:52 * adamw adamw to pass on the screencast idea to the mailing list (adamw, 15:20:00)
15:08:01 <adamw> so, yeah, i sort of forgot a bit :( busy week, last week
15:08:04 <adamw> i also will get that done this time
15:08:10 <adamw> let's clone those:
15:08:24 <adamw> #action tech33 to look into running a test class (see 2010-03-30 minutes)
15:08:35 <adamw> #action adamw to pass on the screencast idea to the mailing list (see 2010-03-30 minutes)
15:08:52 <adamw> okay, there was one more...
15:08:54 * adamw mcepl and tech33 to help etank get started working on the firefox bug mountain
15:09:06 <adamw> i see etank here, how's that getting along?
15:09:43 <Tech33> getting with him tonight
15:09:58 <mcepl> ehm, .... I had one chat with etank, but I am not sure whether we've got anywhere. Did we?
15:10:04 <Tech33> so clone that one too :)
15:10:42 * jeff_hann is here
15:10:45 <adamw> hi jeff
15:10:52 <jeff_hann> hi everyone
15:10:52 * adamw breaks out the cloning machine again
15:11:10 <adamw> #action mcepl and tech33 to help etank get started working on the firefox bug mountain (see 2010-03-30 minutes)
15:12:58 <etank> so far i have looked over the wiki pages. hoping to learn more tonight and be able to start helping.
15:13:04 <adamw> etank: great, thanks for sticking around!
15:13:15 <adamw> alright, that's what we had from last week
15:13:20 <adamw> onto this week...
15:13:33 <adamw> #topic impact of new release policies on BugZapping process
15:13:51 <adamw> so this is one tech33 added to the agenda list - https://fedoraproject.org/wiki/BugZappers:meeting-agenda-list - remember, you can add meeting topics there
15:14:16 <adamw> he listed it as "With the no frozen code, there is now a Fedora 13, even though it hasn't been 'released'. We are assigning bugs to it already. Could this cause issues, such as if a package were to be removed from Fedora before official release? Possibly other issues? RAWHIDE is now Fedora 14?"
15:14:34 <Tech33> I actually removed it an hour ago, because it's probably not an issue, just me being me
15:14:45 <adamw> hey, it gives us something to talk about =)
15:15:04 <Tech33> I noticed that we have bugs belonging to fedora 13...even though there isn't 'really' an F13 yet
15:15:30 <adamw> well, there is. it's still in development, but it _is_ Fedora 13.
15:15:38 <adamw> in terms of practical impact...we already adjusted some housekeeping procedures
15:15:51 <iarlyy> f13 still a rawhide ( I mean, is under devel process )?
15:16:02 <Tech33> so...is there any chance a package could not be in F13 release, but is in alpha or beta?
15:16:19 <Tech33> iarlyy: no :) rawhide is (or will be) f14
15:16:22 <adamw> there's a chance, yes.
15:16:37 <adamw> i don't think that's different from before, though; let's think what would have happened in f12
15:16:54 <adamw> say there's a package in f12 alpha that doesn't wind up in f12 final. sure, any bug initially filed against it would be filed against 'rawhide'
15:17:02 <Tech33> ok,that's actually what caused my concern.,... we could have a bug, recorded for a version, when after that version is 'gold' the package really isn't there
15:17:08 <adamw> but it would then be moved to '12' in the post-release automatic re-assignment of bugs
15:17:16 <Tech33> no
15:17:20 <Tech33> adamw: no
15:17:39 <Tech33> abrt is already assigning bugs to f13
15:18:14 <iarlyy> Tech33, just if reported uses f13, right?
15:18:17 <Tech33> rawhide is now no longer f13... see this is what I was wanting to discuss
15:18:20 <adamw> sure, I know. i'm just thinking if there's actually a difference from previous releases.
15:18:26 <Tech33> oh
15:18:35 <adamw> what I'm saying is, we would have wound up in the same situation even under the previous process
15:18:47 <Tech33> not really
15:19:00 <Tech33> before, there was a relase, and there was rawhide
15:19:36 <Tech33> now, there is a release, there is rawhide, and there is a "will be a release, but isn't yet, becuase it's alpha, beta, whatever"
15:19:53 <Tech33> the $10,000 question is...as triagers, do we care
15:20:23 <adamw> i was thinking about your specific example case, because it's hard to imagine all the possible consequences of the change before they happen. so i just wanted to focus on your particular example.
15:20:45 <adamw> as far as the bigger picture goes, i was mostly planning on the old reliable 'muddle through until something breaks' process =)
15:20:57 <Tech33> heh, ok
15:21:00 <mcepl> Tech33: no, for bug filling purposes we have IMHO stbale F12, we have Rawhide (F13), and then there is something crazy which is not expected to work.
15:21:16 <adamw> mcepl: no, rawhide is not f13. rawhide and f13 are separate things now. rawhide is f14.
15:21:23 <adamw> no bug in f13 should be filed against rawhide.
15:21:43 <mcepl> for bug-filing purposes, Rawhide is IMHO "something which is going to be released soon."
15:21:54 <mcepl> oh?
15:21:57 <adamw> Rawhide is Rawhide :) we can't call it something else 'for bug-filing purposes'
15:21:57 <mcepl> does it?
15:22:12 <mcepl> [17:21:25] adamw: no bug in f13 should be filed against rawhide.
15:22:14 <adamw> if they're running Rawhide, the bug should be against Rawhide. if they're running F13, it should be filed against F13.
15:22:16 <mcepl> why do you think so?
15:22:22 <etank> should there be a different designation (stable, *branched*, rawhide)?
15:22:38 <etank> until the branched is stable
15:22:54 <adamw> etank: Branched is the generic name for whatever-the-upcoming-release-is-right-now
15:22:55 <Tech33> mcepl: rawhide is no longer the f13 branch, if I understand the no frozen code
15:22:59 <adamw> so right now, Branched is 13.
15:23:25 <etank> right
15:23:38 * mcepl feels like completely loosing touch with the latest wave of craziness and returns to his safe crashing RHEL world.
15:23:44 <adamw> mcepl: i don't really know exactly what to say. we have a '13' listing in Bugzilla, we have a '13' out there: alpha, beta, and the trees on the mirrors.
15:24:16 <adamw> mcepl: oh, yeah, that's another part - if you install 13 Alpha and do updates, you're not on the rawhide tree. there's already a 13 tree on the mirrors, and you use that.
15:24:19 <mcepl> yes, but then why should "bugs in F13 be filed against Rawhide", when Rawhide is F14, isn't it?
15:24:37 <adamw> mcepl: i said '*no* bug in f13 should be filed against rawhide'.
15:24:50 <Tech33> adamw: actually, that sort of answers it, if it's a bug in f13, regardless of whether it is 'gold' or not, it gets reported to f13...if the package doesn't make it to f13 stable, then we worry about it
15:24:51 * mcepl goes to shoot himself
15:25:31 <adamw> Tech33: right, for your specific example i think there's a potential hole there but it's just not something we'd lose a lot of sleep over. the bug's still tracked, and any package which gets entirely removed from the distro is one we probably don't care _awfully_ about anyway.
15:26:45 <Tech33> ok, I'm good with that
15:27:15 <Tech33> I wonder how many people out there are using rawhide right now, that expect it to end up as f13
15:27:19 <adamw> okay. i think basically the situation is fairly clear. really as far as bz is concerned, we just act as if f13 already got released and went stable, even though it didn't...in practice for all bugzapping purposes it's as if it were a release already.
15:27:38 <Tech33> adamw: I agree with that
15:28:50 <Tech33> umm
15:28:59 <Tech33> heh, I just thought of something else :)
15:29:08 <Tech33> (sorry)
15:29:56 <Tech33> ok, so in the olden days, housekeeping would include moving all rawhide bugs to the new release...have the housekeeping instructions been modified so that does not happen ? or should have already happened?
15:30:11 <adamw> already happens
15:30:34 <Tech33> ok, so rawhide got moved to f13 some weeks ago by polekat?
15:30:46 <Tech33> err polecat
15:31:10 <adamw> yep
15:31:18 <Tech33> good :) ok, I'm done now
15:31:26 <adamw> can't remember if we planned it here or in qa meetings, but anyway, we did the re-base and adjusted the procedures
15:31:58 <Tech33> topic done?
15:33:19 <Tech33_lunch> I have a date, see you all later, I'll read to catch up
15:34:04 <adamw> alrighty, sorry, just having a distraction here...moving along
15:34:10 <adamw> thanks tech33
15:34:29 <adamw> #agreed no major outstanding issues related to the release policy change that anyone can think of
15:34:36 <adamw> #topic open floor
15:34:43 <adamw> okay, so, anyone have any other business to raise?
15:36:47 <adamw> on a side note, F13 Beta RC4 (confusing, I know) is out and as always the main QA group would appreciate all help with testing - see https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test and https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
15:38:50 <adamw> okay, then - maybe we can give bertie a few minutes :)
15:38:56 <bertie_wooster> :-)
15:39:00 <adamw> welcome bertie, thanks for volunteering. have you been reading the wiki?
15:39:08 <bertie_wooster> i have today
15:39:21 <bertie_wooster> i need to get some accounts and all
15:39:29 <bertie_wooster> at bugzilla... and fedora
15:40:48 <bertie_wooster> what i wanted to know is what a bugzapper actually does like does he reproduce the bug (it appears that he doesn't)
15:41:09 <bertie_wooster> and so on, the basics mainly
15:41:49 <bertie_wooster> you were talking about a bugzappers class earlier so that would have been it :-)
15:41:50 <adamw> right
15:41:52 <adamw> :)
15:42:01 <adamw> that was an idea we had last week, tech33 is working on it
15:42:11 <adamw> if we do run a test class i'm sure we could have you in it :)
15:42:54 <bertie_wooster> as for my background
15:42:57 <bertie_wooster> i have never participated before
15:43:20 <adamw> that's fine, bugzappers is a pretty good way to get started
15:43:21 <bertie_wooster> had been running debian on a bunch of servers/clients some years ago
15:43:38 <bertie_wooster> switched to fedora to try something new and liked it
15:43:40 <adamw> https://fedoraproject.org/wiki/BugZappers/How_to_Triage is probably the best 'what bugzapping actually is' documentation, that's the steps you go through when actually triaging a bug
15:43:42 <adamw> cool.
15:44:25 <bertie_wooster> but i never did any C-programming at all
15:44:38 <mcepl> that isn' expected at all
15:44:53 <bertie_wooster> i'll read the link you gave me
15:44:53 <adamw> yeah, most of us don't code either :)
15:44:58 <mcepl> we are supposed to change diapers on bugs, not fixing them ;)
15:45:04 <bertie_wooster> ok :-)
15:46:02 <adamw> the process is pretty much to send your introduction email to the list, pick a component from https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers (or one that's not on that list, if you're particularly interested in some package or group of packages), and then just start working through the bugs following the instructions on the How_to_Triage page
15:46:29 <adamw> https://fedoraproject.org/wiki/BugZappers/Tools is also helpful
15:47:16 <bertie_wooster> alright, so i read the wiki some more and just dive in. If i get something wrong will i get killed? :-)
15:47:53 <adamw> YES!
15:47:56 <adamw> no, of course not :)
15:48:25 <adamw> as you're going along, you can always ask questions in #fedora-bugzappers if you're not sure of anything (there'll probably be stuff you want to ask about)
15:48:33 <adamw> and if no-one's around, wait and try again or send a mail to the list
15:48:38 <mcepl> bertie_wooster: of course, in front of the whole bugzappers squad!
15:48:42 <adamw> we're all here to help, it's fine to ask questions
15:49:53 <bertie_wooster> so thanks for the info and I'll get to zap a bug soon :-)
15:50:05 <etank> bertie_wooster: Tech33_lunch is going to work with me tonight on how to triage firefox bugs.
15:50:17 <etank> might be good to follow along
15:50:35 <adamw> yeah, that might be helpful too, a lot of the procedure is fine no matter what area you're working on
15:50:42 <adamw> and we can always use more people looking at the firefox bug pile
15:50:43 <bertie_wooster> etank: yes, how will you do it?
15:50:55 <bertie_wooster> on the bugzappers channel?
15:50:59 <mcepl> and/or xorg bugs pile
15:51:04 <etank> bertie_wooster: i am meeting Tech33_lunch in #fedora-bugzappers around 6:30 EDT tonight
15:51:06 <mcepl> bertie_wooster: yes
15:51:36 <bertie_wooster> i have to look up EDT and its difference to UTC
15:51:43 <etank> gmt -4
15:51:59 <adamw> right now is 11:51 eastern time
15:52:01 <etank> it is 11:52 am here right now
15:52:03 <adamw> so they're meeting in 6:40
15:52:16 <adamw> whereabouts are you based?
15:52:22 <bertie_wooster> europe
15:52:29 <bertie_wooster> utc +2 right now
15:52:43 <etank> so that would be past midnight for you then
15:52:45 <Southern_Gentlem> add 6 hours
15:52:46 <adamw> ah, so it'll be night time for you
15:53:08 <etank> bertie_wooster: i log everything so if you like i can send you what happens in irc
15:53:19 <bertie_wooster> can't promise to be there. I'll try
15:54:11 <Southern_Gentlem> adamw,  after the meeting i would like to talk to you a couple of minutes please
15:54:35 * etank is off to lunch now
15:54:42 <mcepl> bertie_wooster: welcome, feel free to ping me ... I am in Prague, so closer to you than those crazy Yanks
15:54:51 <bertie_wooster> :-)
15:55:16 <bertie_wooster> mcepl: thanks, I'll remember to do so
15:56:06 * mcepl now mortally offended adamw, sorry
15:56:44 <adamw> er
15:56:48 <adamw> a) i live in canada
15:56:50 <adamw> b) i'm from england
15:56:51 <adamw> :P
15:57:14 <adamw> you're more likely to offend Southern_Gentlem, I suppose. but hey, you said 'yanks', so he can always figure it doesn't apply to him =)
15:57:53 <Southern_Gentlem> adamw,  term of endearment going back to WWII
15:58:58 <adamw> well, my point was it's derived from 'yankee', which certainly wouldn't describe a southern gentleman.
15:59:00 <adamw> but anyhoo!
15:59:19 <mcepl> adamw: I meant calling Canadian as if he was part of that thing southern of your border ...
15:59:19 <adamw> i think that's everything? did we have anything else?
15:59:29 <adamw> mcepl: hehe
16:01:10 <adamw> alright, thanks for coming everyone
16:01:12 <adamw> #endmeeting