19:00:13 <poelcat> #startmeeting Fedora 13 Beta Release Readiness Meeting
19:00:13 <zodbot> Meeting started Thu Apr  8 19:00:13 2010 UTC.  The chair is poelcat. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:18 * mmcgrath here
19:00:20 * ricky 
19:00:25 * ke4qqq 
19:00:30 * nirik is around
19:00:33 <poelcat> #topic rollcall
19:00:40 * rbergeron is square
19:00:40 <poelcat> hi everyone
19:00:53 <jlaska> hello
19:01:08 <poelcat> Oxf13 in the house?
19:01:22 * jjmcd 
19:01:53 <poelcat> anyone to represent translation or design?
19:02:59 * poelcat waits 60 seconds before starting
19:03:42 * sparks is here for Docs but could be in and out.
19:04:07 <poelcat> alrighty
19:04:19 <poelcat> we're here to do a quick sync-up for the Fedora 13 Beta
19:04:30 <poelcat> and make sure all the teams have what they need from each other
19:04:43 <poelcat> for a smooth and successful launch on Tuesday
19:04:50 <poelcat> anyone dying to go first?
19:05:05 <mmcgrath> poelcat: I'll go
19:05:09 <mmcgrath> done.
19:05:16 <poelcat> #topic Infastructure Status
19:05:26 <poelcat> any questions for mmcgrath ?
19:05:46 <poelcat> mmcgrath: no space issues, etc. that we need to discuss?
19:05:49 <mmcgrath> nothing major, we're in better shape this time then the alpha.  Lots to do before the final, not as much to do for the alpha.
19:05:55 <mmcgrath> poelcat: nope, verified that later last week.
19:06:12 <poelcat> excellent
19:06:24 <poelcat> thank you
19:06:28 <mmcgrath> yup yup :)
19:06:29 <poelcat> #topic Marketing Status
19:06:44 <rbergeron> we're ready. :)
19:06:45 <poelcat> rbergeron: how's things?
19:06:58 <rbergeron> peachy - beta announcement is just about finished.
19:07:01 <poelcat> anything we can help with or answer you need from others?
19:07:28 <rbergeron> nada - we're also still plugging away on fedora insight, just as a heads up - we're hoping it goes to staging soon, as soon as some kinks are worked out
19:07:35 <poelcat> rbergeron: so you'll hand the announce over to Oxf13 to include in his announcement when the bits are ready?
19:07:41 * stickster here
19:07:45 <rbergeron> indeed.
19:08:02 <poelcat> rbergeron: good deal
19:08:07 <poelcat> any questions for marketing?
19:08:21 * stickster notes Docs meeting last night also noted announcement status
19:08:39 <poelcat> rbergeron: thank you
19:08:40 <stickster> Docs team will be finding a few extra pieces of material in release notes to contribute to announcement
19:08:42 * rbergeron caught those notes
19:08:48 * stickster eof
19:08:51 <poelcat> #topic FESCo
19:09:05 <poelcat> nirik: anything from the devel side to note or disucss?
19:09:25 <nirik> Not that I know of off hand. Everything seems ok to me.
19:09:38 <nirik> I think features are all set now.
19:09:38 * sijis apologies for being late
19:09:48 <poelcat> nirik: thats how we like it :)
19:09:51 <nirik> yep
19:09:54 <poelcat> nirik: thanks for tracking those down
19:10:05 <poelcat> any questions for nirik before we move on?
19:10:43 <poelcat> thank you nirik
19:10:46 <poelcat> #topic Websites
19:10:52 <poelcat> ricky: what'd we know?
19:11:16 <poelcat> or sijis ?
19:11:23 <ricky> The only thing we need for the beta is to get the countdown banner up
19:11:41 * nirik notes the desktop spin is back to cd sized. I don't know if there were changes made to website for the 1gb USB?
19:11:43 <poelcat> does anyone know the status on it from desig?
19:11:55 <stickster> Is mizmo here?
19:12:05 <ricky> I think the design team handled collecting translations for the banner this time - I notice there are a bunch of files at http://inkscaper.fedorapeople.org/Fedora13/countdown-banner/source/ - looks like we just need PNG versions
19:12:29 <sijis> see the png directory: http://inkscaper.fedorapeople.org/Fedora13/countdown-banner/png/
19:12:48 <ricky> Er, make that separate PNG versions :-)
19:13:04 <stickster> ricky: per language, you mean?
19:13:05 <ricky> Oh, and the parent directory has tar files - I bet that's what they are
19:13:29 <ricky> Yup, it looks like it's all prepared for us already, awesome :-)
19:13:56 <poelcat> great to hear
19:14:01 <ricky> sijis: Anything to add other than that?  Do you know when the get redesign stuff is scheduled for?
19:14:05 <poelcat> any questions for the websites team?
19:14:21 <ricky> nirik: Good catch on the size change, I'll make a note to change it for beta
19:14:25 <poelcat> i have one question... how are we looking for the final resdesign for GA?
19:14:32 <sijis> ricky: there isn't a specific date.. may be just after this release.. we can deploy it.
19:14:41 <stickster> poelcat stole my question
19:14:48 <sijis> i need to find/do the content on it mostly now.
19:14:59 <sijis> and a little tweaking here/there.
19:15:03 <mmcgrath> sijis: but as far as you guys are concerned it's a post F13 thing?
19:15:05 <poelcat> sijis: so we are NOT targeting to have it complete for GA?
19:15:31 <nirik> ricky: thanks.
19:15:36 <sijis> i think it would be safer to do it post F13
19:15:44 * ricky thinks it's probably better off not rushing something that big
19:16:07 <poelcat> i don't think anyone disagrees there
19:16:18 <poelcat> thanks sijis and ricky
19:16:22 <poelcat> #topic Documentation
19:16:32 <poelcat> jjmcd: how are you guys doing?
19:16:39 <jjmcd> Docs is in good shape.
19:17:00 <jjmcd> we have a question for Oxf13 about the readme, but I think we are ready regardless
19:17:20 <poelcat> are we still missing Oxf13 ?
19:17:40 <poelcat> jjmcd: okay
19:17:49 <poelcat> anyone have any questions for the docs team?
19:17:50 <jjmcd> We do have to say
19:18:01 <jjmcd> L10N has really kicked butt this go around
19:18:21 <poelcat> jjmcd: awesome
19:18:47 <poelcat> anyone here from translation?
19:19:20 <poelcat> thanks jjmcd
19:19:23 <poelcat> #topic QA
19:19:36 <poelcat> jlaska: how are things looking testing party people?
19:19:54 <jlaska> for those who read the eng readiness minutes ... http://lists.fedoraproject.org/pipermail/test/2010-April/089986.html
19:20:08 <jlaska> QA is looking good ... we've completed our planned testing
19:20:12 <jlaska> #link https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test
19:20:18 <jlaska> #link https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
19:20:41 <jlaska> Between now and release, we'll continue to monitor test@ for feedback
19:20:57 <jlaska> We have a few changes pending  for the Common_F13_Bugs wiki (https://fedoraproject.org/wiki/Common_F13_bugs)
19:21:32 <poelcat> any questions for QA?
19:22:09 * stickster 
19:22:12 <Oxf13> oh poop
19:22:17 <Oxf13> forgot that the meeting was today/now
19:22:28 <poelcat> Oxf13: you're just in time :)
19:22:31 <poelcat> jlaska: thanks!
19:22:35 <Oxf13> I was grabbing a quick bike ride before the snow storm comes through
19:22:39 <poelcat> #topic Release Engineering Status
19:22:40 <Oxf13> (yes, it was just snowing in Seattle)
19:22:43 <jlaska> poelcat: anytime, thanks to people for testing!
19:22:59 <stickster> jlaska: General question -- has the flow of packages been more workable/less workable/about the same for QA as previous releases?
19:23:37 <stickster> Might be a better question for retrospective. Feel free to hold 'til then.
19:23:55 <jlaska> stickster: I don't have that info off hand, but that'd be an interesting data point
19:24:10 <Oxf13> stickster: I do have data for that question
19:25:24 <poelcat> Oxf13: how are things looking on release engineering front over all for the beta?
19:25:44 <Oxf13> pretty good
19:25:57 <Oxf13> putting the final touches on the tree today between my appointments and will start staging it this afternoon
19:26:14 <poelcat> Oxf13: excellent
19:26:29 <poelcat> Oxf13: am i correct that http://download.fedoraproject.org/pub/fedora/linux/releases/test/13-Beta  is the correct path for export control filing?
19:28:02 <Oxf13> that is correct sir
19:28:15 <poelcat> alrighty
19:28:27 <poelcat> jjmcd: what was your question for Oxf13 ?
19:28:52 <jjmcd> We wanted to be sure Jesse didn't need anything else from us, esp. README
19:29:59 <stickster> Oxf13: Sorry I went silent on you there -- I'm simultaneously in another phone meeting. Awesome that you have data, if it's appropriate for retrospective we can hold off 'til then (so as not to derail this meeting). My question was probably best held until then.
19:31:07 <Oxf13> k
19:31:24 <Oxf13> jjmcd: um, I'm really not sure.
19:31:31 <Oxf13> I don't typically /do/ anything with a README
19:31:52 <jjmcd> It used to be on the DVD, don't know whether it still is
19:32:03 <jjmcd> in the root dir, no less, of the DVD, not the install
19:32:37 <jjmcd> If you don't do anything then we don't need to feel bad about not having it I guess
19:33:14 <stickster> Does that README still exist on disc?
19:33:42 <jjmcd> which disk? You mean in /usr/share/doc/HTML ?
19:35:32 <Oxf13> the compose tool probably makes a README or grabs one from a package.
19:35:37 <stickster> jjmcd: On the Installation DVD as you mentioned.
19:36:05 <stickster> Oxf13: OK, would be good to know if it's still there, and if so, whence it comes
19:36:16 <Oxf13> it seems to come from buildinstall
19:36:21 <Oxf13> git/anaconda/scripts/mk-images.x86:cat > $TOPDESTPATH/images/README <<EOF
19:36:27 <Oxf13> but that's in images/  not int he root of the DVD
19:36:36 <jjmcd> We will go ahead and update it anyway
19:36:52 <Oxf13> there is no README in the os/ dir
19:36:57 <Oxf13> thus it wouldn't be in the DVD either
19:37:11 <jjmcd> I rarely actually look at the DVD, just install it.  I happened to be looking at an old one the other day and in was in the DVD's root
19:37:32 <jjmcd> Which kind of makes sense for someone thinking about installing it
19:38:01 <poelcat> who owns the actions for this issue?
19:38:25 <stickster> I would say, jjmcd track down if the file still actually exists on the F13-Beta DVD. If not, issue is dead.
19:38:29 <jjmcd> I suppose Ocf13 needs to decide what he wants and I need to get ir for him
19:38:36 <jjmcd> OK, sounds good
19:38:55 <stickster> disco!
19:38:55 <poelcat> #action jjmcd track down if the file still actually exists on the F13-Beta DVD. If not, issue is dead
19:39:06 <poelcat> thanks jjmcd and Oxf13
19:39:11 <poelcat> #topic Ambassadors
19:39:19 <poelcat> ke4qqq: how are we doing?
19:39:39 * Oxf13 has a topic to circle back to when we're done
19:42:19 <poelcat> have we lost ke4qqq ?
19:42:21 <ke4qqq> sorry
19:42:26 <ke4qqq> got pulled away for a moment
19:42:30 <ke4qqq> no blockers on our side
19:42:46 <poelcat> ke4qqq: anything we can help you with or that we should be aware of?
19:43:23 <ke4qqq> nothing - aside from the normal request for advanced access to iso at GA for media production, but that's it
19:43:35 <ke4qqq> nothing for beta release
19:43:47 <poelcat> any questions for ke4qqq ?
19:44:36 <poelcat> thanks ke4qqq
19:44:43 <poelcat> #topic Design or Translation
19:44:51 <poelcat> can anyone give status for these teams?
19:45:08 <poelcat> any topics we need to disucss related to these teams outside of this meeting?
19:47:00 <poelcat> okay
19:47:05 <poelcat> #topic Open Discussion
19:47:13 <poelcat> anything from stickster or spot ?
19:47:20 <Oxf13> There is an issue that just got brought to my attention regarding the desktop live image
19:47:31 * nirik nods.
19:47:35 <Oxf13> there was a feature to make the desktop live image target 1G size limit, to work well with 2G usb sticks
19:47:46 <Oxf13> that's what we did for Alpha, and that's what I had prepared and tested for Beta
19:47:54 <Oxf13> however now they want to drop this feature and go back to CD sized images
19:47:56 <stickster> Nothing from me/.
19:48:12 <Oxf13> we've already built the beta images and I was hours away from staging it for mirrors
19:48:25 <Oxf13> so I think I need some guidance from the desktop team and others on what to do here
19:48:29 <jjmcd> Docs has some unraveling to do if it goes back to CD size
19:48:40 <stickster> rrgh, switching context
19:48:42 * nirik looks for desktop folks.
19:48:50 <poelcat> fwiw the feature page got dropped
19:48:57 <poelcat> because it was never completed
19:49:12 * stickster invited walters, mclasen
19:49:26 * nirik asked over on gimpnet
19:50:49 <walters> here
19:50:58 <Southern_Gentlem> Oxf13, so leave it for beta and if it happens for final fine
19:50:58 <stickster> poelcat: I think one of the issues is, was rel-eng or anyone else notified?
19:51:19 <stickster> And what are the effects of the change, since it was done in accordance with the Feature process?
19:51:24 <Oxf13> walters: we were discussing the Desktop live image
19:51:43 <Oxf13> walters: since we already made the 1G~ sized one for beta, and were just moments away from staging it
19:51:49 <walters> hmm
19:51:56 <Oxf13> walters: reverting back to the CD sized one will cause a respin, as well as a docs scramble
19:52:16 <Oxf13> potentially slipping the beta for a second time
19:52:21 <jlaska> I wasn't aware that we were reverting, I understood that we are providing both
19:52:23 <stickster> Wait, before we start describing things as a "scramble" let's find out exactly what's required.
19:52:23 <poelcat> what is downside of just leaving it the way it is ?
19:52:43 <jjmcd> "The way it is" -- 1G?
19:53:07 <walters> Oxf13: when/how was the 1G one made?
19:53:23 <walters> i don't know the process here; is it using the koji livecd bits?
19:53:31 <Oxf13> jjmcd: right, the way alpha was, just a 1g~ sized image
19:53:56 <walters> and is it done simultaneously when freezing the standalone path stuff?
19:54:00 <jjmcd> OK, that is what the docs reflect.  It is mentioned in a number of documents, not just release notes
19:54:10 <walters> i edited the desktop beat
19:54:15 <walters> which AIUI feeds into the release notes
19:54:16 <Oxf13> walters: it was made a few days ago, using content from the Branched repo (not updates-testing) and the .ks file from git, last updated... Mar 31st
19:54:21 <stickster> walters: That's correct re: release notes.
19:55:27 <jjmcd> But there are other affected docs -- live image, maybe IG & IQSG and maybe burning-ISOs
19:55:42 <walters> ok, well...so an option is going with the compose from alt.fp.org
19:55:45 <walters> http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/
19:55:47 <stickster> jjmcd: Each of those changes is likely a one liner
19:55:52 <jjmcd> Yes
19:56:01 <stickster> jjmcd: OK, just being clear about the scope of work.
19:56:07 <jjmcd> I doubt they are hard, just finding them will be time consuming is all
19:56:33 <walters> (i apologize again for the scramble here, it is really near the top of my list to improve automation and blame so it isn't always a last minute fight)
19:56:37 <Oxf13> changing those docs means a new release-notes package does it not?
19:56:44 <jjmcd> yes
19:56:48 <Oxf13> and getting that done means a respin of the standalone isos too
19:56:48 <stickster> Oxf13: Yes, but that has to happen anyway for translations.
19:56:48 <walters> but...
19:57:03 <Oxf13> stickster: not for Beta
19:57:07 <walters> you'd only see the release-notes package after you've actually insatlled, no?
19:57:12 <Oxf13> stickster: we're talking about what to do for Beta
19:57:13 <stickster> Oxf13: That doesn't make sense -- we didn't include one of the other late breaking issues in 12.0.95-4
19:57:19 <stickster> That couldn't be tagged for Beta either.
19:57:20 <walters> and if you're using standaconda the live image size doesn't matter to you anyways
19:57:41 <Oxf13> walters: do the release notes not get pulled into the live image?
19:57:54 <jjmcd> good point stickster, if the RNs change between beta and GA it isn't the end of the world
19:58:28 <Oxf13> stickster: the point was if we suddenly make the desktop live image /not/ 1G size, then we're shipping notes that explicitly are /for/ it being 1G sized
19:58:42 <Oxf13> ^M  Installing: fedora-release-notes         ################### [ 691/1167]
19:58:45 <nirik> the release notes do get pulled in.
19:58:48 <Oxf13> walters: fedora-release-notes are on the live image too
19:58:51 <stickster> Oxf13: By the point someone experiences relnotes *in* the Live image, they already know the size.
19:58:52 <walters> sure
19:59:05 <stickster> So yes, it may disagree with reality, but that will be corrected in an update like other content mistakes
19:59:21 <Oxf13> stickster: are you Ok with web notes not matching packaged notes?
19:59:35 <stickster> Oxf13: That will happen periodically until the GA release notes are done, so yes
19:59:37 <Oxf13> (or is that already the case)
19:59:54 <Oxf13> ok, so beyond the relnotes issue, we have the releng/qa issue
20:00:21 <Oxf13> eg spinning something we haven't previously looked at for alpha/beta, getting sign off on the compose to make sure nothing went fubar, and getting it staged.  All within a few hours...
20:00:29 <Oxf13> that seems less than possible to me
20:00:35 <jlaska> the existing live images wouldn't change, correct?
20:00:56 <poelcat> what is the core issue here?
20:01:01 <Southern_Gentlem> +1 push beta with the 1Gb images and fix in GA
20:01:02 <walters> Oxf13: what about using the existing images spun on alt?
20:01:15 <Oxf13> walters: wrong iso names
20:01:41 <walters> i've been booting in qemu my homespun ones...though admittedly i understand this isn't the same necessarily as what's happening on alt
20:01:43 <Oxf13> poelcat: the core issue is that we're currently set to ship beta with a live image size that is no longer a feature, and won't be used for Final
20:02:03 <jlaska> what size are we shipping for final?
20:02:05 <jlaska> 1G?
20:02:05 * Oxf13 mutters something about late changing features.
20:02:09 <walters> jlaska: CD
20:02:11 <Oxf13> jlaska: 700M~
20:02:18 <jlaska> oh, interesting
20:02:30 <poelcat> i guess these meetings are a good idea :)
20:02:38 <jlaska> I was under the impression we were shipping 1g (preferred) and 700M (deprecated)?
20:02:46 <nirik> around 635MB or so... but yeah.
20:02:58 <nirik> poelcat: indeed.
20:03:24 <poelcat> nirik: i was thinking this would be another snoozer :)
20:03:43 <Oxf13> jlaska: why would you be under that impression when we didn't do that for ALpha, nor for any of the beta RCs?
20:03:59 <glezos> pop!
20:04:09 <stickster> Oxf13: There was a discussion on desktop@ that we all posted in, I believe
20:04:11 <jlaska> Oxf13: from a discussion walters and I had regarding live images for F13
20:04:28 <stickster> incl. stickster, Oxf13, walters, jlaska, mclasen, and others
20:04:53 <stickster> Concluded here AFAICT: http://lists.fedoraproject.org/pipermail/desktop/2010-April/006045.html
20:04:55 <walters> the last update here is http://lists.fedoraproject.org/pipermail/desktop/2010-April/006009.html
20:05:00 <Oxf13> I fail to see where that discussion came to any conclusion, let alone with proper time to implement any such conclusions for Beta
20:05:41 <jlaska> details.  What do we need to decide here?
20:05:42 <Oxf13> "I think", "we should"
20:05:50 <Oxf13> "I could see us"
20:06:00 <Oxf13> "but I think"
20:06:02 <walters> yes, fair enough
20:06:06 <jlaska> is the decision ... whether to proceed with what we have, or rebuild live images for the Beta?
20:06:21 <nirik> slip, ship what we have and change after I guess?
20:06:28 <Oxf13> jlaska: that's the decision I see.  Go with what we've got, or respin the live images, with potential slipping
20:06:30 <nirik> (Are the two options).
20:06:56 <Oxf13> and slipping means slipping the final release date, again.
20:06:57 * stickster thinks we should ship what we have, which has been thoroughly tested, and change afterward.
20:06:59 <poelcat> what is are the risks/downsides of going with what we've got?
20:07:16 <poelcat> if they are not big enough, let's go w/ what we have
20:07:18 <Oxf13> poelcat: going to final with an image set that was not tested at Alpha or Beta
20:07:55 <walters> i'm not opposed to shipping what we have, though there's potential for confusion in the get-beta pages
20:08:00 <jlaska> that's not entirely accurate
20:08:01 <walters> that's the biggest risk i see
20:08:07 <stickster> That final image set, though, is something that has over time been used for previous releases.
20:08:09 <poelcat> Oxf13: isn't that what usually happens ? :)
20:08:12 <walters> Oxf13: on the other hand, it's exactly how every previous release has worked
20:08:39 <Oxf13> poelcat: no, usually the image sets and sizes we use for alpha and beta are the same ones we use for final
20:08:39 <walters> well, since f8 or whenever live was introduced
20:08:53 <Oxf13> walters: except you've made changes to them since F12 haven't you?
20:09:13 <walters> well yes, but we've made kickstart changes most releases too
20:09:16 * poelcat senses we are starting to reach point of diminishing return on this discussion
20:09:27 <jlaska> +1 for shipping what we have
20:09:41 <walters> admittedly these changes were more substantial in terms of diff size to the .ks files, but i actually diffed the content and it's a relatively small delta in terms of actual package set
20:10:10 <stickster> +1 for shipping what we have
20:10:12 <Oxf13> regardless of the risk, I'm also +1 to shipping what we have.
20:10:22 <Oxf13> in my mind it's far better than delaying yet another week
20:10:25 <walters> can someone point me to where the get-fedora page for beta is?
20:10:33 <poelcat> so is there anyone that objects to shipping w/ what we have?
20:10:39 <stickster> http://fedoraproject.org/get-prerelease  <-- points to Alpha still at this point.
20:11:01 <walters> so there's no messaging on that page about the size of the image now
20:11:36 <stickster> No -- any changes would have happened on the not-yet released branch for sijis' get-fedora redesign work.
20:11:42 <stickster> Not clear that's going to land for F13 at this point.
20:11:46 <walters> ah
20:11:54 * stickster refers to earlier on in this meeting for status, you may need to look at logs afterward.
20:12:05 <sijis> stickster: f13 will have the current layout.. we'll do the get-* after the f13 GA
20:12:17 <stickster> Thanks sijis
20:12:32 <walters> would it be possible to add a note on the beta page that "These images are larger than a CD, but will not be for Fedora final"?
20:12:46 <walters> i can take a stab at this if someone can point me to source
20:13:08 <poelcat> what do need to close on to end this meeting?
20:13:39 <sijis> yeah, we can add that to the prerelease page
20:14:04 <walters> sijis: great!  i think that would be the most useful thing to reduce confusion; i'm far less concerned about the release-notes RPM since my instinct is that far fewer people see/read that
20:14:21 <Oxf13> #agreed ship existing 1G sized desktop live images for Beta
20:15:01 <poelcat> #agreed ship existing 1G sized desktop live images for Beta
20:15:21 * poelcat will close meeting in 60 seconds
20:16:31 <poelcat> thanks everyone!
20:16:33 <poelcat> #endmeeting