21:06:21 <smooge> #startmeeting EPEL meeting 2010-04-09
21:06:22 <zodbot> Meeting started Fri Apr  9 21:06:21 2010 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:06:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:06:33 <smooge> #topic roll call
21:07:07 * nirik is around.
21:07:10 <smooge> and...
21:07:15 * tremble_ is about
21:07:20 <smooge> and...
21:07:35 <smooge> everyone else has gone home because its 1700 ET.
21:07:47 <smooge> #topic Change of meeting time to morning
21:08:27 <smooge> ok we never have had good turnout, and I know changing meeting times is like changing times on network tv (DEATH TO THE SHOW)
21:08:54 <smooge> but I think that 21:00 UTC is too late for too many people.
21:09:04 <smooge> nirik, how do your Friday mornings look?
21:09:34 <nirik> friday morning like. ;) I'm pretty flexable...
21:09:45 <nirik> it's very hard to get a time everyone can agree on.
21:10:05 <smooge> yeah.. so I am going for the 2-3 people who are here day in day out
21:10:24 <nirik> as long as it's not too early, or during another fedora meeting I am usually fine with it.
21:10:39 * smooge goes to figure out where schedules are.
21:11:01 <tremble_> http://fedoraproject.org/wiki/Fedora_meeting_channel
21:11:07 <smooge> I am going to put this up on the list and we will have a +1/-1 there and get it over with before next meeting
21:12:02 <smooge> tremble, what time works for you? 16:00 UTC?
21:12:21 <tremble_> I'm uk based, so any us morning time is fine
21:13:40 <smooge> okie dokie. 1600 UTC is my proposed time
21:13:56 * nirik is ok with that.
21:14:04 * tremble_ too.
21:14:10 <smooge> #action smooge will announce and get input for next meeting. But I think we will be at 1600 UTC
21:14:34 <smooge> thanks for staying up so late then tremble (well I am old and 2100 is my chamomile and digestion bisquit time)
21:14:48 <smooge> #topic python26
21:15:19 <smooge> ok looks like python26 got into the epel-testing and will need some review and looks. I am going to test and see what I can break with it
21:15:42 <smooge> dmalcolm is on a car ride to Boston at the moment so cant go over it (again a reason for moving meeting)
21:16:03 <nirik> I think it's in pretty good shape, but then I reviewed it. ;)
21:17:02 <smooge> I am using it and some others to do mediawiki1x
21:17:11 <smooge> I need to let dog in.. please go over what you know nirik
21:17:35 <nirik> yeah, it should be ok shape...
21:17:46 <tremble_> I assume you can't just use the normal python module packages against it?
21:17:46 <nirik> there are also several python26-whatever packages ready for review.
21:17:52 <nirik> nope.
21:18:07 <nirik> each one needed will have to be a 'python26-whatever' package.
21:18:37 <tremble_> That's going to be fun.
21:18:43 <Oxf13> with a capital FU
21:19:28 <smooge> ok so I think we should try and set aside next friday to do that.
21:19:40 <smooge> #epel at 1600 UTC for deal with pythong26
21:19:50 <smooge> how does that sound?
21:21:14 <smooge> #topic RHEL/CentOS update schedule
21:21:49 <nirik> well, it just needs more reviews, etc. ;) Not sure we can deal with it any in a meeting...
21:22:12 <smooge> #info Soon after an RHEL X.Y update occurs, it is pushed to the buildroots. So when 5.5 came out the EPEL build system was ready for it.
21:23:01 <smooge> #info When CentOS catches up with X.Y we look for packages that conflict/missing and remove them or add them to EPEL.
21:24:05 <smooge> Ok so what has come up after 5.3, 5.4 and 5.5 was that I (and maybe one other person :)) was confused about when packages that needed to be rebuilt against 5.x could be done.
21:24:37 <smooge> I thought we waited until CentOS was out, but that has not been the way of htings.. and I am just logging it here for posterity until it can be added to the Wiki :)
21:25:15 <smooge> nirik, oh I thought they had been built and were in epel-testing.. I was looking at more of running through and seeing htey didnt cause cats and dogs to live togehter
21:25:17 <nirik> yeah.
21:25:22 * abadger1999 watches the fun
21:25:29 <nirik> only python26 has been approved.
21:25:36 <nirik> the other reviews are pending... reviewers wanted. ;)
21:25:51 <smooge> ok well teach me to review and I can start catching fish
21:26:06 <smooge> #topic bzr updates
21:26:27 <abadger1999> So yeah -- I'd like to update.  Rationale went to the list
21:26:56 <smooge> abadger1999 reading it makes perfect sense as currently what we have while working for some subset can't work for the largest use cases.
21:27:11 <tremble_> would a naming scheme like unison's be a better idea?
21:27:41 <smooge> technically it might be.. its a pain as I am finding with mediawiki
21:28:32 <tremble_> ok, I've not tried that yet.
21:28:51 <abadger1999> tremble_: Yeah, it wouldn't be very easy to manage.
21:29:15 <abadger1999> Since we really only want to have compat packages when the API changes.
21:29:41 <abadger1999> So we could end up with bzr2.0-2.0.1 bzr2.2-2.5.1 etc.
21:30:13 <abadger1999> (since the API may or may not break when the x in 2.x changes)
21:30:15 <smooge> would it be bzr20-2.0.1 and bzr22-2.5.1
21:30:39 <smooge> just checking for my spec I am getting beaten by
21:30:44 <abadger1999> smooge: That would be fine... but I'd rather avoid it if I can.
21:30:48 * nirik would be ok with updating. as the breakage would only be those rare people who built against that abi/api... which I don't think would be at all common.
21:31:11 <smooge> abadger1999, no I meant if it was a compat you would call it without a . not that you needed to. (Sorry for the aside)
21:31:28 <smooge> abadger1999, ok lets do the following:
21:32:10 <smooge> 1) Subject: Announcing intent for major update to <package-name> email goes to epel-devel and epel-announce lists
21:32:19 <smooge> 2) Make the build and put it in epel-testing
21:32:52 <smooge> 3) Announce again (and maybe  blog it) that we are doing this and testers are needed or just stuff it when it breaks for you in 2 weeks
21:33:01 <smooge> 4) Push to epel in normal period
21:33:11 * nirik nods.
21:33:41 <nirik> I think this is a much less breakage case than any other of our problem children.
21:33:44 <abadger1999> Sounds good to me
21:33:49 <tremble_> Seems reasonable
21:34:42 <stahnma> dang it
21:34:44 <stahnma> I'm late
21:35:18 <abadger1999> brb
21:35:51 <smooge> stahnma, yes or no
21:36:02 <smooge> :)
21:36:02 <tremble_> With 5.5 occurring this is probably the best time to make that kind of change.
21:37:06 <abadger1999> Okay, I'll send the message out today.
21:37:40 <smooge> ok thanks
21:37:47 <stahnma> ok:)
21:37:59 <smooge> #topic Anything else (Open Floor)
21:39:11 <smooge> stahnma, we are probably going to move the meeting to earlier in the morning. Not sure it helps you any.. but wanted to let you know
21:39:21 <smooge> and after that.. not sure what else
21:39:57 <smooge> oh RHEL-6 was released last week on April 1. However it was only for the Arm particularly the Apple A4.
21:40:25 * tremble_ laughs
21:40:30 <smooge> not sure that we can build against it yet... but hey we can try requisitioning a large number of Ipads to do so.
21:40:45 <stahnma> I saw that
21:40:52 <stahnma> not sure if that will work for me, but I'll survive
21:41:38 <smooge> ok thanks
21:41:52 <smooge> ok stahnma did you have anything for the meeting?
21:42:29 <stahnma> not too much.
21:42:42 <stahnma> I've been hearing a lot more about people epel in the wild
21:42:52 <stahnma> now that EL5 is really starting to pick up traction in the enterprise :)
21:43:04 <smooge> hehehehhe
21:43:05 <stahnma> people using epel
21:43:33 <smooge> you won't believe how many people I know who are planning EL-5 migrations now that EL-3 is moving to the back pasture
21:43:40 <stahnma> I would
21:43:48 <stahnma> we did most of that two years ago though
21:43:54 <stahnma> which made me happy
21:44:16 <smooge> hehehe I am helping someone with a 7.2/2.1 upgrade to RHEL-3
21:44:29 <tremble_> Ouch
21:44:30 <smooge> [they aren't srue if the 2.6 kernel is stable enough for their tastes.]
21:44:46 <Kyril> .... O_O
21:44:57 <smooge> ok we have one last issue:
21:45:05 <smooge> #topic Clamav (again....)
21:45:06 <nirik> I had a link showing more mm hits for epel5 than fedora 12, but I can't seem to find it now.
21:45:23 <smooge> nirik, wow that would have been cool :)
21:45:33 <tremble_> Yeah, that surprised me
21:45:38 <smooge> ok clamav is dropping support for an older db style.
21:45:42 <smooge> They do this every now and then
21:46:03 <smooge> and we are usually stuck with odd things because our clamav packages are 'special'
21:47:01 <smooge> .whowns clamav
21:47:11 <smooge> .whoowns clamav
21:47:12 <zodbot> smooge: ensc (steve in Fedora EPEL)
21:47:24 <nirik> I think we are ok...
21:47:24 <tremble_> 'special' in the hand someone a bottle of bleach style?
21:47:48 <smooge> it is different. and that is all I will go into it.
21:48:07 <smooge> anyway.. I think I have gone over everything my little brain can hold
21:48:14 <smooge> anyone against me closing?
21:48:29 <nirik> we have 0.95
21:48:34 <nirik> which is ok. It's 0.94 thats dying
21:48:43 <nirik> http://fedoraproject.org/awstats/mirrors.fedoraproject.org/#urls
21:49:08 <smooge> ah ok
21:49:42 <smooge> ok I am oging to end in 1 minute
21:51:12 <smooge> #endmeeting