14:04:42 <rdieter> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-04-13
14:04:43 <zodbot> Meeting started Tue Apr 13 14:04:42 2010 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:46 <rdieter> #meetingname kde-sig
14:04:47 <zodbot> The meeting name has been set to 'kde-sig'
14:04:54 <rdieter> #topic roll call
14:05:02 <rdieter> who's present today
14:05:03 <rdieter> ?
14:05:13 <Sho_> I'm present
14:05:19 <Kevin_Kofler> Present.
14:05:39 <rdieter> #chair Sho_ jreznik Kevin_Kofler
14:05:40 <zodbot> Current chairs: Kevin_Kofler Sho_ jreznik rdieter
14:05:40 * than is present
14:05:43 <adimania> Present
14:05:59 <rdieter> #chair than
14:06:00 <zodbot> Current chairs: Kevin_Kofler Sho_ jreznik rdieter than
14:06:09 * SMParrish here
14:06:16 <rdieter> #chair SMParrish
14:06:16 <zodbot> Current chairs: Kevin_Kofler SMParrish Sho_ jreznik rdieter than
14:06:22 * rrix just says hi before detaching screen for school
14:06:32 * jreznik is here
14:06:36 <rdieter> #info adimania Kevin_Kofler SMParrish Sho_ jreznik rdieter rrix than  present
14:07:09 <rdieter> jreznik: seems the 2 topics on the agenda are largely yours, care which we do first?
14:07:28 <jreznik> rdieter: pk-agent?
14:07:34 <rdieter> ok
14:07:46 <jreznik> any other topic to talk today?
14:07:54 <rdieter> #topic Polkit agents reorganization, https://fedoraproject.org/wiki/Features/PolkitAgentReorg
14:08:15 <rdieter> (other agenda item is "Fedora Summer Coding ideas"
14:08:44 <jreznik> see the feature page
14:09:03 <jreznik> mclasen wants to solve it as we have now 3 implementations of polkit-agent
14:09:04 <Kevin_Kofler> cwickert: ping? This one also affects you. :-)
14:09:14 <rdieter> read it, seems to me largely a codification of current best practices
14:09:19 <rdieter> ie, a good idea
14:09:31 <cwickert> what meeting is this?
14:09:34 <cwickert> KDE SIG?
14:09:37 <Kevin_Kofler> Yes.
14:09:38 <jreznik> he wants desktops to take care about their own agents, so no autostart desktop files etc...
14:09:55 <Kevin_Kofler> So I have 2 remarks:
14:09:59 <cwickert> rdieter, I think his proposal is counterproductive
14:10:14 <Kevin_Kofler> 1. doing this will lead to users running some WM-only setup having no polkit agent.
14:10:15 <rdieter> jreznik: so autostart OnlyShowIn=KDE isn't ok?
14:10:29 <Kevin_Kofler> As there will be nothing autostarting them.
14:10:41 <cwickert> I think people should be free to use whatever aget they want to use and this can be easily done in the autostart settings
14:11:02 <cwickert> of course there should be NotShowIn or OnlyShowIn by default
14:11:11 <cwickert> but people can still tweak this
14:11:11 <Kevin_Kofler> 2. as far as polkit-kde is concerned, I think having a .desktop file with OnlyShowIn=KDE; shipped within polkit-kde is no different in practice from having it shipped with KDE.
14:11:24 <jreznik> Kevin_Kofler: ad. 1 - but these users who wants to run wm only are skilled enough to choose one... but still there should be one default
14:11:27 <rdieter> I consider "destkop to take care about their own agents" can be solved by a .desktop with OnlyShowIn=... as acceptable
14:11:34 <cwickert> if it is hardcoded somewehre in the package or even the code, its worse IMO
14:12:15 <rdieter> brb... -Eneed_more_coffee
14:13:42 <jreznik> the question is - do we need default one? isn't it too strict not allow packages to ship autostart?
14:13:46 <rdieter> too bad dbus can't active this on-demand. :(
14:14:06 <Kevin_Kofler> Activating on demand was done in 0.9, it lead to MORE issues.
14:14:10 <rdieter> jreznik: I agree, what's the arguement(s) against using autostart ?
14:14:19 <Kevin_Kofler> Because D-Bus activation would just pick a random one if multiple ones were installed.
14:14:21 <cwickert> I think packages should still be able to ship an autostart file
14:14:32 <rdieter> Kevin_Kofler: right, that's the orgin of my "too bad" comment.
14:14:38 <rdieter> Kevin_Kofler: if dbus were fixed... :)
14:14:56 <jreznik> on demand is much more worst
14:15:57 <jreznik> rdieter: mclasen just added me to that feature page as I'm polkit-kde packager... that's why I brought it here - I wasn't sure about autostart
14:16:16 <rdieter> jreznik: ok, need to find out then I suppose
14:16:50 <rdieter> I don't see the difference between autostart OnlyShowIn=GNOME and starting it in gnome-session, for example
14:17:01 <jreznik> but desktop env. could install own autostart desktop
14:17:27 <rdieter> maybe they meant a global autostart without OnlyShowIn
14:17:49 <jreznik> maybe, I'll ask Matthias - he's oflline
14:17:56 <cwickert> jreznik, but the file belongs to the agend, so it should be in the agent package IMO
14:18:03 <cwickert> s/agend/agent
14:18:21 <jreznik> cwickert: I think so
14:18:27 <rdieter> anyway, I see this as allowing desktop's finer control over what agents they want to use.  ie, a good tihng
14:18:29 <rdieter> thing even
14:18:50 <cwickert> I think Matthias wants one agent for every desktop and people can no longer choose which one is run
14:18:59 <cwickert> this is a typical GNOME developers approach
14:19:01 <rdieter> cwickert: if so, that's silly.
14:19:12 <cwickert> rdieter, +1
14:19:14 <rdieter> well, at least... something I'd disagree with.
14:19:39 <jreznik> I bet Kevin_Kofler wants the only one for KDE too ;-)
14:19:50 <rdieter> it's not clear what the rationale/intent is behind the "no autostart" comments on the feature page.
14:19:55 <Kevin_Kofler> jreznik: Indeed.
14:20:09 <Kevin_Kofler> cwickert: I also think there should be one default for each desktop and it's the desktop's job to set it up.
14:20:13 <jreznik> it's one of core desktop component so I think desktop should choose the right one
14:20:16 <Kevin_Kofler> I pretty much agree with mclasen there.
14:20:36 <cwickert> Kevin_Kofler, think of Xfce for example, it has no agent of it's own
14:20:38 <jreznik> I don't see any reason for user to override it
14:20:52 <cwickert> I think it should remain modulr
14:20:56 <cwickert> modular
14:20:57 <Kevin_Kofler> It's XFCE's job to pick the GNOME or LXDE agent (I doubt its users will want the KDE one ;-) ).
14:21:10 <cwickert> note the word "or"?
14:21:11 <Kevin_Kofler> Or to write their own if they really think it's needed. (I don't think it is.)
14:21:17 <cwickert> the user is to decide, not we
14:21:29 <Kevin_Kofler> Upstream XFCE is to decide, ideally.
14:21:41 <jreznik> cwickert: this is core component - I'm not sure users should change it
14:21:42 <Kevin_Kofler> But if they won't, the XFCE packagers are the next best ones to decide.
14:21:44 <cwickert> well, but if you make the desktop start it, then it's no longer optimal
14:22:09 <cwickert> jreznik, from a KDE pov it may be a core component, but not from a Xfce or LXDE user's pov
14:22:26 <rdieter> I'd suggest waiting to get a clarification on the "no autostart' part of the feature, before throwing any rebellions. :)
14:22:33 <cwickert> agreed
14:22:50 <cwickert> but I doubt this is worth being called a feature after all
14:22:59 <Kevin_Kofler> As I said on #fedora-kde a few days ago, PolicyKit is a core feature of Fedora, many programs assume its presence.
14:23:01 <rdieter> jreznik: you mind asking for clarification on that?
14:23:04 <Kevin_Kofler> And they'll become more and more.
14:23:18 <Kevin_Kofler> So a desktop which does not support PolicyKit is broken.
14:23:22 <jreznik> rdieter: ok
14:23:27 <rdieter> jreznik: thanks.
14:23:27 <cwickert> Kevin_Kofler, there are people who don't use anything that uses Polkit
14:23:43 <jreznik> Kevin_Kofler: I'm with you... you're right
14:23:45 <Kevin_Kofler> There are also people who use a typewriter. ;-)
14:24:01 <cwickert> right, but we are delivering software
14:24:21 <cwickert> if people want typwriters, there should be vendors to sell typewriters
14:24:28 <Kevin_Kofler> Another PolicyKit topic: what about pushing polkit-kde to F12?
14:24:37 <cwickert> anyway, this is becoming offtopic...
14:24:41 <rdieter> cwickert: true, that's a downside of dropping deps here, makes it harder or impossible to track when an agent is needed
14:24:45 <jreznik> but there should be default one for desktops/wms without preference
14:24:48 <Kevin_Kofler> I think that once we have 4.4.2 out there, we should do the required grouped update to finally run polkit-kde in KDE instead of polkit-gnome.
14:25:04 <cwickert> rdieter, yes, exactly
14:25:14 <jreznik> Kevin_Kofler: I'm not sure it's worth the change
14:25:21 <Kevin_Kofler> I think it is.
14:25:25 <Kevin_Kofler> It's trivial to do the work.
14:25:26 <rdieter> Kevin_Kofler: let's come up with a test plan for that, and *if* it proves itself, then we can think about it
14:25:40 <Kevin_Kofler> rdieter: The test plan is: it works fine in F13?
14:25:41 <Kevin_Kofler> :-)
14:25:51 <cwickert> not sure ether. I have no intentions to push lxpolkit to F12, at least not as default in the lxde-desktop group
14:26:13 <rdieter> Kevin_Kofler: :)  I think we can do a little better.
14:26:35 <jreznik> rdieter: there are still few issues - but usually it works
14:27:00 <jreznik> but for released versions - it's bigger change than even one major version update
14:27:08 <rdieter> jreznik: cool, that's part of why I want a test plan.  document the "issues" and test cases
14:27:54 <jreznik> rnovacek is working on it, he's not online right now
14:27:57 <jreznik> I'll ask him
14:28:11 <rdieter> jreznik: cool, thanks.
14:28:46 <zodbot> Announcement from my owner (stickster): Fedora 13 Beta is now available! Visit http://torrent.fedoraproject.org/ and help seed the torrents, please. Draft release notes available at: http://docs.fedoraproject.org/
14:28:50 <rdieter> #action: jreznik to ask rnovacek to help document current polkit-kde issues, to help come up with a test plan
14:29:02 * rdieter yays zodbot
14:29:23 <rdieter> can we move on?
14:29:52 <rdieter> #topic Fedora Summer Coding ideas
14:30:10 <rdieter> jreznik: was this yours?
14:30:23 <jreznik> rdieter: yes, again
14:30:35 <lestatforever> Sorry is the BugZappers meeting here?
14:30:50 <jreznik> I think FSC is quite nice opportunity do have done some jobs we don't have time to work on
14:31:03 <jreznik> the deadline for ideas is tomorrow
14:31:07 <SMParrish> lestatforever: 30 mins from now
14:31:35 <lestatforever> SMParrish: thanks... I was uncertain about the UTC times
14:31:58 <than> jreznik: please add fingerprint support on the list
14:32:20 <rdieter> jreznik: oh boy!  ok, brainstorm time.
14:32:40 <jreznik> than: ok, it's more finishing so it can be nice topic... and not very complicated
14:33:11 <Kevin_Kofler> Fingerprint support is indeed something we really need.
14:33:20 <than> Kevin_Kofler: +1
14:33:35 <Kevin_Kofler> I'd like to be able to use that fingerprint reader on my notebook. :-)
14:33:59 <than> jreznik: it's great if the student could work on this project
14:34:29 <jreznik> that's sad djaara left it, fedora and red hat as well
14:34:47 <Kevin_Kofler> What state is his work in now?
14:35:12 <Kevin_Kofler> Is finishing the work enough to fill a summer? Too much? Not enough?
14:38:08 <rdieter> I can't think of anything good of the top of my head right now, will think about it
14:38:39 <jreznik> I think there's still lot of work - so I think it's suitable as summer work, the easier one
14:39:36 <adimania> An idea is already mentioned on the "ideas" page about creating KDE Netbook Remix
14:40:06 <jreznik> it's Ryan Rix idea, I'd like to help him
14:40:45 <jreznik> adimania: this one is mostly about communication with other kde sig members and kde sig meetings
14:41:54 <Kevin_Kofler> Re fingerprints, we should also make sure that root auth in polkit-kde works with fingerprints.
14:42:05 <Kevin_Kofler> And kdesu support for fingerprint login would be nice too, if possible.
14:43:28 <jreznik> yep, so it's quite a lot work
14:44:27 <jreznik> it's here http://websvn.kde.org/trunk/playground/base/kfingerprint/
14:47:16 <Kevin_Kofler> Any other summer project ideas?
14:47:19 <rdieter> #help brainstorm fedora/kde related Fedora Summer Coding ideas
14:47:55 <rdieter> let's close the topic here for now, and will continue thinking about it...
14:47:59 <rdieter> #topic open discussion
14:48:02 <rdieter> anything else for today
14:48:03 <rdieter> ?
14:48:06 <Kevin_Kofler> 4.4.2
14:48:18 <Kevin_Kofler> There's some kdebase-workspace and kdelibs changes we should pull in.
14:48:25 <Kevin_Kofler> kdelibs to fix the webkit Obsoletes.
14:48:54 <Kevin_Kofler> kdebase-workspace has a fix for the icon in the Konsole entry in the desktop context menu and some KDM Plymouth changes.
14:49:32 <Kevin_Kofler> Re Plymouth, maybe we should leave out the Kubuntu stuff for now and keep only the original simple patch, as that's still what Plymouth is using in Fedora?
14:50:01 <Kevin_Kofler> And we also need to fix the F13 and F14 kde-settings to own /var/spool/gdm like F12's does.
14:51:52 <rdieter> ah, forgot about checking kde-setting
14:52:18 <rdieter> I was about to do the kdebase-workspace builds
14:52:24 <rdieter> for < F-14
14:54:27 <rdieter> ok, times about up, let's wrap up.
14:54:30 <rdieter> Thanks everyone
14:54:33 <rdieter> #endmeeting