21:07:11 <gregdek> #startmeeting
21:07:12 <zodbot> Meeting started Thu Apr 15 21:07:11 2010 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:07:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:07:29 <gregdek> #topic Fedora EC2 image status
21:07:35 <gregdek> So, what do we know?
21:07:57 <gregdek> jforbes, d'you know if huff was able to get an image working?
21:08:02 <jforbes> Well, I got an updated kickstart (basically a test, appliance-creator really needs an update).
21:08:29 <jforbes> When I created an image with it, it did not fix the selinux problem, but it fixed the further issues
21:08:55 <gregdek> What's wrong with appliance-creator?  Did it create a .ks file that needed to be hand-tweaked, basically?
21:08:56 <jforbes> Meaning I can boot it just fine with selinux=0, but we cannot pass kernel args to EC2.  So that needs to be debugged
21:09:27 <jforbes> gregdek: I am guessing so, he just passed me a ks file
21:09:37 <gregdek> Is the EC2 debugging something that we need help from Amazon folks with?
21:09:51 <jforbes> and mentioned that appliance tools needed fixing
21:10:01 <gregdek> Oh, wait...
21:10:02 <jforbes> No, we can reproduce it locally, no need for amazon on this point.
21:10:08 * gregdek misunderstood.
21:10:09 <gregdek> Got it.
21:10:41 <jforbes> So from last week, we knew of 2 issues, the selinux one is the first you encounter
21:10:41 <gregdek> So with selinux=1 it just fails to boot?
21:11:12 <jforbes> We had a local workaround of setting selinux=0 to see if there were further issues.  There were.  the further issues were fixed, but the selinux issues is not
21:11:18 <gregdek> Got it.
21:11:25 <jforbes> correct, the default (selinux on) fails with:
21:11:50 <gregdek> Has anyone pinged dwalsh or any of the selinux folks for advice?
21:12:05 <jforbes> dracut Warning: Machine in enforcing mode and cannot execute load_policy.
21:12:08 <jforbes> dracut Warning: To disable selinux, add selinux=0 to the kernel command line.
21:12:11 <jforbes> dracut Warning: Not continuing
21:12:11 <bobmcw> hey
21:12:32 <jforbes> No, I have not.  I was a bit busy over the last week with virt test day and the follow up there.
21:12:35 <bobmcw> I think we're still failing f12 on ec2
21:13:09 <gregdek> OK, so dracut+selinux=weirdness.
21:13:36 <jforbes> gregdek: not really, dracut + selinux works fine on my images, but they are not trimmed down installs
21:14:09 * gregdek thinks.
21:14:15 * pjones sighs, really wishes we'd moved to /sbin/init being a shell script that loads policy and execs /sbin/upstart
21:14:30 <gregdek> So appliance-creator is cutting something out that dracut needs, maybe?
21:14:47 <jforbes> gregdek: this kernel will boot fine in my images, which are lazy, more full installs.  They fail with images created from this kickstart
21:15:01 <pjones> gregdek: presumably either policycoreutils or one of the policy packages itself
21:15:15 * gregdek nods.
21:16:12 <gregdek> Maybe put policycoreutils + policy-* and see if that works, I guess.
21:16:41 <gregdek> And since huff isn't here, I'll put it on his plate and see if he squeals.  :)
21:17:22 <gregdek> #action huff look at adding policycoreutils + policy packages into ks file for F12 test
21:17:33 <gregdek> We'll ask more about it on the list.
21:17:52 <gregdek> So I guess we try that.  Anything else on image fun and games?
21:18:31 <jforbes> gregdek: anyway, given that those issues are very visibly making the boot fail, and a simple workaround of selinux=0 fixes it locally, I have no reason to believe that there are any issues with the AKI and ARI we have published
21:19:05 <gregdek> Right, it's just the AMI itself that is missing packages, probably.
21:19:09 <gregdek> So that's good.
21:19:17 <jforbes> indeed
21:19:25 <gregdek> Still, until we've got an end-to-end process that pushes all effectively, we don't have what we need.
21:19:57 <jforbes> gregdek: sure... Though the process is still changing soon AFAIK
21:20:02 <gregdek> Heh, true.
21:20:06 <gregdek> And no word on that.
21:20:14 * gregdek will send a quick note to Nathan for update.
21:20:38 <jforbes> gregdek: while you are at it, ask him about the free S3 storage on the fedora account... My credit card got billed for these kernels.
21:20:54 <gregdek> Crap.  Will do.
21:20:55 <jforbes> (All of $0.03 so no big deal)
21:21:02 <gregdek> LOL, ok.
21:21:32 <gregdek> Anything else on image stuff?  If not, I'd like to move on to smooge's questions.
21:21:33 <jforbes> gregdek: but they were uploaded at the end of the month, better to figure it out now before it is an amount that might matter
21:21:41 <gregdek> jforbes, will do.
21:22:10 <gregdek> jforbes, remind me of your account id again?
21:22:42 <jforbes> gregdek: will PM it
21:23:02 <gregdek> k, thx
21:23:46 <gregdek> OK.
21:23:58 <gregdek> jforbes, anything else on this topic?
21:24:03 <jforbes> nope
21:24:06 <gregdek> :)
21:24:08 <gregdek> Moving on.
21:24:13 <gregdek> smooge, you around?
21:25:15 <gregdek> smooOOOOooooge... :)
21:25:17 * huff here
21:25:29 <gregdek> hey huff, read back to see your new action item.  ;)
21:25:33 <smooge> here
21:25:34 <smooge> sorry
21:25:39 <huff> i can manage that
21:25:57 <smooge> coffee ran out
21:26:00 <gregdek> LOL
21:26:09 <gregdek> #topic usage of EC2 for community folks
21:26:14 <gregdek> So smooge, questions?
21:26:47 <smooge> ok so we are starting our cloud focus on Amazon (like everyone else :))... and people need to know... where do I start?
21:27:08 <smooge> do I need to get an amazon account? how much does it cost? where do I go?
21:27:22 <smooge> etc etc.
21:27:46 <gregdek> smooge, I've got some documentation that I've worked on about this.
21:27:53 <gregdek> I need to post it more publicly.
21:27:55 <jforbes> smooge: http://aws.amazon.com/ec2/ has pricing and such
21:28:35 <gregdek> Basically, if you're playing in Fedora-land, we'll front you the account info.  I'll send you the certs.
21:28:50 <smooge> ok thanks
21:28:54 <gregdek> There's lots of "how do I get started" docs that you can go through; I'll point you to the best ones.
21:29:03 <gregdek> I should be able to send that stuff to you early next week, is that ok?
21:29:53 <smooge> ok looking at the Canonical Cloud Cover they are using their version of FAS (inside of launchpad) to see accounts for their eucalyptis stuff
21:30:00 <smooge> gregdek, thats sounds good.
21:30:33 <smooge> or maybe its their EC stuff.. I get eucalyptis and EC mixed up at times
21:30:38 <gregdek> That's clearly the direction we should be going, but we're not there yet.  :)
21:30:53 <gregdek> The goal of Eucalyptus is, of course, to make that distinction nearly invisible.
21:31:06 <gregdek> So that means they're doing a good job of it.  ;)
21:31:09 <smooge> the question for me from infrastructure would be using FAS or something else?
21:31:40 <gregdek> smooge, it's a good question.  I think it'll be one of the next ones after we get Fedora images uploaded and working.
21:33:50 <gregdek> #action gregdek will put up instructions on "how to use community cloud account" on the wiki and send details to smooge
21:33:50 <smooge> ah ok.. I think it would require some 'engineering' on Infra's side to make it work well so I wanted to start looking now
21:33:57 <gregdek> smooge, I agree.
21:34:02 <gregdek> So let's get you up and running first.
21:34:08 <smooge> okie dokie
21:34:11 <gregdek> It'll also be good if you can play with the euca2ools.
21:35:08 <gregdek> Anything else?
21:35:15 <gregdek> If not, I've got a conference session I've got to get to.  :)
21:35:38 <Oxf13> oh I'm here, sorry for not seein earlier pings
21:36:11 <smooge> nope
21:36:14 <gregdek> Oxf13, I didn't actually ping you.  ;)
21:36:18 <gregdek> But I should have!
21:36:56 <gregdek> Anyway.
21:37:06 <gregdek> Any open issues for anyone before I call it?
21:37:15 <smooge> not from me.
21:37:22 <smooge> call it in 3
21:38:29 <gregdek> :)
21:39:15 <gregdek> All right.
21:39:20 <gregdek> #endmeeting