16:09:48 <smooge> #startmeeting EPEL meeting 2010-04-16 new schedule!
16:09:48 <zodbot> Meeting started Fri Apr 16 16:09:48 2010 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:10:07 <smooge> hi guys we will make this a quick one since well I screwed up in advertising it :)
16:10:12 <smooge> #topic who is here
16:11:10 * nirik is around
16:11:20 <smooge> and as someone who didn't advertise.. its pretty lonely here :)
16:11:29 <smooge> #topic tickets
16:11:46 <smooge> ok I don't think we have any outstanding tickets but I figure I should bring them up.
16:12:00 <nirik> No worries... I think we need to just start being very consistent moving forward and will get more folks.
16:12:15 * tremble nods
16:12:49 <tremble> Is there an easy way to get hold of all tickets that I watch bugzilla on?
16:13:19 <smooge> not sure
16:13:34 <nirik> tremble: yep. Your bugzilla frontpage
16:13:42 <nirik> https://bugzilla.redhat.com/frontpage.cgi
16:13:45 <nirik> I think it shows that
16:13:51 <smooge> I see we have 631 packages in testing/{4,5}/i386/ at the moment
16:14:35 <nirik> we also have 202 bugs.
16:14:40 <smooge> cool!
16:14:40 <nirik> https://bugzilla.redhat.com/buglist.cgi?product=Fedora%20EPEL&bug_status=NEW&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&bug_status=POST
16:15:07 <smooge> poor bugzilla.. it has to work so hard on some of these things
16:15:35 <nirik> yeah. ;)
16:15:43 <tremble> Almost as bad as our inhouse ticketing system.
16:16:05 <tremble> We hit Ticket 700000 this week.
16:17:17 <nirik> Also, and most importantly I have 4 epel tickets. ;) Need to poke at them...
16:17:53 <smooge> yeah.. I need to do the same.
16:18:04 <smooge> #url https://bugzilla.redhat.com/buglist.cgi?product=Fedora%20EPEL&bug_status=NEW&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&bug_status=POST
16:18:14 <smooge> #info https://bugzilla.redhat.com/buglist.cgi?product=Fedora%20EPEL&bug_status=NEW&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&bug_status=POST
16:18:41 <smooge> ok we are going to start through those.. will make that a priority for the next meeting
16:18:47 <smooge> #topic rhel-6
16:19:12 <smooge> ok some day we will have an RHEL-6 and our grandkids will say "this is a good os" :)
16:19:26 <nirik> indeed. We can hope. ;)
16:20:08 <smooge> beyond that I know dgilmore has a plan. once RHEL-6 beta comes out, we will be making xen6 a el-6 box and put some test boxes for people to play with.
16:21:31 <nirik> yeah, I will likely spin up a test instance here too for folks.
16:21:32 <tremble> There's going to be a shed load of extra packages needed to rebase some of the existing EL packages to their F-12 (?) counterparts...
16:22:00 <tremble> I have intentions of doing some development on an EL-6 beta box here.
16:22:23 <smooge> tremble, yes.. I expect that we will have a cubic bucketload of builds
16:22:37 <nirik> yeah, should be a lot more packages able to come in...
16:22:52 <smooge> and probably some backfill to 5
16:23:00 <smooge> ok still sometime in te future.
16:23:08 <smooge> #topic rhel-4
16:23:20 <smooge> ok this is our poor stepchild of a release.
16:23:30 * tremble has already stopped asking for EL-4 branches.
16:23:39 <nirik> most people don't ask for them anymore.
16:23:50 <nirik> but also I hear few complaints/bugs from epel-4 packages.
16:24:03 <smooge> well looking at the map, there aren't a lot of requests.
16:24:39 <smooge> but I wanted to bring it up so that we can focus on any issues if they come up.
16:24:39 * nirik nods
16:24:42 <tremble> I quite believe it's out there.  I suspect it's legacy support though.  We cease support same time as RH?
16:25:05 <smooge> or sooner if we find it too burdemsome an no-one pays us :)
16:25:17 * tremble laughs
16:25:34 <smooge> if 4.x goes the same way as 3.x.. when 4.9 comes out that will be the last release.
16:26:15 <tremble> I was under the impression it was X years after 6 comes out...
16:26:21 <smooge> it will then be like an old satellite circling the earth.. slowly coming closer and closer until it burns up in the atmosphere or lands in some Australians house
16:26:59 <smooge> well 3.x is supported til October and then its only supported on long term contracts
16:27:15 <tremble> Ah
16:27:15 <smooge> after 3.9 went out it was only security updates
16:27:20 * tremble nods
16:27:45 <smooge> when 4.9 comes out I would expect the same.. but then again I expected 6.0 when Fedora F-9 came out :0
16:28:20 <smooge> anyway.. I think we will want to have a process for dealing with stuff if 4.9 is the last major update.
16:28:35 <smooge> ok I think I have spouted on that long enough
16:28:40 <smooge> #topic rhel-5
16:28:53 <dgilmore> smooge: we support el4 until security updates stop
16:28:56 <smooge> ok 5.5 came out and the builds have it
16:29:43 <tremble> What was the decision re 5.4 -> 5.5 breakages, are the stable pushes to wait for CentOS?
16:29:56 <smooge> dgilmore, agreed but will we want to add a bunch of new stuff to el4 after some date? The argument against having a 3.9 tree was that 3.9 was in a slow state
16:30:14 * inode0 understands 4.9 to be the last point update too
16:30:17 <dgilmore> smooge: we probably should not add anything
16:30:51 <smooge> dgilmore, agreed
16:31:01 <dgilmore> once the last point update it out then we add nothing and do bugfix/security fix only
16:31:31 <smooge> #action will write last point release support policy for EPEL
16:32:49 <smooge> dgilmore, on the other topic.I believe breakage items that are fixed in epel-testing will go out 2 weeks after they were put in.. no matter if CentOS5.5 is out or not.
16:33:36 <nirik> smooge: it would be up to maintainers at that point.
16:33:49 <nirik> I would hope they would wait for centos to push to stable in cases where it matters.
16:34:46 <smooge> nirik, I thought we auto-pushed stuff if it had been in testing for 2 weeks
16:35:00 <nirik> no
16:35:09 <nirik> bodhi will just nag then...
16:35:20 <nirik> "your update has been in testing 2 weeks, would you like to push it to stable now?"
16:36:08 <nirik> so was it memcached that was in that weird state?
16:36:20 <smooge> ah ok
16:36:37 <smooge> memcached and probably some things linked against openssl stuff
16:37:05 <nirik> yeah, I would hope that maintainers would keep them in testing until centos updates... rhel5.5 people can get the fixed one from testing...
16:37:20 <smooge> speaking of which centos-qa is testing stuff
16:37:36 <smooge> hopefully in a week or two this time
16:37:54 <smooge> #topic open floor and/or closing
16:38:26 <nirik> so next week will be a workshop/work on bugs/help packagers get involved?
16:38:31 <smooge> yes
16:38:47 <nirik> cool. I will try and blog on it/advertise some.
16:38:58 <smooge> we will either have an open floor and or just go down the bugzilla list
16:39:31 <smooge> thanks for people showing up.. sorry for getting confused over the plan I made up :)
16:39:47 <nirik> no problem at all.
16:39:50 <smooge> I will wrap at 10:40
16:39:52 <nirik> thanks for running the meeting smooge
16:40:05 <smooge> np. its what they pay me the big bucks for
16:40:08 <tremble> Without going through AWOL maintainer what would be a sensible way to deal with bz 574409 ?
16:41:13 <nirik> .bug 574409
16:41:14 <dgilmore> smooge: nothing goes out automatically
16:41:18 <zodbot> nirik: Bug 574409 request for perl-Net-SSH EPEL build - https://bugzilla.redhat.com/show_bug.cgi?id=574409
16:41:20 <tremble> It just needs a copy from devel branch, tag, build.
16:41:25 <smooge> dgilmore, thanks I get confused easily on that
16:41:46 <tremble> The branch exists.
16:42:01 <smooge> .whoowns perl-Net-SSH
16:42:02 <zodbot> smooge: steve
16:42:16 <smooge> not sure that helped me any
16:42:34 <smooge> ok I would see about becoming the EPEL maintainer and build it
16:42:37 <nirik> tremble: was I going to build that for you?
16:42:51 <smooge> will talk this afternoon on how I can do that
16:43:00 <tremble> nirik: You said you would if you had chance.
16:43:29 <nirik> tremble: I think I forgot. I did a scratch build, but then got sidetracked. ;(
16:44:10 <nirik> anyhow, I can, or add one of you guys as comaintainer...
16:44:18 <nirik> see me in #epel after the meeting.
16:44:34 <tremble> ok
16:44:47 <tremble> That ticket is me BTW
16:44:58 <smooge> and with that we will end this meeting and go to #epel
16:45:01 <smooge> #endmeeting