14:06:10 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-06-01
14:06:10 <zodbot> Meeting started Tue Jun  1 14:06:10 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:48 <jreznik> #chair Kevin_Kofler than rdieter ltinkl SMParrish_mobile
14:06:48 <zodbot> Current chairs: Kevin_Kofler SMParrish_mobile jreznik ltinkl rdieter than
14:07:08 <jreznik> #topic roll call
14:07:13 <SMParrish_mobile> Here
14:07:14 * ltinkl is present
14:07:15 <Kevin_Kofler> Present.
14:07:18 * than is present
14:07:31 * thomasj waves
14:07:38 <Kevin_Kofler> The agenda needs fixing, the one item that's there is a copy&paste from an old meeting.
14:07:54 <jreznik> #info Kevin_Kofler SMParrish_mobile ltinkl jreznik thomasj than present
14:08:35 <jreznik> Kevin_Kofler: yes, quick copy&paste - few secs ago there was no agenda at all
14:09:09 <jreznik> I need a new template to copy from :)
14:09:11 <jreznik> #topic agenda
14:10:04 <jreznik> anything to be added to agenda for todays meeting?
14:10:22 <jreznik> 4.4.4 status
14:10:35 <jreznik> 4.8.50 status?
14:10:45 <jreznik> 4.4.80 sorry
14:10:50 <Kevin_Kofler> Yeah, those are always good to discuss.
14:10:56 * Kevin_Kofler wants 4.8.50. ^^
14:11:02 <thomasj> :D
14:11:27 <than> Kevin_Kofler: in next 5 year :)
14:12:06 <jreznik> not five years, in two years
14:12:22 <jreznik> ok, anything else?
14:12:31 <jreznik> it's going to be quick status meeting...
14:13:50 <jreznik> ok, let's start
14:14:05 <jreznik> #topic 4.4.4 status
14:14:15 <than> 4.4.4 is imported into CVS yesterday
14:14:42 <than> the patches still need to be adapted for 4.4.4
14:14:49 * rdieter wakes up, sorry.
14:14:50 <jreznik> than: Dirk updated kde-l10n-sr-4.4.4.tar.bz2
14:15:11 <than> jreznik: it's already updated in CVS
14:15:19 <jreznik> great, thanks
14:15:59 * thomasj has to leave (kids).. Thankfully not a big loss for the meeting.. laters..
14:16:00 <jreznik> than: I can do the patches/build work but tmrw
14:16:35 <Kevin_Kofler> We need a tag set up, unless rdieter already did it.
14:16:42 <Kevin_Kofler> rdieter: Can you please set up kde444 tags?
14:16:46 <rdieter> ok
14:17:46 <jreznik> oh, tag first
14:18:08 <jreznik> #action rdieter to set up kde444 tag
14:19:52 <ltinkl> on a related note, KDE 4.4.5 is scheduled to be tagged on June 24th
14:21:03 <Kevin_Kofler> Already?!
14:21:35 <jreznik> #info KDE 4.4.5 is scheduled to be tagged on June 24th
14:21:36 <Kevin_Kofler> That's not even a month after 4.4.4.
14:21:46 <ltinkl> yes
14:22:03 <ltinkl> and to be released on June 29th
14:22:11 <ltinkl> that is still this month :)
14:24:06 <jreznik> it's really soon
14:24:35 <jreznik> so now we need kde444 tag and rebase patches to 4.4.4
14:24:53 <jreznik> it's all for 4.4.4 status, lets' move on 4.5 beta 1 status
14:24:57 <Kevin_Kofler> The problem with .5 releases is that they somehow interfere with 4.n+1 prereleases, so they keep experimenting with "interesting" release dates.
14:26:12 <jreznik> the question is - do we really need to pick up 4.4.5? it's a big update with a few changes usually...
14:27:08 <rdieter> jreznik: word has it that there are a few kdepim-related fixes to land in the 4.4.5 timeframe
14:27:35 <rdieter> but we can reserve judgement, until the time comes and we see the changelog
14:28:03 <jreznik> rdieter: and we can just cherry pick patches we need... better than one big KDE update... but will see
14:29:31 <Kevin_Kofler> Well, I'm for the one big KDE update. :-)
14:30:04 <jreznik> Kevin_Kofler: but it's really huge update for small changes... we'll see...
14:30:10 <ltinkl> ye, especially when ppl start crying "Ubuntu has 4.4.5 already!" :)
14:31:22 <gholms> Does that really happen?
14:32:07 <jreznik> I'm not sure this happens (but I'm far away from Kubuntu word)
14:32:12 <jreznik> ok, let's move on
14:32:27 <jreznik> #topic 4.5.80 (kde 4.5 beta 1) status
14:35:04 <jreznik> kde-l10n is still missing (build failed)
14:35:46 <Kevin_Kofler> Is our kdebindings complete or did we have to disable some stuff (smoke etc.)?
14:36:06 <Kevin_Kofler> There's also a kdepimlibs ABI compatibility fix we need to make kdepim 4.4 work.
14:37:34 <rdieter> Kevin_Kofler: smoke (and frieds) was disabled
14:37:45 <rdieter> friends
14:38:03 <rdieter> something broke wrt qt-4.7.0-beta1 (it builds ok against 4.6)
14:38:45 <than> it should be reported to kde upstream
14:39:13 <rdieter> I notified -bindings list, but doesn't replace a proper bug report I suppose
14:40:18 <Kevin_Kofler> I guess I could fix it, but I don't have time today. Maybe tomorrow.
14:40:36 <rdieter> may be worth waiting for .85 coming later this week
14:40:48 <than> kdebindings is the only package which always has build issue by every major kde update
14:40:54 <than> rdieter: +1
14:41:06 <Kevin_Kofler> than: There's also kde-l10n.
14:41:10 <Kevin_Kofler> I hate those 2 packages.
14:41:13 <Kevin_Kofler> They're always broken.
14:41:29 <than> Kevin_Kofler: yes, kde-l10n too
14:41:41 <rdieter> something odd in .80's new dtd handling broke a bunch of other kde package's docbook generation
14:41:52 <jreznik> it's so difficult to try clean builds before release (even release for packagers?)
14:41:54 <rdieter> I noticed that when rebuilding stuff for new exiv2-0.20 in rawhide
14:42:29 <rdieter> got a handful of ftbfs now
14:42:57 <rdieter> amarok, kphotoalbum are 2 off the top of my head...
14:48:37 <rdieter> that's all, move on?
14:51:06 <jreznik> ops, sorry
14:51:23 <jreznik> #topic open discussion
14:51:57 <nucleo> What do you think about adding default UnredirectFullscreen=false in kwinrc to fix fullscreen applications flickering whenenabled  desktop effects? https://bugs.launchpad.net/ubuntu/+source/kubuntu-default-settings/+bug/327199
14:52:41 <Kevin_Kofler> It hurts performance, doesn't it?
14:53:04 <nucleo> don't know
14:53:27 <nucleo> I didn't noticed any performance issues but I am not sure
14:54:03 <Kevin_Kofler> The reason unredirecting fullscreen apps is done is for performance.
14:55:39 <jreznik> but the flickering is really very annoying
14:56:22 <SMParrish> Yes its annoying so I just turned of the desktop effects.  Dont want to take a performance hit to fix it though
14:57:04 <Kevin_Kofler> I guess we can disable this "feature" if it causes more trouble than good.
14:58:15 <nucleo> SMParrish: is there really bad performance with UnredirectFullscreen=false?
14:58:28 <rdieter> 1.  ask kwin upstream opinion
14:58:55 <rdieter> 2  either way, I think I'd rather document how users can toggle the option, rather than stray from upstream defaults here
14:59:18 <jreznik> +1
14:59:21 <SMParrish> nucleo: not sure just saying if using it causes a performance hit its not worth it just for eye candy
14:59:46 <SMParrish> rdieter: +1
14:59:52 <rdieter> nucleo: you mind asking the kwin folks what they think ?
15:00:21 <rdieter> given that, we can make an informed decision on the best way forward.
15:00:21 <Kevin_Kofler> Is the crash with i950 that's mentioned in Launchpad also reproducible in Fedora?
15:00:33 <Kevin_Kofler> Or is this just a bug in the version of the intel driver Ubuntu ships?
15:00:47 <Kevin_Kofler> Because if there's a crash, that's worse than just flickering.
15:01:05 <nucleo> rdieter: is there kwin channel?
15:01:30 <rdieter> not that I'm aware of, just mailing list
15:01:45 <rdieter> could try asking in #kde or #kde-devel first though
15:02:12 <nucleo> #kwin ?
15:02:34 <rdieter> https://mail.kde.org/mailman/listinfo/kwin
15:02:48 <rdieter> nucleo: looks like it, you found it
15:03:16 <nucleo> rdieter: Ok. I will ask
15:03:21 <rdieter> nucleo: thanks
15:04:37 <jreznik> we're out of time now...
15:05:19 <jreznik> #action nucleo to ask kwin people about UnredirectFullscreen=false option
15:05:21 <adamw> it's alright, we have a light schedule today
15:05:28 <adamw> take another few minutes if you need 'em
15:05:49 <jreznik> adamw: thanks, we can finnish it at #fedora-kde
15:05:50 <jreznik> #endmeeting