14:59:36 <adamw> #startmeeting Bugzappers meeting 2010-06-08
14:59:36 <zodbot> Meeting started Tue Jun  8 14:59:36 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:41 <adamw> #meetingname bugzappers
14:59:41 <zodbot> The meeting name has been set to 'bugzappers'
14:59:44 <adamw> #topic gathering
14:59:50 <adamw> show of appendages!@
15:00:35 <adamw> (who's here?)
15:02:03 * adamw makes sad little echoey noises
15:02:20 <fenris02> 
15:02:29 <adamw> yaay, i have a friend
15:04:49 * fenris02 looks around to see who brought beer
15:05:10 <jraber> Sorry, for some reason I thought this was done in #fedora-bugzappers
15:06:00 <adamw> nope, it's over here
15:06:15 <jraber> my mistake.  Your e-mail points here.
15:06:19 <adamw> fenris02: no beer, but you can always hit up wwoods for some high-octane hobo juice
15:06:45 <fenris02> phear.
15:07:19 <adamw> hmm, so, having no regulars around makes it hard to do the topics i had listed
15:07:23 <fenris02> only 3 active people?
15:07:33 <tcpip4000> no, 4!
15:07:38 <adamw> since all we have is follow-ups from last week, and a topic that's about two years old =)
15:07:54 <adamw> fenris02: we get a different set of people showing up every week, depending on who has conflicts etc
15:08:02 <mdomsch> howdy
15:08:05 * fenris02 nods
15:08:07 <adamw> hey matt
15:08:19 <mdomsch> so I mass filed about 300 FTBFS bugs last week
15:08:27 <adamw> #topic FTBFS
15:08:41 <mdomsch> hopefully using the approved methodology: state=NEW, keyword=Triaged
15:08:49 <adamw> mdomsch: yup, that's correct
15:08:52 <adamw> hey, patrickian
15:09:08 <patrickian> adamw: hello
15:09:12 <mdomsch> and people are slowly cleaning them up; I'm watching every change and "fixing" those that do it incorrectly
15:09:16 <mdomsch> e.g.
15:09:22 <adamw> #info mdomsch filed a new round of FTBFS bugs, correctly marked as triaged
15:09:26 <mdomsch> .bug 599777
15:09:31 <zodbot> mdomsch: Bug 599777 FTBFS valgrind-3.5.0-16.fc14 - https://bugzilla.redhat.com/show_bug.cgi?id=599777
15:09:42 <mdomsch> marked closed notabug, when the fix wasn't even in cvs yet
15:09:56 <adamw> does the 'fixing' involve a large club with rusty nails in it?
15:10:19 <mdomsch> adamw, only for those that are half-way through the obsolete/blocked process...
15:10:42 <adamw> i meant to use on the *packager* ;)
15:11:09 <adamw> okay, that all looks good, thanks for the info
15:11:11 <mdomsch> will there be a mass rebuild for F14?
15:11:26 <adamw> i believe i read somewhere that there will, but don't recall the details
15:11:41 <adamw> there's a rebuild when one is _needed_, which usually comes down to a gcc or glibc update
15:11:48 <mdomsch> then we'll need to "encourage" people to fix their failures either as part of that, or ahead of that
15:11:59 <adamw> best check with -devel for a more reliable answer
15:12:12 <mdomsch> EOM
15:12:16 <adamw> thanks again
15:12:22 <adamw> okay, let's walk the topics I had, anyway
15:12:25 <adamw> #topic follow-up
15:12:31 <adamw> the only real action item from last week's meeting was:
15:12:43 <adamw> kernel triage stock messages should be synced with bugzappers stock messages, anyone can go ahead and do this
15:13:14 <fenris02> adamw, there is a new gcc, is it planned for f14 or later?
15:13:40 <adamw> fenris02: i'm not sure. I guess that's it.
15:13:51 <dougalb> hi, just joining to follow along
15:13:54 <adamw> hi dougal!
15:14:20 <adamw> i see you just joined, welcome
15:14:27 <adamw> we have a couple of other recent members here today too
15:14:35 * fenris02 raises a hand
15:14:42 <adamw> the meeting agenda's fairly light, so once we're through that we could use the time to answer any questions you have
15:15:24 <adamw> okay, looks like the syncing of the old kernel triage stock responses with the current bugzapper stock responses hasn't happened yet...so i'll put that down as an action item for me to make sure it gets done for next week
15:15:47 <tcpip4000> adamw: I can check that
15:16:09 <adamw> tcpip4000: ok cool, i'll make it an action item for you then :)
15:16:13 <fenris02> c&p type answers you mean?
15:16:17 <adamw> #action tcpip4000 to synchronize kernel triage stock responses https://fedoraproject.org/wiki/KernelBugTriage and BugZappers stock responses https://fedoraproject.org/wiki/BugZappers/StockBugzillaResponses
15:16:21 <jraber> for the uninformed (+me) bugzapper stock responses = https://fedoraproject.org/wiki/BugZappers/StockBugzillaResponses but where are the kernel stock responses?
15:16:21 <adamw> fenris02: yeah, see the links
15:16:47 <adamw> jraber: see above :)
15:16:59 <jraber> adamw: you're fast
15:17:02 <fenris02> thanks :)
15:17:43 <adamw> okay, the only new thing on the agenda is one i wanted to mention
15:17:50 <adamw> #topic triage metrics
15:18:01 <adamw> those who've been around for a while tremble in fear when that #topic hits ;)
15:18:27 <adamw> to give some background, we've long wanted to have some data on triage, so we know who our active members are, what components we're covering, what components we're _not_ covering, and so on
15:18:36 <dougalb> metrics seem like a good thing
15:18:53 <adamw> yeah, that's not the trembling reason
15:19:33 <adamw> the thing is that this has been going on for a while =) a member whose nick is 'comphappy' worked on a system a year or so back, and had it going fairly well, then it more or less disappeared in a burst of rewrites and rethinks and reengineerings
15:19:58 <adamw> at last contact he was planning to make it part of Fedora Community instead, but we haven't heard anything on _that_ for months
15:19:59 <dougalb> ah, it needs revisited
15:20:29 <adamw> so my proposal is simple: stop waiting for awesome highly engineered web applications
15:20:45 <adamw> and work up a dull set of good-enough bugzilla queries instead
15:20:57 <adamw> which we can just run manually every week and dump into an email to build up a picture over time.
15:21:13 <fenris02> what sort of metrics do you want?
15:21:24 <fenris02> how do you manually pull them out today?
15:21:25 * mcepl here
15:21:28 <mcepl> sorry, late
15:21:31 <adamw> hey mcepl
15:21:56 <adamw> fenris02: i'll probably think of some as we go =) but the starting point is 'what bugs were triaged in the last $TIME_PERIOD'
15:22:24 <dougalb> and then by whom?
15:22:36 <adamw> then, 'what components were those bugs on', 'who triaged them', and over the longer term, 'are triaged bugs getting RESOLVED', are they getting set as 'needinfo' after being triaged (perhaps indicating we should have done more triage), stuff like that
15:22:37 <jraber> That should be simple with the 'triaged' keyword, right?
15:22:40 <adamw> yup
15:22:54 <adamw> that's why I want to just go ahead and do it in a really dumb low-tech way so we at least have something, very quickly
15:23:06 <adamw> rather than waiting for shiny fully-coded complex webapps
15:24:07 <adamw> so i'm happy to do this myself initially, just to make sure it gets off the ground, but if anyone else would rather, please go ahead; otherwise i can always pass it over in future
15:24:35 <jraber> I'll look into it.
15:24:41 <jraber> I'm not bugzilla savvy
15:24:47 <jraber> but it cannot be that difficult
15:24:48 * iarlyy here now!
15:24:52 <adamw> hey, iarlyy
15:25:02 <adamw> iarlyy: to catch you up: we're on triage metrics again (I know, I know)
15:25:05 <iarlyy> adamw, hi adamw, hi all
15:25:23 <adamw> iarlyy: i'm proposing we give up on the highly-engineered approach and just work up a few bugzilla queries we can run manually every week
15:25:28 <adamw> or day, or month, or whatever
15:25:53 <adamw> jraber: no, it certainly isn't, i'd estimate it'd take me a couple hours to come up with an initial set of queries and dump them into an email
15:26:09 <adamw> jraber: so i'm basically hoping to have this done by next week, or the week after that _max_
15:26:15 <iarlyy> samples?
15:26:30 <adamw> iarlyy: haven't done yet, i was proposing to do it myself but jraber has volunteered
15:27:04 <iarlyy> I need understand what is involved, maybe I can help as well
15:27:30 <adamw> jraber: protip - you may want to go with the command line 'bugzilla' client (package python-bugzilla) rather than using the web interface, it's quite powerful and you can then just script up the queries into a single command
15:27:38 <jraber> https://fedoraproject.org/wiki/BugZappers/Tools#Metrics
15:27:42 <adamw> jraber: but any approach is fine if it lets us get out the data quickly
15:28:12 <adamw> jraber: yeah, that's the leftovers from the comphappy approach
15:28:22 <dougalb> would this help? https://fedorahosted.org/python-bugzilla/
15:28:24 <adamw> iarlyy: i think it's really a one-person job to start with
15:28:29 <jraber> ok.  I will try my hand at it, if nobody objects to letting a newbie try it
15:28:29 <adamw> dougalb: see the protip above :)
15:28:29 <dougalb> query | mail
15:28:48 <dougalb> quick again
15:28:53 <iarlyy> jraber, go ahead
15:29:16 <adamw> jraber: sure, go ahead - if you get into trouble or have questions, just drop a mail to the list or poke IRC and we'll work on it
15:29:28 <jraber> ok
15:30:01 <adamw> jraber: basically we just want an email with the info discussed above, and the process needed to generate the same info on a regular basis. ideally, obviously, a simple short process.
15:30:26 <adamw> #action jraber to look at setting up some bugzilla queries to do simple metrics
15:30:33 <adamw> thanks!
15:30:56 <adamw> okay, that's all that's on the agenda. for the newer members - there's a page where you can list items you want to be on the next meeting agenda
15:31:11 <adamw> so if there's something you want to discuss at the next meeting, stick it in the table at https://fedoraproject.org/wiki/BugZappers:meeting-agenda-list
15:31:19 <dougalb> ok
15:31:28 <adamw> and whoever's setting up the meeting will check that before writing the agenda. unless they forget, in which case, poke them after they send the meeting announcement =)
15:32:09 <adamw> so, that leaves us with...
15:32:11 <adamw> #topic open floor
15:32:28 <adamw> anyone have something they'd like to discuss, or a question or proposal or problem or anything?
15:32:57 <dougalb> nothing to add, just wanted to sit in and hopefully contribute going forward
15:33:11 <adamw> thanks a lot :)
15:33:21 <jraber> Thanks adamw!
15:33:56 <tcpip4000> I always have think that wikipages are good but lacks some kind of index for bugzappers to start on their own to explore all the available documents
15:34:16 <adamw> for the new members - are you finding the instructions on the wiki enough, or is there anything you're not sure about yet?
15:34:22 <fenris02> tcpip4000, like a landing page that explains where all the resources/scripts are hidden?
15:34:29 <tcpip4000> something like : topic -> url
15:34:38 <adamw> tcpip4000: well, it's meant to be discoverable from the top page
15:34:42 <adamw> all the important pages should be linked from there
15:34:59 <fenris02> well, the current topic does not have a url at all in it
15:34:59 <adamw> plus, we send the reading list to new members when they send their introduction emails, which links directly to the important pages
15:35:28 <adamw> fenris02: you mean -bugzappers IRC? yeah, we should probably stick it in there
15:35:31 <adamw> i'm talking about https://fedoraproject.org/wiki/BugZappers
15:35:38 <dougalb> i think the wiki is a good landing
15:35:54 <dougalb> not seen the reading list email (yet)
15:35:54 <fenris02> adamw, yes, that's what i meant.  and yes, if we included that url in the topic it may be of use
15:36:04 <adamw> yeah, good idea
15:36:30 <adamw> #agreed IRC channel topic should have Bugzappers wiki page in it
15:37:32 <tcpip4000> Maybe the  "tool and procedures" section is what I'm talking about
15:37:32 <adamw> done and done!
15:37:40 <adamw> tcpip4000: indeed, that's more or less the idea
15:38:14 <adamw> tcpip4000: also, if you go to the 'Joining' page - https://fedoraproject.org/wiki/BugZappers/Joining - there's a 'how to start triaging' section at the bottom which links to the important pages to start at
15:39:32 <fenris02> adamw, shouldnt that list match what the newcomers get via email?
15:39:34 <tcpip4000> adamw: ok
15:40:03 <fenris02> or does that become a tldr problem?
15:40:37 <adamw> fenris02: heh, that might be optimal =)
15:41:04 <adamw> the 'reading list' kinda developed informally out of responses we'd write to intro mails on the fly
15:41:05 <tcpip4000> I just added the kernel triage page to the bugzapper front page
15:41:14 <tcpip4000> *I've
15:41:14 <adamw> in the end we got lazy and started copy/pasting
15:41:21 <adamw> tcpip4000: we were planning not to do that until it was updated
15:41:24 <adamw> since it doesn't cover current practice
15:41:53 <tcpip4000> adamw: just previewed not committed changes
15:42:35 <adamw> okay, leave it out for now
15:43:01 <adamw> once we manage to get a kernel triage process going again we can update it =)
15:43:42 <fenris02> sort of looking forward to that being published actually.
15:44:06 <adamw> yeah, shame nirik's not around this week to update us
15:44:11 * nirik is sorta here.
15:44:19 <adamw> last i talked to him he was still wondering how to deal with component-izing the kernel
15:44:24 <adamw> ooh, niriky goodness!
15:44:34 <nirik> I have not had much time to poke at it. ;(
15:44:41 <adamw> ah, ok
15:44:46 <nirik> I think we agreed on using blocker bugs for the components now
15:45:01 <adamw> do you expect to in the next week or so, or are you going to be short of time for a while?
15:45:08 <nirik> so, we/I need to make those bugs for the subsystems we know about.
15:45:27 <nirik> this week is going to be busy and I am going to be traveling next week. ;(
15:45:38 <fenris02> blocker bugs for components?  how do you mean?  ide dma issues become a kernel blocker?
15:46:11 <adamw> fenris02: the problem is that we'd like to treat different bits of the kernel as essentially different 'packages' in bugzilla
15:46:25 <adamw> since completely different people handle, say, wireless issues than handle, say, sound issues
15:46:30 <nirik> fenris02: each subsystem would have it's own blocker bug... KERNEL_STORAGE, KERNEL_FS, etc
15:46:41 <adamw> unfortunately we can't have new components added to bugzilla that aren't actually .src.rpms
15:46:50 <adamw> so we have to find a way to hack around it...
15:47:04 <nirik> so, if we triage a bug and it's a filesystem one, we can add it to that blocker... and the subsystem maintainers can watch the blocker bug and get email, etc.
15:47:08 <adamw> more accurately they'd be *tracker* bugs, not blocker bugs.
15:47:14 <nirik> yeah, sorry, tracker
15:47:20 <adamw> they're not really blocking anything.
15:47:50 <adamw> so, nirik, is there anything the rest of us can work on here while you're busy?
15:48:03 <nirik> sure! ;)
15:48:18 <nirik> if anyone wants to clean up the wiki page with stock responses that would be great.
15:48:33 <nirik> I guess for making tracker bugs we need a real up to date list.
15:48:37 <adamw> yeah, we've already got that down as an action item
15:48:41 <nirik> there is some info on the wiki page.
15:48:45 <adamw> a list of kernel bits?
15:49:07 <adamw> i guess the kernel team would be best-placed to give us that
15:49:07 <nirik> yeah, what subsystems there are that we should use.
15:49:11 <nirik> yep.
15:49:23 <adamw> i can take an action item to bug someone from the kernel team to tell us...
15:49:26 <nirik> we could also add them as we go and see lots of bugs in an area.
15:49:35 <adamw> #action adamw to get kernel team to provide a list of kernel subsystems
15:50:32 <nirik> that would be great.
15:50:55 <nirik> once we have some of those setup, we could try a trial run.
15:51:09 <adamw> coolbeans
15:51:56 <nirik> I think we are getting there. ;)
15:51:59 <adamw> yay!
15:52:12 <adamw> hi tech33
15:52:28 <adamw> i think that's most everything...
15:52:31 <adamw> anyone have any other open floor topics?
15:52:45 <Tech33_work> hi
15:52:54 <Tech33_work> none here
15:54:05 <iarlyy> I guess no
15:54:10 <iarlyy> end meeting?
15:54:31 <adamw> yup!
15:54:38 <adamw> thanks for coming everyone, and welcome again newer members
15:55:16 <adamw> remember, ask in IRC if you hit any roadblocks
15:55:19 <adamw> #endmeeting