16:00:56 <smooge> #startmeeting EPEL
16:00:56 <zodbot> Meeting started Fri Jun 11 16:00:56 2010 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:18 * nirik waves to all.
16:01:19 <smooge> hi guys
16:01:28 <smooge> I think its just you and me today
16:01:38 <smooge> I don't like to ping everything
16:02:17 * maxamillion is here but will be back in about 5-ish minutes
16:03:12 <smooge> #topic Order of Business
16:03:35 <smooge> I have been really really lax lately and think we need to fix that
16:04:03 <smooge> So here is what I think is needed:
16:04:22 <smooge> #action Smooge will set up a whenisgood for our meetings and mail to list
16:04:38 <smooge> #action Nirik will make sure smooge does it and beat him if he doesnt
16:04:53 <nirik> ha. :)
16:05:55 <smooge> any other business we need to get done?
16:06:26 <smooge> #topic Who is EPEL these days
16:06:27 <nirik> well, not sure off hand..
16:07:32 <dgilmore> hola
16:07:39 <smooge> at this moment, I am not sure who/what is EPEL etc. We add packages and such.. and we have as many IPs asking for it at as F11 at times
16:07:57 <smooge> but who is actually doing stuff these days beyond dgilmore
16:08:21 <nirik> well, all the various maintainers too. ;)
16:08:45 <dgilmore> smooge: i only do pushing
16:09:03 <smooge> yes, but I have had to tell several people that their packages aren't in EPEL-6 because they have to build them theirselves and they go "ooooooh".
16:09:24 <smooge> I think I have told 3 people in the last week...
16:09:27 <smooge> hi stahnma
16:09:30 <stahnma> :)
16:09:34 <stahnma> yay I made it to a meeting
16:09:35 <nirik> yeah.
16:09:58 <dgilmore> smooge: yeah we told people that they needed to do ita and they did not listen
16:10:01 <nirik> I think it would be nice to generate a list of packages that haven't been built, but have a EL-6 branch, and mail maintainers with a heads up
16:10:13 <dgilmore> nirik: probably a good idea
16:10:14 <stahnma> I know I have a few
16:10:22 <smooge> I think that is a good idea.
16:10:37 * nirik notes he's going to be traveling next week, and cannot do that till the week after at the soonest.
16:10:55 <dgilmore> we quite possibly will need to do some rebuilds at beta2 and GA time
16:11:08 <stahnma> probably
16:11:47 <smooge> most likely.
16:12:11 <smooge> I was thinking we would just do a flag day a couple of weeks after b2 comes out
16:13:01 * maxamillion is back
16:13:17 <smooge> any other issues on who is EPEL these days?
16:13:33 <nirik> I think most people are just happily using it/maintaining packages.
16:13:40 <nirik> they don't want to know how the sausage is made. ;)
16:13:45 <smooge> yeah I think so too.
16:14:21 <smooge> ok  new topic
16:14:24 <maxamillion> but I suppose a question is ... is that a problem?
16:14:33 <smooge> it can be
16:14:41 <maxamillion> are we good carrying on the way we are or does something need changing?
16:15:05 <stahnma> well, most consumers of epel probably just search for the package they want, install it and then move on
16:15:13 <smooge> most things fall into a 90-9-1 role. 90% don't care. 9% like to do a certain 10-30% of the work and 1% do the rest.
16:15:30 <maxamillion> fair enough
16:15:32 <smooge> we need to know who our 1% is, and then work on how to get the 9% doing their bit
16:15:48 <maxamillion> out of the 1%, what work is being done and/or what work needs doing?
16:16:22 <stahnma> bugs
16:16:28 <maxamillion> because I admittedly probably fall in that 9% who just maintains their packages and moves on with life but if there is more needing to get done I'm willing to see if I can carve off some time
16:16:42 <nirik> all of the following would be nice, imho:
16:16:53 <nirik> - testing packages in epel-testing and providing feedback
16:17:02 <nirik> - fixing bugs, our bugs are growing. ;(
16:17:19 <nirik> - reviews of new epel packages or branching existing to epel
16:17:56 <stahnma> http://tr.im/epelbugs
16:19:13 <stahnma> we probably need a better way of triaging existing bugs also
16:20:15 <smooge> yes.. I was thinking we could have a bug day or something
16:20:24 <maxamillion> https://bugzilla.redhat.com/show_bug.cgi?id=525807 <--- I reported this one and its almost a year old and I see bug numbers older than mine .... should we look into getting some provenpackager intervention or is there a way to have a group that has access to build/push packages in everything in an EPEL branch that could do thise?
16:20:30 <maxamillion> this*
16:21:04 <maxamillion> (as a side note, I built the latest version of AbiWord on EL5 and it runs great)
16:21:28 <stahnma> proven packager intervention might be nice
16:21:40 <stahnma> but in some cases, when I have stepped up to fix something, I broke something else :(
16:21:48 <dgilmore> only if there is proven packagers willing to do the work
16:21:58 <maxamillion> how many EPEL-ers are provenpackagers? I'd hate for so few people to have to do so much work
16:22:01 <smooge> well my goal for the next couple of months is to become a proven packager
16:22:24 <smooge> heck I am not even sure I am a packager
16:22:29 * jds2001 is, unsure of how much work i'd be useful for though :)
16:22:39 <maxamillion> or maybe have it to where others could package, submit to the proven packager for review and if the provenpackager signs off on it they could push it out ... that way the provenpackager isn't having to do as much work
16:22:46 <smooge> hehe I am not
16:23:01 <maxamillion> smooge: are you really not a packager yet?
16:23:11 <smooge> its not in my fasinfo groups.
16:23:14 <maxamillion> LOL
16:23:16 <smooge> I wonder how that happened
16:23:40 <smooge> well there is a todo
16:23:44 <maxamillion> :)
16:24:04 <smooge> #action smooge is packaging but not a packager.. uhm why/how and fix it
16:24:19 <jds2001> smooge: that's a task for this weekend :)
16:24:25 <smooge> yes
16:24:38 <smooge> no family to irq so I can just focus on that
16:24:49 <smooge> and Dr Who netflix
16:25:07 * abadger1999 contemplates joining netflix :-)
16:25:26 <maxamillion> abadger1999: I highly recommend it ... streams to my ps3 like a champ
16:25:47 <smooge> #chair nirik
16:25:47 <zodbot> Current chairs: nirik smooge
16:26:35 <smooge> anyway.. I think we need to work on getting an idea of that. I am working on how to use whenisgood so I can send out something tomorrow for us to decide what meeting time is good
16:27:29 <smooge> dgilmore, could you give us a status on the builders/pushing and EPEL-6?
16:27:42 <dgilmore> smooge: sure
16:27:57 <dgilmore> ive been trying to push epel6 once a day
16:28:07 <dgilmore> i did not do so while i was in mexico
16:28:22 <dgilmore> the buildroots are populated by beta1
16:28:37 <dgilmore> when beta2 is released we will update to that
16:28:59 <dgilmore> as soon as any kind of updates are pushed we will setup a sync process
16:29:07 <dgilmore> so that the buildroots stay updated
16:31:03 <dgilmore> people need to be reminded to build there packages
16:31:04 <smooge> how many packages have we pushed out so far if you know
16:31:43 <smooge> #action get a list of packages that have been branched but not built
16:31:55 <dgilmore> ls /pub/epel/beta/6/SRPMS/*rpm|wc -l
16:31:59 <dgilmore> 455
16:32:48 <dgilmore> there is 2812 branches
16:33:11 <smooge> wow quite a few
16:33:17 <dgilmore> we are a long way from having everything branched built
16:33:38 <smooge> bah we should just do it... says the guy who isn't even a packager
16:33:49 <nirik> there is likely to be ordering issues.
16:34:17 <smooge> yes.. most likely
16:34:31 <smooge> thank you dgilmore
16:34:41 <smooge> sorry I forgot my manners
16:35:21 <stahnma> we could just iterate over the missing packages until they all build...
16:35:21 <dgilmore> :P
16:35:22 <stahnma> maybe
16:35:41 <dgilmore> stahnma: failures will annoy the owners to do something maybe
16:36:28 <smooge> from the two people who asked it would seem they were just waiting for an error to show up
16:36:45 <smooge> so I was guessing that might be a pervailing attitude
16:37:34 <dgilmore> smooge: lazyness should not be encouraged
16:37:50 <smooge> I agree
16:38:24 <smooge> however I lost my flogging stick
16:39:15 <smooge> does anyone  have anything else on the topic?
16:39:46 <abadger1999> dgilmore: If we could get a nag mail or something, that would be awesome for me.
16:40:10 <abadger1999> Like "toshio: You could build twenty packages for EPEL-6, listed below:"
16:40:10 <stahnma> will mock configs be updated for EPEL6 soon?
16:40:39 <stahnma> or does that require centos?
16:40:46 <maxamillion> stahnma: I think it requires centos
16:40:53 <dgilmore> abadger1999: yeah
16:40:56 <stahnma> ok
16:41:02 <dgilmore> stahnma: i have some in my mock git repo
16:41:10 <smooge> stahnma, what mock configs and where are they used?
16:41:30 <maxamillion> smooge: I think he means mock configs for doing mock builds on local machines
16:41:35 <stahnma> yeah
16:41:47 <maxamillion> smooge: which we can't do ... because EL6 isn't out, so CentOS6 isn't out
16:41:48 <dgilmore> stahnma: let me grab you the url to them
16:41:56 <dgilmore> stahnma: it will only work for beta1
16:41:59 * skvidal twitches
16:42:02 <stahnma> that's fine
16:42:03 <dgilmore> beta2 will need them updated
16:42:18 <smooge> ah ok. I was wondering about that
16:42:26 <maxamillion> skvidal: ?
16:42:36 <skvidal> maxamillion: nothing
16:42:55 <maxamillion> okie
16:43:22 <dgilmore> stahnma: http://fedorapeople.org/gitweb?p=ausil/public_git/mock.git;a=tree;f=etc/mock;h=abf7c719f850b9a14649d6de622b564012dc10d5;hb=HEAD
16:43:30 <dgilmore> there is some working EL-6 configs in there
16:44:00 <dgilmore> maxamillion: the existing configs i have point at ftp.redhat.com
16:44:34 <maxamillion> dgilmore: ahhh ok ... makes sense since the beta binaries are available
16:44:37 <stahnma> dgilmore: thanks.  I'll check that out
16:44:42 * maxamillion didn't even think about that
16:48:01 <nirik> we done?
16:48:04 <nirik> or more items?
16:48:24 <smooge> no I think we are done
16:48:30 <smooge> closing in 60
16:49:52 <smooge> #endmeeting