14:05:28 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-06-29
14:05:29 <zodbot> Meeting started Tue Jun 29 14:05:28 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:05:43 <jreznik> #topic roll call
14:06:02 * thomasj here
14:06:22 * SMParrish here
14:06:25 * ltinkl here
14:06:39 * than_ is half here
14:06:47 <rdieter> here for a little while
14:06:48 * meGenius is here!
14:07:36 <Kevin_Kofler> Present.
14:07:58 <jreznik> #info jreznik, thomasj, SMParrish, ltinkl, than, rdieter, meGenius, Kevin_Kofler present
14:08:30 <jreznik> #chair rdieter Kevin_Kofler SMParrish ltinkl than_
14:08:30 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik ltinkl rdieter than_
14:08:36 <Kevin_Kofler> #meetingname kde-sig
14:08:36 <zodbot> The meeting name has been set to 'kde-sig'
14:08:40 * gwerra is here
14:08:47 <jreznik> #topic agenda
14:08:58 <jreznik> #info gwerra is here too
14:09:45 <jreznik> any topics for this meeting?
14:10:16 * nucleo here too
14:10:22 <nucleo> Qt 4.6.3 in updates
14:10:24 * adimania is here
14:11:06 <jreznik> #info adimania and nucleo joined us too
14:11:17 <jreznik> nucleo: ok, 4.6.3 update
14:11:52 <gwerra> jreznik, about the ownership of the spin, and further steps to be taken
14:12:16 <jreznik> gwerra: spin is already there
14:12:22 <Kevin_Kofler> "FSC: KDE netbook spin" is already on the agenda if that's what you mean.
14:12:26 <jreznik> ok, lets start
14:12:44 <jreznik> #topic qt 4.6.3 update
14:13:04 <jreznik> the latest CVE that blocked security update is public now
14:13:18 <nucleo> .bug 605677
14:13:18 <jreznik> it was deadlock between apple and our security response team
14:13:19 <zodbot> nucleo: Bug 605677 qt-webkit based browsers crashes with flash-plugin 10.1.53.64 - https://bugzilla.redhat.com/show_bug.cgi?id=605677
14:13:38 <nucleo> this bug was fixed in qt-4.6.3-4
14:13:45 <jreznik> nucleo: already included in latest qt build
14:13:58 <meGenius> #fedora-wiki
14:14:09 * meGenius is sorry
14:14:51 * rdieter has to leave now.  laters
14:15:14 <jreznik> so we should prepare qt update asap to updates-testing
14:15:27 <jreznik> any known issues again 4.6.3 update?
14:15:30 <jreznik> agains
14:15:36 <jreznik> against (sorry too hot here)
14:15:50 <jreznik> ltinkl, than_, Kevin_Kofler...
14:16:14 <ltinkl> none that I know of
14:16:21 <Kevin_Kofler> Same here.
14:16:34 <than_> jreznik: it looks fine.
14:16:52 * Kevin_Kofler is for pushing directly to stable, it's a security update.
14:16:54 <nucleo> I am using 4.6.3-4 without problems
14:16:59 <than_> we can prepare the update
14:17:20 <jreznik> Kevin_Kofler: security update but not a critical one (no know exploit)
14:17:27 <jreznik> and it fixes more issue
14:17:37 <than_> yes, it's security update, we can push it directly to stable
14:17:53 <jreznik> volunteer to prepare update (especially to match CVEs to bugzilla)
14:18:09 <ltinkl> +1 to stable
14:18:37 <Kevin_Kofler> jreznik: Tons of vulns, some potentially arbitrary code execution (though ExecShield might help).
14:18:40 <jreznik> I'm not sure - it's 4.6.3 update with few more fixes... but webkit issues should be fine
14:18:52 <jreznik> Kevin_Kofler: potential ones
14:19:01 <jreznik> but as you wish
14:19:13 <jreznik> three votes for stable
14:19:19 <jreznik> SMParrish: and you?
14:19:45 <SMParrish> I am ok with pushing to stable
14:20:11 <jreznik> 4 votes to stable, 1 for testing...
14:20:22 <jreznik> #agreed to push qt 4.6.3 directly to stable
14:21:00 <jreznik> any volunteer?
14:21:20 <wwoods> uh
14:22:09 * thomasj had a phone call.. Back now..
14:22:29 <thomasj> direct to stable? ouch
14:22:59 <jreznik> thomasj: I don't like it too but I was overvoted...
14:23:11 * thomasj is -1 just for the record
14:23:13 <jreznik> I'll prepare update today/tmrw morning
14:23:18 <jreznik> next topic
14:23:42 <Kevin_Kofler> Several people have been testing 4.6.3 without any issues.
14:23:52 <Kevin_Kofler> And there are many security fixes in the update.
14:23:56 <thomasj> That's at least good :)
14:24:05 <jreznik> #topic Release criteria for KDE
14:24:19 <jreznik> Kevin_Kofler: ?
14:24:40 <jreznik> but looks like connected to criterium to push qt directly to stable
14:24:46 <Kevin_Kofler> Not really.
14:24:55 <Kevin_Kofler> This is about releases, e.g. F14.
14:25:23 <jreznik> ah, ok
14:25:27 <Kevin_Kofler> QA has been asking us to look at the current release criteria, especially the desktop-related ones, and check whether they make sense for KDE.
14:25:36 <jreznik> link?
14:25:44 <Kevin_Kofler> E.g. what's not applicable to KDE, what's missing, …
14:25:47 <jreznik> #info QA has been asking us to look at the current release criteria
14:26:04 <Kevin_Kofler> https://fedoraproject.org/wiki/Fedora_Release_Criteria
14:26:51 <Kevin_Kofler> So what I have pointed out so far:
14:27:29 <Kevin_Kofler> * Beta criterion 17 needs to clarify "automatic mounting", in KDE (and also some other non-GNOME DEs), the expected action is a notification, not direct mounting
14:27:32 <jreznik> #link https://fedoraproject.org/wiki/Fedora_Release_Criteria
14:27:55 <Kevin_Kofler> * Final criterion 11 "Menu sanity" is not fully applicable to KDE:
14:28:22 <Kevin_Kofler> We already agreed a few weeks ago that "No application may unintentionally appear twice in the menus. In particular, items under System must not appear under Applications" should not be a blocker for KDE.
14:28:39 <Kevin_Kofler> And I'd argue that "All Applications listed in the desktop menus must have icons which have a consistent appearance and sufficiently high resolution to avoid appearing blurry" is also an upstream blocker.
14:29:10 <than_> the last 2 points are ok
14:29:16 <Kevin_Kofler> * There should be an additional criterion that autologin works or the live spin will feel like crap (also requested by the XFCE and LXDE folks).
14:31:06 <than_> Beta criterion 17
14:31:36 <Kevin_Kofler> We were also discussing a criterion making sure the password storage mechanism used by the spin's default NM frontend works, otherwise the spin is a PITA to use with WPA. For us, that'd be KWallet. But I think KWallet is less fragile than gnome-keyring anyway.
14:31:54 <Kevin_Kofler> Still, it could IMHO make sense to have that spelled out as a criterion.
14:32:11 <Kevin_Kofler> As long as we make sure that KWallet is what gets tested on KDE, not gnome-keyring.
14:32:42 <thomasj> makes sense
14:36:27 <Kevin_Kofler> So can I tell the QA folks that there is consensus about the points I'm making here?
14:36:38 <jreznik> does not help for me to store password for WPA as I'll have to use token soon :)
14:36:44 <jreznik> Kevin_Kofler: yes
14:36:51 <SMParrish> Kevin_Kofler: Yes sounds good to me
14:38:06 <than_> Kevin_Kofler:  what is with Beta criterion 17 ?
14:38:34 <Kevin_Kofler> https://fedoraproject.org/wiki/Fedora_14_Beta_Release_Criteria#Beta_Release_Requirements
14:38:41 <Kevin_Kofler> "Automatic mounting on insertion of removable media must work in the default desktop environment"
14:39:14 <than_> Kevin_Kofler: thanks for the links
14:39:46 <Kevin_Kofler> This needs to read something like "Removable media should be detected by the spin's desktop environment and trigger the expected default action or notification".
14:40:15 <Kevin_Kofler> "Removable media should be detected by the spin's desktop environment on insertion and trigger the expected default action or notification".
14:40:19 <Kevin_Kofler> (added "on insertion")
14:40:42 <jreznik> Kevin_Kofler: it's bigger - could you send the mail to fedora-kde mailing list to discuss it?
14:40:56 <jreznik> I'm still going through, need some time to think about it
14:41:15 <Kevin_Kofler> Yes, I can bring this up on the ML for more feedback.
14:41:18 <than_> Kevin_Kofler:  17, it makes sense
14:41:42 <Kevin_Kofler> Next topic?
14:42:01 <thomasj> Maybe a quick topic before the bug discussion?
14:42:03 <jreznik> thanks
14:42:18 <Kevin_Kofler> thomasj: ?
14:42:20 <jreznik> #info Kevin_Kofler to bring Release Criteria to KDE mailing list
14:42:29 <thomasj> Decision about pushing xine-lib-1.1.18 to stable for F-12
14:42:36 <jreznik> #topic FSC: KDE netbook spin
14:42:54 <thomasj> It's already a week in updates-testing and i think i get xine-ui crashers due to the old lib
14:43:01 <jreznik> gwerra, adimania: your turn, could you explain what you are doing, your current plans etc
14:43:08 <thomasj> meh
14:43:12 <jreznik> as the whole KDE SIG is decision maker here
14:43:27 <adimania> we have a lot of issues related to the netbook spin
14:43:46 <adimania> 1. Who would be the owner?
14:43:57 <Kevin_Kofler> thomasj: I can just queue it now (I'm a xine-lib comaintainer). But I need to let RPM Fusion know as well.
14:44:20 <Kevin_Kofler> (xine-lib-extras-freeworld needs to go out at the same time.)
14:44:31 <adimania> The rules of summer coding says that students should be the own the work they do but it would be nice to have someone from the SIG as well.
14:44:49 <thomasj> Kevin_Kofler, cool, thank you :)
14:45:27 <adimania> 2. We need to strip a few packages and need to remove some. For this we need to find a way to take opinion of the SIG.
14:46:17 <jreznik> 1. spin owner should be again KDE SIG as for Fedora KDE Desktop
14:47:25 <adimania> fine with me
14:47:35 <adimania> about the second issue. What I suggest is that if any SIG member thinks that a particular app is not useful for netbook he/she can put it on the wiki. anyone who opposes it can vote for it to stay in a tabular form.
14:48:12 <adimania> I'll upload a list of packages on fedorapeople
14:48:13 <jreznik> adimania: we need use cases why to split something/remove from spin
14:48:22 <jreznik> better is wiki, so we can comment it
14:48:55 <killefiz> please also send reminders to the mailinglist so people will notice it
14:49:25 <adimania> everything is on the wiki. A static list of packages contained in f13 kde spin would be on fedorapeople for reference. It would help if someone wants something to be removed.
14:50:13 <adimania> I would like to share a couple of links
14:50:16 <adimania> 1. https://fedoraproject.org/wiki/KDE_Netbook_Spin
14:50:50 <adimania> 2. https://fedoraproject.org/wiki/Spins_KDE_Netbook_Spin
14:51:45 <adimania> [1] contains a list of packages we have split or we are planning to remove. [2] would the feature page which we are working upon.
14:52:27 <jreznik> #link https://fedoraproject.org/wiki/KDE_Netbook_Spin
14:52:33 <jreznik> #link https://fedoraproject.org/wiki/Spins_KDE_Netbook_Spin
14:53:07 <jreznik> I think you should prepare F14 feature page amd contact Fedora Netbook people to work on basic set of packages that should be on spin...
14:53:34 <adimania> jreznik: about the use cases. We did the split primarily to save space. It is just that we can live without a few apps and hence can save some space.
14:53:42 <jreznik> also we're going to akademy with rrix, so we are going to meet (and to meet kde-netbook people too)
14:53:56 <Kevin_Kofler> Removing KCharSelect makes no sense.
14:54:01 <Kevin_Kofler> It's a small app and very useful.
14:54:07 <jreznik> adimania: it's not about space only
14:54:26 <jreznik> usability counts too
14:55:40 <adimania> I am working on feature page and it would be ready soon. I understand the concern with the usability. the thing is something which is usable for someone might not be usable for someone else.
14:55:57 <Kevin_Kofler> I'd like Okteta to be installed by default too (but I need to fix it to not take ages blocking the whole app to display the file browser widget, if you have many files in the homedir, right now it's basically unusable on my main desktop).
14:56:01 <adimania> that is why I am concerned with the way we can take opinion from SIG
14:56:12 <Kevin_Kofler> But I guess Okteta could be done without on a netbook.
14:57:03 <Kevin_Kofler> But TBH I don't like any of those splits.
14:57:11 <Kevin_Kofler> It just looks arbitrary.
14:57:12 <adimania> Kevin_Kofler: I'll ask gwerra to review his package and talk to you about removing kCharSelect
14:58:24 <adimania> Kevin_Kofler: We are ready to work on the splits again provided SIG decides what should stay and wha should not.
14:58:24 <adimania> s/wha/what
14:58:28 <gwerra> Kevin_Kofler, please create a talk page, and let us know your opinion so we can look at it, and talk to others about it
14:59:22 <ltinkl> Kevin_Kofler: okteta :)) 1% of KDE user base can make use of a binary editor?
15:00:25 <Kevin_Kofler> adimania: KCharSelect is extremely useful to input special characters which are not on your keyboard layout.
15:00:31 <adimania> Kevin_Kofler, gwerra: As I said, we can include another column to the table. Those who are against the splits or packages to be removed may simply put their FAS name and write their opinion on Talk page.
15:00:32 <Kevin_Kofler> Foreign characters, symbols etc.
15:00:48 <Kevin_Kofler> Well, I'm really against all splits. ;-)
15:01:00 <Kevin_Kofler> But KCharSelect in particular strikes me as a bad idea to split out.
15:01:09 <gwerra> Kevin_Kofler, I ll fix that
15:01:19 <adimania> Kevin_Kofler: gwerra did that particular split and he would fix that
15:01:37 <jreznik> guys, we're out of time -> let's move to #fedora-kde
15:01:42 <Kevin_Kofler> Kscd makes sense to split out for the netbook spin (netbooks usually don't have CD drives at all), but should probably be installed by default on the regular KDE spin.
15:01:54 <jreznik> #endmeeting