15:01:37 <adamw> #startmeeting Bugzappers 2010-07-06
15:01:37 <zodbot> Meeting started Tue Jul  6 15:01:37 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:44 <adamw> #meetingname bugzappers
15:01:44 <zodbot> The meeting name has been set to 'bugzappers'
15:01:46 * fenrus02 waves
15:01:50 <adamw> #topic gathering
15:01:53 <adamw> it's meet-y time
15:01:56 <adamw> mmmm...meet...
15:02:12 <dafrito> hola
15:02:15 <adamw> who's around? and who's physically here but mentally phoning it in from a beach somewhere?
15:02:18 * adamw joins category B
15:02:27 * jraber is here
15:02:35 <adamw> hey folks
15:02:45 <fenrus02> does it count if you have a different phone in each ear, plus an IM meeting?
15:03:07 <tajidinabd> im here
15:03:31 <adamw> fenrus02: sure, why not? :D
15:03:39 <adamw> hey taj, thanks for coming
15:03:46 <jraber> Anyone that has already looked a https://fedoraproject.org/wiki/User_talk:Jraber please look again, it has been updated (sorry for the last minute update)
15:03:47 <adamw> okay, gimme a minute to butter some toast...
15:05:11 <adamw> alrighty
15:05:15 <adamw> #topic triage metric update
15:05:18 <adamw> jraber: you're up
15:05:28 <jraber> Not much new.
15:05:46 <jraber> Added the "Who are the BugZappers"
15:05:49 <adamw> page is looking nice
15:06:05 <jraber> I have tried to make it a little nicer to look at
15:06:13 <adamw> we could probably start doing a semi-useful weekly mail based on what you have already, i'd say
15:06:21 * jeff_hann is here
15:06:53 <adamw> the last three 'pending' queries are kind of interesting; really, bugzappers _shouldn't_ close bugs, if everyone follows the procedures properly
15:06:54 <jraber> ok by me.
15:07:39 <jraber> Well, dups and WONTFIXES should make the list
15:07:46 <jraber> not sure what else
15:07:48 <adamw> oh, point
15:07:59 <adamw> i was thinking of fixed valid bugs
15:08:21 <jraber> But it does show that BugZappers are helping to eliminate the 'cruft' in BZ
15:08:53 <adamw> definitely looks like there's some valuable data on your page, and clearly some components that are 'covered' aren't really; obviously we have quite a few inactive folks
15:10:07 <adamw> so we could look at trying to talk to people listed on the bugzappers page who aren't on your list, and see what we can do to get them zapping again
15:10:10 <iarlyy> hey there
15:10:33 <tajidinabd> i was reading over that stuff you sent me adamw
15:10:54 <adamw> hey iarly
15:10:58 <adamw> tajidinabd: cool
15:11:29 <tajidinabd> i got the basic idea of zapping so not a problem
15:11:35 <tajidinabd> ;)
15:12:29 <jraber> I have made some changes to the python-bugzilla library to allow querying the Bug History data.  (Getting close to brave being ready to send a patch to wwoods)
15:13:01 <jraber> So some of the other metrics should be available in the near future
15:13:27 <adamw> awesome, thanks jraber
15:13:50 <adamw> it definitely looks like you've given us some actual numbers that can be foundations for work right away, which is what we wanted in the first place, so thanks a lot!
15:14:13 <tajidinabd> but i will need a little help to find out which bugs need triaging
15:14:16 <tajidinabd> :)
15:14:29 <adamw> tajidinabd: theoretically, any newly-filed bug against a fedora component needs triaging
15:14:29 <jraber> It's a pleasure.  I'm glad to be learning something :) (python + bugzilla)
15:14:38 <fenrus02> taj: any that have not been marked, no?
15:14:56 <tajidinabd> alright all the ones labeled new
15:14:59 <fenrus02> taj: one of those links emailed out has a project list that says "needs help"
15:15:00 <adamw> in practice, usually you pick a package from the list at https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers and focus on bugs filed against that package
15:15:18 <fenrus02> thanks, that's the link i meant :)
15:15:18 <wwoods> jraber: I'll be happy to look at whatever code you might have
15:15:24 <tajidinabd> alright
15:15:57 <wwoods> I've got other stuff going on but I'm setting aside time for working on python-bugzilla at least once a week, so whenever you're ready
15:15:58 <jraber> wwoods:  I will send it to you this evening.
15:16:01 <fenrus02> you can add your fav. projects to an rss feeder too - then you can see new bugs pop up anytime you have a few mins
15:16:14 <wwoods> jraber: awesome - no rush, I'm just excited
15:16:14 <wwoods> heh
15:16:50 <jraber> I only hope you aren't disappointed.  (Remember I am a new to python)
15:17:13 <adamw> don't worry, wwoods is easy to excite (rimshot)
15:17:23 <tajidinabd> alright i see one like for gtk2
15:17:32 <tajidinabd> that has no one assigned to triage that one
15:17:35 <adamw> tajidinabd: you might want to start out a bit smaller =)
15:17:38 <tajidinabd> lol
15:17:40 <adamw> but that's the idea, yup
15:17:42 <wwoods> jraber: nah don't worry about it - even if it's not a good fit for the main 'bugzilla' binary I'm happy to help people craft their own custom tools
15:17:47 <wwoods> (and learn a little python in the process)
15:20:15 <tajidinabd> so whats a good small one to start with
15:20:26 <fenrus02> wwoods: happen to have a quick one-liner to locate the bugs you've been cc'd on and not been touched in 30d ?
15:20:53 <wwoods> fenrus02: if you can make that search happen in the web interface, you can make python-bugzilla do it
15:20:57 <fenrus02> wwoods: as in, i've marked a few as 'needsinfo' and need to revisit them (close) in 30d if they have not been appended to
15:21:14 <wwoods> fenrus02: show me a search URL and I'll show you how to turn it into a query/commandline
15:21:23 <fenrus02> ok
15:22:06 <adamw> tajidinabd: just a sec
15:22:47 <jraber> Regarding 'mailing the metrics to the list'  I happy to receive any suggestions in regards to how to format those metrics to make them less horrible to look at.
15:23:33 <adamw> tajidinabd: maybe something like compiz or gdm (sergey seems inactive atm)
15:23:50 <tajidinabd> alright ill take look around there
15:23:51 <adamw> jraber: yeah, i'll try and come up with something for that. right now i'm worrying more about proventesters, though :/
15:24:04 <adamw> #agreed jraber's work looks great, thanks
15:24:15 <adamw> #action adamw to look at ways to format a regular weekly stats update
15:25:33 <adamw> #topic open floor
15:25:43 <adamw> we didn't have anything else on the agenda, anyone have questions / proposals / problems etc?
15:26:11 <tajidinabd> nothing here
15:27:14 <tajidinabd> the workflow chart was very simple to understand
15:27:33 <jraber> Last week I spent a little time and 'touched' a few of the the wiki pages.  I saw "Triage Days are held each week  immediately following the meeting in #fedora-bugzappers" and wonder if it was true.
15:27:33 <jraber> s/wonder/wondered
15:27:46 <adamw> tajidinabd: great!
15:28:01 <adamw> jraber: it's kinda outdated :/ we never really got the concept off the ground
15:28:05 <adamw> so we've stopped it lately
15:29:08 <jraber> Is it okay to remove it then?
15:29:24 <tajidinabd> well i have some knowledge on python myself
15:29:35 <jraber> I'd hate to have someone show-up and be disappointed
15:30:23 <jraber> tajidinabd: checkout the python-bugzilla package
15:30:46 <jraber> and maybe https://fedoraproject.org/wiki/User_talk:Jraber
15:31:12 <adamw> jraber: for now, sure.
15:35:32 <adamw> okey dokey, i guess we're done then!
15:35:34 <adamw> thanks for coming folks
15:35:57 <tajidinabd> have a goodafternoon over there
15:36:00 <tajidinabd> :)
15:36:11 <jraber> Have a great day everyone.
15:36:56 <adamw> hey tech33, we just finished =)
15:37:01 <adamw> Tech33: did you have anything to add?
15:37:05 <Tech33> that's fine with me :)
15:37:09 <Tech33> nope
15:37:49 <adamw> okey dokey
15:37:52 <adamw> #endmeetiong
15:37:54 <adamw> d'oh
15:38:01 * adamw puts the whisky bottle down
15:38:03 <adamw> #endmeeting