21:00:22 <rbergeron> #startmeeting Cloud SIG
21:00:22 <zodbot> Meeting started Thu Jul  8 21:00:22 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:29 <jforbes> doh, I was just typing that
21:00:31 <rbergeron> #meeting name Cloud SIG
21:00:32 <smooge> darn it I needed to go potty
21:00:34 <rbergeron> oh, HAI :)
21:00:39 <jforbes> heya :)
21:00:41 <LinuxCode> smooge, haha
21:00:42 <rbergeron> smooge: here's a pass, don't lurk in the hallway :)
21:00:58 <rbergeron> #chair jforbes
21:00:58 <zodbot> Current chairs: jforbes rbergeron
21:01:01 <rbergeron> jforbes, how goes it?
21:01:07 * mdomsch 
21:01:08 * jsmith is here (mostly to lurk)
21:01:14 <jforbes> It goes, working on the feature page
21:01:21 <rbergeron> excellent
21:01:27 <rbergeron> anyone else want to volunteer for roll call :)
21:01:51 <smooge> back
21:02:03 <rbergeron> okay, now we can start that smooge is here :D
21:02:06 <rbergeron> #topic Agenda
21:02:11 <rbergeron> #link https://fedoraproject.org/wiki/Cloud_SIG#Upcoming_meeting_agenda
21:02:20 <smooge> snape caught me in the hall and took another point from gryfindor
21:02:23 <rbergeron> Let's get through the last meeting's stuff quickly.
21:02:25 * Sparks is here
21:02:27 <rbergeron> ke4qqq, you around?
21:02:45 <rbergeron> he's looking into amazon testing costs - I don't know offhand if he's heard anything back on that front.
21:02:49 * gregdek pokes up his wizened head.
21:03:02 <rbergeron> hiya gregdek :)
21:03:07 <gregdek> :)
21:03:19 <jforbes> heya gregdek
21:03:22 <rbergeron> sparks was going to make a wiki page with some documentation on publishing to EC2 images - and he's done so
21:03:29 <rbergeron> #link https://fedoraproject.org/wiki/Publishing_image_to_EC2
21:03:41 <jsmith> hey gregdek!
21:03:49 <rbergeron> now i'll go on record and say it's empty - but he's willing to whip into shape whatever other people dump there.
21:04:02 <gregdek> jsmith... who is that again?
21:04:14 <rbergeron> jforbes, your item from last week about populating the wiki page - that's the wiki page to start dumping into ;)
21:04:19 * jforbes just needs time to dump there
21:04:30 * rbergeron agrees, where is our time generator we ordered???
21:04:32 <rbergeron> :)
21:04:45 <rbergeron> jforbes to ping gholms about eucatools <--> kernel <--> pvgrub image
21:04:54 <rbergeron> i think i saw some mail on this on the mailing list? is that right justin?
21:05:15 * rbergeron pulls it up
21:05:19 <jforbes> Feature submission deadline coming up has been taking some time
21:05:41 <jforbes> No, there was some discussion about Eucalyptus packaging, slightly different
21:05:45 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2010-July/000223.html
21:06:03 <jforbes> Oh right
21:06:10 <rbergeron> Eucalyptus upstream claims to support block device mapping in
21:06:11 <rbergeron> development versions of euca2ools, but unfortunately that also requires
21:06:11 <rbergeron> a somewhat recent svn snapshot of python-boto.  I presume pvgrub images
21:06:11 <rbergeron> still need that capability?  I can upload a package with a recent
21:06:11 <rbergeron> euca2ools snapshot, but python-boto's maintainer prefers to stick with
21:06:13 <rbergeron> stable releases.  Where do you suppose we should go from here?
21:06:16 <rbergeron> oh, that's ugly. sorry
21:06:40 <rbergeron> So - I guess we shoudl answer the question of "where should we go from here"
21:07:09 <smooge> I signed up for amazon items earlier this week. It caused my credit card to do a credit lockdown for weird patterns
21:07:13 <jforbes> So we will need the new version of eucatools, but time is not so critical on that as we can manually work aroudn it
21:07:25 <jforbes> smooge: nice :)
21:07:35 <rbergeron> #info So we will need the new version of eucatools, but time is not so critical on that as we can manually work aroudn it
21:07:39 <smooge> so I will try to start testing publishing stuff next week once I build eucatools for el-6
21:07:56 <rbergeron> smooge: thank you sir
21:08:23 <rbergeron> Can someone respond to this mail on the list with some sort of answer? :)
21:08:39 <jforbes> Sure
21:09:09 <rbergeron> #action jforbes to respond to gholms mailing list email on eucatools stuff.
21:09:18 <smooge> we go to bahamas
21:09:26 <rbergeron> Okay. Next up - FeatureList, jforbes? :)
21:09:29 <jforbes> smooge: I am all for it
21:09:36 * rbergeron promises jforbes this is the second to last thing and yes, for the love, bahamas, please
21:10:01 <jforbes> rbergeron: I am in the middle of that now, should be published shortly
21:10:09 <rbergeron> jforbes: awesome
21:10:23 <rbergeron> #info jforbes in the middle of creating FeatureList submission, woot.
21:10:37 <rbergeron> and - jforbes to get with huff and get http://github.com/huff/kickstart-stuff/blob/master/fedora-ec2-min.ks updated to F13
21:10:39 <jforbes> I will also represent it in FESCo
21:10:50 <rbergeron> wait, no!
21:10:56 <rbergeron> oh, yes. that's right
21:11:04 * rbergeron is looking at 2 separate lists and that is the correct item
21:11:24 <jforbes> Right, haven't gotten ahold of huff yet (though admittedly I have only tried a few times)
21:11:38 <rbergeron> yeah, i haven't seen him on irc
21:11:47 <rbergeron> .last huff
21:11:47 <zodbot> rbergeron: (last [--{from,in,on,with,without,regexp} <value>] [--nolimit]) -- Returns the last message matching the given criteria. --from requires a nick from whom the message came; --in requires a channel the message was sent to; --on requires a network the message was sent on; --with requires some string that had to be in the message; --regexp requires a regular expression the message must match; --nolimit (1 more message)
21:11:59 <rbergeron> smooge: what's the command?
21:12:21 <smooge> I think that was it... and huff doesn't show up in memory or looks like a help command
21:12:27 <rbergeron> yeah
21:12:29 <smooge> .last smooge
21:12:29 <zodbot> smooge: (last [--{from,in,on,with,without,regexp} <value>] [--nolimit]) -- Returns the last message matching the given criteria. --from requires a nick from whom the message came; --in requires a channel the message was sent to; --on requires a network the message was sent on; --with requires some string that had to be in the message; --regexp requires a regular expression the message must match; --nolimit returns (1 more message)
21:12:43 <smooge> or zodbot is proken
21:12:44 <rbergeron> #action jforbes to continue trying to get ahold of huff on .ks stuff.
21:13:34 <rbergeron> okee dokee.
21:13:56 <rbergeron> i had two items - making a to-do list, and a testing list. I combined these both into ... one very small wiki portion.
21:14:05 <rbergeron> #link https://fedoraproject.org/wiki/Cloud_SIG#To-Do_List
21:14:15 <rbergeron> now: I admit that this list is pretty weak and probably needs to be fleshed out.
21:14:26 <rbergeron> I'm going to send a mail to the list and see if poeple start throwing some darts at it and fix it up.
21:14:33 <jforbes> kernel news... kernel is in updates-testing So test and give it karma!
21:14:36 <rbergeron> Because basically, I'm just listening to everyone else here about what needs to happen :)
21:14:48 <gregdek> Why isn't huff at this meeting?
21:15:02 <rbergeron> #info kernel news... kernel is in updates-testing So test and give it karma!
21:15:11 <jforbes> gregdek: not sure, he doesn't seem to show at this time, which is why I tried to move it before
21:15:16 <rbergeron> gregdek: unknown - i mailed him and asked if this is a bad time - haven't heard back
21:15:35 <rbergeron> and he's not been on irc
21:15:49 <gregdek> rbergeron, tell spevack to walk across the street and smack him.  Or at least ask nicely why he doesn't love us anymore.
21:16:00 <rbergeron> rbergeron: huff was last seen in #fedora-cloud 2 weeks, 0 days,  0 hours, 19 minutes, and 8 seconds ago: <huff> if you need  anything from me please shoot me an email, Ill have and updated  ks file to the list tomorrow
21:16:06 <jforbes> kernel update is crit path security, so I expect it to move out of teting very soon
21:16:19 <smooge> .last --from huff
21:16:19 <zodbot> smooge: Error: I couldn't find a message matching that criteria in my history of 1000 messages.
21:16:23 <gregdek> Ouch.
21:16:25 <gregdek> Maybe he died.
21:16:25 <rbergeron> .seen huff
21:16:25 <zodbot> rbergeron: huff was last seen in #fedora-meeting 3 weeks, 3 days, 3 hours, 35 minutes, and 49 seconds ago: <huff> jlaska: yes
21:16:33 <rbergeron> gregdek: don't say that :)
21:16:44 <gregdek> No worries.  I would have smelled it.
21:16:46 <rbergeron> maybe he's on one of those funny vacation things i hear about from other people
21:17:10 <rbergeron> #action rbergeron to talk to spevack about location the huff
21:17:13 <rbergeron> #undo
21:17:13 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1d413550>
21:17:18 <rbergeron> #action rbergeron to talk to spevack about location of the huff
21:17:27 <smooge> does anyone have a real life contact for huff? or is he a magic dragon and we forgot to believe in him
21:17:29 <jsmith> Vacations?  I thought they were extinct, like pensions and gold watches
21:17:36 <rbergeron> okay, back to kernel stuff
21:17:44 <rbergeron> smooge: apparently spevack may have a IRL contact.
21:17:54 <smooge> ok cool
21:18:01 <smooge> kernel stuff where are we?
21:18:11 <rbergeron> jforbes: so - can we talk for a second about what needs to be tested?
21:18:19 <rbergeron> or does everyoen else here know what that entails besides me :)
21:18:25 <jforbes> Ahh, actually last comment there: his update has been pushed to stable  so tomorrow :)
21:19:09 <jforbes> rbergeron: well, first we need the .ks updated.  I guess since we haven't heard from huff, and will have a kernel available really soon, I will modify the ks myself and send him a patch
21:19:10 <smooge> no I don't
21:19:18 <rbergeron> #info update has been pushed to stable - so should be available tomorrow
21:19:58 <rbergeron> awesome.
21:20:09 <rbergeron> so - where do we go from here?
21:20:11 <jforbes> rbergeron: but testing is first boot testing the image created from the mythical ks file, then testing image functionality
21:20:45 <rbergeron> okay. so we're kind of hinging on huff here.
21:20:50 <rbergeron> is that true?
21:20:59 <rbergeron> hingeing?
21:21:14 <jforbes> Well, yes and no.  I will go ahead and modify the ks file myself and send him a patch
21:21:21 <rbergeron> okay
21:21:29 <jforbes> in the meantime I can send said ks file to the list with instructions for people to test
21:22:01 <rbergeron> yes!
21:22:15 <rbergeron> #action jforbes to send patched .ks file to the list with testing instructions
21:22:23 <rbergeron> and what's next after that?
21:22:40 * rbergeron feels bad for repeatedly action-ing jforbes :)
21:23:27 <jforbes> After that, provided basic testing feedback is positive, we put the image on EC2 for wider testing
21:23:46 <smooge> I am ready once that happens. Then we need to work on getting F-14 feature ready to replace all the F8's out there :)
21:24:14 <rbergeron> #action rbergeron to put more of this to-do stuff in wiki to-do list, mail to mailing list.
21:24:40 <rbergeron> smooge: what does that entail? or will we see that in jforbes's feature page?
21:24:42 <jforbes> smooge: the hope is to get a real F-13 image out before then.  the F14 feature is really that we can do a concurrent release of EC2 and local install versions
21:25:21 <smooge> rbergeron, basically it would take getting some images out there that do various things out of the box
21:25:45 <smooge> say asterisk, webserver, zope, p0wn-box, etc
21:25:51 <smooge> well maybe skip the p0wn-box
21:26:01 <rbergeron> so should we test that some of those apps actually work
21:26:06 <smooge> correct
21:26:19 * rbergeron has to run outside for a second, feel free to carry on without me - mailman
21:27:00 <smooge> after that I think its about getting various authors to 'adopt' what we have and why
21:27:07 <smooge> not sure how that is done..
21:27:16 <jforbes> smooge: Marketing :)
21:27:31 <smooge> ooooooh isnt that a 4 letter word?
21:27:47 <smooge> ok 9 but close to 2 4 letter words
21:27:59 <jforbes> smooge: heh
21:28:30 <jforbes> better to market what we have done than do what we are marketing though :)
21:28:34 <smooge> I have no skill in marketing. Mongo is but a pawn in the great game of life
21:29:06 <jforbes> smooge: me either... I think that is where rbergeron comes in
21:30:01 <smooge> oh right
21:30:12 <smooge> ok so now that we have done the keystone cops routine.
21:30:15 <smooge> whats next
21:30:37 <jforbes> create/test/publish  I think that's it..
21:30:47 <jforbes> Oh, Document... but we already covered that
21:31:11 <rbergeron> okay, back :)
21:31:17 <rbergeron> HEY, did someone say marketing? :)
21:31:23 <Sparks> no
21:31:36 <Sparks> :)
21:31:53 <jforbes> It was mentioned and deferred to you
21:31:54 <rbergeron> what do you mean - various authors?
21:32:14 <rbergeron> you mean coder types :)
21:33:17 <smooge> I guess
21:33:30 <rbergeron> allllrighty.
21:34:13 <rbergeron> so - do we think we will be on time to hit all of these milestones for F14?
21:34:18 <rbergeron> in addition to getting F13 out there?
21:34:30 <rbergeron> and how can we make sure we're doing this continuously for every cycle?
21:34:54 <rbergeron> since I'm sure jforbes probably doesn't want to do this till F38, it would be good to figure out how to get hte process down pat
21:34:58 <jforbes> The milestone for F14 is really concurrent release, and part of doing that for F14 is putting process into place for future releases
21:35:29 <jforbes> F13 images will be one offs... F14 and future releases should be driven by a real releng process
21:35:29 <rbergeron> and I think we're kind of figuring out process as we good - maybe it's a matter of sitting down once we get F13 out the door and figuring out what the process needs to be
21:35:49 <smooge> Well the big thing will be expanding past Amazon after this. Say slicehost or something
21:35:54 * rbergeron nods
21:36:07 <rbergeron> other public hosting places.
21:36:23 <rbergeron> smooge: do you think that's more of an F15 time frame thing? Or doable in F14?
21:38:26 * rbergeron pokes smooge ;)
21:38:40 <smooge> sorry
21:38:41 <smooge> sorry
21:38:43 <rbergeron> np
21:38:52 <smooge> I believe we should look at it for F15.
21:39:08 <smooge> We might be able to get it done by F14 but man time is approaching faster than we expect on that
21:39:18 <smooge> and we all only have so much time
21:39:21 <rbergeron> smooge, jforbes: what about other cloud stuff - i know deltacloud is .... out there..... and even if it doesn't fit with this stuff it still helps to round out fedora's cloud story in some ways
21:39:45 <rbergeron> are they getting that stuff more updated in fedora? or is that unknown to you guys
21:39:49 <jforbes> Good question
21:39:59 <smooge> I have no idea about deltacloud or some others..
21:40:00 <rbergeron> smooge: yeah, i just didn't know like - how much of a varying effort that was
21:40:18 <smooge> I think I subscribed to something a while abck and saw patches but not much else
21:40:25 <rbergeron> do we know who we have to poke to get an answer about deltacloud
21:40:45 <smooge> rbergeron, my guess will be that for some of the clouds it will be little. But the big thing the vendors are looking for is us actually doing it somewhere
21:40:55 * rbergeron nods
21:40:58 <smooge> then it becomes "hey why didnt you do it with us?"
21:41:16 <rbergeron> right
21:41:35 <smooge> at which point we have a goal and hungry hippos to pull our chariots to it
21:41:55 <rbergeron> mmm. hippos
21:43:18 <rbergeron> any other pieces of the pie we shoudl think of ... longer-term here
21:43:29 <rbergeron> or start trying to find owners for?
21:44:41 <jforbes> not off the top of my head
21:44:41 <smooge> not really I can think of. I feel like I need  a good solid victory before planning ahead
21:44:55 * rbergeron nods
21:45:05 <rbergeron> V for victory, yo
21:45:21 <rbergeron> alrighty. we have anything else?
21:45:24 <rbergeron> #topic Open Floor
21:45:42 <mdomsch> mirrors
21:46:05 <mdomsch> we're not there yet, but soon as we have an image, and a few running instances, we want to set up a mirror in each availability zone
21:46:20 <mdomsch> for which I still need the account information to be able to create such mirrors
21:46:27 <rbergeron> #info mirrors: we're not there yet, but soon as we have an image, and a few running instances, we want to set up a mirror in each availability zone
21:46:34 <rbergeron> mdomsch: who holds that key?
21:46:42 <mdomsch> rbergeron, max?
21:46:56 <gregdek> Should be max, yes.
21:46:57 <jforbes> yes
21:47:04 <rbergeron> #action rbergeron to ping spevack about getting account info to create mirrors
21:47:13 <rbergeron> #action said account info for mdomsch :)
21:47:16 <mdomsch> no rush; we'll want to set them up using the fedora images created
21:47:25 <mdomsch> or a RHEL-like image
21:47:43 <rbergeron> #info no rush; we'll want to set them up using the fedora images created
21:47:49 <rbergeron> #info or a RHEL-like image
21:48:11 <smooge> also disk space for mirroring images.
21:48:13 <rbergeron> well, i'll ping max, and give him some time so it's not an emergency when we do need it.
21:48:15 <smooge> how to do it, and where
21:48:39 <rbergeron> does max have that info, or do we need to decide that when we get to that point
21:49:00 <jforbes> he has it
21:49:15 <rbergeron> #info also need info on disk space for mirroring images; how to do it, and where
21:49:27 <rbergeron> cool.
21:49:53 <rbergeron> mdomsch, anything else from your end?
21:50:38 <mdomsch> rbergeron, not at this time; and I'm on vacation next week, so no rush. :-)
21:50:56 <rbergeron> mdomsch: a vaca-whata? :) have fun.
21:51:00 <mdomsch> smooge, we can create a medium-sized instance, with lots of disk.
21:51:57 <rbergeron> alrighty.
21:52:00 <rbergeron> any other business?
21:53:05 <smooge> not me
21:53:14 <rbergeron> jforbes: anything else?
21:53:20 <gregdek> I want a cloud pony.
21:53:38 <jforbes> rbergeron: none here
21:54:22 <rbergeron> gregdek: i'll get right to work on that ;)
21:54:27 <Sonar_Guy> gregdek: http://www.sc.tri-bit.com/images/2/23/pony.jpg
21:54:51 <rbergeron> sonar_guy: awwwwwwwwe, he's gonna be so sad
21:55:15 <rbergeron> i thought gregdek had two ponies.
21:55:31 <rbergeron> http://rix.si/files/greg-plow.png
21:55:36 <rbergeron> oh, those aren't ponies. we'll work on that
21:55:43 <rbergeron> anyway.
21:55:48 * rbergeron waves to all, thanks for coming :)
21:55:54 <rbergeron> #endmeeting