23:00:00 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:00:00 <zodbot> Meeting started Wed Jul 14 23:00:00 2010 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:00 <Sparks> #meetingname Fedora Docs
23:00:00 <zodbot> The meeting name has been set to 'fedora_docs'
23:00:00 <Sparks> #topic Roll Call
23:00:10 * Sparks is here
23:00:21 <GadgetWisdomGuru> I'm here.
23:00:34 * rbergeron lurks
23:00:34 <GadgetWisdomGuru> Trying to remember the action IRC command.
23:00:38 <GadgetWisdomGuru> Haven't used it in a while.
23:00:39 * crantila is here
23:00:42 * jjmcd 
23:00:46 * rbergeron hands gadgetwisdomguru a /me
23:00:54 * GadgetWisdomGuru tests the action command
23:01:22 * joat is here
23:01:35 * GadgetWisdomGuru thanks rbergeron for reminding him of that
23:01:36 * bethlynn is here
23:03:43 * Sparks gives stragglers a little more time to wander in...
23:04:16 * GadgetWisdomGuru thinks the first step of getting involved is showing up and has thus shown up
23:04:38 * GadgetWisdomGuru feels like Bob Dole, referring to himself in the third person
23:05:02 * GadgetWisdomGuru will now shut up.
23:05:08 <Sparks> Okay, lets get this show on the road
23:05:18 <Sparks> #topic Follow up on last week's action items
23:05:26 <Sparks> jjmcd to have doc-publican-rpm packaged and submitted for review by 14 July
23:05:38 <jjmcd> Close but no cigar
23:05:39 <Sparks> jjmcd: It's...  what is it today?  Bastile Day?
23:05:43 <jjmcd> http://koji.fedoraproject.org/koji/tasks?state=all&owner=jjmcd&view=tree&method=all&order=-id
23:06:09 <jjmcd> Should be close, but I haven't had a chance to thoruoghly test and examine, and won't until the weekend
23:06:28 <Sparks> okay, I'll let it slide this one time... :)
23:06:30 <jjmcd> Oh, top 3 builds on that page 2.0.1
23:06:51 <Sparks> #action jjmcd to have doc-publican-rpm packaged and submitted for review by 21 July
23:06:52 <jjmcd> My todo list is on git, but I don't feel like we need to get all the goodies in
23:07:01 <Sparks> :)
23:07:13 <jjmcd> What is there should be close.  It works
23:07:17 <jjmcd> No obvious warts
23:07:21 <Sparks> rudi to come back with additional information on getting docs-writers building packages in koji for docs.fp.o
23:07:41 <Sparks> rudi_: Had any new epiphanies?
23:08:03 <rudi_> Yeah, but not written up yet sorry
23:08:30 <Sparks> Okay, we can talk about it later in the meeting if you like.
23:08:36 <rudi_> Thanks yeah
23:08:42 <Sparks> #action Sparks Work on magazine article work about the guides and docs.fp.o
23:08:54 <Sparks> #link https://fedorahosted.org/marketing-team/ticket/122
23:09:05 <Sparks> I'm still working with rbergeron/Marketing on this.
23:09:15 <Sparks> quaid: You around?
23:10:04 <quaid> hey
23:10:15 <Sparks> quaid: Hey!
23:10:16 <Sparks> quaid to bring to the list a discussion about Beacon and web-based XML editors for Docs use.
23:10:23 <Sparks> quaid will kindly ask poelcat to put up taskjuggler schedule sources in a f'hosted repo, pref. git
23:10:32 <Sparks> Got any input on those two tasks?
23:11:22 <quaid> on the second, I probed poelcat about that, he was amendable but still thinking about how it is going to work with some other schemes.
23:12:07 <quaid> I forget the latest on our list discussion about web-based editors
23:12:48 <Sparks> quaid: I haven't seen a list discussion.
23:14:28 <Sparks> s/a list/a new list
23:14:53 <quaid> hmm, looks like not :)
23:15:16 <Sparks> #action quaid to discuss on the list about Beacon and web-based XML editors for Docs use.
23:15:17 <Sparks> :)
23:15:42 <Sparks> quaid: Okay, maybe we'll have some information to discuss come next week
23:15:47 <Sparks> Moving on!
23:16:04 <Sparks> #topic Fedora 14 Schedule
23:16:16 <Sparks> I've seen some input on the schedule.
23:16:38 <Sparks> jjmcd rudi_: Have you guys been able to comb through the schedule completely?
23:16:58 <rudi_> Sparks -- yes, looks sane to me
23:17:03 <jjmcd> no combing
23:17:10 <jjmcd> But next up is 7/27
23:17:15 <Sparks> Yes
23:18:29 <Sparks> Okay, moving on
23:18:46 <Sparks> #topic Publican
23:19:14 <Sparks> rudi_: Want to talk about your latest thoughts?
23:19:48 <rudi_> Well, the most fundamental problem we face is that to automate the website fully, the webserver needs to run Publican 2
23:20:01 <rudi_> nb -- are you here today?
23:20:17 <Sparks> Is Publican 2 not available on EPEL, yet?
23:20:29 <rudi_> No, and it can't be for RHEL5
23:20:37 <Sparks> Can't?
23:20:49 <rudi_> because it depends on later versions of certain Perl modules than what's available in RHEL5
23:20:49 <jsmith> EPEL policy not to upgrade major versions, as I recall
23:21:04 <rudi_> jsmith -- publican's not in RHEL5 at all
23:21:11 <jsmith> rudi_: Oh, that's right...
23:21:29 <rudi_> EPEL can only provide extra packages for RHEL, not update RHEL packages
23:21:45 <rudi_> (so that we don't break stuff :)
23:21:48 <Sparks> #info Publican depends on later versions of Perl and thus cannot be put into EPEL
23:22:23 <Sparks> So what's the plan?
23:22:26 <rudi_> Also, although Publican looks like it will go into RHEL6, we don't know whether it will be a late Publican 1 or whether Publican 2 will get in
23:22:49 <rudi_> So we *could* wait and see, but that would depend on infra migrating the server to RHEL6
23:22:54 <rudi_> There are basically two options:
23:23:13 <rudi_> 1. host d.fp.o on a server running Fedora 12 or 13
23:23:41 <rudi_> 2. keep d.fp.o where it is, and build the extra and updated packages for the server
23:24:10 <Sparks> Can't we put the necessarily files in the infra repo?
23:24:25 <rudi_> Sparks -- yeah, that's a mechanism for option 2
23:24:50 <rudi_> (AIUI the infra repo, anyway)
23:25:07 <Sparks> Okay, I'm guessing you are working with nb on the infra stuff
23:25:15 <rudi_> Well, I will be ;)
23:25:42 <rudi_> Sorry, I've had some internal Publican 2 fallout to mop up :)
23:25:42 <Sparks> Okay, anything else?
23:25:55 <Sparks> heh
23:26:17 <rudi_> That's about it -- when we get the server running Publican 2, we can start worrying about the build system
23:26:43 <rudi_> So I need to go off and learn more about the infra repo this week
23:27:05 <jsmith> It's not too difficult
23:27:37 <Sparks> Okay, moving along
23:27:42 <Sparks> #topic Release Notes
23:27:48 <Sparks> jjmcd: How's it going?
23:27:51 <jjmcd> Time for a commercial
23:28:17 <jjmcd> Pretty soon I will be checking that previous beat writers will take their beats and working to recruit new writers
23:28:35 <jjmcd> If you would like to pick up a beat or help on a beat, let me know
23:28:56 <jjmcd> The beats are not yet opened and this is a great, low impact way, to be invlved
23:29:01 <jjmcd> </commercial>
23:29:04 <bethlynn> what is a beat?
23:29:06 <Sparks> jjmcd: And what is a beat?
23:29:26 <jjmcd> bethlynn, We have folks pick up and report on certain areas, like a newspaper beat
23:29:33 <GadgetWisdomGuru> JJmcd, I'll volunteer
23:29:39 <jjmcd> So there is a writer for filesystems, etc
23:29:39 <GadgetWisdomGuru> I'm looking to start getting involved.
23:29:46 <jjmcd> Cool GadgetWisdomGuru
23:29:49 <GadgetWisdomGuru> And start slow, and build steam
23:29:56 <jjmcd> Its really kind of a fun thing
23:30:06 <GadgetWisdomGuru> specialization is wonderful
23:30:08 <bethlynn> like gather the scoop on new features? I'm in
23:30:11 <jjmcd> Gives you an excuse to poke around
23:30:15 <GadgetWisdomGuru> JJmcd, where do I find you exactly to follow up?
23:30:17 <jjmcd> Exactly bethlynn
23:30:26 <jjmcd> Wait, le me get the link
23:30:28 <crantila> I'm also interested, depending on what's available to beat on
23:30:41 <GadgetWisdomGuru> Crantila, good point
23:30:47 <GadgetWisdomGuru> Please don't put me on a beat I can't cover
23:30:50 <Sparks> jjmcd: What's the URL for the beats?
23:30:51 <jjmcd> https://fedoraproject.org/wiki/Documentation_Beats
23:31:04 <Sparks> #link https://fedoraproject.org/wiki/Documentation_Beats
23:31:18 <jjmcd> The "writers" were for F13.  Many of them probably won't return due to $DAYJOB etc
23:31:27 <crantila> oh - I really like reading these!
23:31:39 <GadgetWisdomGuru> Ok
23:32:01 <jjmcd> You know, if you're interested in e.g. webservers, it gives you an excuse to find out whats new
23:32:26 <jjmcd> The crossed out ones had nothing for F13 is all
23:32:56 <jjmcd> Of course, ppc is now history
23:33:04 <crantila> can we reserve already?
23:33:21 <jjmcd> Sure, if its open just edit in your name -- it's a wiki after all
23:33:35 <bethlynn> desktop beat is closed?
23:33:35 <jjmcd> If someone has their name in there, put yours next to his
23:33:42 <crantila> okay, thanks!
23:33:55 <jjmcd> Oh, those right columns were status for F13
23:34:05 <jjmcd> in a week or so they will all be cleared out for F14
23:34:17 <jjmcd> Closed meant we had completed it for F13
23:34:28 <bethlynn> ok
23:35:04 <jjmcd> Each of the beat files has a template that says don't touch, those will be removed before 7/27
23:35:05 <rudi_> What is a beat? http://en.wikipedia.org/wiki/Beat_reporting
23:35:37 <Sparks> anything else?
23:35:47 <jjmcd> nope that's it.  thanks
23:35:49 <Sparks> #topic Guide Status
23:35:52 <Sparks> Okay...
23:36:10 <bethlynn> jjmcd: seriously, I'm interested in owning a beat
23:36:11 <Sparks> Anyone have anything to discuss about their guide(s)?
23:36:25 <jjmcd> cool bethlynn anything in particular you like?
23:36:31 <rudi_> Nothing much to report here; Power Management Guide and Storage Administration Guide getting ready to swim upstream :)
23:36:40 <bethlynn> jjmcd: Desktop
23:36:42 <Sparks> Awesome
23:37:12 <rudi_> And more IG material to come upstream too
23:37:29 <Sparks> I really need to get some time to work on the Security Guide
23:37:47 <Sparks> This would also be a good time for anyone to ask questions about guides
23:38:21 <rudi_> crantila -- FMG is looking pretty complete now :)
23:38:27 <GadgetWisdomGuru> JJmcd, I'm interested too. But I need to look more.
23:38:44 <crantila> the Musicians' Guide is getting there... let me see
23:39:23 <crantila> I had a question about security; I'm asking users to add a file, and it's not the same SELinux context as the Fedora-repo version
23:39:35 <Sparks> crantila: Ooooo
23:39:50 <Sparks> crantila: You can provide instructions for relabeling... correct?
23:39:53 <rudi_> crantila -- what kind of file?
23:39:58 <crantila> it's a plug-in... should I press to ensure it's the same?
23:40:31 <crantila> they're both usr_t, and somebody else suggested that's all that's important, but I wanted to be sure to get the Docs practice
23:41:26 <Sparks> crantila: I'd put in instructions for relabeling if it were me.
23:41:46 <Sparks> I'd hate people to get messed up or, worse, disable SELinux
23:41:56 <crantila> also, the first drafts are being posted here when they're ready, which should be by the end of the week: https://fedoraproject.org/wiki/User:Crantila/FSC/Drafts
23:42:04 <jjmcd> There was a thread on dev-list about making sure the context is right in the rpm
23:42:08 <GadgetWisdomGuru> Sparks, it is running so smoothly, I haven't had to disable it in a long while.
23:42:28 <crantila> in particular I would like help testing the "Audacity" chapter, because I think it will be heavily used
23:42:48 <crantila> Sparks: I'll find out about SELinux, thanks
23:43:44 <Sparks> jjmcd: That would be best, probably.
23:44:19 <crantila> jjmcd: the incorrect files are downloaded from elsewhere
23:44:29 <jjmcd> ahhh
23:44:36 <crantila> the RPMs are fine
23:44:44 <jjmcd> So better put the chcon command in there
23:44:48 <crantila> okay
23:44:53 <crantila> is chcon permanent?
23:45:09 <crantila> or "persistent"
23:45:14 <jjmcd> ummmm, sort of
23:45:29 <jjmcd> If the directory is autolabeled by rule then a reboot will fix it
23:45:34 <crantila> okay, I'll figure it out later.
23:45:42 <jjmcd> which might not be what you want
23:46:50 <crantila> so, read about "Audacity," which is useful for lots of things... and that's it for now, thank you
23:47:11 <Sparks> excellent
23:47:16 <Sparks> anyone else?
23:48:05 <Sparks> #topic Outstanding BZ Tickets
23:48:12 <Sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
23:48:49 <Sparks> #info 96 bugs open
23:49:16 <Sparks> #info 26 new bugs
23:49:35 <Sparks> There has been some excellent work done
23:50:07 <Sparks> If you are looking for something to do please look at those bugs!
23:51:45 <Sparks> All you have to do is attach a patch and change the ticket to MODIFIED to be a lot of help!
23:51:55 <Sparks> Questions or comments?
23:52:15 <Sparks> #link https://fedoraproject.org/wiki/Handling_Docs_Project_bugs
23:52:21 <jjmcd> Anyone with a VM or stick is invited to play with the d-p-r rpms
23:52:34 <Sparks> ^^^ Those are the instructions for working with bugs.
23:52:56 <Sparks> #topic Open floor discussion
23:53:06 <Sparks> Okay, anyone have anything they want to talk about?
23:53:56 * Sparks hears crickets
23:54:16 <Sparks> jsmith: Anything from our Fearless Leader?
23:55:37 <GadgetWisdomGuru> Might I suggest what Young Mr. Grace said on Are You Being Served every time he showed up. "I want you to know you're all doing very well."
23:55:51 <Sparks> heh
23:55:58 <Sparks> Okay, thanks everyone for coming tonight!
23:56:05 <jjmcd> thanks Sparks
23:56:11 <Sparks> Drinks and finger food served in #fedora-docs
23:56:19 <Sparks> See you all on the list!
23:56:22 <Sparks> #endmeeting