#fedora-meeting: Fedora Release Engineering

Meeting started by Oxf13 at 17:01:01 UTC (full logs).

Meeting summary

  1. roll call (Oxf13, 17:01:16)
    1. present are brunowolff poelcat notting jsmith nirik (Oxf13, 17:03:32)

  2. Spins (Oxf13, 17:03:54)
    1. rdieter also present (Oxf13, 17:05:42)
    2. Spin owners must check in with testing before the go / no go date or risk having spin dropped (Oxf13, 17:37:44)
    3. A slip of the release will reset the spin go / no go date as well and give MIA spin owners an extension (Oxf13, 17:38:05)
    4. In case of a slip, if the updated packages are not on a spin, a re-test will not be needed (Oxf13, 17:38:25)
    5. All releng requires is that testing be done. The amount of testing is to be determined by QA and the spin owners (Oxf13, 17:38:49)
    6. releng will communicate to spin owners when RC phase starts, and when new packages are needed beyond nightly compose for future RCs (Oxf13, 17:39:26)

  3. dist-git (Oxf13, 17:40:48)
    1. Users can now use dist-git and fedpkg for cloning, committing, pushing, and building in koji.stg (Oxf13, 17:41:15)
    2. oxf13 feels that we are pretty close to required functionality for initial roll out (Oxf13, 17:41:36)
    3. new package creation and branch scripts have been modified to work with dist-git, as has the lookaside cgi (Oxf13, 17:41:59)
    4. Need to detect broken conversions and attempt with git cvs-import (Oxf13, 17:49:41)
    5. will try directory based upstream top level branches for target discovery (eg F-13/HEAD F-13/coolbranch) (Oxf13, 17:50:07)
    6. We need to draft a roll out plan and present it to FESCo, complete with rollback plan (Oxf13, 17:51:00)
    7. ACTION: We need people to start gathering a list of wiki pages that will need modifications for dist-git (Oxf13, 17:51:52)
    8. ACTION: Oxf13 to talk to fedora admins about resources for pkgs.fedoraproject.org production dist-git server (Oxf13, 17:55:21)

  4. open floor (Oxf13, 17:59:30)


Meeting ended at 18:02:01 UTC (full logs).

Action items

  1. We need people to start gathering a list of wiki pages that will need modifications for dist-git
  2. Oxf13 to talk to fedora admins about resources for pkgs.fedoraproject.org production dist-git server


Action items, by person

  1. Oxf13
    1. Oxf13 to talk to fedora admins about resources for pkgs.fedoraproject.org production dist-git server


People present (lines said)

  1. Oxf13 (93)
  2. brunowolff (47)
  3. dgilmore (19)
  4. nirik (11)
  5. poelcat (10)
  6. notting (7)
  7. zodbot (4)
  8. rdieter (3)
  9. jsmith (2)


Generated by MeetBot 0.1.4.