16:02:03 <smooge> #startmeeting EPEL
16:02:03 <zodbot> Meeting started Mon Jul 19 16:02:03 2010 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:04 * nirik is around
16:04:12 <tremble> Here
16:04:23 <smooge> hi guys
16:04:31 <smooge> sorry I did it by reflex in here
16:04:36 * mdomsch 
16:05:29 <smooge> so how is everyone on Monday? I am running on coffee and fumes today
16:06:50 * tremble is fine with it, but it's 5pm over here not first thing in the morning as it is for you guys.
16:07:08 <nirik> yeah, crazy weekend catch up here too. ;(
16:08:00 * maxamillion is here
16:08:03 <smooge> #topic EPEL-6 status
16:08:19 <smooge> mdomsch did a lot of rebuilds and such on his build farm
16:08:20 <tremble> 1600 packages tagged now :)
16:08:39 <nirik> yeah, slowly we are getting stuff built up.
16:08:44 <smooge> It looks like something like perl and perl-version conflict
16:08:48 <mdomsch> good news there is that nearly anything in Fedora could be easily built into epel
16:09:04 <mdomsch> I leave it as an exercise to decide _if_ something should go in epel though
16:09:22 <maxamillion> crap, brb
16:09:42 <mdomsch> perl bug is https://bugzilla.redhat.com/show_bug.cgi?id=597982
16:09:47 <smooge> well I need my hamster-applet and alpine and I think 6 more important packages
16:09:59 <tremble> On the perl front there will be fun gaves with packages not being tagged across which are now deps.
16:10:55 <smooge> still working on rt ? tremble
16:11:52 <smooge> mdomsch, thanks for the bug number I will go look
16:11:53 <tremble> It's mostly there, there are a few issues with packages that are in x86_64 only, and I've hit fun and games with perl-DateTime-...
16:12:01 <smooge> #chair nirik
16:12:01 <zodbot> Current chairs: nirik smooge
16:12:25 <nirik> we have some perl packages that were in rhel/64bit that we branched and people updated...
16:12:32 <rdieter> smooge: oops, sorry about alpine not being done yet, I'll get that done today
16:12:34 <nirik> we need to make sure all those get downgraded back to the rhel version.
16:12:49 <smooge> ah yes i386 has become the red-headed child who looks like the neighborhood plumber
16:13:12 <tremble> ppc64 is even worse for desktop packages IIRC.
16:14:12 <tremble> I've knocked together a script to compare EL-6 versions of things with the latest versions tagged into koji, hence the email on Saturday (or was it Sunday)
16:14:25 <nirik> tremble: did that go out to maintainers?
16:14:32 <tremble> epel-devel
16:14:41 <smooge> personally I am all for saying foo to ppc64 until I get hardware to test it with :)
16:14:48 * tremble grins
16:15:11 <smooge> I noted this a bit past.. looks like we will need to get a dep checker on epel
16:15:14 <smooge> Error: Package: smolt-server-1.4.2-1.el6.noarch (epel)
16:15:14 <smooge> Requires: python-turboflot
16:15:26 <smooge> not sure if that is still the case for that package
16:15:42 <nirik> tremble: might be good to mail maintainers too... we need those fixed soonly.
16:15:44 <tremble> nirik: I wanted to know exactly how to fix it before I sent mails to maintainers.
16:15:58 <mdomsch> what arches are epel-6 building for?
16:15:59 <nirik> just downgrade in cvs to the rhel version and build it.
16:16:07 <tremble> nirik : Should they just be able to untag in koji?
16:16:09 <mdomsch> and why are they different than RHEL?
16:16:27 <nirik> tremble: no need to untag. The more recent build will win.
16:16:33 <nirik> even though it's older.
16:16:41 <nirik> mdomsch: we are doing the same as rhel I think...
16:16:41 <tremble> nirik : Oh ok.
16:16:48 <nirik> mdomsch: why do you think otherwise?
16:16:55 <smooge> mdomsch, we build for x86_64, i686 and ppc64
16:17:05 <smooge> we do not do s390 currently
16:17:08 <mdomsch> nirik, the post on epel-devel-list on friday seems to show different
16:17:19 <mdomsch> from Mark Chappell
16:17:25 <tremble> mdomsch : That's due to error,
16:17:38 <tremble> mdomsch Mark Chappell == tremble
16:17:43 <mdomsch> danke!
16:17:55 <nirik> mdomsch: rhel ships the virt products and it's deps only on x86_64
16:18:05 <nirik> so, there are a number of packages that only exist in the x86_64 repo
16:18:11 <tremble> This is what nirik and I are talking about how to fix,
16:18:12 <smooge> I am guessing centos will do the full suite
16:18:30 <nirik> we agreed that we could build them for epel for other arches (since we need them) but that we should keep them the same version as the rhel one so we don't upgrade it on x86_64
16:18:45 <nirik> some maintainers upgraded past the rhel versions on those.
16:19:16 <tremble> Some maintainers had branched before beta2 when the contents changed.
16:19:56 <smooge> others are RH maintainers who didn't know that their stuff was in mainstream now :)
16:22:02 <smooge> ok I think thats about it for EL-6.
16:22:06 <smooge> #topic Open Floor
16:22:35 <smooge> I am hoping that after the coffee kicks in I will be able to post out meeting notes from the last ooooooooh six months
16:23:20 * tremble grins
16:23:32 <Southern_Gentlem> smooge,  IV of Mountain Dew works faster
16:23:39 * nirik doesn't have anything else off hand.
16:23:46 * tremble either
16:24:22 <smooge> Southern_Gentlem, I get horrible sugar crashes :/
16:24:33 <smooge> ok in that case.. lets call this a meeting.
16:24:34 <nirik> oh, I did have one more note:
16:24:39 <smooge> ooooh never mind
16:24:45 <smooge> nirik, go ahead
16:25:33 <nirik> heartbeat (last thing on my list) needs stuff from the "HighAvailabilty" repo. If we could add that into our builders I could build it. If we can't then I guess I need to mark it dead. ;)
16:26:44 <smooge> ok will ping dgilmore on that
16:27:11 <smooge> actually nirik would they be able to install it if they don't have HA?
16:27:31 <nirik> not sure, it needs cluster-glue-libs...
16:27:38 <nirik> so, they would need that likely to also install it.
16:27:45 <nirik> but it's also public in the beta at least.
16:27:51 <smooge> hmmm ah ok
16:28:03 * nirik looks to make sure thats true.
16:28:06 <tremble> Just got a response from z00dax, CentOS will probably be trying to mirror RHEL with the "some packages only in some arches"
16:28:16 <smooge> ah ok
16:28:25 <smooge> probably saner that way..
16:28:32 <nirik> yeah... mirrors.tummy.com/pub/ftp.redhat.com/redhat/rhel/beta/5.90Server/x86_64/os/HighAvailability/
16:31:23 <nirik> anyhow, just a FYI
16:32:04 <tremble> smooge : while I remember, it might be worth updating http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies re parallel installable packages and mirroring RHEL some-arch packages
16:32:21 <smooge> yes will do so. I will also try to rename it
16:32:30 <smooge> to meet new wiki namespace
16:32:36 * tremble nods
16:32:48 <smooge> ok I have another meeting I found out I am supposed to be in
16:32:57 <smooge> #action Smooge will post logs
16:33:08 <smooge> #action Smooge will update Guidelins and Policies
16:33:20 <tremble> Do we want the EL-6 nag message to go out again this week?
16:33:29 <smooge> tremble, lets wait til next week
16:33:33 <nirik> tremble: well, we don't want to nag too much.
16:33:33 <tremble> ok
16:33:55 <smooge> #endmeeting