21:02:36 <brunowolff> #startmeeting
21:02:36 <zodbot> Meeting started Mon Jul 19 21:02:36 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:44 <brunowolff> #meetingname spins-sig
21:02:44 <zodbot> The meeting name has been set to 'spins-sig'
21:02:54 * sdziallas waves
21:02:57 <brunowolff> #topic who's here
21:02:58 * pbrobinson is here
21:03:23 <brunowolff> nirik?
21:04:00 <brunowolff> #topic approving spins
21:04:08 <nirik> sorry I'm late.
21:04:18 <brunowolff> I'd like to see if we can through approving spins today.
21:04:50 <brunowolff> Except for MeeGo the others don't seem to have complications with our approval as continuing spins.
21:04:54 <nirik> it's been hard to test lately as none of the nightlies have worked for me, and many of them don't compose. ;(
21:05:11 <brunowolff> AOS might be withdrawn later if David doesn't have time to keep up with it.
21:05:30 * sdziallas nods. yeah, the nightlies are pretty broken right now (looks like it's rawhide and another issue).
21:06:03 <brunowolff> I think for recurring spins, we are just approving the idea of the spin and the ks file, so build issues right now don't block that.
21:06:03 <pbrobinson> there's a lot of churn in things like evolution with very few heads up to breakages
21:06:23 <nirik> yeah...
21:06:34 * nirik is +1 on meego... simple ks and looks fine to me.
21:06:48 <brunowolff> So what I'd like to do is see if we can vote to approve everything other than MeeGo with one vote, and then talk about MeeGo.
21:06:55 <nirik> ok.
21:06:58 <brunowolff> If people want we can split them out though.
21:07:31 <brunowolff> Games dropped one game that is in orphan status, SoaS added pygame, otherwise I didn't see much.
21:07:44 <sdziallas> SoaS might add another activity or so, but should be good otherwise.
21:07:49 <pbrobinson> brunowolff: what needs discussion here about MeeGo. Its awaiting board approval AFAICT
21:07:55 <brunowolff> I don't think those changes will make or break approval, so if we approved them before reapproval seems likely.
21:08:01 <nirik> Xfce should stay pretty much the same as f13.
21:08:06 <sdziallas> Design might see a few package additions or removals, nothing impacting it overly, though.
21:08:35 <sdziallas> (though I'm not the only one looking into design, and quite happy about that)
21:08:54 <nirik> I think lxde is also largely the same as f13.
21:09:23 <brunowolff> The proposal is to approve all recurring spins except MeeGo (which will get a separate vote after we discuss it). Please vote.
21:09:26 <brunowolff> +1
21:09:26 <nirik> http://git.fedorahosted.org/git/?p=spin-kickstarts.git for diffs. ;)
21:09:32 * pbrobinson wants to know why the addition or removal of a package matters?
21:09:41 <nirik> +1 here. They all seem fine.
21:09:42 <pbrobinson> +1 to the approval
21:09:46 <sdziallas> +1 from me, too
21:10:08 <brunowolff> Usually it doesn't, but if there is a big change it might be. That's why I think approvals this time should be pretty automatic.
21:10:11 <nirik> pbrobinson: I guess if they were adding something broken or otherwise bypassing guidelines? not sure that the content matters as long as it looks sane.
21:10:29 <brunowolff> OK so that passes.
21:10:38 <brunowolff> #topic MeeGo approval
21:10:42 <pbrobinson> nirik: how can it bypass guidelines if its already in Fedora?
21:11:04 <brunowolff> First, is the trademark thread trailed off.
21:11:15 <nirik> pbrobinson: perhaps it's not? (of course it wouldn't compose then).
21:11:23 <nirik> anyhow, back to meego.
21:11:40 <brunowolff> My impression is that the board doesn't have a problem in general, but some detail may need to get ironed out.
21:12:04 <brunowolff> I am not sure that this is something we need to worry about, but maybe we do.
21:12:09 <pbrobinson> brunowolff: trademarks need to be decided by the board and legal I believe
21:12:35 <brunowolff> Techincally this would be putting it in ready for board instead of directly into ready for fedora 14.
21:12:50 <pbrobinson> so I presume they need to hand down a specific yes or no or a specifically approved name
21:12:54 <nirik> yep.
21:13:49 <brunowolff> Alright, so I think we will be moving it to be ready for board and the interim wranlger (that's me) will bug them to make a decision.
21:14:01 <nirik> sounds good.
21:14:07 <brunowolff> The second issue is the experimental video drivers.
21:14:39 <brunowolff> My memory from Fedora 13 was that the agreement was that that was supposed to be removed for release.
21:14:57 <pbrobinson> well I don't remember the previous discussion you mentioned on the list but without it the spin isn't currently usuable on nvidia or ati hardware
21:15:19 <nirik> ati isn't experemental anymore... .
21:15:20 <brunowolff> The view at that time is that if the drivers aren't ready for the default release, then they shouldn't be used by spins.
21:15:26 <nirik> but yeah, I could see the nvidia side being a problem.
21:15:35 <pbrobinson> it was for some hardware for F-13
21:15:49 <pbrobinson> brunowolff: who's view?
21:15:53 <brunowolff> One question is that I don't believe ATI benefits from  this, and perhaps it is less needed.
21:16:12 <brunowolff> I believe kanarip who was lead when that discussion came up.
21:16:15 * nirik is pretty sure there is no more radeon code in the experemental package for f13.
21:16:26 <kanarip> pong
21:16:27 <brunowolff> I also feel that way, but that exceptions can be made if justified.
21:16:47 <nirik> pbrobinson: whats the failure mode if you have no 3d?
21:16:47 <pbrobinson> well what about all the nouvea cards out there.
21:17:01 <nirik> does it error out? or just not work? or ?
21:17:03 <pbrobinson> nirik: it doesn't work
21:17:25 <nirik> blank screen or something? ;(
21:17:31 <brunowolff> Well, I can tell you that the experimental driver breaks things on my system. So that this isn't a harmless thing to turn on.
21:17:35 <pbrobinson> depends on the card. Some you get a _REALLY_ slow interface, some you get a white screen and some X just crashes
21:18:06 <brunowolff> If it just was neutral or good, I would expect it wouldn't be in the experimental package.
21:18:35 <pbrobinson> brunowolff: I've not had a lot of complaints with the use of them
21:18:38 <brunowolff> Is meego targeted for specific hardware?
21:19:00 <brunowolff> Does that hardware use nvidia chips?
21:19:04 <pbrobinson> brunowolff: mostly Netbooks and NetTops as per the spins page
21:19:40 <pbrobinson> yes, in the case of the NV chipset that ships with atom processors
21:19:45 <brunowolff> What doesn't work without experimental?
21:19:55 <nirik> well, is this something we might want to visit closer to release?
21:19:55 <pbrobinson> and with the experimental it works well
21:20:04 <pbrobinson> nirik: agreed
21:20:09 <brunowolff> You had mentioned mutter in email; is that a key package for this spin?
21:20:12 <nirik> ie, do we know if they plan to make them non experemental at some point in f14?
21:20:20 <pbrobinson> as I suspect we'll know more with gnome-3 and what happens there.
21:20:31 <nirik> yeah, that might push to get more working too.
21:20:40 <brunowolff> I doubt it will be ready for F14 at this visible pace of change.
21:20:47 <pbrobinson> if they ship it I don't see why I can't, if they don't I'll happily drop it
21:21:26 <brunowolff> I am seeing some problems with an older card (nv 28) that are either driver or settings tools related, plus warzone 2100 crashes.
21:21:40 <pbrobinson> well they'd better, there's a metric bucket load of bugs almost daily with X issues against mutter
21:21:58 <brunowolff> Probably other games as well, but I haven't retested them lately and those other games don't work in 2d anyway.
21:22:32 <brunowolff> If desktop ships with the experimental drivers package, then for sure we should except meego as well.
21:22:40 <pbrobinson> so are people happy with my above point so we can move on?
21:22:55 <brunowolff> What I am trying to get to here is whether we want to except meego either way.
21:23:44 <nirik> well, in it's case I can see why it would want to do that.
21:23:49 <brunowolff> So Peter, do you feel that meego is unusable on the targeted devices that use nvidia hardware?
21:23:56 <pbrobinson> well i haven't had massive issues with adding experimental that wasn't seen other wise. 3D is somewhat experimental which ever way you look at it
21:24:01 <nirik> because even bad support has a better chance to work than no 3d, which won't work at all.
21:24:30 <pbrobinson> yes. with the open nouvea drivers on my work laptop and my nettop device it was unusable with out it
21:24:53 <pbrobinson> in the case of the work laptop it still wasn't great with it but it sort of worked
21:25:46 * nirik is probibly ok with an exception. I bet desktop will have it as well...
21:25:55 <nirik> if we even need one. ;)
21:26:08 <brunowolff> Then I think we should vote on an exception with the proviso that we may revisit it later if it is found to cause problems for ATI users.
21:26:28 * pbrobinson is happy with that
21:26:37 <nirik> how could it cause ati users problems?
21:26:41 <brunowolff> Proposal: meego be allowed to use the experimental driver package for f14.
21:26:45 <brunowolff> +1
21:26:48 <pbrobinson> +1
21:26:51 <sdziallas> +1
21:26:58 <nirik> +1 here. Seems reasonable
21:27:54 <brunowolff> Proposal: MeeGo be apporved by the SIG and moved to ready for board status for trademark approval.
21:27:57 <brunowolff> +1
21:28:38 <kanarip> +1
21:28:41 <sdziallas> +1 here, too.
21:29:05 <nirik> +1 too
21:29:05 <kanarip> it just so happens /me has a stake in meego's success ;-)
21:29:27 <brunowolff> #agreed all recurring spins have been approved by the SIG. MeeGo needs trademark approval by the boad.
21:29:48 <brunowolff> #topic livecd-desktop removing packages
21:29:53 <sdziallas> kanarip: :)
21:30:28 <pbrobinson> kanarip: please explain?
21:30:34 <brunowolff> While reviewing things I noticed that the livecd-desktop kickstart file removed some packages in post.
21:31:02 * sdziallas must have missed that commit log, or it happened while the commit emails got queued up.
21:31:11 <nirik> I think that might be due to the perl dep that came back in.
21:31:16 <kanarip> pbrobinson, has to do with my job
21:31:16 <brunowolff> I believe this is prohibited by spins policy and seems like it has the potential to break spins that include the ks file.
21:31:17 <nirik> as a workaround.
21:31:24 <pbrobinson> brunowolff: that gets rid of the perl deps. syslinux is only needed for the setup. The perl dep will be fixed by release of F-14
21:31:30 <sdziallas> I tend to try (though I sometimes fail) to stay up2date on the commit logs.
21:31:44 <nirik> yeah, so this is a MUSTFIX before f14.
21:31:57 <nirik> either remove it or fix syslinux (which should already be fixed upstream)
21:32:08 <pbrobinson> nirik: already F14blocker bug
21:32:09 <brunowolff> What I would like to see is that this stuff is removed now and that we live with an oversize image for alpha and/or beta if necessary.
21:32:19 <sdziallas> nirik: +1.
21:32:27 <brunowolff> This should have little impact on testing.
21:33:06 <nirik> well, it may mean it doesn't fit on media...
21:33:12 <nirik> which could impact testing.
21:33:14 <pbrobinson> and f-13 daily and I think alpha/beta were bigger than 700 meg anyway
21:33:25 <nirik> yeah, they often are.
21:33:49 <brunowolff> If it is CD sized, it should stull fit on a DVD. That may limit people with old hardware or with just a cd reader, but I expect
21:33:56 <nirik> true
21:33:58 <brunowolff> that effect to be negilible.
21:34:00 <pbrobinson> so its not impacting testing by being the only thing pushing it over the size
21:35:02 <nirik> so, can someone talk to desktop folks and get that reverted then?
21:35:20 <brunowolff> I don't think we have moved to a vote yet.
21:35:39 <nirik> ok
21:36:12 <sdziallas> Maybe it'd make sense to hear the desktop folks' opinion on this?
21:36:15 <brunowolff> There are plusses and minuses for removing that stuff for testing purposes, but I think removing it will be better.
21:36:21 <sdziallas> Although I think what has been said makes sense.
21:36:40 * sdziallas nods.
21:37:06 <brunowolff> Also if any other spins base off of livecd-desktop instead of live-desktop, that change could be breaking them.
21:37:48 <brunowolff> Any other discussion before taking a vote?
21:39:13 <brunowolff> Proposal: The yum remove command in livecd-desktop's post area should be removed now rather than waiting for the syslinux fix.
21:39:17 <brunowolff> +1
21:40:08 <nirik> +1, but if the desktop folks come back with some reason we didn't think of, revisit.
21:40:08 <sdziallas> +1
21:40:16 <pbrobinson> sorry, was away. Only question I have is whether being the "official" spin whether it comes under our jurisdiction?
21:40:17 <sdziallas> (actually, +1 to nirik)
21:40:28 <kanarip> +1 no matter what the circumstances
21:40:49 <kanarip> a yum remove is unacceptable imho
21:40:52 <brunowolff> If Desktop disagrees, we can ask FESCO to arbitrate.
21:40:54 <nirik> it sorta does, sorta doesn't.
21:42:16 <brunowolff> #agreed The yum remove command in livecd-desktop's post area should be removed now rather than waiting for the syslinux fix.
21:42:59 <brunowolff> Peter, do you want to discuss this with desktop and then do it or if they disagree, report this back to the spins list?
21:44:03 <pbrobinson> I'm actually in agreement with it, it was more just a query (sorry, trying to eat dinner and do work as well)
21:44:38 <pbrobinson> so +1 and also +1 on fesco arbitration if necessary
21:45:13 <brunowolff> Are you willing to talk to desktop about this? (I got the impression you work with them, but maybe that's incorrect.)
21:46:05 <pbrobinson> brunowolff: I don't work for RH at all, I'm an infrastructure engineer for a hosting company
21:46:24 <brunowolff> OK, then I'll handle it.
21:46:25 <pbrobinson> brunowolff: this is a hobby
21:46:43 <brunowolff> I meant work with as a volunteer not as an employee.
21:47:22 <pbrobinson> oh, i can email desktop list for that. NP
21:47:37 <brunowolff> #action brunowolff will deal with reverting livecd-desktop after giving them a heads up
21:48:18 <brunowolff> #action pbrobinson  will deal with reverting livecd-desktop after giving them a heads up
21:48:28 <brunowolff> Thanks, that's what I was looking for.
21:48:39 <brunowolff> If they push back just let us know.
21:48:57 <pbrobinson> will do
21:49:05 <brunowolff> #topic QA
21:49:18 <brunowolff> I didn't get as far a long as I would like with this.
21:49:53 <brunowolff> At releng it was agreed that we should do QA, but that the work needed to be done by spin owners.
21:50:33 <brunowolff> We will need to decide on some minimum set of tests we expect people to run.
21:50:45 * nirik nods.
21:51:10 <nirik> composes -> boots (virt/bare) -> login screen -> autologin works -> apps run (at least yum/PackageKit).
21:51:14 <brunowolff> This will only need to be done formally for the GA release, for alpha and beta people should test stuff shortly before freeze, but we
21:51:36 <brunowolff> aren't going to be asking for confirmation.
21:51:58 * sdziallas nods.
21:52:12 <brunowolff> Suggestions welcome.
21:52:51 <brunowolff> We aren't going to require the tests on the RCs, but rather on the nightlies from the day the RC process starts.
21:52:58 <nirik> might be best to continue on list with that... compile a list and then make a wiki page.
21:53:10 <brunowolff> The RCs for spins get built too late to be able to test against them.
21:53:29 <brunowolff> Spin owners must report success by the Go / No go meeting.
21:53:42 <brunowolff> Failures should get tentative blocker bugs filed.
21:54:21 <brunowolff> No report will result in a spin being dropped for the release. (Which will require design team to adjust web pages.)
21:54:33 <brunowolff> I need to write this up for further discussion.
21:55:08 <brunowolff> We need to make sure all of the spin owners are aware of the process, since not doing it will result in spins being dropped.
21:55:20 <nirik> right
21:55:26 <brunowolff> If people have comments now, I'd be glad to here them.
21:55:43 <brunowolff> Otherwise we can take this up more seriously next week.
21:55:56 * nirik looks at the time...
21:56:10 <sdziallas> I think this makes sense. There's obviously always the question of keeping the work at a sane level, but it also sounds sane to me to require some amount of testing if it actually should be labeled and promoted as Fedora.
21:56:30 <brunowolff> I am going to be unavailable for the first two Mondays in August so I'd like to have this pretty much resolved before then.
21:57:02 <brunowolff> I don't think we want to go crazy for the first go around.
21:57:09 * sdziallas nods.
21:57:36 <brunowolff> But whether we require install as well as boot test and whether they need to be repeated for both i686 and x86_64 seems to be
21:57:45 <brunowolff> a question in at least my mind.
21:58:07 <nirik> there's lots of questions for sure.
21:58:10 <sdziallas> Yeah...
21:58:34 <brunowolff> And there are issues of does it need to be tested on CD/DVD or can USB or VMs be used?
21:59:15 <brunowolff> So I'll come up with something and send it to the list and others can make changes.
21:59:44 <brunowolff> #topic Open
21:59:45 <nirik> sounds good.
21:59:54 <nirik> I have a quick topic... the nightlies...
22:00:08 <sdziallas> nirik: yeah, +1. we should talk about that.
22:00:12 <brunowolff> Since we are at an hour, I think we should check for other pressing issues and then call it a day.
22:00:18 <nirik> things are currently not booting.
22:00:23 <nirik> for me or sdziallas
22:00:28 <nirik> in virt or non virt
22:00:30 <brunowolff> The last kernel was bad.
22:00:42 <nirik> brunowolff: ah. is that fixed now?
22:00:49 <sdziallas> brunowolff: there were two different issues we were running into.
22:00:55 <brunowolff> I wasn't sure if it was just my hardware and no dmesg file was left behind.
22:01:03 <sdziallas> right now, I can't even get to an isolinux screen.
22:01:14 <brunowolff> I reverted to the kernel from before and my F14 system booted.
22:01:17 <nirik> yeah, just blank.
22:01:19 <sdziallas> before, dracut would fail (nirik, h\h and I narrowed that down).
22:01:36 <brunowolff> It was dying in udev, but wasn't leaving logs behind.
22:01:41 <sdziallas> we have a BZ for that dracut thing and escalated that as a blocker for alpha (thx pbrobinson)
22:01:51 <brunowolff> Maybe that was a different issue then.
22:01:55 <sdziallas> Mhm!
22:02:09 <sdziallas> https://bugzilla.redhat.com/show_bug.cgi?id=615443
22:02:11 <nirik> yeah, also a number of spins are still not composing currently due to broken deps. ;(
22:02:26 * nirik syncs over todays nightly compose if people would like to test them.
22:02:30 <brunowolff> Are any of those deps FTBFS related?
22:02:39 <brunowolff> I might take a look if there are any.
22:02:48 <nirik> not sure.
22:03:23 <nirik> in any case we should try and get things under control by alpha.
22:03:44 <brunowolff> If they just need rebuilds, I can't help much as I am not provenpackager, but if the builds are failing I can try to diagnose what's wrong.
22:03:46 <nirik> just FYI, testing or fixes welcome.
22:04:20 <nirik> oh, I also have the nightly scripts smart enough now to keep old isos around (I think)
22:04:29 <sdziallas> nirik: :)
22:04:31 <nirik> so once everything composes it should always keep the last one that worked.
22:04:48 <sdziallas> brunowolff: I'm in #fedora-devel lurking, so if there's a rebuild that needs to be done, just holler.
22:05:06 <brunowolff> That is nice. Since we are going to have people use these for alpha and beta it is good that there will always be something to test.
22:05:58 <brunowolff> #info Borken deps are blocking some builds
22:06:07 <brunowolff> #info there is currently a boot issue
22:06:13 <brunowolff> Anything else?
22:06:28 * nirik has nothing
22:06:33 * sdziallas shakes head
22:06:34 <brunowolff> I'll send out the notes.
22:06:46 <brunowolff> #endmeeting