15:06:57 <tk009> #startmeeting Bugzappers
15:06:58 <zodbot> Meeting started Tue Jul 20 15:06:57 2010 UTC.  The chair is tk009. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:09 <tk009> #meetingname BugZappers
15:07:09 <zodbot> The meeting name has been set to 'bugzappers'
15:07:32 <tk009> #chair adamw
15:07:32 <zodbot> Current chairs: adamw tk009
15:07:40 <adamw> yaay, I like chairs
15:07:47 <tk009> #topic gathering bodies
15:08:02 * fenris02 grabs a chair before they are all gone
15:08:22 <tk009> #chair fenris02
15:08:22 <zodbot> Current chairs: adamw fenris02 tk009
15:08:50 <tk009> jrabaer around?
15:09:01 <tk009> jraber
15:09:48 <fenris02> * [jraber] idle 00:32:31, signon: Tue Jul 20 09:37:07
15:09:48 <fenris02> maybe he's afk
15:10:00 <tk009> #topic Need help and owners for this page:
15:10:09 <tk009> https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora14
15:10:10 <adamw> poelcat: ping
15:10:21 * mcepl waves
15:10:22 <fenris02> #link https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora14
15:10:33 <tk009> jraber was doing some of this already I wondered if he wanted to continue
15:10:58 <fenris02> are f12 warn/close automated?
15:11:04 <mcepl> adamw: for later ... I would have a point to laster
15:11:20 <adamw> fenris02: don't think anything's automated
15:11:26 <fenris02> d'oh.
15:11:28 <tk009> they are not
15:12:38 <tk009> because the board decides when EOL is it's hard to automate a day you don't know, I am guessing anyway
15:12:39 <fenris02> i've not played with bugzilla cli much, but it seems possible to automate that
15:12:48 <fenris02> warn is easy thouhg
15:13:20 <fenris02> no actual dates are in the warning, just "soon".  close can wait until the board says it's closed.
15:14:33 <tk009> we don't know when to send the warning tho until the board says, I might be confused here if so disregard me
15:14:37 <adamw> well, it depends what you mean by automated
15:14:42 <adamw> we don't go through it bug by bug
15:15:01 <adamw> when we have the date, someone (which up till now has basically meant 'poelcat') sets up a query that lists all the bugs we want changed
15:15:12 <fenris02> two bugs for f11 are still around --
15:15:32 <adamw> then we get the bugzilla admin (dave lawrence) to do the change. iirc
15:15:47 <adamw> fenris02: some bugs are exempted from being closed, see the search for details
15:15:57 <tk009> I will take ownership of the page and any due items. we can review it again next week and maybe someone will want to take it.
15:15:59 <fenris02> 12726 open bugs for f12.  ouch.
15:16:30 <fenris02> adamw, stupid question i'm sure - but why not reassign such bugs to $next_release?
15:16:31 <tk009> #action tk009 will take ownership until relived.
15:16:52 <tk009> damn that spelling, one day I will know how but not today
15:17:22 <adamw> fenris02: we don't know if they're still valid on $next_release . mostly we hope they aren't because they got fixed upstream or something. the comment that gets posted warning about EOL tells people to bump them to a newer version if they're still valid.
15:18:33 <tk009> bah I did spell it right, nm me =)
15:18:45 <fenris02> why this one?  https://bugzilla.redhat.com/show_bug.cgi?id=615711  the install date is past the eol date
15:19:00 <adamw> tk009: actually it's relieved
15:19:09 <adamw> relived is a real word but it doesn't mean the same thing. =)
15:19:20 <fenris02> reincarnated :)
15:19:27 <adamw> jraber: really here?
15:19:41 <jraber> not really.  not yet
15:19:45 <fenris02> is there a way to block fc1-f11 bugs from being opened under those versions?
15:20:01 <tk009> so I missed an e sue me
15:20:24 * adamw calls his lawyer
15:20:36 <tk009> I don't believe so fenris02
15:20:39 <adamw> fenris02: good question. i think it's been asked before, and I think the answer's no
15:21:16 <fenris02> ah, too bad.  opening any bug report under an eol release is bad mojo
15:22:07 <tk009> most bugs under EOL's are easy closes
15:22:25 <tk009> gives newer people some to get started
15:22:31 <fenris02> imho, the user really should be warned that it's an EOL release prior to even opening it
15:23:13 <tk009> that sounds resonable
15:23:47 <tk009> getting that implemented might not be easy tho
15:23:55 <tk009> I never know with bugzilla
15:24:04 <adamw> it probably wouldn't be easy
15:26:06 <tk009> more on this or should we move on?
15:26:49 <fenris02> next
15:27:17 <tk009> #topic Need help nagging developers for feedback in blocker bugs. Could we create a template for comments and a simple SOP of things triagers should review blocker bugs for?
15:28:22 <adamw> who was this from again?
15:28:22 <tk009> don't all raise your hand at once
15:28:23 <fenris02> anyone from the wordsmith team that can write up such a template?
15:28:29 <tk009> poelcat
15:29:44 <tk009> I suxors and docs so no short straw for me
15:29:55 <tk009> s/and/at
15:30:24 <fenris02> i'm good at copy/paste. but rather concise for docs.
15:30:38 <tk009> ask for help on the list?
15:30:57 <adamw> it seems like a bit of a complex suggestion, i think it might be best for poelcat to explain it in more detail, on the list if he's not here
15:31:19 * poelcat sorry to hit and run on that topic... i'll follow up more later
15:31:34 * poelcat was hoping to discuss at this meeting, but pulled away to other things :-/
15:32:31 <tk009> #action poelcat to provide further information on this request at a later date.
15:33:00 <tk009> well if no jbrother then I guess...
15:33:07 <tk009> #topic Open Floor
15:33:31 <tk009> did mcepl have something?
15:33:44 <mcepl> yes, please
15:33:45 <adamw> poelcat: if you can just mail the list about it that'd be great
15:34:04 <tk009> #chair mcepl
15:34:04 <zodbot> Current chairs: adamw fenris02 mcepl tk009
15:34:34 <mcepl> I would really appreciate if some courageous souls uninstall his bugzilla jetpack scripts, and install https://fedorahosted.org/released/bugzilla-triage-scripts/bugzilla-triage.xpi
15:35:01 <fenris02> mcepl, i've been using that, seems to work well on linux and winxp.  broken on macos.  no idea why.
15:35:06 <mcepl> I think it should be mostly working (and I am trying to make it approved in AMO as https://addons.mozilla.org/cs/firefox/addon/192496/) but I would need more testers
15:35:44 <mcepl> fenris02: interesting, any error messages anywhere (stderr, Ctrl-Shift+J)?
15:36:10 <adamw> i'll grab it later
15:36:33 <fenris02> mcepl, ctrl+shft+J do nothing.  no errors
15:36:33 <tk009> mcepl I just installed it and will run it regular like
15:36:39 <fenris02> mcepl, just doesnt do anything.
15:36:57 <mcepl> hmm, weird
15:37:05 <mcepl> tk009: thanks
15:37:29 <mcepl> fenris02: no idea, probably bug in Jetpack itself, will ask about issues on Mac on #jetpack
15:38:35 <mcepl> that's it from me
15:39:03 <fenris02> it's really neat on the others though, everyone should try it :)
15:39:16 <mcepl> adamw: do you hear it? ;)
15:39:25 <tk009> =)
15:39:30 <adamw> hehe
15:39:43 <tk009> kk, anyone got anything else?
15:40:07 <mcepl> i will have a presentation about it at Guadec next week, so I would like to have it as stable as possible.
15:40:27 <jraber> Not sure if it was mentioned, but the triage metrics have changed home.
15:40:27 <fenris02> getting it approved on AMO would be a big help
15:40:44 <tk009> okaiji are you here in the meeting?
15:40:50 <jraber> https://fedoraproject.org/wiki/BugZappers/Metrics
15:40:51 <okaiji> yes!
15:41:01 <tk009> anyting you would like to say or ask
15:41:03 <fenris02> jraber, for triage, should we be marking them triaged prior to closing them?
15:41:06 <tk009> please feel free
15:41:16 <jraber> great.
15:41:19 <fenris02> err, for metrics rather
15:41:28 <okaiji> |nop
15:41:32 <jraber> oh, that was a question...
15:41:34 <okaiji> interesting though
15:42:03 <tk009> well if you have any questions please ask away
15:42:09 <okaiji> triage metrics?
15:42:17 <okaiji> as in stats rite
15:42:20 <fenris02> jraber, yes.  i've had a *bunch* of bugs that just get closed outright.  (abrt without debug, fixed in #newrelease) etc... those currently do not get counted by metrics
15:42:21 <tk009> correct
15:42:45 <adamw> jraber: oh nice, that's new - thanks
15:43:08 <jraber> My plan was to (eventually) have a metric that showed the bugs that were CLOSED by a triager.
15:43:33 <jraber> with 'triager' being = someone that has used the triage keywork in the last 90days.
15:43:43 <fenris02> jraber, *nod*  i'm wondering if it would be easier tagging it as "closed by triager"
15:43:50 <jraber> but it would be easier if we just set the 'triaged' keyword before marking the bug as CLOSED
15:44:01 <jraber> exactly
15:44:09 <fenris02> easy enough to hit 'triage' first, then close.
15:44:32 <jraber> I wanted to discuss it here.  To see if there was any problem with marking them as 'triaged' when closing them
15:44:33 <tk009> #topic Should BugZappers set the 'triaged' keyword when closing bugs?
15:44:57 <tk009> I don't see that there is any problem wit hthat
15:45:03 <fenris02> i seriously want to know what magic mcepl uses to get through that many bugs so quickly ^^
15:45:13 <tk009> pay check
15:45:16 <tk009> =)
15:45:17 <jraber> I think that it is a valid thing to do.  The bug was looked at by a triager, and determined to be DUP/INSUFFICIENT INFO/whatever
15:45:31 <mcepl> fenris02: that's it mostly ... eight hours a day
15:45:37 <adamw> i guess it makes sense to.
15:45:41 <jraber> +1
15:45:47 <tk009> +1
15:45:52 <fenris02> mcepl, oh, i thought you had some other task for your job too.  you seemed involved in many projects
15:46:08 <jraber> mcepl: can you modify the greasemonkey/jetpack/addon to set the flag when closing?
15:46:23 <mcepl> jraber: sorry, which flag?
15:46:32 <jraber> sortry, to set the Triaged keyword
15:46:37 <mcepl> (let's swtich it to #fedora-bugzappers, this is not appropriate here)
15:47:05 <mcepl> oh, I see
15:47:08 <jraber> seemed relevent to the topic
15:47:13 <tk009> it is
15:47:24 <mcepl> yeah, it should be trivial ... file a ticket at https://fedorahosted.org/bugzilla-triage-scripts/ please
15:47:29 <tk009> tho are time grows short
15:47:30 <mcepl> (or I will do it)
15:47:30 <jraber> will do
15:47:34 <okaiji> what does res by upstream mean?
15:47:44 <okaiji> by resolution
15:47:49 <fenris02> okaiji, upstream package has fixed the issue
15:48:00 <okaiji> thanks
15:48:06 <mcepl> fenris02: no, the bug has been pushed upstream and it is followed on there
15:48:11 <mcepl> okaiji: ^^^
15:48:16 <okaiji> =#
15:48:32 <okaiji> :)
15:48:50 <mcepl> (and it would be awesome if Fedora maintainer help with resolving it there)
15:49:03 <okaiji> that list of bug 'triaged' is really long
15:49:07 <fenris02> mcepl, do the rhat bz items get closed out prior to come scm commit upstream?
15:49:23 <fenris02> s/come/some/
15:49:28 <mcepl> yes
15:49:44 <fenris02> my tpyeing skills are worse than my speling skills today.
15:50:09 <mcepl> BUT, bug triager (aka me) should then promise that it will really follow the bug upstream and let our maintainer know when it is interesting to patch our package.
15:50:30 <jraber> Should we update a wiki page somewhere to show that we now want to set the 'Triaged' keyword when CLOSE'ing bugs?
15:50:39 <fenris02> mcepl, ok, fair enough. my bad
15:51:10 <tk009> jraber yes but off hand I can't think of where
15:51:24 <jraber> any volunteer to find/update it?
15:51:25 <mcepl> fenris02: and of course, what really matters is what our maintainer wants
15:51:26 <adamw> probably https://fedoraproject.org/wiki/BugZappers/How_to_Triage
15:51:31 <tk009> I am distracted by hunger atm
15:51:34 <adamw> specifically https://fedoraproject.org/wiki/BugZappers/How_to_Triage#Closing_Bugs
15:52:00 <tk009> jraber did I just see you raise your hand?
15:52:26 <adamw> good work, volunteer!
15:52:29 <tk009> =)
15:52:31 <okaiji> that's reali helpful.
15:52:39 <okaiji> #closing bugs
15:52:43 <mcepl> jraber: https://fedorahosted.org/bugzilla-triage-scripts/ticket/25
15:52:58 <fenris02> mcepl, https://fedorahosted.org/bugzilla-triage-scripts/ticket/26
15:53:00 <mcepl> tk009: ^^^ or whoever asked for it
15:53:05 <fenris02> f'oh
15:53:14 <mcepl> wow! my first duplicate!
15:53:14 <tk009> that is my thinking as well
15:53:20 <fenris02> mcepl, sorry :)
15:53:29 <tk009> Jraber do you mind taking that task?
15:53:57 <jraber> Well, I hadn't intended to volunteer.  It is a minor change, I can handle it.
15:54:04 <mcepl> fenris02: no, that's OK ... I feel like my project is getting real life ; mom, see, I have duplicate bugs!
15:54:36 * fenris02 chuckles
15:55:12 <tk009> #action jraber will update the wiki with the added close procedures
15:55:44 <tk009> okay closing this puppy out soon, anything else?
15:55:58 <tk009> pancakes are calling
15:56:04 <jraber> I didn't announce the change to location for the metrics, has anyone looked at their new home: https://fedoraproject.org/wiki/BugZappers/Metrics
15:56:05 <jraber> ?
15:56:09 <adamw> jraber: bugzappers is like the army. it's very easy to volunteer. ;)
15:56:11 <fenris02> unless you have a free pony, i'm good.
15:56:23 <adamw> #info jraber moved the triage metrics info page to a new location: https://fedoraproject.org/wiki/BugZappers/Metrics
15:56:32 <jraber> I intended to just copy/past, but ended up changing the look a bit.
15:56:42 <tk009> yes I am on that page now
15:56:48 <adamw> on my old action item to write an initial triage statistics email, on closer inspection, we don't really have enough useful metrics to make it worthwhile yet; i'll wait until jraber has a couple more implemented
15:57:55 <jraber> Some of the data have been replace with links to BugZilla.
15:58:37 <jraber> I will update https://fedoraproject.org/wiki/Talk:BugZappers/Metrics with progress as it happens.
15:58:51 <tk009> you are doing a great job brother
15:58:58 <mcepl> fenris02: what version of FF you used on Mac?
15:59:48 <fenris02> mcepl, 3.6.6 at the moment
16:00:22 <fenris02> mcepl, think i'd have better luck with 4?
16:00:24 <tk009> you don't have to go home, but you can't stay here.
16:00:27 <tk009> #endmeeting