21:00:39 <jforbes> #startmeeting Fedora Cloud SIG
21:00:39 <zodbot> Meeting started Thu Jul 22 21:00:39 2010 UTC.  The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:40 <zodbot> rbergeron: Error: Can't start another meeting, one is in progress.
21:00:43 <rbergeron> doh :)
21:00:44 <gholms> Haha
21:00:44 <zodbot> gholms: Error: Can't start another meeting, one is in progress.
21:00:56 <jforbes> heh
21:00:58 <gholms> #meetingname cloud
21:00:58 <zodbot> The meeting name has been set to 'cloud'
21:00:59 <mdomsch> #endmeeting
21:01:00 * rbergeron grins
21:01:00 <smooge> here
21:01:05 * ianweller 
21:01:09 * rbergeron 
21:01:09 <jforbes> #chair rbergeron
21:01:09 <zodbot> Current chairs: jforbes rbergeron
21:01:10 <smooge> fuck
21:01:14 * smooge goes home
21:01:14 <rbergeron> thank you, sir. :)
21:01:15 * pbrobinson is here
21:01:18 * gholms takes a seat in the bleachers
21:01:27 <rbergeron> how's everyone doing? :)
21:01:32 <jeevan_ullas> hi all
21:01:39 <gholms> I've asked some people from #openstack to stop in and answer any questions people may have.
21:01:43 <rbergeron> #topic agenda
21:01:44 <smooge> I am here for the trash talk
21:01:48 <dendrobates> o/
21:01:51 <rbergeron> #link https://fedoraproject.org/wiki/Cloud_SIG#Upcoming_meeting_agenda
21:02:01 <rbergeron> So - really quick - a few things on the agenda
21:02:06 <jforbes> I am here somewhat :)  a lot going on this week with feature freeze on Tues
21:02:25 <rbergeron> First is - OpenStack - and i do believe we have one person here to talk about that :) /me poitns to dendrobates
21:02:40 <rbergeron> Second - Documentation stuff - third, talking about a trac instance
21:03:06 <rbergeron> but I know most people have come to chat about OpenStack so - if we can't cover other things in the next hour we can take that stuff to the mailing lists. Unless jforbes has any pressing items wrt Feature freeze.
21:03:10 <rbergeron> :)
21:03:17 <rbergeron> Questions? Comments? Flames before I proceed to openstack stuff?
21:03:20 <rbergeron> :D
21:03:31 <jforbes> Nope, openstack is good
21:03:33 <rbergeron> okee dokee.
21:03:37 <rbergeron> #topic OpenStack
21:03:44 <rbergeron> #link http://openstack.org
21:03:51 * mmcgrath is here
21:04:04 <rbergeron> So - I think there is some subagenda here, not sure how to proceed.
21:04:08 <rbergeron> I think some people want to talk about packaging
21:04:13 <dendrobates> wiki.openstack.org is less markety
21:04:13 <rbergeron> others want to know "what it is" perhaps
21:04:30 <pvo> right now it is only 2 projects
21:04:34 * mmcgrath certainly does :)
21:04:38 <rbergeron> so - dendrobates, want to introduce yoruself to the good folks here quickly and give a little background? :)
21:04:44 <pvo> 2 components really
21:04:49 * rbergeron is not sure who else here is from openstack - plz raise your hand ;)
21:04:55 <dendrobates> ok I am the project lead of Openstack
21:04:58 * pvo raises hand
21:05:04 * notmyname is a swift (openstack storage) dev
21:05:05 * _0x44 raises his hand.
21:05:05 <pvo> there are others here...
21:05:16 <dendrobates> I was formerly the engineering manger of Ubuntu server
21:05:17 * antonym raises hand
21:05:17 <rbergeron> excellent :) glad you guys could make it.
21:06:10 <pvo> notmyname: you want to detail swift?
21:06:17 <notmyname> sure
21:06:26 <rbergeron> yes - feel free to dive in!
21:06:36 <ianweller> things must be going quickly, i didn't even see swift when i looked at this on the plane tuesday
21:06:46 <notmyname> swift (swift.openstack.org) is a distributed object/blob store
21:07:05 <notmyname> it is used in production as Rackspace Cloud Files
21:07:27 <notmyname> and supports big scale, high concurrency, and fault tolerance
21:07:52 <ianweller> and apparently is written in python?
21:08:00 <smooge> notmyname, do you have definitions of those somewhere? I have run into too many places defining them differently
21:08:02 <notmyname> 100% in python
21:08:09 <pvo> nova is the compute component contributed by nasa. it currently uses kvm and is under heavy development. all written in python
21:08:35 <notmyname> smooge: we target 100PB per cluster, 100K connections/second
21:08:44 <mmcgrath> notmyname: how does basic node/server communication work, how many services does it actually use, etc?
21:08:56 <pvo> dendrobates got killed by teh oscon wifi
21:09:14 <notmyname> mchua: everything communicates via HTTP. it's very loosely coupled.
21:09:29 <notmyname> there are 4 big parts to swift: proxy, account, container, and object
21:09:42 <notmyname> the proxy servers are the public facing part
21:10:07 <notmyname> these can all be run on one machine or on separate machines (or any combination)
21:10:24 <smooge> wow.. thats a lot
21:10:49 <notmyname> account and container servers handle listings. the object servers handle the storage
21:11:33 <notmyname> each container and account are managed as a separate sqlite database and the object storage uses the filesystem store data and metadata
21:12:05 <notmyname> http://swift.openstack.org/overview_architecture.html goes in to more detail
21:12:12 <mmcgrath> notmyname: thanks
21:12:47 <rbergeron> So - I know some people wanted to talk about packaging type stuff - I don't want to interrupt anything - just so we have sort of a timeline and not get too wrapped up in one area or another
21:13:01 <rbergeron> I would guess some of that might entail dependencies type things - and then secondary to that
21:13:21 <rbergeron> talking about how maybe we can work together on packaging type stuff, if we think this is something we can work out. :)
21:13:22 <silassewell> rbergeron: I already got a rough package which works
21:13:44 <ianweller> i'd be very interested in helping to sponsor new packager(s) from openstack
21:14:00 <mmcgrath> yeah packaging is the rough spot
21:14:13 <mmcgrath> silassewell: how close to the packaging guidelines are they?
21:14:27 <mmcgrath> no bundled libraries or anything?  Packaging is always the biggest hurdle I'm afraid :(
21:14:32 * rbergeron wonders where the openstack folks are sitting at oscon to irc
21:14:36 * mmcgrath would love to see this in Fedora though
21:14:47 <silassewell> mmcgrath: nope, just need to figure out man pages
21:14:50 <gholms> I can review, though I can't sponsor.
21:15:16 <redbo> mark
21:15:18 <rbergeron> silassewell: do you have that someplace where people could take a peek?
21:15:59 <silassewell> rbergeron: yeah, I can though it up somewhere, I'm setting up a vm now to test everything
21:16:20 <silassewell> obvious fedora requires stuff like man pages and reasonable defaults, subpackages and other stuff I haven't done yet
21:16:32 <silassewell> obviously*
21:17:01 <ianweller> i don't think we *require* man pages but they're nice to have
21:17:04 * ianweller goes to double check what he just said
21:17:36 <ianweller> ah, it's a "should" / "work with upstream"
21:17:39 <silassewell> basically there is still a lot to do, but I'm working on it (putting on github now)
21:17:52 <gholms> The guidelines strongly recommend man pages.
21:18:33 <ianweller> silassewell: if you already have a rough package that works, what i would suggest is going ahead and creating a review request for that package -- at that point, i can take a look at it and we can openly discuss what needs to be improved for inlcusion in fedora
21:18:46 <mmcgrath> silassewell: any idea how deep the dep chain is?  IE: how many packages we'd have to make that aren't already in Fedora?
21:18:59 <mmcgrath> silassewell: has this been tested on Fedora/RHEL or do you guys use $OTHER_OS ?
21:19:18 <silassewell> mmcgrath: fedora looks to have all the deps (not many)
21:19:28 <mmcgrath> excellent
21:19:37 <silassewell> mmcgrath: won't work on el 5 because of python 2.4 vs 2.5 (uses with statement)
21:19:54 <notmyname> for what it's worth, someone put this up on the openstack wiki: http://wiki.openstack.org/RhelInstructions
21:20:00 <smooge> python26?
21:20:17 <gholms> Can python26 even go in epel?
21:20:28 <ianweller> python26 is going to be in el 6, last i knew
21:20:31 <mmcgrath> silassewell: actually in epel-5, python26 is an option so getting it to work with RHEL5 might be fine.
21:20:35 <mmcgrath> gholms: already there.
21:20:40 <mmcgrath> python26 is the package name
21:20:42 <gholms> O_o
21:20:48 <gholms> When did that land?
21:20:50 * gholms goes to look
21:20:55 <ianweller> cool!
21:21:23 <mmcgrath> gholms: beats me, dmalcolm is a python god
21:21:48 <silassewell> wow, when did epel add that?
21:21:52 <gholms> Awesome, I get to stop maintaining our internal copy!
21:22:06 <mmcgrath> notmyname: thanks for that link
21:22:49 <gholms> Any info on image building?
21:24:11 <brianlamere> looks like python26 is actually in rhel itself
21:24:27 <gholms> Of course, it's based on f12/13.
21:24:47 <brianlamere> I just meant versus epel; it's in rhel proper
21:24:53 * gholms makes a note to build eucatools for el5
21:25:19 <ianweller> silassewell: so do you guys have someone/some people who would be willing to become packagers in fedora?
21:26:16 <silassewell> ianweller: I'm not one of the openstack guys ( https://admin.fedoraproject.org/pkgdb/users/packages/silas )
21:26:20 <mmcgrath> So as far as getting this into Fedora, what would your guys goals be?
21:26:23 <mmcgrath> the openstack people I mean.
21:26:23 <pvo> ianweller: I might know someone who isn't here now, but would be very interested
21:26:30 <mmcgrath> any wants or concerns or questions?
21:26:30 <rbergeron> yes - I'd like to come out of thsi with maybe some people who are willing to work together and get some conversations started and maybe assess things over the next week or two and see where we stand in terms of packaging, what that hill would look like.
21:26:33 <pvo> I'll ping him and let you know
21:27:28 <rbergeron> As an FYI - feel free to join our mailing list :)
21:27:33 <rbergeron> #link https://admin.fedoraproject.org/mailman/listinfo/cloud
21:27:44 <pvo> mmcgrath: There are 2 components now and I think the desire is to keep them separate openstack-nova and openstack-swift
21:27:56 <pvo> because they should be able to be installed separately
21:28:04 <mmcgrath> <nod> I don't think that's a problem
21:28:11 <mmcgrath> pvo: any timelines or anything yet?
21:28:27 <pvo> mmcgrath: targeting a 10/1
21:28:38 <pvo> oct 1
21:28:53 <_0x44> pvo: Did that change? The wiki still says 21 oct
21:28:58 <mmcgrath> cool
21:29:10 <pvo> _0x44: possibly... October-ish. : )
21:29:13 <ianweller> silassewell: whoops :)
21:29:27 <_0x44> pvo: Someone better tell dubs and sirp, they're already freaking about the late oct date.
21:30:43 <pvo> ianweller: I'll reach out to rackerhacker to see if he would be interested in maintaining the packaging
21:31:11 * rbergeron notes there is a #openstack channel as well for fedora peeps to reach out to
21:31:20 <rbergeron> it
21:31:26 <rbergeron> it's very popular right now :)
21:31:30 <silassewell> pvo: I'm up for creating and maintaining the packages unless you guys want to
21:31:55 <pvo> silassewell: either way. If you already ahve some, that will work
21:32:39 <ianweller> pvo: well, to whoever wants to do it, here's the instructions -- https://fedoraproject.org/wiki/Join_the_package_collection_maintainers
21:32:47 * rbergeron nods
21:32:59 <silassewell> http://github.com/silas/rpms/blob/master/swift/swift.spec is the start
21:33:06 <pvo> silassewell: right on. Thanks.
21:33:11 <mmcgrath> #link http://github.com/silas/rpms/blob/master/swift/swift.spec
21:33:30 <ianweller> that is an amazingly clean specfile :)
21:35:18 <gholms> BuildRequires python(abi)?
21:35:30 <pvo> hey guys, I have to run...
21:35:40 * gholms recommends moving on and following up on the cloud list
21:35:41 <rbergeron> pvo: thanks for coming
21:35:50 <pvo> sure thing. talk to you soon
21:36:13 <rbergeron> so - who is still here from openstack?
21:36:22 * rbergeron peeks around
21:36:33 <_0x44> I am still here.
21:36:41 <silassewell> gholms: python-siphrex imports the main code for generating docs and the main code uses the with statement
21:36:43 <_0x44> dendro-afk: Is from openstack also
21:36:48 <gholms> Ah
21:37:15 * gholms hasn't seen subpackage-specific BuildRequires before
21:37:44 <rbergeron> So - I'd like to come out of this with maybe some next steps and get some contacts made with Fedora people who are willing to help guide us through packaging with this.
21:38:07 <rbergeron> _0x44: can i email you the meeting minutes and the cloud list address so we can make sure we'er all on the same train here?
21:38:08 <gholms> I can review Python packages, though I can't sponsor new packagers.
21:38:18 <rbergeron> and maybe have you shoot that info out to the people who were here?
21:38:23 <rbergeron> :D
21:38:26 <_0x44> rbergeron: Sure, chris@slicehost.com
21:38:33 <rbergeron> excellent. thanks :)
21:38:59 <rbergeron> #action rbergeron to mail chris@slicehost.com with meeting minutes, mailing list address, some fedora contact info.
21:39:26 <rbergeron> #action _0x44 to send that stuff out to other openstack folks who were here.
21:39:39 <rbergeron> So - from fedora side - who did we have raising hands to help out?
21:39:42 <rbergeron> ianweller?
21:40:15 * ianweller raises his third hand
21:40:16 <silassewell> rbergeron: I'm probably going to submit the package for review, it looks like I'll end up using it at a hosting company this fall anyway
21:40:29 <ianweller> silassewell: i'll review it, just assign it to ian@ianweller.org when you post it ;)
21:40:51 <rbergeron> #action silassewell goign to submit package for review.
21:40:57 <pbrobinson> it would be good if there could be some form of tracking bug for all the packages. Makes it easy for others to track the over all status
21:41:00 <rbergeron> #action ianweller to review
21:41:01 * rbergeron nods
21:41:11 <rbergeron> that's sort of the next thing i wanted to talk about, actually
21:41:21 <rbergeron> are we somewhat wrapped up on openstack stuff? any other business here?
21:41:33 * rbergeron wants to thank openstack folks for coming and for lovely party last night ;D
21:42:04 <rbergeron> if not - i'll move on to tracking stuff.
21:42:27 <rbergeron> #topic Tracking of Packages
21:42:36 <rbergeron> pbrobinson - sounds like you have some suggestions here. :)
21:42:36 <gholms> Of packages?
21:42:47 <rbergeron> #topic Tracking .. in general.
21:42:53 <ianweller> heh
21:42:55 <rbergeron> I'll back that up.
21:43:07 * rbergeron notes she is very untechnical but is awesome with meetbot.
21:43:17 <gholms> rbergeron: There's an #undo command, for future reference.  ;)
21:43:23 <rbergeron> yeah, you'er right
21:43:33 <pbrobinson> rbergeron: yes. you set up a tracking bug. See F14Blocker or F14alpha bugs as eg and then just make all the reviews block that bug
21:43:36 * rbergeron is kind of beat today ;)
21:43:51 <ianweller> pbrobinson: so something like FedoraCloud
21:44:08 <gholms> What's the purpose of this tracker?
21:44:17 <pbrobinson> ianweller: openstack might be better. There's also sorts of cloudy stuff
21:44:35 <rbergeron> So - I guess maybe what i've been thinking is parallel - I've been thinking about doing a trac instance to kind of keep track of some of our "to do" list things.
21:44:57 <rbergeron> Since we have other stuff on the plate other than openstack, and keeping track of it in wiki form i think is going to get a little hairy.
21:45:12 <pbrobinson> gholms: to track all the associated package reviews. Makes it easier to see all that need to be done to get all the packages in. Makes it easy for someone like me who might have a spare 30 mins for a review to see what needs to be done etc
21:45:30 <rbergeron> Do we have objections to that idea for higher-level tracking of action items in general?
21:45:38 <jforbes> none here
21:45:41 <pbrobinson> as well as any other deps such as bugs with other packages etc
21:45:45 <gholms> How about feature pages like fedoraproject.org/wiki/Features/EC2?
21:45:48 <rbergeron> And i'll let someone else drive this train as far as what pbrobinson is discussing
21:46:01 <jforbes> gholms: too late for F14 feature process now
21:46:13 <ianweller> so, have a trac instance, in addition to a bugzilla tracking bug?
21:46:36 <gholms> jforbes: That doesn't prevent us from creating and using feature pages to track progress for future releases.
21:46:49 <pbrobinson> ianweller: why do we need a trac instance?
21:46:59 <gholms> "Fedora on Slicehost" could be a F15 feature, for instance.
21:47:39 <ianweller> i think i may have misread what rbergeron was saying
21:47:42 <rbergeron> so - we have other things aside from packaging stuff we'd like to track. Things like - documentation being done, etc.
21:47:44 <ianweller> hold on while i clear my head
21:47:51 <ianweller> ok, no, i didn't ^_^
21:47:58 <rbergeron> Okay: rule number one of rbergeron is, I defer to everyone else's expertise.
21:48:12 <rbergeron> I feel like tracking of things is a good idea. What the best way to do that is - I let you good folks decide.
21:48:23 <rbergeron> and if it's not a good idea, i'm happy with that tool.
21:48:26 <rbergeron> err, too.
21:48:51 <gholms> How do bug CCs/assignments work for other SIGs?
21:49:37 <rbergeron> I don't want us to have things to do on 13 different feature pages, is my concern - i'd like it to be centralized.
21:50:37 <brianlamere> btw, for slicehost (since someone mentioned it) it's a problem that's already mostly solved; pyactiveresource (or the ruby version, activeresource) is a really simple api for slicehost.  There's not many things you can really do anyway, it's not as involved as ec2
21:50:58 <rbergeron> otherwise - we start losing things, I think. also, newcomers can't easily identify stuff they could be doing, and I'd like to have us be able to pick up other awesome people and have them find things to do.
21:51:05 * rbergeron puts on her positive patty hat ;)
21:51:10 <brianlamere> a simple script does most of the things anyone would want via a package though, is the point
21:51:14 <pbrobinson> for Fedora mini I use mostly BZ with trackers and dependencies. Not saying its the best method but as that where package review go and bugs are reported its a single spot. Then wiki to document
21:51:42 <gholms> What's the bug called?
21:52:06 * pbrobinson goes to look
21:52:14 <brianlamere> (spoken as someone moving from slicehost to ec2 currently)
21:53:15 <pbrobinson> this is the over all Fedora Mini tracker https://bugzilla.redhat.com/show_bug.cgi?id=462851
21:53:49 <pbrobinson> if you look at the dep tree you can see all the reviews etc
21:54:16 <rbergeron> So - how does this handle things that .... aren't necessarily bugs, per se
21:54:23 <rbergeron> or dependencies or related to the code side
21:54:37 * rbergeron hasn't really used bugzilla for tracking non-code types of things
21:54:52 <pbrobinson> its not great. Most of the rest is documented on the wiki.
21:54:58 <rbergeron> Even simple things like - I need to assign ian to go build wiki page
21:55:05 <pbrobinson> dependencies are links
21:55:55 <pbrobinson> the web team use it for non code related things, it might be good to ping them for that stuff (sorry for not giving more details)
21:56:36 <gholms> Interested in shooting them an email and revisiting this next week?
21:56:38 <rbergeron> Okay. So - since we're approaching the hour
21:56:39 <rbergeron> yes
21:56:42 <rbergeron> exactly, gholms
21:56:58 <rbergeron> I'm thinking ... even taking this discussion to mailng list itself in the interim
21:57:03 <rbergeron> and asking what other people's thoughts are.
21:57:03 <pbrobinson> its better for tracking and dealing with packaging and assoicated bits. EG changes to a package already in Fedora that say a package review depends on.
21:57:47 <rbergeron> I'm happy to shoot a mail to cloud list asking for feedback - if someoen wants to ask websites about how they do things and bring that feedback over, that'd be great as well.
21:58:27 * rbergeron wonders if anyone wants to raise their hand on talking to web team
21:58:55 <rbergeron> okay, i'll shoot out both those email ;)
21:59:24 <rbergeron> #action rbergeron to mail cloud list on feedback re: tracking of things, and talk to web team and find out what they're doing since they use bz for non-code type tracking.
21:59:28 <rbergeron> kosher? yes?
21:59:35 <gholms> worksforme
21:59:37 <rbergeron> #topic Anything else
21:59:52 <rbergeron> jforbes: sorry to have taken all the time up.
21:59:53 * gholms will look into pushing euca2ools to el5
21:59:53 <smooge> bacon does not make a good coffee replacement
21:59:58 <rbergeron> do you have anything pressing going on?
22:00:04 <gholms> (Not that anyone even bothers to use it...)
22:00:23 <smooge> gholms, what people aren't using eucatools?
22:00:27 <rbergeron> gholms: if you build it, they will come? :)
22:00:35 <smooge> I have been looking at how/why I would
22:00:37 <smooge> then do so
22:00:44 <jforbes> rbergeron: heh, no big deal, busy this afternoon anyway, nice to not have such active participation today
22:00:51 * rbergeron grins
22:00:52 * smooge needs to get a better home server that actually supports VT
22:01:24 <rbergeron> #info gholms looking into pushing euca2ools to el5
22:01:30 <rbergeron> anything else from anyone?
22:01:33 <gholms> I have a small yum repo with a prerelease that might be useful for building Fedora images.  That would really help get things tested.
22:01:53 <rbergeron> gholms: want to keep us updated on list with your progress?
22:02:17 <gholms> #link http://www.physics.umn.edu/~holms/repo/custom/13/
22:02:27 <gholms> Sure, if anything new happens.
22:02:36 <rbergeron> cool. thanks!
22:02:45 * ianweller goes to subscribe to the list
22:02:54 <gholms> python-boto could use a co-maintainer; its owner doesn't really know much about it.
22:02:56 <rbergeron> ianweller: METAL
22:03:27 <smooge> gholms, do you think you could run a 'class' on eucatools
22:03:30 <rbergeron> #info python-boto could use a co-maintainer - please step up :)
22:04:04 <gholms> smooge: I could do that.  It's designed to be a drop-in replacement for ec2-*-tools, with the same syntax and everything.
22:04:05 <rbergeron> smooge: like irc classroom session?
22:04:21 <smooge> gholms, I do not know how to use those either :)
22:04:28 <gholms> Ooh, all right.
22:05:09 <gholms> When it comes time to test Fedora images on EC2 that would be the ideal moment to do so.
22:05:10 <smooge> What I know about EC. .. they send me email saying I have an account and I havnet used it. And they put 3 calls to my CC and I got a phone from the bank to make sure it was legit
22:05:33 <rbergeron> do we want to discuss that a bit more maybe at the next meeting? what we'd want to do for a irc classroom there?
22:05:39 <smooge> rbergeron, yeah.. ideally I would love to get to know it enough to have our show-person mizmo make a video
22:06:00 <rbergeron> ohhhhhh.
22:06:13 <gholms> When do we hope to test EC2 stuff?  I would be happy to try to walk people through using euca2ools and friends then.
22:06:29 <jforbes> gholms: after Tuesday
22:06:31 <rbergeron> jforbes - thoughts on that?
22:06:32 <rbergeron> ah
22:06:35 <rbergeron> okay then!
22:06:41 <gholms> I presume you will send mail to the list?
22:07:05 <jforbes> I will
22:07:07 <rbergeron> #action rbergeron to add euca2ools irc classroom agenda item to next week's meeting
22:07:08 <gholms> Awesome.  Thanks!
22:07:29 <rbergeron> #action jforbes going to send mail to list on testing ec2 stuff after tuesday.
22:07:36 <rbergeron> Anything else?
22:07:41 <smooge> not from me
22:07:49 * rbergeron looks around for hands, feet, lighters....
22:07:57 * gholms runs out of tea
22:07:58 <rbergeron> awesome.
22:07:59 <jforbes> nothing here
22:08:01 <rbergeron> thanks for coming everyone
22:08:12 <rbergeron> and thanks to the openstack guys again for coming
22:08:24 <rbergeron> community stuff is awesomez and etc ;)
22:08:31 * rbergeron will send out meeting notes shortly
22:08:35 <rbergeron> #endmeeting