18:01:07 <stickster> #startmeeting Fedora Insight
18:01:07 <zodbot> Meeting started Thu Jul 22 18:01:07 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:11 <stickster> #meetingname Fedora Insight
18:01:11 <zodbot> The meeting name has been set to 'fedora_insight'
18:01:22 <stickster> #chair rbergeron gwerra smooge_afk
18:01:22 <zodbot> Current chairs: gwerra rbergeron smooge_afk stickster
18:01:26 * rbergeron is stepping away for like 3 minutes
18:01:29 <stickster> #chair Sparks
18:01:29 <zodbot> Current chairs: Sparks gwerra rbergeron smooge_afk stickster
18:01:34 <rbergeron> yay chairs
18:01:36 <stickster> #topic Roll call!
18:01:37 * stickster 
18:02:42 <stickster> :-)  *chirp chirp*
18:03:24 * mchua is lurking
18:03:37 <stickster> I know smooge_afk is... afk :-)
18:04:03 <stickster> rbergeron will rejoin us shortly, maybe Sparks is around somewhere (he said he wanted to make it if possible).
18:04:14 <stickster> I'll hold the gavel until :10
18:04:42 <stickster> #info Meeting on hold until :10 (UTC 1810) to allow people to get to their chairs ;-)
18:05:46 * Sparks is here
18:05:54 <Sparks> stickster: Sorry for the delay
18:06:20 <stickster> No problem sir
18:06:30 <stickster> Sparks: Can you hang for a few while we wait for rbergeron to rejoin us?
18:06:37 * stickster will restart at :10
18:07:01 * rbergeron is here
18:07:02 <Sparks> yes
18:07:28 <rbergeron> :D
18:08:05 <stickster> Cool, shall we proceed?
18:08:13 * stickster suspects gwerra will read later
18:08:58 <stickster> #link https://fedoraproject.org/wiki/Insight#Meeting_agenda -- Agenda
18:09:34 <stickster> #topic Review action items (https://fedoraproject.org/wiki/Insight#Meeting_agenda)
18:09:51 <stickster> I can report on my action item :-)
18:10:02 <stickster> #info  1.  stickster to work more on plugin this weekend and hopefully have functioning plugin next week
18:10:13 <stickster> #info STATUS: Working 0.1 has been achieved!
18:10:51 <rbergeron> wow :)
18:10:54 <rbergeron> yay
18:11:15 <stickster> So this means that, once the AuthFAS plugin is configured with a proper URL, the system will authenticate using a FAS instance.
18:11:21 <stickster> *furthermore*... ;-)
18:11:48 <stickster> It also features an addition to the "user role" screen so that any Drupal role can be mapped to any FAS group
18:12:04 <stickster> So if user "pfrields" is a member of the "cmsadmin" group in FAS...
18:12:36 <stickster> ...and the Drupal instance maps "cmsadmin" to a role called (for example) "big-kahuna,"
18:12:59 <stickster> ...then when "pfrields" next logs in, he will be automatically placed in the "big-kahuna" role.
18:13:06 <rbergeron> wow.
18:13:09 <rbergeron> nice.
18:13:24 <stickster> If "pfrields" has been removed from the "cmsadmin" group in FAS for some reason, the next time he logs in, he'll be *removed* from the "big-kahuna" role.
18:13:33 * rbergeron notes that the fedora booth is on the same corner as the durpal booth at oscon. :)
18:13:35 <Sparks> that's awesome
18:13:41 <rbergeron> yes, very awesome.
18:14:01 <stickster> It functions very much like the AuthFAS plugin in Zikula although I wrote this one on my own just to see if I could manage it using Drupal's documentation.
18:14:06 <stickster> Turned out to not be so hard.
18:14:25 <stickster> All right, enough about my action item then.
18:14:30 <stickster> More about this later in the agenda
18:15:02 <stickster> Shall we move on?
18:15:45 <rbergeron> yes.
18:15:46 <stickster> #topic Test platform changes (https://fedoraproject.org/wiki/Insight#Meeting_agenda)
18:16:09 <stickster> #info We have working instances of Zikula, Drupal 5.22, and Drupal 6.17 on publictest6
18:16:26 <stickster> #info The AuthFAS plugin is written for Drupal 6.x and does not work on Drupal 5.x.
18:16:46 <Sparks> Do we want to/need to set it up with multiple app servers?
18:16:57 <stickster> Sparks: Not really at this point
18:17:06 <stickster> Sparks: But knowing we *can* -- that's important
18:17:16 <stickster> Sparks: What were you able to find out?
18:17:16 <Sparks> ok
18:17:28 <Sparks> about the multiple app servers?
18:17:38 <stickster> Sparks: Yes
18:17:47 <Sparks> It's actually very easy and logical...
18:17:54 <stickster> I think I found your page
18:18:04 <Sparks> Every installation requires you to point to a database...
18:18:05 <stickster> #link http://fedoraproject.org/wiki/How_to_install_Drupal_in_a_cluster (Instructions for what it says) :-)
18:18:21 <Sparks> so all you have to do is point it to the same database
18:18:32 <rbergeron> hmm
18:18:48 <Sparks> and all Drupal instances will have the exact same information instantaneously.
18:18:59 <rbergeron> :)
18:19:18 <stickster> Sparks: So no contention in the case that someone saves the same content node at the same time?
18:19:30 <stickster> Is that managed by the MySQL server transparently?
18:19:30 <Sparks> Well....
18:20:00 <Sparks> the same could be said if you were using a single instance of Drupal
18:20:15 <stickster> Ah, good point
18:20:23 <Sparks> Not sure how MySQL would handle that but it would be highly unlikely that two changes would come in a the exact same time
18:20:28 <Sparks> down to the millisecond.
18:20:32 <stickster> So yeah, the app + MySQL server is expected to just deal with it.
18:20:54 <Sparks> yeah
18:20:57 * stickster thinks it's pretty unlikely our application would hit that particular problem.
18:21:06 <Sparks> The only thing you are fixing by the multiple apps...
18:21:34 <Sparks> is the ability to host the data out to lots of people
18:21:41 <stickster> *nod
18:22:08 <stickster> #info The drupal6 RPM installed on the pt6 server is from here: https://bugzilla.redhat.com/show_bug.cgi?id=569833
18:22:31 <stickster> This package is under review, I note that ke4qqq seems to be the person who took the assignment, but the review is stalled.
18:23:06 <ke4qqq> what's stalled about it?
18:23:16 <ke4qqq> aside from me?
18:23:23 <stickster> Oh, there's a new comment from you!
18:23:29 * stickster hadn't seen it since last night
18:23:29 <ke4qqq> and Jon
18:23:45 <ke4qqq> yeah we are just getting what I think is one final wrinkle figured out
18:24:15 <stickster> ke4qqq: Is that the wrinkle with /usr/share/drupal6/.htaccess ?
18:24:23 <ke4qqq> yes
18:24:30 * stickster notes that file almost certainly needs to be edited in most instances.
18:24:39 <ke4qqq> sounds like Jon is going to un config(noreplace) it - and that will be solved
18:24:39 <smooge> sorry
18:24:41 <smooge> here now
18:25:06 <stickster> ke4qqq: So the README.fedora should probably say to copy that into /etc/httpd/conf.d/drupal6-somethingorother.conf
18:25:08 <ke4qqq> might need to be symlinked in then - package guidelines say no config files under /usr
18:25:29 <stickster> There's already a regular ol' /etc/httpd/conf.d/drupal6.conf file, so it can't be called that
18:25:34 <ke4qqq> I made the argument earlier in the review to make it a .conf
18:25:45 <stickster> Maybe /etc/httpd/conf.d/drupal6-sites.conf
18:26:16 <ke4qqq> it could be added to the existing .conf I think though - which is what I advocated - but I wasn't doing the work and he was, and will have to continue doing it.
18:26:32 * stickster thinks doing a bunch of munging isn't fun with conf-files
18:26:35 * stickster will pitch in on the bug
18:26:45 <ke4qqq> yeah it isn't
18:26:50 <stickster> #action stickster to add opinion to the bug, with realization that packager is doing the work :-)
18:26:55 * ke4qqq realizes Jon is trying to stay close to upstream
18:26:57 <stickster> Yup
18:27:09 <stickster> That's why I like the symlink idea
18:27:31 <ke4qqq> yeah symlink is what webapps typically do to get configs under /usr
18:27:48 <ke4qqq> or at least what I commonly see
18:27:53 <stickster> Right
18:27:59 * stickster moves on then, we'll solve this in the bug
18:28:11 <stickster> This does bring up a question regarding instances
18:28:20 <stickster> I know Sparks has installed one since he wrote up those cluster instructions
18:28:35 <Sparks> stickster: yep, and it's super easy
18:28:38 <stickster> Has anyone else started playing around with their own test on a F13 box (which already has 6.x) ?
18:28:55 * Sparks notes his tests were on CentOS 5
18:29:01 <stickster> #link http://fedoraproject.org/wiki/How_to_install_Drupal (Standard instructions for a Fedora system)
18:29:21 <stickster> rbergeron: How 'bout you?
18:29:47 <rbergeron> i have not had the opportunity yet. ;)
18:30:21 <rbergeron> i will do so this afternoon, though
18:30:24 <stickster> rbergeron: Just FYI -- not to be pushy! :-) -- those instructions take a grand total of about 10 minutes on a Fedora 13 box
18:30:27 * rbergeron has some fun booth time ;)
18:30:38 * rbergeron grins
18:30:46 <stickster> rbergeron: I can even walk you through it later if you catch me online.
18:30:49 <stickster> 'nuff said about that.
18:31:03 <rbergeron> awesome.
18:31:37 * rbergeron has installed previous versions of da drupalz
18:31:38 <stickster> #info People who want to participate in getting something rolled out are encouraged to put up their own little test instance (a laptop works fine). It really helps understand the system.
18:31:53 <stickster> OK, shall we move on?
18:32:26 <rbergeron> yes plz :)
18:32:27 <stickster> #topic AuthFAS status (https://fedoraproject.org/wiki/Insight#Meeting_agenda)
18:32:41 * stickster only needs one +1 and he springs
18:33:00 <stickster> #info As noted already, 0.1 seems to work with expected functionality thus far
18:33:10 <Southern_Gentlem> +1 has been trying to play with drupal since SELF
18:33:51 <stickster> #info stickster welcomes people to install AuthFAS plugin on their own installation but it's important to note that unless you do some extra stuff, *entering your credentials in your own Drupal instance is not automatically secure*.
18:34:18 <Sparks> stickster: Have you made notes on how to configure it to be secure?
18:34:44 <stickster> Sparks: Actually, the connection from AuthFAS plugin --> FAS is https
18:34:54 <Sparks> There you go
18:35:00 <stickster> But on your own system you may want to use https also :-)
18:35:43 <stickster> It should work out of the box, although you're accepting an untrusted credential from your laptop (or wherever your server is).
18:35:47 <stickster> It's up to you to verify it.
18:36:06 <stickster> #info Verify your server, but you can use https:// to access it.
18:36:20 <stickster> Here's the next important step
18:36:28 <stickster> in having a working test instance that everyone can use.
18:36:37 <stickster> Maybe smooge will know something about this :-)
18:36:46 <stickster> #info publictest3 "FakeFAS" instance appears to be down
18:37:11 <smooge> I am not sure what is going on with this yet
18:37:15 <stickster> The "fas" RPM doesn't appear to be installed any longer, but there is a "fasbackup" pgsql database on the box
18:37:31 <stickster> smooge: Is it something you'd feel comfortable with me trying to look at/fix?
18:37:36 <smooge> I have to see who/what been playing around with
18:37:39 * stickster has sysadmin-test but tries not to step on any toes
18:37:53 <smooge> well I need to learn how to do this so if you want to work together on it.. let me know
18:38:03 <stickster> smooge: I'd love to do that!
18:38:17 * stickster will find smooge in #fedora-mktg later
18:38:32 <stickster> #action stickster smooge Figure out what happened to FakeFAS and prop it up again
18:38:57 <smooge> okie dokie
18:39:00 * rbergeron has to wave, need to go tend to conference-y things for a bit.
18:39:05 <smooge> I think we will be moving it to another server
18:39:07 <stickster> rbergeron: Sparks: gwerra: Important note, until we get that working, there's no way for you to login to the pt6 drupal6 instance
18:39:19 <rbergeron> noetd.
18:39:20 <smooge> rbergeron, eating doughnuts does not count as coferencey things
18:39:23 <rbergeron> noted, also.
18:39:30 <stickster> rbergeron: Sparks: gwerra: But we can add accounts manually for you for now if/when you need
18:39:31 <rbergeron> smooge: :)
18:39:34 <smooge> especially when you don't share
18:39:54 <stickster> Any questions on this stuff?
18:39:56 <smooge> I heard you bit off a man's hand yesterday because he got too close to a doughnut
18:39:58 <stickster> :-D
18:40:06 <stickster> smooge: That's collateral damage
18:40:33 <smooge> so if marketing pays for collateral does it come out of their budget?
18:41:02 <stickster> :-)
18:41:07 <stickster> OK, moving on :-D
18:41:18 <stickster> #topic Project plan (https://fedoraproject.org/wiki/Insight#Meeting_agenda)
18:41:29 <stickster> Here's where I wanted to get to, and at a good time too :-)
18:41:54 <stickster> Taking on Insight is something I want to try to do as my "20% job" in my new role at Red Hat
18:42:22 <stickster> Right now, it's more like "2% Job" while I help Jared get comfortable in his role, but I'll be able to spend the equivalent of a day a week on this
18:42:32 * Sparks wishes he could make it his 20% job
18:42:33 <stickster> But even so, if this project is to succeed it can't depend on me
18:43:23 <Sparks> I'm willing to help out as much as I can
18:43:24 <stickster> If I'm eaten by raptors, I want other contributors able to handle running the system, including putting content on it, tweaking things to make it work better, and planning new uses for it.
18:43:50 <stickster> I'm very sensitive to the fact that everyone sitting in this meeting has already got other involvements in Fedora :-)
18:44:42 <stickster> So I've started reaching out to some Drupal folks to make some contacts -- we have found a few people who camp in #fedora and #drupal whom I'm going to reach out to
18:45:04 <stickster> Because my suspicion is they care about both, and might be keen to contribute to Fedora if it's something they know well, like Drupal
18:45:30 * stickster does not want to use an engagement model of "Come help us set this up, independent Drupal person(s), and then inherit a bunch of work forevermore."
18:45:39 <stickster> That works great for paid consultants :-)
18:46:07 <stickster> And as Sparks knows, we only have so many 200% raises to give ;-)
18:46:18 <Sparks> heh
18:47:39 <stickster> So what I'm going to work on first is a project plan that will draw on what we did already for our first Insight attempt, and see if I can flesh that out a bit more to help us craft a schedule, make technical choices, etc.
18:48:22 <stickster> I think there might be other stakeholders interested, like mizmo / Design, etc.
18:48:23 <Sparks> stickster: Is there a list of items that need to be completed?
18:48:37 <stickster> Sparks: That comes as part of the plan, I think :-)
18:48:53 <stickster> http://en.wikipedia.org/wiki/Project_plan
18:49:27 * stickster is not going to do some long, drawn-out ISO-xxxx thing, but it's very difficult to grok our plan from the current Insight page.
18:49:48 <stickster> #action stickster to work on Insight page and a coherent project plan
18:51:15 * stickster might even consult his personal guru poelcat to get an idea of how to do this more effectively in this kind of "start/stop" situation we've found ourselves in.
18:51:25 * stickster is out of topics, so...
18:51:38 <stickster> #topic AOB -- all other business (https://fedoraproject.org/wiki/Insight#Meeting_agenda)
18:51:38 <smooge> open floor
18:51:44 <stickster> Go for it!
18:52:18 <smooge> got nothing at the moment.. stuck too much in systemd burning plane thing
18:52:33 <stickster> smooge: Is the new dev / stage / production model that Infrastructure's talking about going to affect us right away, or is it OK to go ahead and just stick with using publictest6 for now?
18:53:05 <smooge> I would say its not going to affect anything until insight is ready
18:53:13 <stickster> OK
18:53:24 <smooge> then instead of uisng a publictest we would do all new development on a .dev box
18:53:32 <stickster> #info New dev / stage / production model in Infrastructure is OK to not worry about for now
18:55:09 <smooge> ok I have a question.. is the need for a FakeFAS permanent need or a temporary one? The reason is where I put it
18:55:43 <stickster> smooge: It can go anywhere on a pt I think, pt3 is where it was before
18:56:11 <stickster> It's needed as long as Infrastructure people tell me that it's not a good idea for us to use real FAS from publictest systems :-)
18:56:45 <stickster> smooge: Also... since we need to often manipulate groups and group membership to do testing, it helps if we're not twiddling RealFAS groups
18:56:52 <smooge> np I will talk with mmcgrath about it. I sense fakefas01.fedoraproject.org coming along
18:57:01 <smooge> but it could be heartburn from lunch
18:57:02 * stickster did that this past weekend and felt bad about it, but did warn the owners of 'cmsadmin'
18:57:10 <stickster> smooge: :-)
18:57:17 <stickster> #action smooge Will talk to mmcgrath about fakefas instance
18:58:04 <stickster> smooge: I'm OK either way, we could even make some temporary groups in the real FAS if someone says that's an OK way to go (we can switch the groups later in Drupal without disturbing FAS).
18:58:33 * stickster just wants to not be a PITA to anyone
18:58:41 <stickster> TOO LATE! ;-)
18:59:15 <stickster> OK, anything else today?
18:59:34 <smooge> not me
18:59:36 * stickster will end on the hour, there's someone due in here after us
18:59:45 <stickster> Thanks for coming, everyone!
18:59:54 <Sparks> Thank you!
19:00:13 <stickster> #info Please continue to use 'logistics' list to discuss Insight!
19:00:17 <stickster> #endmeeting