21:00:05 <rbergeron> #startmeeting Cloud SIG
21:00:05 <zodbot> Meeting started Thu Jul 29 21:00:05 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:08 <onekopaka_laptop> I wish could attend this next meeting
21:00:12 <rbergeron> #meetingname Cloud SIG
21:00:12 <zodbot> The meeting name has been set to 'cloud_sig'
21:00:21 <jforbes> Helo :)
21:00:23 <rbergeron> #topic Roll Call
21:00:25 <onekopaka_laptop> but I gotta pick up pieces of a tree branch that fell
21:00:26 <jforbes> hello even :)
21:00:33 <mdomsch> EHLO
21:00:35 <CodeBlock> 
21:00:35 * rbergeron never can remember if she does roll call or not, but whatever :)
21:00:39 * gholms sips his tea
21:00:45 <rbergeron> heya justin. :)
21:00:59 * rbergeron peeks around for others
21:01:16 <onekopaka_laptop> mdomsch: if that didn't spew as much output as it does
21:01:22 * tremble ducks for cover
21:01:44 <rbergeron> #topic Agenda
21:01:46 <onekopaka_laptop> oh by the way, I'm actually away, freenode just doesn't like me adding _away
21:01:50 <smooge> EHLO
21:01:59 <rbergeron> #link http://fedoraproject.org/wiki/Cloud_SIG#Upcoming_meeting_agenda
21:02:08 <rbergeron> woo, look at all the awesome people coming.
21:02:21 <rbergeron> #topic EC2 feature status
21:02:28 <rbergeron> #link http://fedoraproject.org/wiki/Features/EC2
21:02:32 <rbergeron> jforbes: how goes it?
21:03:19 * gholms notes that that feature was on the chopping block email that went out yesterday
21:03:21 <jforbes> rbergeron: It goes, went over the test images from Marek with some folks from Amazon.  They have a list of recommendations for us to change
21:03:39 <jforbes> heh, hard to update status on a feature that isn't really a code feature, it is simply a different release spin
21:03:47 * rbergeron nods
21:03:56 <rbergeron> Are there any changes that people can help out with?
21:04:12 <gholms> For that matter, can we see the list?  :)
21:04:20 <rbergeron> In case of raptors... ? :)
21:04:21 <jforbes> From a feature page standpoint, it will pretty much go from current stat to maybe 75% when the beta is out
21:04:52 <jforbes> gholms: yes, I am getting an email together to the list, since these are things that will apply to people spinning their own images too... Best practices type stuff
21:04:59 <gholms> Awesome
21:05:13 <rbergeron> sweet.
21:05:27 <rbergeron> yes, let's keep it off the chopping block :)
21:06:27 <rbergeron> Anything else here? I think people want to help you out if they can, and I'm all about giving out cookies.
21:06:30 * rbergeron grins
21:06:38 <gholms> Ooh, before I forget:
21:07:20 <rbergeron> yes?
21:07:22 <gholms> FESCo doesn't like the idea of having to use ec2-api-tools as part of the release process because it isn't in Fedora.
21:07:35 * jsmith tends to agree w/ FESCo on that
21:07:39 <rbergeron> oh. Soooo... we should work on packaging that.
21:07:47 <jforbes> it cannot be packaged
21:07:48 <gholms> We can't.  It's closed source.
21:07:54 <rbergeron> oh.
21:07:57 <gholms> (It's in rpmfusion-nonfree)
21:08:03 <jsmith> And we can't do the same with euca2ools?
21:08:11 * rbergeron tries to not show her lack of knowledge here :)
21:08:11 <gholms> Not with 1.2 that's there now.
21:08:17 <jforbes> We can when euca2ools is updated
21:08:20 <onekopaka_laptop> hello
21:08:29 <gholms> Prereleases *should* be able to, but we need a new python-boto build for that.
21:08:31 <jforbes> there are other ways around it too...
21:08:33 <gholms> brianlamere: Ping
21:08:35 <rbergeron> is anyone working on that currently?
21:08:46 <rbergeron> jforbes: show us the ways :)
21:08:57 <jsmith> We can update python-boto in rawhide, and then use that perhaps?
21:09:12 <gholms> brianlamere uses boto a lot and would be willing to take up (co-)maintainership of that package.
21:09:16 <rbergeron> #info jforbes went over test images with marek with folks from amazon, there is a list of change recommendations
21:09:22 <brianlamere> ec2-api-tools doesn't do a lot that boto tools can't do already
21:09:31 <rbergeron> #action jforbes to send email to list about changes / recommendations
21:09:35 <brianlamere> in fact, a lot of the ec2-api-tools don't do things very well ;)
21:09:39 * rbergeron catching up on some stuff above
21:09:44 <jforbes> rbergeron: image is alreeady generated and manifest created, we could write simply python ap, or grab any existing ones for the upload/register bit
21:09:47 <jsmith> brianlamere: That was my general impression of the ec2-api-tools
21:09:57 <gholms> Boto's current maintainer doesn't really know much about it; he just packages it because it's a dependency of something he does use.
21:10:01 <brianlamere> so, we (someone?) could easily re-write anything that is needed using completely open-source tools
21:10:38 <gholms> rsc: You around?
21:10:41 <jforbes> Yes, the api is well documented
21:10:45 <brianlamere> aye - gholms gave me some tips on trying to become a co-maintainer of the boto package; I need to work through the newbie initialization phase first
21:10:46 <rsc> gholms: yes.
21:11:17 <gholms> rsc: brianlamere uses python-boto a lot for $dayjob.  Would you be all right with having a co-maintainer?
21:11:50 <rsc> gholms: that sounds interesting
21:12:07 <gholms> :D
21:12:16 <rsc> brianlamere: it would be great if you would be in touch with upstream - because they're unresponsive to me.
21:12:17 <brianlamere> we're a python webdev shop that is moving things to amazon currently - have a few clusters there already
21:12:52 <brianlamere> so yeah, most the stuff I write/use has "import boto" up near the top :P
21:13:47 <rsc> brianlamere: drop me an e-mail to robert@fp.o, please :)
21:13:49 <brianlamere> rsc: I can try to catch them, certainly - we know several "industry" peeps here, maybe I know someone who knows someone who knows the boto person, I'll ask around
21:14:14 <brianlamere> rsc:  ok, will do
21:14:27 <rbergeron> okay. soooo - aside from wrangling a boto package comaintainer, which we just did, woo - what is the rest of course of action here?
21:14:46 <rbergeron> are we recommending doing something from scratch, orrrrrrrrr... ?
21:15:05 <rbergeron> euca2ools fixing?
21:15:09 <rbergeron> etc?
21:15:26 <gholms> I can build a recent enough euca2ools as soon as a recent enough python-boto lands.
21:16:16 <brianlamere> rbergeron: well if there are things that require ec2-api-tools to function, and that can't be used since it's closed-source, those tools could be re-written in boto.  I think that's how boto was brought up
21:16:30 <gholms> #info FESCo dislikes using closed-source ec2-api-tools for building Fedora images
21:16:37 <rbergeron> thanks, gholms
21:16:56 <gholms> #action brianlamere and rsc to communicate about co-maintaining, packaging recent python-boto
21:17:00 <rbergeron> so - we can do it in python-boto, or we need python-boto to make euca2ools build with a more recent version?
21:17:02 <brianlamere> my stuff is all so spotty though, I've never attempted to replicate the look and feel of ec2-api-tools, I write just what I need.  Anything that is needed could be written, though
21:17:03 <rbergeron> #chair gholms
21:17:03 <zodbot> Current chairs: gholms rbergeron
21:17:08 <gholms> Hehe
21:17:09 <rbergeron> #chair jforbes
21:17:09 <zodbot> Current chairs: gholms jforbes rbergeron
21:17:25 * rbergeron isn't sure if you can action without being a chair - might scroll up and hit the enter button again to be sure :)
21:17:32 * ianweller is here
21:17:43 <gholms> (I'm fairly certain it works.)
21:17:45 <rbergeron> oh thank goodness :)
21:17:53 * rbergeron hugs ianweller
21:17:57 <gholms> If not we'll find out afterwards.
21:18:00 <rbergeron> indeed.
21:18:33 <rbergeron> so - it looks like when we get a new python-boto built, we can try a more recent build of euca2ools - and if that doesn't work, we can do something in boto itself?
21:18:49 * rbergeron hopes she isn't slowing everyone down with her questioning :)
21:19:09 <gholms> #action After recent python-boto lands in rawhide gholms will build sufficiently new euca2ools to create Fedora EC2 images
21:19:24 <rbergeron> awesome.
21:19:35 <rbergeron> Does that cover all EC2-related items?
21:20:01 * rbergeron waits a minute before moving onwards
21:20:04 <gholms> Once we have a new enough build to test we can find out if boto/euca2ools are missing some bit of functionality we need.
21:20:22 <rbergeron> and if not, we ... move to doing something from scratch.
21:20:46 <gholms> Hopefully that would mean supplying patches to one of those projects.  :)
21:20:57 <rbergeron> okeedokee. :)
21:21:05 * gholms leaves that in the maintainers' capable hands
21:21:24 <rbergeron> awesome. okay!
21:21:43 <rbergeron> #topic Who wants to drive the meeting bus next week? rbergeron is on vay-cay-shun
21:21:50 <rbergeron> Any takers? jforbes? gholms?
21:21:59 <jforbes> I will
21:22:16 <gholms> Next item!  :P
21:22:17 <rbergeron> #action jforbes to run the meeting next week ;)
21:22:34 <rbergeron> #topic Openstack packaging
21:22:51 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=617632
21:23:13 <rbergeron> So - I think this is more or less packaged, and ianweller is going to review it soonish. This is the swift package, not nova, which is the other half.
21:23:24 <gholms> He asked me to review it, and I totally dropped the ball on doing that.
21:23:30 <gholms> Thanks for picking it up, ianweller.
21:23:30 <rbergeron> Anyone have anything to add here? i know silas_sewell isn't here to comment, and he's been working on it.
21:23:47 <ianweller> gholms: sorry if i stole it :(
21:23:55 * rbergeron is sure that ianweller is still willing to share that responsibility if you still want to do it :)
21:24:00 <rackerhacker> i'm getting my feet wet on fedora packaging, so i can probably assist at some point
21:24:00 <gholms> Hehe
21:24:04 <rackerhacker> but i'm too green right now ;)
21:24:09 <ianweller> i'm very good at sharing responsibility, because it means i do less work ;)
21:24:26 <rbergeron> ianweller: or because there is a pile of other stuff we'll hand to you ;)
21:25:01 <gholms> I started doing the license audit and fell asleep.  :(
21:25:11 * rbergeron notes that rackerhacker is one of the openstack folks and is a fedora lover, and we're glad to have him here and he's working on packaging glusterfs at the moment :)
21:25:24 <gholms> But I have a formal review of an older version of the srpm about halfway done.
21:25:26 <rbergeron> maybe not THIS moment, but in general. ;) amongst his other things he's doing.
21:26:01 <rbergeron> okay - sooo - ianweller, gholms, i'll let you guys work out who's doing what there. :)
21:26:20 <gholms> #action ianweller and/or gholms to work on reviewing openstack-swift
21:26:23 <rbergeron> #action ianweller and gholms reviewing openstack swift package
21:26:37 * gholms <— faster  ;)
21:26:40 <gholms> #undo
21:26:40 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1f44bd10>
21:26:52 <gholms> Hmm, somebody didn't define __str__...
21:27:04 <rbergeron> And I suppose nova will... come along, has a number of dependencies we'd have to package in addition to the package itself.
21:27:40 <rbergeron> #info if anyone is interested in starting on openstack-nova or its dependencies, drop a note to the mailing list :)
21:28:02 <rbergeron> #link http://nova.openstack.org/getting.started.html#dependencies
21:28:06 <creiht> Heads up for those packaging swift, We are currently testing the latest sqlite with WAL support which should improve performance quite a bit
21:28:25 <gholms> "We" being who?
21:28:27 <creiht> So it might be useful to have updated packages for that as well
21:28:39 * creiht introduces himself as one of the swift devs at rackspace
21:28:44 <gholms> Oh, cool.
21:28:46 <rbergeron> #info Heads up for those packaging swift, We are currently testing the latest sqlite with WAL support which should improve performance quite a bit. (we = openstack)
21:29:16 <rbergeron> creight: thanks for the info. glad you're here :)
21:29:32 <gholms> creiht: Does one get that for free when compiling recent enough sqlite, or do we need to file a bug against it to get it added to F14?
21:30:11 <creiht> WAL mode was added in 3.7.0
21:30:39 <onekopaka_laptop> .whoowns sqlite
21:30:39 <zodbot> onekopaka_laptop: pmatilai (itamarjp in Fedora EPEL)
21:31:15 <gholms> Rawhide currently has 2.6.23.1.
21:31:31 <rbergeron> yow
21:31:35 <creiht> ouch
21:31:38 <creiht> 2.6 or 3.6?
21:31:46 <gholms> Err, 3.6.  ;)
21:31:55 <rbergeron> oh, that's not quite as horrible sounding.
21:31:56 <rbergeron> :D
21:32:05 <creiht> hehe... I think that is the latest version before 3.7
21:32:31 <onekopaka_laptop> so if you want that updated, talk to the people mentioned by zodbot
21:32:39 <onekopaka_laptop> .fas pmatilai
21:32:40 <zodbot> onekopaka_laptop: pmatilai 'Panu Matilainen' <pmatilai@redhat.com>
21:32:47 <onekopaka_laptop> .fas itamarjp
21:32:47 <zodbot> onekopaka_laptop: itamarjp 'Itamar Reis Peixoto' <itamar@ispbrasil.com.br>
21:33:35 <gholms> Hang on a sec; I'll see if there's already a bug for it.
21:33:44 <creiht> We don't use Redhat, so I'm just mentioning it so that those who are planning on packaging have a heads up
21:33:58 <rbergeron> creiht: much appreciated :)
21:34:21 <gholms> #link https://bugzilla.redhat.com/show_bug.cgi?id=617145
21:34:37 <creiht> And we appreciate those packaging for Redhat as well :)
21:35:07 <onekopaka_laptop> gholms: that seems like it's rather untouched
21:35:31 <gholms> #info openstack-swift benefits greatly from new features in sqlite 3.7
21:36:20 <onekopaka_laptop> so either email pmatilai or check out his spec file (from git now!)
21:36:26 <creiht> gholms: Well that isn't for sure yet, but we are pretty certain it will be
21:36:33 <creiht> We are in the process of verifying this week
21:36:44 <onekopaka_laptop> at least git is where things should be ;-)
21:37:48 <gholms> Anything else on openstack?
21:37:52 <rbergeron> creiht: will that info go out on the swift list?
21:38:05 <creiht> rbergeron: I can make sure it does
21:38:10 <rbergeron> awesome, thank you.
21:38:17 * rackerhacker has an angry, screaming baby in his lap, so he must depart
21:38:35 <gholms> rackerhacker: Have fun.  :P
21:38:40 <rbergeron> #action rbergeron to keep an eye on swift-list for info on sqlite <--> swift updates.
21:38:47 <rbergeron> rackerhacker: good luck with that :)
21:39:11 <rbergeron> #topic Trac / Bugzilla Stuff
21:39:23 <rbergeron> Soo - I promised last week I'd send out a mail to discuss this on the mailing list and I totally failed.
21:39:38 <gholms> D:
21:39:50 <rbergeron> So I can either do that again and actually do it this time, or, we can do decision now, unless we have other pressing issues people need to discuss.
21:39:51 <jsmith> rbergeron: Don't feel bad -- we've all been busy :-/
21:40:09 * rbergeron is somewhere between unpacking from OSCON and repacking to go to yellowstone :)
21:40:22 <onekopaka_laptop> I was just at Yellowstone!
21:40:33 <rbergeron> :)
21:40:57 <rbergeron> Thoughts, anyone? take it to the mailing list?
21:41:33 <gholms> The KDE SIG just CCs everyone in the group on all KDE packages' bugs.
21:42:06 <onekopaka_laptop> cc'ing athe mailing list on trac and bugzilla is always a good idea
21:42:07 <gholms> I'm not a big fan of that, personally.  I'm also not a fan of tracker bugs, but I can't come up with much else at the moment.
21:42:11 <rbergeron> right - but I feel like we may have more than "just packages" here - things like, if we want documentation, if we want a webpage, etc. I suppose all that stuff could go in bugzilla, but I don't know if officially that is a best use / allowed use for it.
21:42:41 <rbergeron> I happen to like trac since... I understand how it works a little better, but that's probably by virtue of the fact that I haven't been forced to spend a lot of time in bugzilla.
21:42:56 <rbergeron> I just worry about if bugzilla is a place for things non-bug to be tracked.
21:42:57 <gholms> A trac instance might work, though we don't exactly have very many people.
21:43:00 <rbergeron> or non-package.
21:43:15 <onekopaka_laptop> rbergeron: tracker bugs are very common
21:43:30 <onekopaka_laptop> rbergeron: in Bugzilla
21:43:51 <rbergeron> gholms: so we could, theoretically, just keep track of to-do items on a wiki, and link to bugzillas as needed.
21:44:08 <gholms> Possibly, sure.
21:44:30 <rbergeron> onekopaka_laptop: you mean - linking work items from one database type into another?
21:44:35 <rbergeron> essentially?
21:45:04 <onekopaka_laptop> rbergeron: no, bugzilla won't jump off to your Trac instances and link to them
21:45:07 <gholms> rbergeron: Your big source of concern is non-package-related bugs, right?  Perhaps the list would be sufficient for those.
21:45:17 <rbergeron> right.
21:45:17 <gholms> s/bugs/issues/
21:45:53 <rbergeron> I just like to be able to make sure we're sufficiently keeping track of things to be done - and also trac is nice to actually go back and say "wow, look at all we did" or "who did this in the past" or things to that effect.
21:45:57 <rbergeron> particularly for things that need to be on a timeline.
21:45:58 <onekopaka_laptop> and non-package-related bugs are filed too, but if it's not something concerning outside the group, you can just use a trac instance
21:46:06 <rbergeron> i just worry about things getting lost on mailing lists, and so forth.
21:46:23 <gholms> The cloud list doesn't have enough traffic for stuff to get lost.
21:46:25 * rbergeron nods
21:46:30 <rbergeron> NOT YET! muhahahaha
21:46:39 <gholms> …at which point we can revisit this.
21:46:48 <rbergeron> okay: let's keep things on-list for now, and if we feel like things are getting lost, we can revisit, as gholms just pointed out.
21:47:13 <onekopaka_laptop> mailing lists are helpful because a good record is always kept
21:47:16 <rbergeron> #agreed keep non-package bugs / issues / to-do's on list; if we need to revisit having a trac instance, we can.
21:47:18 <gholms> #info Non-package-related communications to stay on the list until it becomes unmanageable
21:47:22 <gholms> #undo
21:47:22 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1f44b950>
21:47:26 * rbergeron won that time :)
21:47:36 * gholms shakes fist at rbergeron
21:47:47 <rbergeron> i'm one of those meddling kids! you'll get me next time!
21:47:47 <rbergeron> :)
21:47:52 <rbergeron> okay.
21:47:54 <gholms> What's next!
21:47:57 <rbergeron> #topic Any other business?
21:47:58 <gholms> s/!/?/
21:48:17 <gholms> It's called Open Floor, silly.  :P
21:48:34 * rbergeron grins
21:48:58 * rbergeron notes that gholms has da power of da chair
21:49:07 * gholms shrugs
21:49:07 <brianlamere> funny question: are people already working on ec2 ami's?  I know there's some work integrating into euca and such, but I mean just a straight-up fed13/14 ami
21:49:22 <brianlamere> with pv-grub, of course
21:49:30 * rbergeron pokes jforbes
21:49:38 <gholms> I think jforbes was working on that.  Or was it huff?
21:49:53 <jforbes> Yes, just a straight up AMI
21:49:54 <rbergeron> huff is now working on other things, i believe. new job role.
21:49:54 <brianlamere> I only ask because I spent yesterday trying to get my fedora13 ami working with pv-grub, and didn't get it quite there.
21:50:21 <brianlamere> (so I'm still using an ubuntu aki at the moment)
21:50:23 <gholms> Did we at least get his latest kickstart?
21:50:39 * gholms looks for a link on the wiki
21:51:01 <jforbes> I still don't have commit access there, though I can start another repos just as easily I suppose
21:51:04 <onekopaka_laptop> I will be back
21:51:12 <onekopaka_laptop> jforbes: where?
21:51:21 <rbergeron> gholms: i think there are some links in these meeting minutes
21:51:29 <rbergeron> in the, ahem, "open floor" topic
21:51:31 <rbergeron> http://meetbot.fedoraproject.org/fedora-meeting/2010-07-01/fedora_cloud_sig.2010-07-01-21.01.html
21:52:01 <jforbes> onekopaka_laptop: to huff's ks repos
21:52:09 <rbergeron> for ks stuff
21:52:13 <onekopaka_laptop> mmkay.
21:52:24 <onekopaka_laptop> well I'm leaving for lunch ,for real
21:52:56 <rbergeron> onekopaka_laptop: thanks for coming by :)
21:53:09 <rbergeron> brianlamere: do we have your questions answered, or not really :)
21:54:54 <gholms> [You hear the sound of distant drums]
21:55:32 <rbergeron> indeed
21:55:41 <gholms> Close in 30?
21:56:04 <rbergeron> indeedy. :)
21:56:15 <gholms> Thanks for coming, people!
21:56:16 * rbergeron looks at the clock
21:56:40 * rbergeron wonders if gholms will beat her to ending the meeting ;D
21:56:49 <gholms> Nope
21:56:57 <rbergeron> #endmeeting