20:59:21 <brunowolff> #startmeeting
20:59:21 <zodbot> Meeting started Mon Aug 30 20:59:21 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:59:30 <brunowolff> #meetingname spins-sig
20:59:30 <zodbot> The meeting name has been set to 'spins-sig'
20:59:31 * nirik is around.
20:59:43 <brunowolff> #topic Who's here
20:59:53 <brunowolff> #chair nirik
20:59:53 <zodbot> Current chairs: brunowolff nirik
21:00:34 <brunowolff> #topic compose status
21:00:44 <nirik> everything is composing currently...
21:00:48 <nirik> including games. ;)
21:00:59 <brunowolff> Too give a bit of time for people to show up let's do the FYI stuff fist.
21:01:12 <nirik> ok.
21:01:16 <brunowolff> Games is real close to the limit though.
21:01:26 <nirik> many spins need to work on size limits.
21:01:33 <brunowolff> Perl is still getting pulled in.
21:01:34 * nirik is going to look at xfce for that soon.
21:01:58 <nirik> yeah, anaconda->vnc I think
21:02:00 <brunowolff> Once there is a new F14 anaconda that should get fixed. The other stuff is in place.
21:02:25 <brunowolff> livecd-desktop is over size. Not pulling in perl will make it very close.
21:02:32 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=627280
21:02:56 <brunowolff> I think the new tigervnc is in place. For sure its either in stable or testing.
21:03:25 <brunowolff> #info spins composing, need to watch sizes for some spins.
21:03:33 <ajax> finishing the gtk2 downbuilds would help too.
21:04:02 <brunowolff> #topic FYI livecd-tools
21:04:34 <brunowolff> I want to try to get a new livecd-tools out this week. That's about as late as I'd want to go with other than bug fixes.
21:04:52 <brunowolff> There are a couple of interesting scripts being added, that shouldn't break anything.
21:05:09 <nirik> ok.
21:05:14 <brunowolff> A couple of fixes, and maybe a change to --skipcopy.
21:05:54 <brunowolff> Jasper has been doing a lot of work with this, but I need to go through the list for patches making sure stuff is upstream for the new build.
21:06:13 <brunowolff> If something bad happens we can go back to 033.
21:06:40 <brunowolff> #topic fedora repo changing in git repo
21:06:55 <brunowolff> #link https://fedoraproject.org/wiki/Spins_repo_directives
21:07:27 <brunowolff> I found the few places that supply repo directives aren't very consistent.
21:07:54 <brunowolff> I think the install ks is an exception and don't want to make it the same as the others.
21:08:03 <nirik> agreed.
21:08:10 <brunowolff> So I'd like to make the other three the same.
21:08:13 <nirik> we should make all the other 3 the same.
21:08:14 <nirik> yeah.
21:08:34 <brunowolff> I'd like them to not have release numbers, but rather use the releasever macro.
21:08:51 <nirik> ok, what populates that?
21:09:01 <brunowolff> The timing would be that when Fedora branches we change the master branch to use fedora and fedora-updates.
21:09:34 <brunowolff> And then at the release (after branching the repo) we change master back to using the rawhide repo again.
21:09:35 <nirik> ok, although sometimes when branching there is no updates repo, just updates-testing.
21:09:55 <nirik> sounds good to me otherwise.
21:10:03 <brunowolff> I think the mirror manager is supposed to handle that.
21:10:12 <nirik> yeah, could be
21:10:22 <brunowolff> It should point to an empty repo.
21:10:41 <brunowolff> yum does the macro substitution.
21:10:57 <brunowolff> I think that is a relatively new feature.
21:11:07 <skvidal> ?
21:11:10 <skvidal> releasever?
21:11:12 <skvidal> it is not new
21:11:18 <brunowolff> There is also a command line override, but no way to pass one through livecd-creator.
21:11:20 <nirik> brunowolff: how do we set that with livecd-creator I mean
21:11:55 <brunowolff> livecd-creator will use whatever version it finds.
21:11:59 <nirik> so it defaults to whatever the current machine's value is. ?
21:12:22 <brunowolff> In mock it would pick up the version from fedora-release in the chroot.
21:12:58 <brunowolff> It may also look at environment.
21:13:28 <brunowolff> For most testers, I suspect they'll be doing custom stuff to point to their own local repos.
21:13:41 <nirik> ok
21:13:53 <brunowolff> The nightly compose script seems to do something special to use the correct mirrors as well.
21:14:27 <nirik> yes, it seds the lines to the correct value
21:15:09 <brunowolff> I didn't see much in the yum man page other than for the command line option.
21:15:29 <brunowolff> Do you think that making this change now will break the nightly composes?
21:15:47 <nirik> it shouldn't... and it should be easy to fix if it does.
21:16:19 <brunowolff> OK, then I think we'll go ahead with this. We have time to tweak things if there are issues.
21:16:44 <brunowolff> #action brunowolff will implement https://fedoraproject.org/wiki/Spins_repo_directives
21:17:02 <brunowolff> #topic odd install ks repo directives/
21:17:37 <brunowolff> I noticed the install ks has --excludes on its repo directives.
21:18:07 <brunowolff> I am guessing is that this blocks things harder than using -packagename in the %package section?
21:18:30 <brunowolff> Do we have any problems with releng doing this in the install script?
21:18:50 <brunowolff> If someone wanted to do this for a live image would we have problems with it?
21:19:11 <brunowolff> I think that install is releng's domain and don't have a problem with that.
21:19:14 <nirik> yeah, seems odd, but there's likely a reason.
21:19:20 <nirik> we could ask them about it for our info...
21:20:06 <brunowolff> I think it would be a bad idea for live images, as doing things like --excludes=perl would remove anaconda (currently) which is a no no.
21:20:40 <brunowolff> There are also some odd things like btanks.
21:20:57 <nirik> yeah.
21:21:24 <brunowolff> Does Jesse usually do that?
21:21:54 <brunowolff> Or are their multiple people likely to mess with that file?
21:22:08 <brunowolff> I suppose I could do a git blame or something to see.
21:22:14 <nirik> I think it's only possibly notting or Oxf13
21:23:16 <brunowolff> #action brunowolff will ask releng about the install ks as an FMI.
21:23:56 <brunowolff> We don't need to decide about live images doing that right now as no one is doing it.
21:24:20 <brunowolff> #topic others
21:24:38 <Oxf13> an FMI ?
21:24:46 <brunowolff> I only got the one document done, so I don't have testing recommendations yet to review.
21:24:54 <brunowolff> For My Information.
21:25:06 <Oxf13> what was the question, maybe I can help now?
21:25:17 <brunowolff> I wanted to ask why you guys use --excludes instead of -packagename?
21:25:33 <Oxf13> because pungi is an inclusive gatherer
21:25:43 <Oxf13> it will gather all matches of a particular package name or requirement
21:25:48 <brunowolff> I figured it was to make sure the package was blocked and not brought in when dep solving.
21:26:05 <Oxf13> and the way that kickstart semantics are things that are -foo can still be brought back in via requirements
21:26:18 <Oxf13> so if we really don't want a particular package in our composition, we have to exclude it from the repo itself.
21:26:28 <brunowolff> OK, that's what I guessed.
21:27:05 <brunowolff> Does that get reviewed from time to time? I saw btanks was excluded which seemed odd to me.
21:27:19 <Oxf13> not often
21:27:23 <Oxf13> git blame would help
21:28:05 <brunowolff> Thanks for the answers. That will help if we get a request for someone to do this for a live image.
21:29:38 <brunowolff> Does anyone have anything else for today's meeting?
21:30:35 <brunowolff> #action brunowolff will send out meeting notes.
21:30:53 <brunowolff> That sounds like a wrap for today. Thanks for attending!
21:30:59 <brunowolff> #endmeeting