21:01:35 <poelcat> #startmeeting Fedora 14 Beta Go/No-Go Meeting
21:01:35 <zodbot> Meeting started Wed Sep 22 21:01:35 2010 UTC.  The chair is poelcat. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:35 <jlaska> and like that, he's here to guide us through the storm
21:01:50 <poelcat> #chair jlaska jsmith adamw
21:01:50 <zodbot> Current chairs: adamw jlaska jsmith poelcat
21:02:04 <poelcat> who else is here for this momentous occassion?
21:02:11 * rbergeron 
21:02:12 * jsmith is here
21:02:15 * fenris02 waves
21:02:19 * SMParrish here representing FESCo
21:02:19 * stickster lurks too
21:02:20 * jlaska 
21:02:31 * adamw waves to the adoring masses
21:02:43 * brunowolff is here
21:03:13 * jlaska holds up his adamw #1 foam hand
21:03:17 <poelcat> #info attendees rbergeron jsmith fenris02 SMParrish stickster jlaska adamw brunowolff
21:03:42 <poelcat> #topic http://fedoraproject.org/wiki/Engineering_Readiness_Meetings
21:04:07 <poelcat> we are here to determine if the release criteria for the Fedora 14 Beta have been met and if the release is considered GOLD
21:04:32 <poelcat> all agreed that is why were are here?
21:04:42 <adamw> i'm here for the beer
21:04:51 <fenris02> in holding out for the pony
21:04:51 <poelcat> :)
21:04:54 <stickster> +1 poelcat :-)
21:05:01 <jlaska> agreed, with chuckles
21:05:03 <rbergeron> +1 to everything just mentioned :)
21:05:07 * SMParrish agrees
21:05:12 <adamw> maybe the pony will bring beer
21:05:13 <poelcat> jlaska: adamw what do we know?
21:05:24 <poelcat> #topic review of release criteria and open bugs
21:05:26 <rbergeron> it could be a pony keg...
21:05:26 <adamw> do we want to establish who's representing who?
21:05:32 <adamw> usually we need qa, releng and devel
21:05:35 <poelcat> adamw: that's a good idea too :)
21:05:40 <jsmith> adamw: Great idea!
21:05:48 <adamw> jlaska and I are here for qa
21:05:59 <jsmith> Do we have representatives from releng and devel?
21:06:15 <adamw> dgilmore: oxf13: ping
21:06:22 <poelcat> nirik or someone from FESCo?
21:06:27 <adamw> smparrish is fesco
21:06:30 <poelcat> oops
21:06:37 * rbergeron is here for marketing
21:06:40 <dgilmore> adamw: pong
21:06:57 <mmcgrath> pong
21:07:17 <adamw> mmcgrath: which do you want to be? :)
21:07:18 <poelcat> #info adamw and jlaska here for qa
21:07:27 <mmcgrath> infra
21:07:28 <poelcat> #info SMParrish here for devel/FESCo
21:07:38 <poelcat> #info dgilmore representing releng
21:07:41 <brunowolff> #brunowolff is here for Spins SIG
21:07:42 <adamw> excellent
21:07:51 <poelcat> #chair brunowolff
21:07:51 <zodbot> Current chairs: adamw brunowolff jlaska jsmith poelcat
21:07:56 * jsmith is here for the sheer joy
21:07:59 <adamw> okay, so here's the main points
21:08:00 <brunowolff> #info brunowolff is here for Spins SIG
21:08:06 * stickster is here to hold jsmith's water
21:08:11 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_14_Beta_RC3_Install <--- install test matrix
21:08:25 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_14_Beta_RC3_Desktop <--- desktop test matrix
21:08:49 <adamw> https://bugzilla.redhat.com/showdependencytree.cgi?id=611991&hide_resolved=1 <--- beta blocker list
21:09:05 <skvidal> stickster: eww
21:09:46 <poelcat> adamw: is there anything specific we need to discuss or is it all good news?
21:09:59 <adamw> there's one bug on the blocker list, https://bugzilla.redhat.com/show_bug.cgi?id=627789
21:09:59 <adamw> it's not an AcceptedBlocker; we can review its status here. i don't believe it constitutes a beta blocker, it's not functionality covered in the beta criteria. it's a bug in writing non-live ISOs to USB with livecd-iso-to-disk .
21:10:20 <adamw> poelcat: there's a handful of specific issues i'll bring up one at a time :)
21:10:29 <dgilmore> adamw: i dont think thats a beta blocker but is a ga blocker
21:10:33 <adamw> so this bug is the first. i'm -1 to it being a beta blocker.
21:11:15 <adamw> anyone want to vote +1 for holding the beta for this?
21:11:46 <jlaska> no sir
21:11:51 <poelcat> no
21:12:04 <poelcat> particularly if there is no criteria remotely related to it
21:12:09 <brunowolff> no
21:12:11 <jsmith> no
21:12:23 <jsmith> It's a "nice-to-have" fix, but I don't see it as being a blocker for the beta
21:12:37 <adamw> no, we really don't cover writing images to USB in the criteria. though we should probably have at least live-to-usb in there, actually.
21:12:51 <poelcat> does it qualify for any of the final release criteria?
21:12:54 <adamw> #agreed 627789 is not a beta blocker
21:13:03 <jlaska> #idea create release criteria asserting some level of functionality of livecd-tools
21:13:10 <adamw> off the top of my head I think no, but i'll move it to the final blocker list for now and we can review it at the first final blocker review meeting
21:13:13 <stickster> +1 jlaska
21:13:53 <brunowolff> With more people using live images on USB devices, I think there should be something there.
21:14:01 <jsmith> +1 to jlaska's idea
21:14:12 <adamw> +1 too
21:14:17 <dgilmore> +1 as well
21:14:20 <jlaska> we can tackle that post beta
21:14:33 <jsmith> Of course
21:14:57 <jlaska> adamw: any additional issues you wanted to draw attention to here?
21:15:00 <poelcat> #agreed move https://bugzilla.redhat.com/show_bug.cgi?id=627789 to f14blocker
21:15:01 <adamw> okay, so, second specific issue: we have a bug that prevents install entirely on systems which use EFI rather than BIOS, https://bugzilla.redhat.com/show_bug.cgi?id=635887 (and 635873)
21:15:35 <adamw> we have a criterion that specifically calls this out: "The installer must boot and run on systems using EFI other than Apple Macs "
21:15:44 <adamw> however, we had something of a process fail here; no-one ran this test until rc3
21:16:02 <mjg59> adamw: That's fine, it'll work on HPs
21:16:05 <adamw> qa and anaconda team have discussed this, and we propose that for the beta we ship an updates.img as a workaround for this, documented on CommonBugs
21:16:06 <mjg59> They don't require GPT
21:16:28 <jlaska> mjg59: ah, good to know
21:16:29 <adamw> for the future qa and anaconda will try to ensure we cover this case better
21:16:52 <mjg59> Which I think means "The criterion is poorly worded" rather than "This isn't a problem"
21:17:07 <adamw> in practice the number of non-Mac EFI systems in the wild is pretty small, so we think that's an acceptable solution
21:17:18 <dgilmore> is there a way to test efi with kvm?
21:17:21 <jlaska> side issues, we have a hardware and knowledge gap to address in order to improve test coverage on non-Mac EFI systems
21:17:25 <adamw> afaik, no.
21:17:31 <bcl> dgilmore: no
21:17:33 <jlaska> dgilmore: no, but pjones is best to talk to about that
21:17:42 <jlaska> I stand corrected, bcl is here too
21:17:47 <dgilmore> ok
21:18:00 <dgilmore> it would be nice if we could test this easily
21:18:14 <dgilmore> i.e in a virt environment
21:18:16 <jlaska> agreed, add iBFT to the virt wishlist
21:18:18 <adamw> (in case anyone's wondering, there are specific problems with supporting Mac EFI, and EFI Macs can be handled via bootcamp so supporting them isn't vital)
21:18:37 <jlaska> adamw: good background info, thx
21:18:41 <bcl> KVM needs EFI support to test in a KVM, but really there is no substitute for hardware.
21:18:45 <dgilmore> adamw: im ok with an updates.img for this
21:19:01 <adamw> yup, so, let's vote - obviously, i (and qa) are +1 for updates.img + documentation for this
21:19:06 <stickster> adamw: If this problem is not fixed for final GA, would it represent a regression from F13?
21:19:25 <jsmith> That's my understanding
21:19:34 <jsmith> I'm sure adamw can better address that, though
21:19:46 <adamw> stickster: according to the table, yes
21:19:49 <stickster> thanks.
21:19:50 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_13_Final_RC3_Install
21:19:59 <adamw> has a pass for the efidisk.img test from pjones
21:20:22 <poelcat> so we're voting on making an exception to the stated criteria?
21:20:53 <dgilmore> for beta im ok with a  workaround  for ga we need it to be right
21:20:56 <adamw> so per our testing at the time, f13 final had working efi install
21:20:56 <adamw> we can certainly fix this for final, though - the fix is actually tiny, that's why we can do an updates.img, and the fix will go into the next anaconda build after beta freeze
21:21:08 <jlaska> poelcat: that's another way to phrase it, yeah
21:21:12 <adamw> poelcat: not exactly, as the criteria allow for the possibility of workarounds
21:21:21 <jlaska> poelcat: it will be working but requires a workaround
21:21:36 <jlaska> we do have exceptions for 'reasonable' workarounds
21:21:37 <poelcat> cool, that makes sense
21:21:51 * jsmith is +1 for the workaround exception in this limited case
21:21:56 <jlaska> and I think consensus was that the addition of an updates.img for this case was acceptable
21:22:04 <jlaska> adamw: bcl can confirm/deny
21:22:10 <poelcat> adamw so we are within the criteria, you're just calling out something that might cause some people problems
21:22:26 <adamw> poelcat: it's best to discuss every unmet criterion, even ones with a workaround.
21:22:44 <poelcat> adamw: good point
21:22:50 <bcl> jlaska: confirm which bit? I broke it, and I fixed it and I'll make sure it gets into final and is tested. :)
21:22:51 <poelcat> adamw: carry on!
21:23:10 <jlaska> bcl: haha, no no ... just the proposed workaround
21:23:20 <adamw> oh, i should have provided the other options here: we roll an rc4 entirely blind with just this fix and trust the rc3 testing, or we slip. those are the other options.
21:23:21 <bcl> oh, yes. That too :)
21:24:26 <adamw> by isolating the fix in an updates.img we provide it for the few who need it without running the risk that it somehow breaks stuff for the people who don't.
21:24:39 <adamw> so, sounds like we're +1 on the updates.img workaround?
21:24:45 <dgilmore> yep
21:24:46 <jlaska> +1 for the +1
21:24:50 <dgilmore> +1
21:25:48 <adamw> #agreed publishing a documented updates.img with a fix for 635887 is an acceptable workaround, move 635887 to be a final blocker
21:26:09 <adamw> okay, the final specific issue I have to call out is https://bugzilla.redhat.com/show_bug.cgi?id=542255
21:26:57 <adamw> strictly per the criteria, since we're experimenting with extending the desktop criteria to kde, xfce and lxde this cycle, this is a beta blocker under the criterion "No part of the default desktop's panel (or equivalent) configuration should crash on boot of the installed system using default installation choices"
21:27:15 <adamw> in practice, it's a fairly minor issue and we're unlikely to be able to fix it on any reasonable time scale as upstream is dead
21:27:21 <dgilmore> -1 to being a blocker
21:27:24 <adamw> so qa and lxde sig are proposing we waive this issue
21:27:52 <adamw> for final, we'll either come up with a fix, or switch lxde to a different mixer
21:28:33 <adamw> this issue has been known for a long time - i think we shipped f13 with it broken, in fact - but just no fix available from anywhere
21:28:58 <adamw> anyone want more info, or votes?
21:29:14 <jsmith> Let me play devil's advocate for a second
21:29:17 <adamw> sure
21:29:28 <jsmith> Assuming we *do* decide this is a blocker
21:29:36 <adamw> assuming that :P
21:29:40 <jsmith> and we slip because of it...
21:29:57 <jsmith> ... do you think that would help get the attention it deserves to get the problem fixed?
21:30:32 <adamw> i doubt it would prompt anything from upstream, but i expect someone in fedora would come up with a fix. in the middle of the inevitable 1,000 post -devel thread. :P
21:30:34 <dgilmore> jsmith: hoestly i think  the answer is no
21:30:46 <jlaska> adamw: heh
21:31:54 <adamw> i suspect it's probably a fairly 'duh' issue in the code, to be honest, it just hasn't mattered much to anyone yet.
21:31:54 <adamw> in practice we're not likely to want to keep using a dead upstream app as lxde's mixer anyway, so i suspect it'd get changed even if we fixed this.
21:31:54 <adamw> the maintainer of gmixer has said that if lxde stopped using it, he'd kill the package.
21:32:08 <poelcat> i don't understand how lxde qualifies being that it is not the default desktop
21:32:26 <adamw> poelcat: so, that's the big theoretical discussion i was hoping to avoid by waiving this bug :)
21:32:33 <fenris02> lxde is one of the four official primary spins
21:32:41 <dgilmore> adamw: which makes me think the right thing is kill gmixer and move to something else
21:32:50 <adamw> poelcat: the short version there is this: extending the criteria was basically my project for f14. oxf13 and i are in the middle of a long discussion about this and how it relates to fedora's major mixed messaging over spins
21:33:02 <adamw> which we're going to distil into some questions for the board after beta
21:33:43 <adamw> in practice, i'd agreed with jesse that if major blockers in non-desktop spins remained at beta, i'd modify my whole spins-as-blockers proposal temporarily and propose we don't treat them as blockers but as nice-to-haves until the board has considered the questions
21:33:53 <mjg59> If a spin has sufficiently few developers that it can't fix a crash in their default panel setup, why is it a blocking part of the release?
21:33:58 <poelcat> adamw: since the criteria hasn't yet been extended it seems like a non-issue to me
21:34:45 <jsmith> I don't like to get in the habit of saying "This problem is hard to solve... let's ignore it."
21:34:55 <adamw> mjg59: actually the developers are quite active, they fixed a much more serious blocker in a very short time
21:35:08 <mjg59> adamw: But this crashes on startup, and has done since F13?
21:35:19 <kalev> adamw: I just looked at the bug and I'd strongly suspect that gmixer crashes when no sound cards are available
21:35:22 <kalev> self._current_mixer.list_tracks()[0]
21:35:27 <kalev> returns out of index
21:35:38 <adamw> kalev: it appears to crash in all cases, it crashes on my tests where a sound card is available.
21:35:43 <adamw> but let's stay on track. =)
21:36:06 <adamw> jsmith: so, here's the thing - i definitely want to address the whole issue of blockers in non-desktop spins
21:36:25 <adamw> but as i said, jesse and i have come up with a number of issues here that we're trying to parse to form the basis for an orderly discussion
21:36:47 <adamw> so for now we figured it's best to just ship the beta and then concentrate on that issue, as it's not going to get sorted out in two days
21:36:52 * poelcat still doesn't follow. If we're following the release criteria in the same way we have for the other bugs and this particular criteria says the *default* spin must work and lxde != default spin then there is nothing to decide except maybe a release note
21:37:05 <poelcat> to help people who encounter it
21:37:10 <jsmith> So I'm confused... is lxde part of the blocker criteria or no?
21:37:18 <poelcat> jsmith: no
21:37:20 * jsmith was under the impression that it was
21:37:20 <adamw> poelcat: oh, i should have edited that criterion when i pushed the proposal to extend the desktop criteria
21:38:16 <fenris02> default spin = all four primary livecd's right? or do you mean only gnome?
21:38:31 <poelcat> fenris02: default spin has always meant gnome
21:38:34 <jlaska> fenris02: it started with the default desktop, gnome
21:38:44 <adamw> when that criterion was written it was specifically meant to apply to the desktop spin
21:38:52 <adamw> but i should have edited it for f14 with the plan to extend the criteria
21:38:55 <adamw> it was just an oversight
21:39:33 <dgilmore> poelcat: we are using the 4 desktops
21:39:38 <jlaska> adamw: has there been a wider discussion/consensus on extending the criteria beyond their initial focus?
21:39:45 <jlaska> or is it still a pilot?
21:39:53 <adamw> if it helps the discussion, for now, i can go with the thing i mentioned above: revise the idea of extending the desktop criteria for now, pending board discussion
21:39:56 <poelcat> wow, i didn't realize that and dont' recall seeing the discussion
21:39:59 <adamw> jlaska: i put it up for discussion on -test iirc
21:40:03 * adamw is searching archives atm
21:40:15 <adamw> doesn't help that my mails get split across fifteen different boxes when i send 'em to multiple lists, heh
21:40:41 <jlaska> the feedback in this meeting indicates there is more discussion needed before we can accept these issues
21:40:56 <adamw> poelcat: as i said, i'm now of the opinion we shouldn't treat non-desktop bugs as blockers until certain issues have been discussed+resolved at board level
21:41:12 <adamw> i was hoping to avoid this whole messy discussion for now just by waiving this bug and moving on, but ah well =)
21:41:28 <poelcat> :)
21:41:38 <poelcat> me and my trying to follow the process ;-)
21:41:44 <jsmith> adamw: That's what you get for trying to sweep things under the rug!
21:41:55 <adamw> jsmith: but i'm reaaaallly tired. :P
21:42:02 <jlaska> ah the joys of transparency :D
21:42:08 <poelcat> so what is the proposed #agreed now?
21:42:43 <dgilmore> that the gmixer bug not block beta
21:42:52 <adamw> i don't think this meeting is the place to address the wider issues, honestly...for now can we agree under *some* justification that we're not blocking the beta for this and moving on?
21:42:52 <adamw> i don't care if it's that we consider the impact of the bug or we decide not to consider non-desktop bugs as blockers for now or whatever makes people happiest
21:43:21 <adamw> or we can go for a combination if you like =)
21:43:30 <dgilmore> adamw: since its not a regression im ok with shipping as it
21:43:32 <dgilmore> is
21:44:01 <adamw> how about this: propose #agreed 542255 is not a regression, is of minor impact, and the question of non-desktop bugs blocking releases requires further discussion and clarification, so we will not block the beta for this bug
21:44:12 <dgilmore> +!
21:44:14 <dgilmore> +1
21:44:19 <jsmith> +0
21:44:25 <poelcat> s/non-desktop/non default spin
21:44:31 <adamw> yeah, thanks
21:44:42 <poelcat> +1
21:45:08 <adamw> and qa is +1
21:45:08 <maxamillion> +1
21:45:26 <adamw> #agreed 542255 is not a regression, is of minor impact, and the question of non-default-spin bugs blocking releases requires further discussion and clarification, so we will not block the beta for this bug
21:45:58 <adamw> okay, sorry for the messiness :)
21:46:26 <adamw> a couple of quick ones: j_dulaney's fail on booting the desktop live image appears to be some kind of system-specific issue, no-one else has reported it (that's 636380)
21:46:48 <adamw> jreznik's fail on sound in KDE seems again to be a bug in his system, multiple other testers inc. me reprot working sound in kde
21:47:29 * maxamillion has working sounds in KDE
21:47:36 <maxamillion> on 3 machines
21:47:43 <maxamillion> (physical hardware)
21:47:48 * SMParrish my sounds in kde works np
21:48:13 <adamw> ajwerkman's https://bugzilla.redhat.com/show_bug.cgi?id=633815 relates to ipv6, so though it's listed as a fail in a beta install validation test it doesn't really invalidate the criteria (it should probably be marked as warn not fail)
21:48:31 <adamw> i think that's all the standouts on the validation tables
21:48:32 <jlaska> agreed
21:48:38 <jlaska> 2 additional quick notes
21:48:43 <adamw> take it away!
21:48:54 <jlaska> the version of preupgrade in fc12 needs to be updates to the latest
21:49:06 <jlaska> I've contacted hughsie, and I'm sure this will be resolved by beta GA
21:49:17 <adamw> jlaska: preupgrade from two versions ago is an informational test anyway, too - it's not a beta criterion (or even final), we just do it to know how well it's working
21:49:39 <jlaska> last point, most everything now uses 'report' to report bugs, including the installer
21:50:04 <jlaska> this change introduced some scenarios where the installer could potentially fail, and it fails to activate networking to submit a bugzilla
21:50:20 <jlaska> the cases are rare, and only involve non-network installs where failures happen at a certain point
21:50:22 <adamw> i noticed a workaround for this earlier, btw - there's an 'activate network' button somewhere very early in anaconda
21:50:34 <jlaska> yeah, that'll do it
21:50:35 <adamw> so if you're hitting such a fail you can reboot, set up the network early, reproduce the fail, then report it
21:50:42 <jlaska> there are a few that we'll document on CommonBugs
21:50:44 <fenris02> jlaska, hm?  why?  preupgrade from f12 -> f14 is not supported anyhow.
21:50:54 <jlaska> fenris02: adamw discussed earlier
21:50:55 <fenris02> needs to go f12 -> f13 -> f14
21:50:56 <adamw> fenris02: see above - it's something people tend to do, so we test it to know how well it's working
21:51:04 <fenris02> sorry, i missed that discussion.
21:51:13 <jlaska> fenris02: no worries, thanks for calling that out
21:51:23 <jlaska> that's it from me
21:51:24 <maxamillion> I was under the impression f12 -> f14 was supported ... I think the test day wiki page said it was
21:51:57 <bcl> The upgrade dialog says 'two previous releases'
21:51:57 <fenris02> maxamillion, oh.  if it is supported there are major problems.  it fails often.
21:52:08 <bcl> jlaska: has a nice screenshot of it
21:52:14 <fenris02> maxamillion, end result == non-bootable system
21:52:19 <dgilmore> fenris02: AFAIK we support it
21:52:24 <jlaska> we're off topic
21:52:27 <adamw> yup
21:52:33 <maxamillion> fenris02: ah .... it worked for me in my VM going from F12 -> F14
21:52:36 <adamw> whether we support it or not, it doesn't block beta =)
21:52:41 <maxamillion> I think I reported on the test day wiki .... if not, I meant to
21:52:41 <dgilmore> adamw: all blockers covered?
21:52:47 <maxamillion> adamw: +1
21:52:49 <adamw> that covers everything from qa end afaik
21:53:03 <jlaska> indeed, thanks adamw
21:53:06 <dgilmore> adamw: so we have no release blockers and F-14 beta is a go?
21:53:27 <poelcat> are there any known issues releng or devel needs to raise?
21:53:50 <adamw> so given all of that, qa is a big +1 to releasing rc3
21:53:50 <adamw> actually i think it's bloody good quality for a beta =)
21:53:51 <dgilmore> releng has no issues
21:54:01 <SMParrish> fesco has no issues
21:54:08 <dgilmore> releng is +1 to releasing rc3 as beta
21:54:15 <brunowolff> Spins SIG +1
21:54:23 <poelcat> proposed #action there being no unresolved blocking issues or unmet release criteria, Fedora 14 Beta is declared GOLD
21:54:26 <poelcat> ack/nak/patch
21:54:42 <adamw> ack!
21:54:51 <jlaska> I'd like to give a BIG thanks to the increased commmunity participation we had for testing the Desktop and Installation matrices this time
21:54:52 <brunowolff> ack
21:55:05 * stickster says "nice work" to all developers and testers who helped get us here.
21:55:14 <jlaska> there's no way we would be here without extra hands/eyes to help do the work, and review the failures
21:55:22 <dgilmore> ack
21:55:34 <poelcat> #action there being no unresolved blocking issues or unmet release criteria, Fedora 14 Beta is declared GOLD
21:55:36 <adamw> yep, big thanks to releng and devel for all the work to fix the blockers, and all the testers
21:55:37 <poelcat> #topic open discussion
21:55:45 * jsmith has nothing futher to add
21:55:55 <poelcat> reminder that tomorrow we'll have the release wide readiness meeting
21:56:01 <poelcat> i'll send a reminder later today
21:56:03 * dgilmore will notify mirrors
21:56:05 <adamw> just a note - if anyone wants to chat about the whole non-default-spin-blockers thing let's meet up in #fedora-qa
21:56:09 <adamw> i can bore you all rigid about it =)
21:56:25 * adamw sends apologies in advance for the readiness meeting, i'll be on a plane
21:56:39 <brunowolff> Now?
21:56:46 <adamw> brunowolff: spins? yup
21:56:52 <poelcat> great job everyone! we're on time and you know how I like that :)
21:57:09 * poelcat will end meeting in 90 seconds
21:57:20 <jsmith> Thanks poelcat... thanks all!
21:57:28 <brunowolff> OK, I'll be there, though I am also trying to follow the visions meeting.
21:57:35 <jlaska> we need to try and hit earlier milestones so that I don't lose all my hair
21:57:42 * adamw remembers hair
21:57:55 <jlaska> compressing the testing schedule is inpleasant
21:58:19 <poelcat> jlaska: add to https://fedoraproject.org/wiki/Fedora_14_Schedule_Retrospective today!
21:58:28 <poelcat> thanks again everyone
21:58:31 <poelcat> #endmeeting