19:34:06 <tremble> #startmeeting epel
19:34:06 <zodbot> Meeting started Mon Oct  4 19:34:06 2010 UTC.  The chair is tremble. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:34:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:34:40 <tremble> #topic init process
19:34:59 <tremble> So, who do we have this week?
19:35:14 <stahnma> me
19:35:26 * nirik is around
19:35:27 <stahnma> looks like nirik and smooge are partially around
19:35:37 * rsc is also partially around
19:35:43 <tremble> #chair smooge stahnma nirik
19:35:43 <zodbot> Current chairs: nirik smooge stahnma tremble
19:36:37 <stahnma> agenda:  Meeting Time finalization; Bugs Update; Broken Deps Update; EL-6 Branching
19:37:04 <stahnma> #topic EPEL Meeting Time
19:37:15 <nirik> this time generally works ok for me.
19:37:17 <stahnma> Seems like the list has been rather uncaring about the times of these meetings
19:37:27 <stahnma> this time is good for me most often
19:37:28 <tremble> So anybody *not* like the time ?
19:38:11 * tremble listens to the chirping of crickets.
19:38:16 <smooge> I like the time.
19:38:26 <smooge> sorry tremble thankyou for running htis from UK
19:38:38 <tremble> .de these days actually
19:39:14 <stahnma> ok, I think we're on board now
19:39:19 <stahnma> meeting time finalzied?
19:39:21 <stahnma> +1
19:39:24 <tremble> +1
19:40:09 <stahnma> ok everybody else said it was ok too
19:40:20 <stahnma> #topic epel bug update
19:40:26 <tremble> #agreed New time slot 1930 UTC
19:40:41 <stahnma> bug count still below 200 :)
19:40:54 <tremble> So they're still dropping, if not as fast as before.
19:40:55 <stahnma> #info 190 bugs --> see http://tr.im/epelbugs
19:41:20 <nirik> already got some of the low lying fruit?
19:41:50 <stahnma> yeah, tremble has knocked out a bunch of it
19:41:57 <nirik> yeah, good work on that.
19:41:58 <stahnma> I've got a few I think will clean up this week with pushes
19:42:13 <tremble> I think most of the really low lying fruit's gone now, it's a case of going through the simple fixes rather than the out right closures.
19:42:14 <stahnma> goal is still 1 bug per week
19:43:20 * nirik nods. I will try and help where I can.
19:43:37 <tremble> There's a number of "please update me" and "please branch me" bugs, I wonder if the please branch me for EL-4 ones should just get "Feel free to branch, if you can't sorry this is a WONTFIX"
19:44:16 <nirik> I poked at the lua thing last week.
19:44:31 <tremble> Success?
19:44:49 <nirik> it oddly doesn't build for me from git. I am now wondering if it's patch got mangled by the git conversion.
19:45:04 <nirik> jpo had an updated rpm that should work.
19:45:41 <nirik> I'll get him to commit it or I will soon.
19:47:28 <tremble> Next item?
19:47:34 <nirik> sure.
19:47:44 <tremble> #topic broken deps update
19:47:44 <stahnma> #topic EPEL broken deps update
19:47:46 <stahnma> eheh
19:48:01 <nirik> ha
19:48:14 <stahnma> Not too much new here.  I worked on the script a tiny bit last week.
19:48:20 <smooge> guys are going to lunch. read summary later.
19:48:39 <stahnma> I was wondering how the emails should be separated
19:48:45 <stahnma> like one for EL-4 with all arches?
19:48:55 <stahnma> for stable and testing each?
19:49:16 <stahnma> that's 4 emails until el6 is live
19:49:21 <nirik> yeah.
19:49:25 <stahnma> how much information do we want to send?
19:49:26 <nirik> I think that makes sense to me.
19:50:06 <stahnma> ok
19:50:08 <stahnma> I can do that
19:50:16 <stahnma> hmm
19:50:21 <stahnma> there still probably won't be ppc
19:50:27 <stahnma> since I have to repoquery to run
19:50:35 <stahnma> s/have to/have no
19:50:51 <stahnma> deps are certainly looking better in the repos too
19:50:51 <tremble> Do we want to un-push updates with broken deps from testing, as a start?  Say at the end of the month?
19:50:52 <nirik> right, thats the problem with running against centos
19:51:07 <stahnma> I'd rather unpush from stable
19:51:10 <nirik> well, I would say we should get stable fixed first.
19:51:20 <nirik> perhaps not even send the testing ones yet... until stable is fixed.
19:51:21 <stahnma> broken deps in testing may be waiting on a build override or something
19:51:52 <tremble> stahnma: yeah, but shouldn't be pushed until 2 weeks after the whole lot is ready
19:52:13 <stahnma> mmm should
19:52:24 <stahnma> I know I have messed that up before ;)
19:52:54 <tremble> And if we un-push them from testing then they have to wait for the deps to be ready too before pushing to stable.
19:53:20 <tremble> This at least prevents things from getting worse which is a starting point from which to improve things.
19:53:25 <nirik> how about this:
19:53:42 <nirik> do stable and mail people. unpush any that aren't fixed in a week.
19:53:48 <nirik> do testing and mail the list.
19:53:54 <nirik> revisit that after stable is fixed.
19:54:10 <stahnma> +1
19:54:12 <tremble> +1
19:54:52 <stahnma> ok
19:55:20 <tremble> #agreed Stahnma will mail out the list of currently broken "stable" packages
19:55:43 <tremble> #agreed One week after that we will unpush any that are still broken.
19:55:51 <stahnma> cool
19:56:49 <tremble> #agreed We will also run the dep-check on testing and revist what to do with them after we un-push the packages with broken deps from stable
19:57:09 <stahnma> ok
19:57:30 <tremble> Moving swiftly on?
19:57:45 <tremble> #topic EL-6 Branching
19:58:16 <tremble> So we have a load of packages that didn't branch because they were in RHEL-6 beta 1, but have now gone.
19:58:56 <nirik> do we have a list of them?
19:59:02 <tremble> This has resulted in broken deps for a few packages and some people have been asking after branches for these.
19:59:30 <stahnma> I don't know if rubygem-rails was in the beta1, but's not in beta2
19:59:44 <stahnma> and it's holding out a decent sized portion of the ruby stuf
19:59:47 <tremble> perl-Tk disappeared
20:00:39 <tremble> We can generate a full list reasonably easily...
20:00:39 <nirik> these are ones that are not at all in beta2 refresh?
20:00:45 <tremble> yes
20:00:51 <nirik> ie, not just the ones that are in workstation only?
20:00:54 <tremble> Gone completely
20:01:06 <nirik> ok
20:01:14 <nirik> I wish we knew if they would be back. ;)
20:01:56 <tremble> Hopefully we don't need to wait too much longer.
20:03:00 <tremble> So do we...
20:03:08 <tremble> a) Just branch them
20:03:36 <tremble> b) Tell people to go through the usual branching process, basically waiting a week if there's no response
20:04:06 <tremble> c) Just let people branch them but expect them to at least add the existing owner as an owner.
20:04:14 <nirik> how many are there?
20:04:17 <tremble> d) Wait for GA
20:04:46 * nirik guesses he doesn't care much... perhaps b seems easiest.
20:05:20 <tremble> I'm aware of 1 or 2 for certain did find a list earlier...
20:06:31 <stahnma> I'm kind of in favor a D, but at the same time, I'd like to have latest packages ready to go in epel
20:08:01 <tremble> So refresh... Removed package: dogtail
20:08:01 <tremble> Removed package: mozldap
20:08:01 <tremble> Removed package: perl-Mozilla-LDAP
20:08:01 <tremble> Removed package: python-bugzilla
20:08:33 <nirik> we already branched python-bugzilla I think.
20:08:42 <nirik> .branches python-bugzilla
20:08:43 <zodbot> nirik: EL-5 EL-6 F-12 F-13 devel f14
20:09:10 <stahnma> hmm, I use perl-Mozilla-LDAP a lot
20:09:15 <stahnma> or, at least I use to
20:10:10 <nirik> only those 4?
20:10:12 <tremble> Beta 1->2 Removed package: amqp
20:10:12 <tremble> Removed package: bitmap-fonts
20:10:12 <tremble> Removed package: bluecurve-icon-theme
20:10:12 <tremble> Removed package: dcbd
20:10:12 <tremble> Removed package: eclipse-egit
20:10:12 <tremble> Removed package: eclipse-jgit
20:10:14 <tremble> Removed package: fastback
20:10:16 <tremble> Removed package: fedora-bookmarks
20:10:20 <tremble> Removed package: fedora-gnome-theme
20:10:22 <tremble> Removed package: fedora-icon-theme
20:10:24 <tremble> Removed package: htmlview
20:10:26 <tremble> Removed package: jetty
20:10:28 <tremble> Removed package: libmcrypt
20:10:30 <tremble> Removed package: livecd-tools
20:10:32 <tremble> Removed package: perl-Config-Tiny
20:10:34 <tremble> Removed package: python-krbV
20:10:36 <tremble> Removed package: qpid-tests
20:10:38 <tremble> Removed package: rhpl
20:10:40 <tremble> Removed package: rng-utils
20:10:42 <tremble> Removed package: wxGTK
20:10:54 <tremble> and like I said, I can't find perl-Tk any more...
20:10:59 <nirik> some of those should die. ;) Like rhpl.
20:11:02 <tremble> So there may be more.
20:11:30 <tremble> The list isn't as big as I feared it might be.
20:11:32 <nirik> so, why not just allow them to branch as per normal... as we find them and someone wants to maintain them.
20:11:40 <tremble> Yeah
20:12:16 <tremble> It was asked that we also discuss the Server/Workstation packages game...  Personally I think we just wait for GA.
20:12:41 <stahnma> It's difficult to be prepared for an unknown target
20:13:07 <nirik> sadly, I think so too. I know it's frustrating to wait while deps are broken...
20:13:24 <nirik> but adding them in now and then having to remove them later would be a pain... and it would also cause issues for rhel
20:13:32 <stahnma> well, at the same time, most orgs don't adopt over night ;)
20:13:55 <tremble> It wouldn't be too hard to yank them once the package list is public.
20:14:46 <tremble> We could also implement the suggestion of putting in a repo priority, however that could catch out people on i686 and ppc64...
20:15:00 * nirik is not liking it because it's us basically bypassing the workstation/server split. Ie, would paying rhel folks get something from us when they normally would have paid for access to another channel.
20:15:56 <nirik> dgilmore: I don't suppose you have heard anything on this recently?
20:16:23 <tremble> nirik: The other side is that they wouldn't be getting the support from RH for those packages.
20:16:52 <nirik> sure.
20:17:10 <stahnma> I don't have much of an opinion on that, other than sometimes servers get things classified as workstation packages
20:17:19 <dgilmore> nirik: i dont expect to have any update until rhel is ga's at this point
20:17:23 <stahnma> and sometimes workstations get server packages
20:17:29 <stahnma> I really don't see why they seperate them at all
20:17:36 <tremble> The split is generally rather arbitary
20:17:38 <stahnma> but, I'm not a sales/marketing person
20:17:42 * nirik doesn't either personally, but thats just us I guess.
20:17:50 <tremble> Workstation is sold at a lower price.
20:18:42 <stahnma> true
20:18:56 <stahnma> but I don't see how when I pay the higher price, I am missing things from the lower price
20:19:01 <tremble> and that I can understand, but the libs from Workstation that can't be found in Server makes EPEL's life awkward.
20:19:08 <nirik> right.
20:19:19 <stahnma> alas, we will not solve that problem today
20:19:37 <nirik> So how many of these do we know of?
20:19:47 <nirik> I think I know of 2 that are being asked about a lot by maintainers...
20:20:10 <nirik> we could add those 2 as a special exception now, and pull them later...
20:20:16 <nirik> or just wait. ;)
20:20:27 <dgilmore> I think we should just wait
20:20:32 <tremble> +1
20:20:39 <tremble> (on waiting)
20:21:36 * nirik shrugs.
20:21:52 <tremble> I think it's worth people considering the options, but I think actually doing anything should wait.
20:22:49 <stahnma> +1 to wait
20:23:20 <nirik> ok
20:23:58 <tremble> #agreed We're not going to branch the Workstation only packages (beyond anything already branches) until at least after GA.
20:24:29 <tremble> #agreed For packages that got dropped between betas people should just put in branch requests as per normal.
20:25:31 <tremble> #topic Open Floor
20:25:46 <stahnma> just a reminder to try to get the latest version of your package in to epel6
20:26:08 <stahnma> there was some discussion on list about system management tools.  It got no real resolution, but I liked the discussion
20:26:17 * tremble nods
20:27:17 <tremble> Oh, packages we're building to satisfy some arches...
20:27:25 * stahnma has to go to next meeting
20:27:27 <stahnma> thanks!
20:28:11 * nirik vuagely thinks he had something, but can't recall what it was.
20:28:48 <tremble> My suggestion is as follows : file "README-PACKAGER" in the EL-6 branch
20:29:00 <tremble> Warning:
20:29:00 <tremble> This package is available for *some* architectures in RHEL6.
20:29:00 <tremble> The EPEL policy is that where possible we should simply rebuild the
20:29:01 <tremble> RHEL6 source packages, so that we can avoid overriding files/RPMs.
20:29:01 <tremble> As such, be very careful when updating this package.
20:29:09 <nirik> oh yeah, that.
20:29:16 <nirik> sounds good. Make it so! :)
20:29:34 <tremble> Okay I shall start dropping that file into Repos.
20:30:10 <tremble> I said "where possible" because I actually found a package that doesn't build in koji due to a missing dep on perl-CGI.
20:30:22 <nirik> ;(
20:30:45 <tremble> #action tremble to start putting a warning message into EL-6 branches where we're rebuilding RHEL SRPMS.
20:31:23 <tremble> Any Other Business?
20:31:32 * nirik can't think of his.
20:32:03 <tremble> Closing in 1 minute if nobody comes up with anything...
20:32:46 <nirik> thanks for running the meeting tremble!
20:33:04 <tremble> #endmeeting