20:58:54 <brunowolff> #startmeeting Spins SIG 2010-10-11
20:58:54 <zodbot> Meeting started Mon Oct 11 20:58:54 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:58:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:59:06 <brunowolff> #meetingname spins-sig
20:59:06 <zodbot> The meeting name has been set to 'spins-sig'
20:59:13 * nirik is here.
20:59:17 <brunowolff> #topic Who's here?
20:59:39 <brunowolff> Good, I mostly wanted to ask you about branching at the meeting!
20:59:53 <brunowolff> #topic spins status
21:00:19 <brunowolff> I guess we have to wait a bit to see if everything starts working again.
21:00:25 <nirik> I have no idea what happened to the git repo. ;(
21:00:36 <nirik> it must have run into a network issue and not updated right...
21:00:48 <brunowolff> But both the broken links and the desktop size change appeared to happen on the same day.
21:01:40 <brunowolff> I wouldn't worry about it. Being able to look at the nightly builds and history makes it a lot easier to notice brokenness compared
21:01:48 <brunowolff> to what used to happen in the past.
21:02:41 <brunowolff> I'll try to remember to look again tomorrow to make sure everything got fixed.
21:02:55 <nirik> yeah, no branched compose today due to comps breakage.
21:03:02 <nirik> I can run them as soon as we have one.
21:03:37 <brunowolff> The board hasn't confirmed the Meego stuff is all set, but I'm assuming that's just a formallity and won't block anything other than the
21:03:47 <brunowolff> status setting based on that.
21:04:16 <nirik> yeah.
21:04:19 <nirik> I hope so too.
21:04:38 <brunowolff> There have been a couple of minor updates recently to the repo, but nothing that looked bad.
21:05:13 <brunowolff> In general things look good on that front.
21:05:24 <brunowolff> #topic branching
21:05:25 <nirik> yeah... knock on wood
21:06:16 <brunowolff> I had branching scheduled for the 12th and rebuilding the package if there had been any changes since beta. (Which there
21:06:21 <brunowolff> has been.)
21:06:49 <nirik> ok, so we have a f14 and a master branch after that?
21:06:58 <nirik> and I should have nightlys build from f14 for now?
21:07:03 <brunowolff> When I did that schedule I assumed I could push the package update quickly, since it was unlikely to break anything else.
21:07:42 <brunowolff> So I think for next cycle, I think we need to do that a week before freeze.
21:08:10 <nirik> yeah, sounds reasonable. to allow more time to push out, etc.
21:08:25 <brunowolff> I had a plan to do one after release if any changes happened after the freeze anyway, so even if the update doesn't get in the iso,
21:08:30 <brunowolff> it's not a big deal.
21:09:14 <brunowolff> So I need to check with you about having the nightlies track a new f14 branch instead of master until shortly after the release.
21:09:52 <nirik> yeah, i think that should be not much problem.
21:09:59 <brunowolff> Plus I think I want to see at least one set of updates with your fix, before making another change.
21:10:01 <nirik> just need to change the script to -b f14 or whatever it's called.
21:10:37 <nirik> sounds good.
21:11:21 <brunowolff> Do you think it will be a problem if a set of nightlies gets done from master instead of f14 after f14 is created?
21:11:55 <brunowolff> If that isn't a big deal, than I'll just plan on doing after I see a good update and then announce to the spins list.
21:12:42 <nirik> it shouldn't be... unless someone commits something crazy to master
21:12:42 <brunowolff> If another set gets built inbetween, there could in theory be a change intended for f15 that shows up.
21:12:46 <nirik> which I think is unlikely.
21:13:11 <brunowolff> Me too. And it should get fixed on the following builds unless new breakage was introduced.
21:13:49 <brunowolff> So I think that sounds like a reasonable plan.
21:13:56 <nirik> yeah.
21:14:25 <brunowolff> #action brunowolff will do the branch after the nighly composes get another good build.
21:14:55 <brunowolff> #topic QA
21:16:08 <brunowolff> I still haven't done the QA choices. I'll really get it done this week. As it should be done during the freeze which is about to start.
21:16:51 <brunowolff> #topic No meeting scheduled for Spins SIG future
21:17:16 <brunowolff> No one got back to me about scheduling a meeting to discuss the future of Spins SIG yet.
21:17:21 <nirik> ;(
21:17:37 <brunowolff> I look at poking people about it again next week, if I don't hear anything.
21:17:46 <nirik> I suppose we could just announce that we are going to not do spins in f15 and see who shows up...
21:18:35 <brunowolff> Well, I think it will be different. But exactly how I don't know. Probably a few will get handled by their SIGS, and the rest
21:18:44 <brunowolff> will just publish ks files.
21:18:59 <brunowolff> Or ISOs on third party web sites.
21:19:28 <brunowolff> #topic Other stuff?
21:19:38 <brunowolff> Did you have anything else to go over today?
21:20:24 <nirik> nope... nothing I can think of.
21:20:59 <brunowolff> I'll mention again that I really like having the nightly builds for keeping a general overview of stuff in the run up to releases.'
21:21:08 <nirik> yeah, they have been handy.
21:21:12 <brunowolff> OK.
21:21:44 <brunowolff> Thanks for participating, expect an announcement about the branch in the next day or so.
21:21:50 <brunowolff> #endmeeting