21:00:48 <rbergeron> #startmeeting Cloud SIG
21:00:48 <zodbot> Meeting started Thu Oct 21 21:00:48 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:54 <dgilmore> jgreguske: i will
21:00:58 <rbergeron> #meetingtopic Cloud SIG
21:01:23 * rbergeron looks around to see if anyone's about
21:01:30 <rbergeron> jforbes :)
21:01:31 * jforbes is about
21:01:46 <rbergeron> awesome. it may be just us, i'm not sure
21:01:53 <rbergeron> #topic EC2 status
21:02:00 <rbergeron> anything fun to update us on, jforbes?
21:02:00 * obino is about?
21:02:06 <rbergeron> hey obino :) how goes it?
21:02:10 <obino> good thanks
21:02:23 <smooge> here and about
21:02:25 <obino> what does anyone's about means? :D
21:02:34 <obino> what one is doing?
21:02:50 <rbergeron> if you're nearby, in the room, in the channel :)
21:02:50 * jgreguske waves
21:03:00 <rbergeron> heya jgreguske. and smooge :)
21:03:06 <obino> thx
21:03:17 <smooge> needs to see a man about a dog and will be back
21:04:23 <mdomsch> I've been trading mails with Amazon re yum repo hosting
21:04:32 <mdomsch> which is to say, i asked, they said they'd get back to me
21:04:36 * skvidal listens
21:04:47 <skvidal> oh
21:04:52 <skvidal> that's not very interesting
21:04:55 <mdomsch> they apparently do have a tool they use to sync yum repos into S3, but they're not sure if they can give it to us to use
21:04:58 <jforbes> mdomsch: I was copied on those emails, right? or are there others?
21:05:05 <mdomsch> jforbes: you were yes
21:05:36 * skvidal wonders what special about a yum repo on s3 vs any other data
21:05:41 <jgreguske> Not to be judgmental, but if we want to get info from Amazon, push hard before the US holidays & shopping season start
21:05:50 <jgreguske> because that is a big time for them
21:05:56 <jforbes> right, so nate is good about trying to get us info, but there is a bit O red tape
21:06:09 <mdomsch> skvidal: only that it's a file store, you can do puts and gets, but there's no file system to walk...
21:06:11 <jforbes> jgreguske: I doubt so much for the EC2 folks
21:06:21 <mdomsch> so you  have to know what you put into it
21:06:24 <skvidal> ok
21:06:26 <jforbes> All I wanted was a server instance for Christmas
21:06:43 <jgreguske> jforbes: that's what a little bird on the inside told me :)
21:07:00 <mdomsch> so the common tools like rsync are useless with S3
21:07:49 <jforbes> Isnt there an S3 fuse?
21:08:12 <mdomsch> jforbes; yes, but by accounts it's useless for large amounts of data
21:08:16 <jds2001> probably slow as can be.
21:08:39 <jds2001> we'll have F14 up there by the time
21:08:42 <jds2001> F15 comes along :D
21:09:49 <rbergeron> :)
21:10:07 <rbergeron> jforbes: aside from contacting humanz at amazon ... any other issues at this point?
21:10:54 <jforbes> rbergeron: nope, just doing test composes daily at this point to make sure we are in sync with the F14 test composes and dont get any surprises
21:11:18 <rbergeron> okay.
21:11:31 <rbergeron> Do we need to get with some documentation and such for people who intend to use it?
21:11:49 <jforbes> Probably so, yes
21:11:51 <rbergeron> sparks has said he'd be willing to help out, but he needs a frame of reference to get started from
21:12:08 * rbergeron looks for sparks to see if he's around
21:12:16 <jforbes> Okay, if you can point him at me, this is basically my number 1 priority over the next week
21:12:40 <rbergeron> Okay.
21:12:54 <rbergeron> He's sent a few mails to the mailing list, but I can poke him more generally in your direct direction
21:13:10 <rbergeron> #action rbergeron poke sparks to talk to jforbes about docs
21:13:18 <rbergeron> #chair jforbes
21:13:18 <zodbot> Current chairs: jforbes rbergeron
21:14:24 <jds2001> is it as simple as "point at AMI, boot"?
21:15:16 <rbergeron> jds2001: I have no clue ;)
21:15:24 <jds2001> also, this is a somewhat orthognal question, but are there plans to integrate EC2 into libvirt (I realize that it's *slightly* outside the libvirt domain, but somehow withn it)
21:15:25 <jforbes> jds2001: Yes, but we need pointers to the Amazon docs for people who have no clue what EC2 is, and perhaps a bit of background on the login/permissions/etc
21:16:19 <jforbes> jds2001: I asked that about 18 months ago, and was told that it was a good idea, but have not checked on the direction there.  These days there are other tools which might be more suited
21:17:04 * jds2001 not a C coder or would help with it :)
21:18:07 <rbergeron> okay. jforbes, i shot a mail to you and sparks about docs.
21:18:23 <jforbes> Thanks, will take it from there
21:19:11 <rbergeron> mdomsch: do you know when / if we'll find out about the aforementioned sync yum tool stuff, or if it's critical for us to have?
21:19:37 <mdomsch> rbergeron: it's not critical, it's really nice to have though, as it'll cut down on end user's costs
21:20:41 <jforbes> I would really like the full infrastructure piece (yum repos and such) to be a feature of F15, and hopefully done early
21:21:02 <rbergeron> okay. but no eta or anything on that info, at this point
21:21:45 <rbergeron> #info mdomsch to wait for amazon to let him know on yum repo hosting and tools
21:22:10 <rbergeron> #info jforbes would really like the full infrastructure piece (yum repos and such) to be a feature in F15 and hopefully done early :)
21:22:26 <rbergeron> okay. Anyone else have any commentary / questions / status on EC2 stuff?
21:23:06 * rbergeron shall move on
21:23:11 <rbergeron> #topic Any other business?
21:23:18 * rbergeron looks around
21:23:26 <mdomsch> openstack 1.0 released today
21:23:42 <mdomsch> anyone know if the packages are in rawhide yet?
21:24:59 <rbergeron> I'm not sure how up to date the packages are we have offhand. And we only have the swift portion, not the nova portion.
21:25:16 * rbergeron goes and looks
21:25:58 <mdomsch> swift was last built 07-Sept
21:26:06 <mdomsch> is anyone working on this?
21:26:51 <mdomsch> silas owns it
21:27:05 <mdomsch> .fasinfo silas
21:27:06 <zodbot> mdomsch: User: silas, Name: Silas Sewell, email: silas@sewell.ch, Creation: 2008-08-29, IRC Nick: silassewell, Timezone: US/Mountain, Locale: en, Extension: 5113527, GPG key ID: , Status: active
21:27:10 <zodbot> mdomsch: Approved Groups: cla_fedora cla_done packager fedorabugs gitpyjigdo
21:27:14 * rbergeron goes to look in cloud channel for him
21:27:55 * mdomsch is going to the OpenStack Design Conference in a couple weeks.
21:28:04 <mdomsch> It's in San Antonio, so I can just drive down for the day
21:28:18 <rbergeron> ah. they're good guys.
21:28:38 * rbergeron will ping silassewell on the list and see what his plans are
21:28:44 <rbergeron> unless you want to :)
21:29:32 <rbergeron> i'd like to get nova going as well, but it's a lotta packaging work.
21:29:40 <mdomsch> what does it need?
21:30:05 * Sparks is here
21:30:22 <rbergeron> http://nova.openstack.org/getting.started.html#dependencies
21:31:09 <rbergeron> iirc, ke4qqq took a look at it and while we have most of the dependencies covered, a lot of the code was looking like bundled libraries and that type of thing that would need to be undone.
21:31:22 <mdomsch> uh huh
21:31:25 <rbergeron> (my apologies if my recollection is incorrect, which has been known to happen on occasion)
21:31:30 <mdomsch> IPy we already have
21:31:37 <mdomsch> twisted we already have
21:31:59 <mdomsch> tornado we already have
21:32:10 <mdomsch> boto we already have
21:32:31 <rbergeron> yeah - we have most of it covered as far as dependencies, i think with the exception of redis
21:32:32 <mdomsch> so yes, some time, but not new packages
21:32:58 <mdomsch> redis-2.0.3-1.fc15.src.rpm
21:33:26 <rbergeron> heyyyy, where'd that come from
21:33:55 <mdomsch> so, we undo the vendoring, and we're good
21:34:03 <rbergeron> oh, silas, it appears
21:34:28 <mdomsch> I'd love a "yum groupinstall openstack"
21:34:54 <rbergeron> silassewell :) thanks for coming over
21:35:00 <rbergeron> we were just talking about openstack stuff
21:35:19 <silassewell> cool
21:35:48 <rbergeron> mdomsch pointed out that openstack 1.0 went out today
21:35:50 <mdomsch> traceback: http://fpaste.org/NvAq/
21:36:17 <silassewell> yeah, there are a lot of deps missing for the compute (nova) package, I've got a lot of them already packaged but haven't submitted them for review yet
21:37:27 <rbergeron> silassewell: anything we can do to help along?
21:38:26 <silassewell> I'm need reviewers once I get stuff up and obviously people to test
21:38:27 <silassewell> I'll need*
21:38:33 <prabindatta> link for openstack: https://launchpad.net/swift/+download
21:38:48 <silassewell> Swift is already packaged
21:38:53 <silassewell> nova is what you want
21:38:54 <silassewell> https://launchpad.net/nova/+download
21:39:31 <silassewell> is there a wiki page I should track my status or something?
21:40:04 <rbergeron> that would be *awesome* - if you want, you can just plop it on the cloud wiki page and if we need to break it out into something separate, we can.
21:40:11 <mdomsch> or if you need help with reviews
21:40:25 <rbergeron> https://fedoraproject.org/wiki/Cloud_SIG#Current_Projects
21:40:51 <rbergeron> I think some people list their ticket numbers for things to be reviewed, so we can see them easily (in other parts ofthe project)
21:41:34 <rbergeron> whatever you're comfortable with, basically - just make it easier to help others help you, more or less :)
21:41:35 <silassewell> ok, I'll create a page at https://fedoraproject.org/wiki/Cloud_SIG/OpenStack and start getting it all organized
21:41:53 <rbergeron> #action silassewell to make wiki page for tracking OpenStack status
21:42:01 <rbergeron> thanks :)
21:42:12 <rbergeron> mdomsch: do you think that's something that we could do in F15 as a feature?
21:42:25 <mdomsch> absolutely
21:42:26 <rbergeron> (assuming manpower is around)
21:42:33 <mdomsch> that's a great idea
21:42:50 * rbergeron would love to see a bunch of cloud-sig features in F15
21:43:01 <mdomsch> the more server focus for F15, the better
21:43:02 <rbergeron> deltacloud is on that list too
21:43:07 <mdomsch> yep
21:43:18 <rbergeron> and I know they're working on getting things packaged up as well
21:43:44 <rbergeron> #link http://deltacloud.org/page/Packaging_list
21:44:34 <rbergeron> mdomsch: any other F15 thoughts? :)
21:44:48 * rbergeron would like to start recruiting that stuff sooooooon
21:45:14 <jgreguske> after dgilmore tests out spin-appliance in koji, I'll propose image building as an F15 feature too
21:45:46 <rbergeron> #info Would be great to see OpenStack and Deltacloud as features in F15
21:45:53 <mdomsch> jgreguske: awesome.  That's a great feature in the openSUSE Build Service, and it's great to have it in koji too
21:46:07 <jgreguske> agreed
21:46:10 <rbergeron> #info jgreguske would like to propose image building as an F15 feature as well, after dgilmore tests out spin-appliance in koji
21:47:01 <jgreguske> I've been watching the boxgrinder project with interest too, there may be future integration work with Koji there too, depending on how it goes
21:47:06 <rbergeron> Excellent. Feel free to drop your thoughts on it in email to the list, jgreguske - I think momentum on the list helps us out in general in finding community folks to help out.
21:47:12 <jgreguske> but that's 2011 or so I think
21:47:24 <jgreguske> rbergeron: noted
21:47:31 <rbergeron> Yes, I know marek has been starting on packaging that as well (boxgrinder)
21:48:40 <rbergeron> sparks: i didn't mean to ignore you - i was talking to jforbes about documenting stuff on EC2, so I sent you two an email so you could get more acquainted ;)
21:49:01 <Sparks> rbergeron: Awesome.  I just got home and logged in.
21:49:09 <rbergeron> coolio.
21:49:15 <rbergeron> Okay. Anything else?
21:50:20 <rbergeron> silassewell: if you do have any packages that need reviewing in the near-term - poke the mailing list and maybe we can find some folks to help out there, or reference the wiki page you're going to work on with the info. Would probably help out as far as finding some helpers :)
21:50:59 <silassewell> rbergeron: will do
21:51:00 * rbergeron will close out the mtg in a few minutes if nobody else pipes up
21:53:32 <rbergeron> alrighty then. :)
21:53:36 <rbergeron> Thanks for coming, everyone :)
21:53:41 <rbergeron> #endmeeting