19:33:20 <tremble> #startmeeting EPEL
19:33:20 <zodbot> Meeting started Mon Oct 25 19:33:20 2010 UTC.  The chair is tremble. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:33:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:33:30 <tremble> #chair nirik smooge
19:33:30 <zodbot> Current chairs: nirik smooge tremble
19:33:44 <tremble> #topic Roll Call
19:33:50 * nirik is sorta around.
19:33:51 * stahnma here
19:33:55 <stahnma> for 30 minutes
19:33:55 * tremble is here.
19:33:56 * nb is sort of around too
19:35:09 <tremble> #topic agenda
19:35:14 <tremble> * Matters Arising:
19:35:15 <tremble> * - Rubygem rack
19:35:15 <tremble> * - Broken Deps in Stable
19:35:15 <tremble> * Bug List
19:35:15 <tremble> * Conflicting Packages Policy
19:35:15 <tremble> * EPEL support cycle
19:35:17 <tremble> * Open Floor
19:35:18 * abadger1999 here
19:35:33 <tremble> Anything else people want to add?
19:35:39 <stahnma> looks good to me
19:35:43 <nb> not i
19:36:03 * nirik has nothing.
19:36:14 <tremble> #topic Rubygem rack
19:36:25 <stahnma> rack update:  I updated the package.  I sent a note to epel-annoucen and the ruby sig.  I expect everything to go fine. 2 weeks, push to stable and done.
19:36:30 <tremble> I believe this is in testing now?
19:36:40 <stahnma> it has +1 karma already too :)
19:36:59 <nirik> cool. Is there any easy way for interested folks to test it?
19:37:16 <tremble> #info New version in testing, announce message sent, already has positive karma
19:37:38 <stahnma> hmm, not super easy, or at least not in a way that I would consider a good test quickly. '
19:38:00 * maxamillion is here
19:38:03 <maxamillion> late ... but here
19:38:08 <stahnma> i mean very basic stuff is easy to test, but I am more concerned about any potential API breakage or odd rails/sinatra bugs
19:38:18 <stahnma> or even passenger/puppet master
19:38:19 <nirik> yeah, ok
19:38:53 <stahnma> I'd more inclined to leave it testing for the full two weeks, even if it gets enough karma
19:38:57 <maxamillion> stahnma: there any rails apps that could be deployed on the old version, then upgraded and test functionality post upgrade?
19:39:15 <stahnma> maxamillion: possibly, but not if they're using the rails we ship in EPEL.
19:39:23 <stahnma> the rails in EPEL is too old to even be rack-aware
19:39:23 <maxamillion> stahnma: ah
19:39:31 <maxamillion> :(
19:39:41 <stahnma> I don't know of anybody using the epel 5 version of rails anymore
19:40:01 <stahnma> but again, it has abi/api breakage when moving from 2.2 to 2.3.8
19:40:08 <stahnma> stupid ruby
19:40:27 <stahnma> we might have to look at rails 2.2 with some of the CVEs though
19:40:34 <stahnma> I thought I might tackle that next
19:40:56 <stahnma> anyway, that's all for this topic from me
19:41:05 <tremble> #info Next on stahnma's ruby hit list... rails...
19:41:29 <tremble> #topic Broken Deps in stable
19:41:40 <stahnma> rack fixes the last of the ruby ones in epel5
19:41:49 <nirik> I was out last week, so I didn't untag anything last week...
19:41:52 <stahnma> I need to find a way to weed out the centos vs rhel artifacts
19:42:00 <tremble> #info rack fixes the last of the ruby ones in epel5
19:42:02 <stahnma> I just haven't put forth the time
19:42:17 <tremble> #info need to weed out the centos/rhel artifacts still
19:42:19 <stahnma> it's also still on my todo list to mail individual maintainers
19:42:25 <stahnma> rather than just the epel lists
19:42:27 <nirik> I can poke some more on the el5 ones.
19:42:35 <nirik> and start on the el4 ones too.
19:42:35 <stahnma> and also to add x86_64 at least
19:42:57 <stahnma> still not sure on ppc, but I'll cross that bridge when I get there
19:43:03 <tremble> With the broken updates in testing, do we want to consider unpushing them and mailing owners when doing so?
19:43:17 <stahnma> i would vote to finish all cleanup in stable first
19:43:26 <nirik> we could. I don't think testing is as important as stable tho.
19:43:33 <tremble> To prevent anything new turning broken up in stable
19:43:36 <nirik> yeah, I would say lets clean up stable, then move on to testing.
19:43:41 <stahnma> then hopefully we can start usign the stable scripts in testing and have it move from there
19:44:45 <tremble> #info General consensus that we should tidy up stable, then look at testing.
19:45:03 <tremble> Any other thoughts or shall we move on?
19:45:10 <nirik> #action nirik will work on untagging/cleaning up deps as possible this week.
19:45:42 <nirik> move on
19:46:08 <tremble> (making a vague attempt today to put enough in info and actions that the short zodbot logs are useful...)
19:46:16 <tremble> #topic Buglist
19:46:45 <tremble> #info Currently stands at 189
19:47:26 * stahnma closed 1 this week
19:47:28 <stahnma> ;)
19:47:32 * tremble smiles
19:47:43 <tremble> Think I closed off at least one...
19:47:46 <stahnma> I'm still meeitng the minimum :)
19:48:28 <nb> minimum?
19:48:49 <tremble> nb: We're trying to get 1 per person closed off each week,
19:49:02 * nirik slacked, but was gone on vacation. ;)
19:49:03 <nb> oh ok
19:49:06 <stahnma> it's not much, but it's better than zero
19:49:45 <tremble> nb that combined with a little triage has dropped the queue down rather drastically from where it was 2 months ago.
19:50:52 <tremble> #info If anyone wants help on bugs they should feel free to post to the epel-devel mailing list or to ask on #epel and there's a couple of us willing to lend a hand if possible.
19:51:38 <tremble> #topic Conflicting packages policy
19:51:50 <tremble> Anyone remember where everything got with this one?
19:52:00 <nirik> yeah, I thought we decided it last week didn't we?
19:52:50 <nirik> packages shouldn't conflict. If that means you have to configure it to use one over the other, note that in a README.fedora
19:53:08 <tremble> #info packages shouldn't conflict. If that means you have to configure it to use one over the other, note that in a README.fedora
19:53:29 <nirik> at least I thought thats what we decided...
19:53:30 <tremble> I had this vague memory that we took it back to the list...
19:53:30 <nirik> at least for now.
19:53:41 <tremble> or off onto #epel
19:54:17 <nirik> I think derks was going to do that...
19:54:26 <nirik> but then we got more info after the meeting perhaps?
19:55:14 <tremble> Yeah I think there was a discussion on #epel were it was pointed out that there are valid use cases for having both installed
19:55:19 <nirik> dunno. we could wait for derks to decide?
19:55:43 * stahnma has to leave early. I'll catch up on scrollback later
19:55:45 <stahnma> thanks
19:56:04 <abadger1999> I think that nirik's recollection is correct.  The specific case had the specific example of an admin configuring multiple apaches that can use the different modules.
19:56:12 <nirik> right.
19:57:11 <tremble> Okay so let's leave it as above (basically conflicts should be strongly avoided as per Fedora) and move on?
19:57:44 <nirik> sounds fine to me.
19:58:05 <tremble> #topic EPEL support cycle
19:59:02 <tremble> As with the conflicts policy I think we sent it back to the list?  But didn't hear much?
19:59:33 <nirik> yeah.
19:59:40 <nirik> I didn't have a chance to reply there either...
19:59:56 <nirik> there was definite pushback about not allowing new packages to el5 once el6 is released tho.
19:59:58 <tremble> With a consensus that if we can't get the updates from RH we'd stop supporting it in EPEL
20:00:55 <tremble> #info People generally agreed we wouldn't go to a hard "no new packages" policy for EPEL-5 as sooon as RHEL-6 is available.
20:02:13 <tremble> #topic open floor
20:02:41 <tremble> Any one got anything?
20:02:56 <nirik> is there anything else we should do on epel6? seems el6 is in rc mode, so release might happen before too long.
20:03:19 <tremble> #topic Open floor (EPEL-6)
20:04:08 <nirik> we could do a final email to folks who didn't build and say that we will allow others to take over their packages if not built soon?
20:04:16 <tremble> There was a general agreement before that we should attempt to get packages as up to date as possible prior to RHEL6 GA...
20:04:50 <tremble> The big issue with that one has been the whole Workstation/Server split that meant some packages weren't available.
20:05:01 <nirik> yeah.
20:05:16 <nirik> perhaps we will know soon if there will be a productivity channel?
20:05:48 <tremble> I suspect we'll have to wait for GA for such an announcement.
20:06:01 <nirik> see also https://fedorahosted.org/fedora-engineering-services/ticket/41 if anyone would like to help trac in epel6.
20:07:52 <tremble> So we may want to leave EPEL in the "rawhide" style state for say 1 month post GA?  Give people 2 weeks post GA to build then allow people to pickup packages that haven't been built?
20:08:26 <nirik> yeah, that might work... or well, they could just build and use updates like normal at that point...
20:09:05 <nirik> it would be nice to announce epel6 around the same time as rhel6/centos6.
20:09:20 <nirik> perhaps we could keep doing beta until centos6 is released? that would likely be a month or so.
20:09:32 <tremble> Well I don't expect Centos-6 for a month or so...
20:09:38 <tremble> (post GA)
20:10:15 <tremble> 5.5 took a month or so IIRC and this is a bigger step.
20:10:25 <nirik> yeah, not sure.
20:11:24 <nirik> well, we can ponder it and decide later. ;)
20:11:41 <tremble> Send an email to the list?
20:12:26 <tremble> or not worth it yet?
20:13:45 <tremble> #info We need to think about when we want to leave "beta" state and start requiring updates
20:14:04 <tremble> Any other open floor topics?
20:14:13 * nirik has nothing.
20:15:01 <tremble> Closing in 1 minute...
20:16:03 <tremble> #endmeeting