20:59:39 <rbergeron> #startmeeting Cloud SIG
20:59:39 <zodbot> Meeting started Thu Oct 28 20:59:39 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:59:45 <rbergeron> or skip the date, which is what I do. ;)
20:59:50 <rbergeron> #meetingname Cloud SIG
20:59:50 <zodbot> The meeting name has been set to 'cloud_sig'
20:59:53 <jsmith> WORKSFORME
20:59:56 <rbergeron> #topic Roll call!
20:59:56 <gholms> Meh
21:00:02 * jsmith is here
21:00:05 * jforbes is here
21:00:10 <gholms> buck buck biquak
21:00:17 * mdomsch 
21:00:38 * jgreguske waves
21:00:42 <brianlamere> hola!
21:01:08 <rbergeron> woo hoo
21:01:27 <rbergeron> #topic F14 is out next week!
21:01:32 <gholms> Yay!
21:01:41 * rbergeron just wants to take a minute to thank everyone, esp jforbes :)
21:01:45 <rbergeron> we're almost to the finish line.
21:01:53 <brianlamere> yay jforbes!
21:02:04 <jsmith> w00t!
21:02:18 <brianlamere> I thought F15 was the finish line?
21:02:22 <rbergeron> http://press.redhat.com/2010/10/28/fedora-14-has-its-head-in-the-cloud/
21:02:25 <jforbes> heh, there is no finish line
21:02:26 <brianlamere> (ducks)
21:02:29 <gholms> There is no finish line
21:02:32 <rbergeron> Well, once we get to the finish line it starts all over again :)
21:02:33 <jforbes> But F14 is a nice start
21:03:00 <rbergeron> anyway. Thanks to everyone, really, for coming to meetings and helping grow our group. :)
21:03:16 <rbergeron> #topic EC2 Status
21:03:19 <rbergeron> #chair jforbes
21:03:19 <zodbot> Current chairs: jforbes rbergeron
21:03:32 <rbergeron> jforbes: I know you're on track for next week. Need any last minute help with anything?
21:04:07 * gholms wants EBS images  ;)
21:04:07 <jforbes> So, the biggest thing we need to finalize is the bucket names.  Since there is no need (or desire) to have the images inside the mirror structure
21:04:26 <gholms> fedora-images?
21:04:32 <jforbes> My guess was F14-us-west-1 etc
21:04:40 <jsmith> That works for me
21:04:49 <jforbes> gholms: yeah, right now I just have F-14-test
21:04:53 <brianlamere> F14?  you'd tag it with the release?
21:04:54 <gholms> A separate bucket for each release?
21:04:56 <jforbes> But I have to mirror these out
21:05:04 <brianlamere> so it will only have F14, not F13 or F15?
21:05:14 <gholms> How about fedora-images-us-west-1 so we don't have to keep reserving bucket names?
21:05:14 <jforbes> That was the thought
21:05:23 <jsmith> That works as well
21:05:24 <jforbes> Good point
21:05:37 <rbergeron> #chair gholms
21:05:37 <zodbot> Current chairs: gholms jforbes rbergeron
21:05:46 <rbergeron> feel free to note what's agreed :)
21:05:49 <jforbes> Noted and agree
21:06:06 <gholms> ...as in with #agreed
21:06:13 <jforbes> thought zodbot and I don't get along so well :)
21:06:21 <rbergeron> ahh
21:06:26 * rbergeron grins
21:06:34 <rbergeron> zodbot loves you :)
21:06:40 * gholms pets zodbot
21:06:40 <jforbes> #agreed images should live in fedora-images-<region> buckets
21:06:58 <gholms> They can probably go in per-release directories or something.
21:07:14 <jforbes> Yeah, that makes sense
21:08:26 <rbergeron> jforbes: anything else? Did you and spevack work out billing / credit card stuff, etc?
21:08:54 <jforbes> rbergeron: I still need some clarification on that, but that is more for the mirrors piece, and not holding up F14 release
21:09:36 <rbergeron> okay.
21:09:52 <rbergeron> But other than that, we're good? :)
21:10:02 <jforbes> rbergeron: we are
21:10:06 <rbergeron> woot.
21:10:22 <gholms> Any luck figuring out scripts that will update S3 mirrors?
21:10:29 <rbergeron> Anyone else with questions / comments / thoughts / cookies? :)
21:10:35 <rbergeron> ah
21:10:40 <gholms> Ooh, I brought bagels!
21:11:10 <jforbes> gholms: in answer to your EBS backed request, I have some scripts, but I have not had time to test them yet (rhel folks use them though).  I will try to get F14 released with EBS variants too, but I am not promising anything
21:11:20 <mdomsch> gholms: word from Amazon was that yes, they had tools, but no they can't give them to us at this time
21:11:20 <gholms> jforbes: Fair enough
21:11:23 <jforbes> gholms: Got today though monday
21:11:31 <gholms> mdomsch: :(
21:12:05 * rbergeron wonders why on earth they wouldn't give things out that help us help them make more money....
21:12:28 <jsmith> How 'bout on the documentation front?
21:12:40 <brianlamere> jforbes: yeah, and apologies on that; I had some stuff come up that took me out of pocket on everything for a couple weeks.  Lemme know what stage you're at on that jforbes; I can either shoot you a basic PoC for it, or help you get what you have locked down, or...just lemme know
21:12:57 <jsmith> Do people have the information they need to start rolling machines?
21:13:04 <jforbes> They have enough money, dont need any more :)
21:13:10 <rbergeron> lol
21:13:32 <jforbes> brianlamere: thanks :)
21:13:49 <rbergeron> jforbes: i think i read that you're working on some basic documentation, yes?
21:13:53 * rbergeron saw that at some point today
21:14:11 <jforbes> rbergeron: I am
21:14:49 <rbergeron> going on the wiki, i assume? :)
21:14:52 <jforbes> And I have put in a request to get a cloud-kickstarts repository on fedorahosted
21:14:55 <jforbes> rbergeron: I am
21:14:59 <rbergeron> ah
21:15:26 <gholms> jforbes: Thanks
21:15:31 <jforbes> so we can drop the kickstarts, and basic build bits for EC2 (and other hosts)
21:16:20 <smooge> ok sort of here now
21:16:40 <rbergeron> jforbes: how soon do you need that repo?
21:16:45 <rbergeron> is it for tuesday?
21:16:50 <rbergeron> aka launch
21:17:23 <jforbes> rbergeron: not required for tuesday, it is more a build thing, but the sooner the better.  That said, infrastructure is good at taking care of those tickets very quickly, I would be surprised if they dont get it by end of day
21:18:05 <rbergeron> okee dokee.
21:18:40 <gholms> What else is new/old?
21:19:03 * rbergeron has nothing else on ec2 to cover
21:20:11 <rbergeron> anyone else? :)
21:20:58 <gholms> [A tumbleweed drifts past]
21:21:16 * rbergeron laughs
21:21:27 <rbergeron> #topic to F15 and beyond
21:21:31 <rbergeron> A few things here:
21:21:48 <rbergeron> #info rbergeron started a thread on this on the mailing list; feel free to add your thoughts
21:22:17 <rbergeron> Is anyone intersted in cleaning up the Cloud SIG wiki page a bit over the next week or two to get us ready for F15?
21:22:26 <brianlamere> so 15 is where the integration/support for cloud tools will be more of a focus, right?
21:22:37 <rbergeron> Well, we could go that route.
21:22:51 <gholms> It can be.  What do people want to work on?
21:23:05 <rbergeron> I don't have a huge preference or bias here; i just think we have some momentum, and lots of interested parties, and we should start going somewhere, even if that's just supporting what all interested parties are coming to do. :)
21:23:50 * rbergeron notes that we have people finishing up OpenStack packaging, we have the Deltacloud folks from Red Hat packaging, Eucalyptus folks wanting help, and a variety of other things going on as well.
21:23:54 <rbergeron> Which I think is a good start.
21:24:06 <rbergeron> And a lot of those things can be features, which I think would be awesome.
21:24:10 <brianlamere> aye
21:24:14 <jforbes> I think the biggest thing is getting mirrors/infrastructure up, and focus on tools to make these easier to consume and create
21:24:25 * jgreguske agrees
21:24:41 <rbergeron> But if we want to start supporting that stuff, and keeping track of them, or keepign track of anythign in general, i think we could use some wiki rework to support that, and to somewhat enable people to be self-sufficient a bit.
21:24:50 <rbergeron> jforbes: indeed.
21:25:03 <rbergeron> oh, and mgoldmann is workign on packaging boxgrinder, as well, speaknig of consuming and creating.
21:25:16 <jforbes> Oh nice!
21:25:27 <rbergeron> and a huge plus 1 to seeing jboss stuff in Fedora :)
21:25:43 <rbergeron> jforbes: aye.
21:26:12 <rbergeron> So i'd like to make sure we can help each other out as we can, by trying to at least keep track of bz's and whatnot in the wiki, so we have sort of a centralized place where we can find all our collective stuff that is going on.
21:26:21 <gholms> I want to get cloud-init working on Fedora so we and boxgrinder can stop eciting rc.local.
21:26:22 <rbergeron> And if we want tohave a brainstorming section in the wiki page, that works too.
21:26:24 <gholms> *editing
21:26:39 <jforbes> gholms: indeed
21:26:50 <rbergeron> And with that: is anyone interested in taking on wiki re-work? :)
21:27:25 <gholms> [Everyone falls silent and stares]
21:27:37 * rbergeron grins
21:28:18 <rbergeron> okay. Well, we'll find someone :)
21:28:19 <brianlamere> coincidentally, there was a netsplit after you asked that...
21:28:23 <rbergeron> yeah
21:28:41 <rbergeron> ANYONE WANT TO .... omg netsplit now now now
21:28:43 <rbergeron> :)
21:28:52 <gholms> [Nothing happens]
21:28:59 <rbergeron> anyway: if we can keep teh convo going on the list re: f15 stuff, that would be great.
21:29:01 <brianlamere> "coincidence" -
21:29:16 * jforbes is not soo good at making things look pretty
21:29:23 <rbergeron> Since we'll be starting that in, well, less than a week, and feature submission is not long after that.
21:29:39 <gholms> Development on f15 is happening *now.*
21:29:48 <rbergeron> yup.
21:29:52 <brianlamere> yes, assuming we want to be ahead of the curve instead of sneaking in past the deadline :)
21:30:08 <rbergeron> I like being ahead rather than behind :)
21:30:18 <jforbes> We absolutely want to stay ahead of the curve
21:30:53 <rbergeron> so just expect me to be banging that feature drum quite a bit over the next few weeks :)
21:31:13 <rbergeron> ie: happy thanksgiving, DID YOU ADD YOUR FEATURE YET... yummm, turkey
21:31:59 <rbergeron> anyawy.
21:32:05 * rbergeron will move on, unless someone has smoethign to add here
21:32:43 <rbergeron> #topic Any other business?
21:33:16 <rbergeron> #info if you're coming to FUDCon (which I hope you are), you need to book your rooms NOW :)
21:33:21 <gholms> Oh crap
21:33:46 <rbergeron> yeah, me too
21:34:23 * gholms needs to talk to jds2001 about that
21:34:30 <rbergeron> oh, nice!
21:34:34 * rbergeron didn't know you were with jds2001
21:35:10 <rbergeron> And unless anyone else has anything else, I'll close out shortly. :)
21:35:11 <gholms> As long as we're talking about stuff that's off-topic, apparently 111111111 * 111111111 = 12345678987654321.
21:36:06 <silassewell> fun
21:36:56 <gholms> Anything else, or shall we close shop for the night/day/morning/whatever?
21:37:08 <silassewell> If anyone is feeling bored I still need 2/5 packages required for nova reviewed: https://fedoraproject.org/wiki/Cloud_SIG/OpenStack
21:39:09 <rbergeron> cool. :)
21:39:29 <rbergeron> #info looking for some package reviewers:  https://fedoraproject.org/wiki/Cloud_SIG/OpenStack
21:40:53 <gholms> [Frost gathers on the windows]
21:41:04 <rbergeron> thanks for your help there, silassewell :)
21:41:28 <rbergeron> Alrighty.
21:41:33 <rbergeron> Thanks to everyoen for coming.
21:41:46 <rbergeron> And be sure to spread the word on Tuesday :)
21:42:01 <rbergeron> #endmeeting