#fedora-meeting: Fedora Release Engineering Meeting

Meeting started by Oxf13 at 17:03:25 UTC (full logs).

Meeting summary

  1. Roll Call (Oxf13, 17:03:38)
    1. present are nirik dgilmore rdieter skvidal Oxf13 (Oxf13, 17:06:12)

  2. Fedora 14 Release (Oxf13, 17:06:20)
    1. notting also present (Oxf13, 17:07:14)
    2. smooth from releng (Oxf13, 17:09:39)
    3. only needed one RC, and it was delivered on time (Oxf13, 17:09:46)
    4. almost ready to go, just need to create torrent configs (Oxf13, 17:09:54)
    5. ACTION: Oxf13 to finish creating torrent configs and contact pre-seeders (Oxf13, 17:10:04)
    6. poelcat is also present (Oxf13, 17:14:01)
    7. Plan to unlock mirrors and torrents the evening before release (Oxf13, 17:14:14)
    8. releng tasks would be complete for release morning. Release afternoon/evening will do mirrormanager redirect change. (Oxf13, 17:14:37)

  3. Fedora Release Engineering Future (Oxf13, 17:18:45)
    1. Oxf13 (Jesse Keating) to step down as Fedora Release Engineering lead for a years time to work on internal Red Hat source migration (Oxf13, 17:23:17)
    2. dgilmore (Dennis Gilmore) to take over as Release Engineering Lead (Oxf13, 17:23:37)
    3. Transition to happen in 1~ month's time after dgilmore returns from vacation (Oxf13, 17:23:56)
    4. Oxf13 to remain available for contact and knowledge base throughout this time (Oxf13, 17:24:32)
    5. ACTION: dgilmore to take over Fedora releng meetings, potentially arranging a new time (Oxf13, 17:32:31)
    6. Oxf13 to continue working on fedpkg. (Oxf13, 17:36:22)
    7. ACTION: nirik to be on point for updates for the next few weeks (Oxf13, 17:38:54)

  4. Fedora 15 Schedule (Oxf13, 17:45:22)
    1. https://fedorahosted.org/rel-eng/ticket/4233 (poelcat, 17:46:04)
    2. https://fedorahosted.org/fesco/ticket/467 (nirik, 17:50:23)
    3. AGREED: Move feature freeze and all later dates 2 weeks later to make way for FUDCon and Ubuntu release (Oxf13, 18:03:49)
    4. AGREED: Release Engineering accepts amended F15 schedule (Oxf13, 18:05:29)

  5. Package Signing (Oxf13, 18:07:40)
    1. releng plans on reducing to one key to sign all rpms and automatically signing every official build that comes through koji with it. (Oxf13, 18:09:06)
    2. Changes coming in package signing, desire to move to detached signatures, and no longer using gpg for the signatures (Oxf13, 18:10:01)
    3. effort led by RHT security team (Oxf13, 18:11:03)
    4. hopeful timeline is to be able to make x509 sigs by F15, but not necessarily include them (Oxf13, 18:27:27)
    5. skvidal is planning to do a FUDCon session about this. (Oxf13, 18:30:25)
    6. yum api break may be happening soon (Oxf13, 18:34:25)

  6. Rawhide and deltas (Oxf13, 18:34:38)
    1. xz had api change, which results in an odd deltarpm situation (Oxf13, 18:35:05)
    2. delta generation currently broken in rawhide, will attempt to re-enable after inheritance fixes are done. (Oxf13, 18:39:13)
    3. ACTION: Oxf13 to break inheritance between F15 and anything earlier, and force tag all currently inherited packages into dist-f15 (Oxf13, 18:39:35)
    4. developers who want a new build to show up in rawhide will have to explicitly build for rawhide. (Oxf13, 18:39:48)

  7. Open Floor (Oxf13, 18:41:54)


Meeting ended at 18:44:16 UTC (full logs).

Action items

  1. Oxf13 to finish creating torrent configs and contact pre-seeders
  2. dgilmore to take over Fedora releng meetings, potentially arranging a new time
  3. nirik to be on point for updates for the next few weeks
  4. Oxf13 to break inheritance between F15 and anything earlier, and force tag all currently inherited packages into dist-f15


Action items, by person

  1. dgilmore
    1. dgilmore to take over Fedora releng meetings, potentially arranging a new time
  2. nirik
    1. nirik to be on point for updates for the next few weeks
  3. Oxf13
    1. Oxf13 to finish creating torrent configs and contact pre-seeders
    2. Oxf13 to break inheritance between F15 and anything earlier, and force tag all currently inherited packages into dist-f15


People present (lines said)

  1. Oxf13 (167)
  2. skvidal (81)
  3. dgilmore (61)
  4. notting (38)
  5. nirik (28)
  6. poelcat (26)
  7. Southern_Gentlem (5)
  8. rdieter (3)
  9. zodbot (3)
  10. mdomsch (3)
  11. abadger1999 (1)
  12. cjb (1)


Generated by MeetBot 0.1.4.