21:04:49 <jforbes> #startmeeting Cloud_SIG
21:04:49 <zodbot> Meeting started Thu Nov  4 21:04:49 2010 UTC.  The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:05:04 <jforbes> #topic roll call
21:05:06 * eric-smith_ is here
21:05:10 * jgreguske waves
21:05:14 * mmorsi is here
21:05:15 * sgordon is here
21:05:17 * mgoldmann is here too
21:05:26 * ke4qqq looks on from the cheap seats
21:05:27 * mmcgrath is here
21:05:27 * jforbes is here, but really bad at running meetings :)
21:05:53 <jforbes> #topic EC2 status
21:06:35 <jforbes> Soo, images are up, though we are doing a bit of a respin (will leave existing images up as well, just not on the featured page)
21:07:26 <sgordon> what's the reason for the re-spin jforbes ?
21:07:29 <jforbes> And I am working on doing those images (as well as EBS versions) using kvm so that we have images installed by anaconda, and a bit more consistency
21:07:41 <jforbes> sgordon: people wanted a few more packages in the base images.
21:07:47 <sgordon> fair enough :)
21:07:52 <mgoldmann> for the record - link to AMI's: https://fedoraproject.org/wiki/Cloud_SIG/EC2_Images#Fedora_14
21:08:19 <jforbes> sgordon: there is nothing broken in the images (that we know of), but we are going to expand the base to include all of @core
21:08:30 <sgordon> kk
21:08:42 <sgordon> i was wondering if you have any cliff notes on how you are building the images
21:09:01 <sgordon> as i was hoping to possibly include the process is the cloud guide that fedora-docs have started
21:09:10 <sgordon> *in the cloud guide
21:09:17 <mgoldmann> sgordon: I just found this: http://fedoraproject.org/wiki/Publishing_image_to_EC2
21:09:25 <jforbes> I do, but you don't want them.  this new kvm method looks a bit easier, standard kickstart, and easily scripted.  It will all drop very soon
21:09:38 <sgordon> that
21:09:43 <sgordon> that's what i was hoping
21:09:52 <sgordon> i will wait till we can document that process instead :)
21:10:25 <brianlamere> please do ;)
21:10:52 <brianlamere> that's just a "so, you want an image today, running a recent Fedora, eh?" page ;)
21:11:03 <jgreguske> jforbes: you'd use this new method for EBS images too?
21:11:12 <jforbes> jgreguske: indeed
21:11:41 <jgreguske> jforbes: please make sure the list sees that process :) I'm rather curious
21:12:03 <brianlamere> are you pushing to a mounted EBS, then snapshotting that?   Or are you going to be going from kickstart to EBS directly?
21:12:05 <jforbes> jgreguske: with the advantages of using real anaconda, and getting a lot more testing for future releases than appliance-tools
21:12:08 <rbergeron> I fail! :) hi folks
21:12:14 * rbergeron lacked intarwebz here for a few
21:12:17 <jforbes> #chair rbergeron
21:12:17 <zodbot> Current chairs: jforbes rbergeron
21:12:21 <rbergeron> thanks justni
21:12:31 <jgreguske> jforbes: yeah, app-tools hasn't seen much love lately, so I'm interested in alternates
21:12:38 <mgoldmann> brianlamere: is there a chance to do this directly?
21:12:42 <jforbes> brianlamere: not positive yet, I really hate the idea of running an image at all after install
21:13:06 <mgoldmann> EBS volumes can be mounted only on EC2 instances
21:13:20 <brianlamere> jforbes:  wouldn't need to run it, not if you did what was mentioned on the list
21:14:13 <jforbes> mgoldmann: yeah, I know, just need a method to go from image -> ebs.
21:14:22 <brianlamere> jforbes:  start an instance, mount an EBS at X, push the image directly on that mounted EBS, snapshot that EBS.  Then it never ran :)
21:14:52 <smooge> is here (late)
21:15:00 * rbergeron high fives smooges from the late corner
21:15:03 * rbergeron was late too
21:15:06 * mgoldmann kindly says it one more time - this is what BoxGrinder does :)
21:15:32 <brianlamere> mgoldmann: aye, someone said such on the list ;)  if it was you then coolies
21:16:04 <jgreguske> mgoldmann: I'd think BG would be interested in the anaconda method jforbes mentioned too, right?
21:16:04 <mgoldmann> the idea was described by jgreguske
21:16:28 <jforbes> mgoldmann: it does, and it is a decent tool, though when last I looked, F14 was not supported
21:16:33 <brianlamere> it's not elegant, certainly.  But you'd only need to do it once ;)
21:16:38 <mgoldmann> if there is other method to build an image using anaconda - sure
21:16:50 <mgoldmann> but I don't know the process now, will wait for some docs
21:16:51 <jgreguske> mgoldmann: it's always more powerful to say "this image came from the same installer you use on normal hardware" imo
21:17:10 <jforbes> mgoldmann: (easy enoguh to fix) but we still have to come up with a method that releng can use, and they have said nothing that isn't in fedora
21:17:26 <mgoldmann> jforbes: I released 0.6.2 a few minutes ago with F14 support S3/EBS/whatever
21:17:40 <jgreguske> jforbes: rel-eng can be so hard to please :P
21:17:58 <mgoldmann> jgreguske: sure
21:18:19 <mgoldmann> well, still fighting with euca2ools
21:18:27 <jforbes> the other difficulty with doing the kvm method in boxgrinder is running kvm on an EC2 host would be squidgy
21:18:46 <mgoldmann> jforbes: in two weeks / month it'll be there
21:19:53 <jforbes> mgoldmann: will get with you on a boxgrinder method as well then
21:20:24 <mgoldmann> jforbes: it takes exactly 20 min from zero to EBS-based AMI on EC2
21:20:50 <jforbes> So at the moment, that is all I have on EC2 at the moment.  Anyone have anything else?
21:21:06 <jgreguske> how did the mm solution work out?
21:22:10 <jforbes> It hasnt yet that I have heard
21:22:44 <rbergeron> mm? /me needs an acronym check here
21:22:55 <jgreguske> oh, maybe I should read old meeting notes then. Was curious how the update infra worked out
21:23:20 <jforbes> jgreguske: it hasn't that I know of, F14 is updating from the regular mirrors
21:23:54 <jgreguske> ok
21:24:17 <jforbes> The infrastructure piece was always and F15 goal
21:24:43 <rbergeron> jforbes: did you see gholms' questions to the list in response to today's meeting reminder?
21:24:58 <rbergeron> I will likely miss today's meeting, so could you folks please discuss
21:24:58 <rbergeron> what you think of shipping images with...
21:24:58 <rbergeron> a) the @core yum group (jforbes might be working on this)
21:24:58 <rbergeron> b) SElinux enabled like it is on default Fedora installs?
21:24:58 <rbergeron> SElinux works on EC2, but you have to have the @core group installed.
21:25:01 <rbergeron> If you have an image with SElinux disabled you might first have to
21:25:03 <rbergeron> relabel everything.
21:25:32 <jforbes> rbergeron: Is that from gholms? :)
21:25:40 <rbergeron> yes
21:25:44 <jforbes> He already knows we are respining for this
21:25:45 <rbergeron> :)
21:25:57 <rbergeron> for which one
21:26:04 <rbergeron> a?
21:26:14 <jforbes> b is a symptom of a
21:26:56 <brianlamere> jforbes: did the EBS driver patch make any progress?  Last I saw was Ben saying it was rejected upstream; EBS performance is an issue at times, however.
21:27:17 <jforbes> brianlamere: rejected upstream isnt going into Fedora
21:27:41 <jforbes> brianlamere: I haven't seen any updates to satisfy upstream, so not sure what the status is
21:29:24 <rbergeron> okee dokee.
21:29:29 <rbergeron> anything else here?
21:29:56 <rbergeron> Okay. Moving on then
21:30:07 <rbergeron> #topic FUDCon Tempe
21:30:22 <rbergeron> I know a bunchof folks are thinking of coming / planning on coming - if you haven't added yourself to the list, please do so.
21:30:51 <rbergeron> Also, we've apparently filled our block, and so we're renegotiating a second block, but likely at a higher price, so we're also trying to find alternative, comparable priced lodging.
21:31:15 <rbergeron> #info If you are planning on doing a session, please add it to the FUDCon wiki page
21:31:25 <rbergeron> #link http://fedoraproject.org/wiki/FUDCon:Tempe_2011
21:31:28 <rbergeron> :)
21:31:39 <rbergeron> And that's just an announcement from me, local fudcon girl ;)
21:31:51 <rbergeron> #topic F15 Schedule
21:32:11 <rbergeron> #link http://fedoraproject.org/wiki/Schedule
21:32:19 <rbergeron> #info Feature submission deadline is 1/25/2011
21:32:31 <rbergeron> Is anyone currently here planning on submitting cloud-related features?
21:32:41 <rbergeron> mgoldmann? ;)
21:32:43 <mgoldmann> BoxGrinder!
21:32:45 <mgoldmann> :)
21:32:59 <rbergeron> cool. Do you need any help / pointers / etc?
21:33:02 <rbergeron> Or have you already started?
21:33:15 <mgoldmann> definitely I wan to push it as a Feature for F15
21:33:21 <jforbes> I will be glad to help out with any feature submission pieces.  At some point we need to get the page up for infrastructure bits
21:33:41 <mgoldmann> I'm talking with deltacloud guys - they teach me how to add new packages, etc
21:34:03 <mgoldmann> but I don't know how to add a new feature request
21:34:28 <mgoldmann> and what I need to create/fill to make it happen
21:34:34 <rbergeron> #link http://fedoraproject.org/wiki/FeatureList
21:34:43 <mgoldmann> so yes, I would appreciate some help :)
21:34:43 <jforbes> mgoldmann: I can walk you through it when you have time
21:34:50 <mgoldmann> jforbes: perfect!
21:35:51 <silassewell> I'm planning on doing an OpenStack feature, it will be ready way before F15 is released but it makes a nice bullet point.
21:36:13 <mgoldmann> jforbes: I'll ping you next week re guidance
21:36:15 <rbergeron> silassewell: exactly
21:36:26 <mgoldmann> silassewell: same here :)
21:36:29 <rbergeron> mgoldmann: there is also some info at the bottom of that page
21:36:37 <rbergeron> about what to fill out, etc.
21:36:40 <mgoldmann> yes, I'll read it all
21:36:46 <rbergeron> silassewell: do you need some help as well?
21:37:00 <jforbes> silassewell: feel free to ping me as well
21:37:25 <rbergeron> #action jforbes and mgoldmann to get together on some featurelist guidance for BoxGrinder, silassewell can ping jforbes for help as well
21:37:29 <rbergeron> jforbes: thanks!!
21:37:55 <mgoldmann> rbergeron: btw, first step is done - I have RPM's prepared: http://repo.boxgrinder.org/boxgrinder/packages/fedora/13/RPMS/noarch/
21:38:17 <silassewell> jforbes: cool, thanks
21:38:25 <rbergeron> cool ;)
21:38:37 <mgoldmann> for F14 too
21:39:04 <rbergeron> verynice.
21:39:10 <rbergeron> Okay.
21:39:25 <rbergeron> #info If anyone else is planning on submitting features, please drop a note on list so we can start keeping track!
21:39:33 <rbergeron> #topic Possible new meeting time
21:39:46 <rbergeron> So - I know that .. well, tryign to get this meeting time together was ...... difficult
21:40:17 <rbergeron> We have a request from someone on the other side of the planet who would like to participate
21:40:18 <mgoldmann> here is almost 11pm
21:40:27 <rbergeron> http://lists.fedoraproject.org/pipermail/cloud/2010-October/000320.html
21:40:36 * rbergeron noes that she'd much rather go to a meeting at 11pm than 5am ;)
21:40:58 <mgoldmann> true true
21:41:04 <rbergeron> On the other hand, the time proposed here is right in the middle of school runs in the morning
21:41:30 <rbergeron> I'm not sure what alternatives we can come up with here that work for people
21:41:37 <rbergeron> without it just being ungodly late or early for some folks.
21:42:26 <rbergeron> Anyone have thoughts?
21:42:31 <rbergeron> Are we in love with this meeting time?
21:42:44 <sgordon> well, i am in the same boat as the guy in singapore
21:42:57 <sgordon> though it is 7am here so it's a bit more palatable
21:43:21 <silassewell> Mid mornings will be hit or miss for me, depending on work stuff.
21:43:25 <jforbes> Not particularly, but when last we tried, there was not really any time that worked for everyone...  Perhaps we could alternate times to get people included in every other meeting?
21:43:34 <eric-smith> didn't we vote last time to come up with this slot? should we repeat the process?
21:43:44 <sgordon> i don'
21:43:50 <rbergeron> We did, more or less.
21:43:56 <sgordon> don't feel particularly aggrieved
21:43:59 <rbergeron> I guess increasing popularity can be tricky sometimes ;D
21:44:02 <rbergeron> EVERYONE WANTS TO COME
21:44:05 <rbergeron> lol
21:44:17 <sgordon> maybe if you get one or two more requests from this side of the world re-consider
21:44:22 <mgoldmann> uhm :)
21:45:03 <rbergeron> iirc, it's some wacky hour for silassewell as well, right?
21:45:20 <rbergeron> or maybe i'm confused
21:45:23 <silassewell> rbergeron: no, I'm EST
21:45:28 <silassewell> nyc
21:45:28 <rbergeron> ah. lucky ;)
21:45:32 <rbergeron> ooh, double lucky
21:46:21 <rbergeron> Okay. Well, I'll write back to harish on list - I think sometimes it's just difficult to accommodate everyone, but see if he's interested in maybe a alternate time once a month or so.
21:46:30 <rbergeron> Not really a winning situation for anyone.
21:46:34 <rbergeron> :)
21:47:10 <rbergeron> #action rbergeron to mail harish about maybe a once a month meeting on different time - it's just already impossible to schedule this meeting
21:47:14 <jforbes> An alternate time every so often wouldnt be bad
21:47:41 <rbergeron> No, it wouldn't - and may help us pick up new folks also
21:48:08 <eric-smith> agreed
21:48:21 <rbergeron> #topic Any other Business?
21:48:31 * rbergeron gives a round of applause to jforbes, btw ;)
21:48:55 <eric-smith> indeed! thanks, jforbes
21:49:40 <silassewell> If anyone wants to start looking at openstack-nova I'd appreciate any feedback: https://bugzilla.redhat.com/show_bug.cgi?id=649495
21:51:59 <rbergeron> indeed.
21:52:02 <jforbes> Still work to do...
21:52:12 <mgoldmann> so, I want to say goodbye and thank you all for moving this Cloud stuff forward!
21:52:23 <rbergeron> #link  https://bugzilla.redhat.com/show_bug.cgi?id=649495
21:52:35 <rbergeron> #info please help out with reviewing / giving feedback on openstack-nova
21:53:00 <rbergeron> thanks, silas.
21:54:33 <rbergeron> Anyone else?
21:54:44 * rbergeron will close out in a minute if there are no other things
21:56:32 <rbergeron> Thanks for coming, everyone! Looking forward to a good F15 :)
21:56:34 <rbergeron> #endmeeting