14:01:29 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-11-30
14:01:29 <zodbot> Meeting started Tue Nov 30 14:01:29 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:39 <jreznik> #meetingname kde-sig
14:01:39 <zodbot> The meeting name has been set to 'kde-sig'
14:02:02 <jreznik> #chair Kevin_Kofler than_ rdieter_work jreznik
14:02:02 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter_work than_
14:02:40 <jreznik> #topic roll call
14:02:51 * jsmith lurks
14:02:56 <Kevin_Kofler> Present.
14:03:11 <jreznik> jsmith: hi ;-)
14:03:53 * ltinkl is a bit late but present
14:04:03 <jreznik> #chair Kevin_Kofler jreznik rdieter_work than_ ltinkl
14:04:03 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter_work than_
14:04:22 <jreznik> let's wait a moment for rdieter_work and than_
14:04:40 * than_ is present
14:05:32 <jreznik> seems like rdieter_work is afk, let's start, he can join us later
14:06:12 <jreznik> #info Kevin_Kofler than_ jreznik ltinkl present, jsmith lurks ;-)
14:06:21 <jreznik> #topic agenda
14:07:29 <jreznik> anything else for meeting? it looks like the quick one today...
14:07:57 <Kevin_Kofler> Well, there's xsettings-kde, but it's just one sentence to report about it. :-)
14:08:31 <Kevin_Kofler> rdieter and I noticed that the builds I had pushed to testing didn't actually fix the lack of GTK+ app menu icons, I did new ones which actually work.
14:09:40 <Kevin_Kofler> I can't think of other agenda items which are not already on it.
14:10:10 <jreznik> #info Kevin_Kofler fixed xsettings-kde to support  GTK+ app menu icons properly
14:10:34 <jreznik> #topic kde 4.5.4 status
14:10:39 <than_> Kevin_Kofler: ist the new one pushed to testing?
14:11:09 <Kevin_Kofler> I queued it, it's not pushed yet, it'll be pushed during the next push.
14:11:59 <jreznik> ok, back to the topic - 4.5.4 status
14:12:19 <jreznik> seems like all tarballs needs respin
14:12:39 <Kevin_Kofler> Right, upstream accidentally tarred up the wrong tag.
14:12:57 <Kevin_Kofler> All tarballs got respun and the release delayed until Thursday.
14:12:59 <than_> yes, i'm uploading 4.5.4 respin
14:13:05 <jreznik> than_: when you expect to finish it? do you need help?
14:13:49 <than_> 4.5.5 import should be done today
14:13:57 <than_> s/4.5.5/4.5.4
14:14:32 <jreznik> ok
14:14:32 <than_> we still need 4.5.4 buildtarget for f13(f14
14:14:53 <jreznik> yep, we need buildtarget, rdieter_work should prepare it
14:14:54 <than_> rdieter will take care of it
14:15:10 <than_> i will ping you when i need help
14:15:44 <jreznik> #info than reuploading kde 4.5.4 tarballs as upstream accidentally tarred the wrong tag
14:16:12 <jreznik> #info rdieter to set up f13/14 kde 4.5.4 buildtarget
14:16:18 <jreznik> than_: ok
14:16:26 <jreznik> anything else?
14:17:22 <jreznik> ok, move on
14:17:29 <jreznik> #topic knetworkmanager: vpnc, pptp, opnvpn on live images?
14:18:03 <jreznik> .bug 601056
14:18:05 <zodbot> jreznik: Bug 601056 LiveCD-KDE does not contain plugins for knetworkmanager - https://bugzilla.redhat.com/show_bug.cgi?id=601056
14:18:09 <ltinkl> space isn't an issue here, why not?
14:18:20 <Kevin_Kofler> Yeah, this is really just a question of how.
14:18:30 <Kevin_Kofler> Do we just change them from optional to default in comps-f15?
14:18:40 <Kevin_Kofler> (They already got added as optional.)
14:18:49 <Kevin_Kofler> Or do we want to merge them into the main package altogether?
14:18:53 <jreznik> ltinkl: with all deps?
14:19:10 <Kevin_Kofler> jreznik: It's only ~1 MB with all deps.
14:19:34 <jreznik> Kevin_Kofler: ah, ok - then it sounds reasonable
14:19:38 <than_> Kevin_Kofler: i don't see problem if it's only 1mb with all deps
14:19:39 <Kevin_Kofler> I think the comps change is probably best for now.
14:19:40 <ltinkl> I don't understand why it isn't put together in one package
14:20:09 <Kevin_Kofler> (but I can see the case for just getting rid of the useless subpackage split)
14:20:22 <Kevin_Kofler> ltinkl: Because upstream goes out of their way to ship the stuff as plugins.
14:20:26 <ltinkl> the app itself doesn't tell you to install the appropriate plugin if needed
14:20:37 <jreznik> ltinkl: yep, that's the problem
14:20:43 <Southern_Gentlem> ?
14:20:46 <ltinkl> which sucks because the user doesn't even know there is support for those VPNs
14:20:49 <jreznik> and using package kit is overhead
14:21:14 <jreznik> to install missing vpn plugin automatically
14:21:27 <ltinkl> exactly, so the user might never find out
14:21:36 <than_> Kevin_Kofler: yes, i agree comps change is best
14:21:51 <Southern_Gentlem> isnt the correct way to add this things to the livecd is resubmit a ks to the spins group
14:22:13 <Kevin_Kofler> Southern_Gentlem: No.
14:22:39 <Kevin_Kofler> kde-plasma-networkmanagement is part of KDE, the KDE comps group is the right place to list it.
14:22:42 <jreznik> #info all dependencies are just 1 mb
14:22:49 <Kevin_Kofler> (That way, KDE installs from the DVD also get it.)
14:23:21 <Kevin_Kofler> So:
14:23:26 <Kevin_Kofler> Proposal 0: Do nothing.
14:23:45 <Kevin_Kofler> Proposal 1: Make the kde-plasma-networkmanagement-* subpackages default instead of optional in comps.
14:24:00 <Kevin_Kofler> Proposal 2: Explicitly list the kde-plasma-networkmanagement-* subpackages default on the live CD kickstart.
14:24:05 <jreznik> 0: -1
14:24:15 <Kevin_Kofler> Proposal 3: Merge them into the main package.
14:24:33 <Kevin_Kofler> I think 2 is the wrong solution, and 0 only makes sense if we're really out of space.
14:24:35 <than_> Kevin_Kofler: 1: +1
14:24:51 <jreznik> 1: what about future deps? for example vpnc replaced by mega hyper cool VPNKit with hundred deps ;-)
14:24:52 <Kevin_Kofler> It's either 1 or 3, and I don't care all that much about which one we pick.
14:25:18 <Kevin_Kofler> jreznik: 1 still allows us flexibility there, 3 is the problem approach.
14:25:31 <Kevin_Kofler> (in case deps skyrocket, I mean)
14:25:37 <jreznik> yep
14:25:52 <jreznik> so I incline more to 1
14:26:13 <Kevin_Kofler> The difference is that 3 allows people to install k-p-nm without the VPN support if they want.
14:26:33 <Kevin_Kofler> Which is IMHO a good thing, but on the other hand it also means that VPN won't work if they do it accidentally.
14:26:35 <jreznik> Kevin_Kofler: 1 allows
14:26:45 <Kevin_Kofler> Uh, yes, 1 allows it, 3 doesn't.
14:27:16 <jreznik> Kevin_Kofler: but if you don't install it - it's your problem, by default it will be installed
14:27:31 <than_> jreznik: yes, it's user problem
14:27:34 <Kevin_Kofler> 1. is the more flexible approach.
14:27:40 <Kevin_Kofler> So we're agreeing on proposal 1?
14:27:41 <jreznik> on the other hand - getting rid of VPN if you are never going to use it - it's nice offer to them
14:27:52 <jreznik> I'm +1 for 1
14:28:02 <jreznik> ltinkl: ?
14:28:03 <Kevin_Kofler> ltinkl? (You seemed to advocate doing 3., what do you think?)
14:28:41 <ltinkl> either 1 or 3 is fine with me
14:29:12 <jreznik> I think we agreed - proposal 1
14:29:15 <Kevin_Kofler> Yes.
14:29:30 <Kevin_Kofler> 2 votes for 1, 2 for "1 or 3", means 1 passes.
14:29:39 <jreznik> #agreed make the kde-plasma-networkmanagement-* subpackages default instead of optional in comps.
14:29:58 <jreznik> anyone taking the task?
14:30:22 <Kevin_Kofler> I can do it.
14:30:34 <jreznik> Kevin_Kofler: thanks
14:31:03 <jreznik> #info Kevin_Kofler to update comps according accepted proposal
14:32:13 <jreznik> I think it's all, move on
14:32:25 <jreznik> #topic open floor
14:32:40 <jreznik> anything else?
14:33:51 <jreznik> ok, it was a quick meeting as I expected :)
14:34:07 <nucleo> qt-4.7.1?
14:34:36 <nucleo> testing it< works fine
14:36:53 <Kevin_Kofler> Well, F14 already has it:
14:36:56 <Kevin_Kofler> qt-4.7.1-3.fc14                           dist-f14-updates      rdieter
14:37:03 <jreznik> yep, it's already in stable
14:37:14 <jreznik> 2010-11-28
14:37:20 <Kevin_Kofler> F13 is another question.
14:37:24 <Kevin_Kofler> It's still on 4.6.
14:37:31 <nucleo> didn't noticed this ( I installed from updates-testing)
14:37:45 <Kevin_Kofler> F12 definitely will not get 4.7, its EOL is 2 days from now.
14:38:57 <jreznik> Kevin_Kofler: yep, no F12...
14:39:38 <jreznik> F13 - I don't feel the need for it from users but more voices against (but just voices, no arguments :(
14:41:02 <Kevin_Kofler> FYI: https://bugzilla.redhat.com/show_bug.cgi?id=601056#c5
14:41:07 <Kevin_Kofler> http://git.fedorahosted.org/git/?p=comps.git;a=commit;h=de392ced777bb3e14c975a36d8533083a8719f0f
14:42:07 <jreznik> Kevin_Kofler: thanks
14:46:03 <jreznik> ok, I think it's all today
14:46:31 <jreznik> waiting one more minute... 59, 58...
14:48:06 <jreznik> #endmeeting