21:02:44 <rbergeron> #startmeeting Cloud SIG
21:02:44 <zodbot> Meeting started Thu Dec  2 21:02:44 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:48 <rbergeron> #meetingname Cloud SIG
21:02:48 <zodbot> The meeting name has been set to 'cloud_sig'
21:03:04 <rbergeron> #topic Roll Call!
21:03:19 * jforbes is here
21:03:23 * clalance is here
21:03:36 <clalance> jforbes: Hello Justin :).
21:03:51 <jforbes> heya clalance :)
21:03:53 <rbergeron> oh, there's jforbes ;)
21:03:55 <rbergeron> hey clalance.
21:04:03 * mdomsch 
21:04:10 <clalance> rbergeron: Hey ther.e
21:04:29 * rbergeron holds a moment for other folks
21:05:28 <rbergeron> alrighty.
21:05:35 <rbergeron> #topic EC2
21:05:54 <rbergeron> So I guess while we have a captive audience :) https://bugzilla.redhat.com/show_bug.cgi?id=651861
21:06:06 <rbergeron> clalance: thanks for piping in on this ticket, btw.
21:06:30 <clalance> rbergeron: Ah, no problem.  I did xen for plenty of years, so I can help sometimes :).
21:06:43 * rbergeron would throw you a box of cookies or bacon if you were any closer.
21:07:16 <rbergeron> jforbes: so - do we have an easy way of asking amazon if they can fix the hypervisor?
21:07:27 <jforbes> rbergeron: no, they cant
21:07:39 <jforbes> rbergeron: trust me, it would make our life much easier, but it aint going to happen
21:07:48 <clalance> rbergeron: I think the best thing to do here is to fix up the kernel? package to do the nosegneg thing.
21:07:50 <rbergeron> can't or won't?
21:07:57 <clalance> jforbes: And then can we respin the amazon AMIs?
21:08:11 <rbergeron> clalance: do we know what that involvees?
21:08:31 <jforbes> so the fix for this, is to add hwcap 1 nosegneg
21:08:34 <rbergeron> hola mr. darcy
21:08:38 <jdarcy> Hi all.
21:08:54 <jforbes> and I have that, though I cannot produce images at the moment due to an augeas bug I am trying to work around
21:09:19 <clalance> jforbes: Ah, cool.  I forget; is that equivalent to what bonzini mentioned in comment #48?
21:09:54 <jforbes> clalance: no, that would be a new build, which is not desirable
21:10:21 <jforbes> but similar results we can do in post on EC2 image generation...
21:10:31 <clalance> jforbes: OK, gotcha.
21:11:03 <rbergeron> jforbes: does it make sense to reassign this ticket to you?
21:11:45 <jforbes> rbergeron: sure, since I do not see this being fixed by crippling glibc for the rest of us anymore...
21:11:55 <rbergeron> okay.
21:12:11 <rbergeron> #action rbergeron get bz651861 reassigned to jforbes
21:12:13 <jforbes> grabbing it now
21:12:20 <rbergeron> oh. well thank you ;)
21:12:39 <jdarcy> BTW, thanks to Chris Lalancette for explaining this stuff to me.
21:12:47 <rbergeron> indeed.
21:12:55 <rbergeron> and thanks to you for helping out ;)
21:13:23 <rbergeron> anyone else have any ec2 business to discuss?
21:13:58 <jforbes> There was talk on the lists of increasing the root size to 10G for the next spins... this makes sense to me, so I had planned to do it... Anyone opposed for any reason?
21:14:13 * rbergeron has no opposition to that
21:14:20 <clalance> Sounds like a good idea to me.
21:14:47 <rbergeron> #action jforbes increase root size to 10G for next ec2 spins
21:15:02 <rbergeron> jforbes: some folks have been asking around about ebs - what's shakin with that?
21:15:12 * rbergeron wields the action probably a bit too fast, lol
21:16:31 <jforbes> rbergeron: same thing, we switched to boxgrinder for image builds, it seems the best method for easy generation.  It was working briefly, but seems to no longer work.  libguestfs has an issue with augeas.  This is fixed in the latest F14 augeas, but not f13, so I am trying to get a working build system
21:16:48 <rbergeron> ahhhh.
21:16:53 <jforbes> mgoldmann has been very helpful in getting the process moving.
21:16:59 <rbergeron> awesome.
21:17:07 * rbergeron notes mgoldmann is now coming to fudcon too ;)
21:17:14 <jforbes> oh great!
21:17:17 <rbergeron> yep.
21:17:40 <clalance> I may come as well, though that is not set in stone yet.
21:17:54 <rbergeron> so it might be a good opportunity to do... <insert something awesome and collaborative here that would be more productive in person>
21:18:00 <rbergeron> (feel free to think about it)
21:18:11 <rbergeron> clalance: excellent
21:19:22 <rbergeron> #info ebs-backed stuff is still in progress; jforbes has some issues with augeas that he's working through
21:20:13 <rbergeron> okee dokee.
21:20:27 * rbergeron guesses there's not anything else EC2-related, so shall move on....
21:21:14 <rbergeron> #topic Cloud-ish Features in F15 - OpenStack, CloudFS, Deltacloud, & friends
21:21:28 <rbergeron> jdarcy - need any assistance / reviewing love / etc?
21:22:05 <jdarcy> I might soon.
21:22:15 * rbergeron hasn't checked lately how deltacloud packaging is coming along, and will check it out, unless someone else knows offhand
21:22:20 <jdarcy> I've finished the at-rest-encryption translator, I could use some eyeballs on that.
21:22:33 <clalance> rbergeron: I'm not sure, I haven't heard anything recently.
21:22:54 <rbergeron> jdarcy: want to send a mail to the list asking for eyes? or have the info/link handy for mtg logs?
21:22:56 <clalance> rbergeron: We also probably want to try to get the deltacloud aggregator (cloud engine) in, though I'm not sure if we'll have something in time.
21:22:57 <jdarcy> First I need someone to complete my infrastructure request to host it.  ;)
21:23:04 <rbergeron> orly
21:23:08 <rbergeron> do you know that # :)
21:23:21 * rbergeron can probably find someone to do that :)
21:23:45 <jdarcy> I'll do some more poking, if nothing budges I'll raise the flag.
21:24:32 * clalance steps away for 2 minutes
21:25:01 <ke4qqq> jdarcy: you want caps in your project and repo name?
21:25:38 <jdarcy> ke4qqq: I generally prefer CloudFS, but it's not a big deal.
21:25:56 <ke4qqq> jdarcy: ok - I'll get it knocked out this afternoon
21:26:24 <rbergeron> ke4qqq: i'll add another box of cookies to ur pile, thanks.
21:26:38 <jdarcy> ke4qqq: Thanks!  :)
21:26:45 <ke4qqq> np
21:26:50 <rbergeron> woot.
21:27:23 <rbergeron> alrighty - anything else? I know mgoldmann couldn't make it, but he's coming along on the BG stuff as well.
21:28:13 <jforbes> oh, right
21:28:19 <rbergeron> jforbes: ?
21:28:57 * rbergeron just saw clalance's comment about cloud engine - will poke him later about what the timeline on that might be
21:28:59 <jforbes> he asked me to have someone familiar waith euca2ools take a look at https://jira.jboss.org/browse/BGBUILD-55
21:29:26 <rbergeron> yeah, he was looking for obino earlier, i suspect gholms might be able to assist there too.
21:29:44 <rbergeron> #action rbergeorn ping on list about someone familiar with euca2ools to look at https://jira.jboss.org/browse/BGBUILD-55
21:30:03 * rbergeron knows there is trouble when she can't even type her own last name
21:30:09 * clalance back now
21:30:28 <rbergeron> clalance: ^^ any ideas on timeline about cloud engine?
21:30:51 <rbergeron> and is that part of deltacloud or would that be a separate ... oh god, here comes the marketing speak... building block all on its own?
21:30:52 <clalance> rbergeron: When is the F-15 feature deadline?  (probably already passed, I always miss these things)
21:31:00 <clalance> rbergeron: It is separate.
21:31:08 <rbergeron> clalance: WOO THATS MY NEW JOB TO KNOW... let me look
21:31:09 * rbergeron grins
21:31:21 <clalance> rbergeron: Though it requires deltacloud API, of course.
21:31:27 <rbergeron> http://fedoraproject.org/wiki/Schedule
21:31:29 <rbergeron> Jan. 25
21:31:36 <clalance> rbergeron: We have packages that definitely work on F-13, more-or-less work on F-14 now.
21:31:55 <clalance> rbergeron: The problem is that it requires one non-free package.
21:32:30 <clalance> rbergeron: (ec2-ami-tools, or whatever it is called)
21:32:52 <clalance> Assuming BG now can use euca2ools, we could switch over to that, though that will require a bit of work to test/fix.
21:33:02 * rbergeron nods
21:34:00 <rbergeron> clalance: well I think it'd be good to keep in mind.  If there are things you think that can be tested by community folks, and y'all can help out with some documentation on how to test / what to look for, that would surely help out.
21:34:11 <clalance> Absolutely.
21:34:53 * rbergeron notes that those testing notes apply to all other features - we have people happy to help out as much as they can, but documentation on how to test - even basic stuff - *really* helps out as far as testing beyond the
21:35:02 <rbergeron> "test passed! it installed"
21:35:04 <rbergeron> type of testing.
21:35:05 <rbergeron> :)
21:35:06 <clalance> ;)
21:35:40 <jforbes> We can also hold a cloud test day for F15 if we have enough features to justify it... I would be happy to get it together
21:35:50 <rbergeron> jforbes: that would be ultra cool.
21:36:11 <rbergeron> I think that would also be something where we could do some rough ideas of what to test / how to test it type stuff at fudcon.
21:36:16 <jdarcy> Hm, maybe I could use BoxGrinder to cook up CloudFS server images.
21:37:08 <jforbes> rbergeron: I will get one together, maybe we can work out some requirements over the next few weeks, discuss it at fudcon a bit
21:37:13 * rbergeron thinks it would also be helpful to know how to put this stuff together and do things with it, as another idea for fudcon
21:37:20 <rbergeron> jforbes: sounds good.
21:37:52 <rbergeron> #action jforbes / rbergeron to start thinking about Cloud Testing Day -- requirements, etc.
21:38:16 <rbergeron> jforbes: you know I'm not much help on the technical side of things but I'll do what I can there. If nothing else, I will stock up on cookies.
21:38:23 <rbergeron> :)
21:38:30 <jforbes> rbergeron: it is appreciated!
21:38:49 <jforbes> rbergeron: (cookies are too actually)
21:39:12 <rbergeron> jforbes: I'm glad I live local to fudcon because I can bring lots of cookies ;)
21:39:25 * rbergeron will refrain from buying a cloud cookie cutter though
21:39:53 <jforbes> fudcon seems to be bad enough for my waistline due to the unusually high amount of hops and barley consumed
21:40:06 <rbergeron> jforbes: I will be doing my part to contribute to that ;)
21:40:17 <jsmith> jforbes: I've really been thinking hard about doing a Cloud FAD -- are you still in Texas?
21:40:25 <jforbes> jsmith: I am
21:40:34 <jsmith> Hmmmmn....
21:40:41 <rbergeron> jsmith: were you thinking pre- or post- fudcon?
21:40:51 * jsmith looks at his calendar, and wonders if it's going to be feasible for him to attend
21:40:53 * rbergeron knows you are like, travellin man during january/early february
21:41:06 <jsmith> rbergeron: I'm pretty much on the road from now until the middle of Feb
21:41:55 <rbergeron> jsmith: my apologies ;)
21:42:16 <rbergeron> #topic Possible Cloud FAD
21:42:29 <rbergeron> jsmith: what were you thinking of accomplishing?
21:42:35 * rbergeron loves grilling the FPL
21:42:37 <rbergeron> :)
21:42:45 <rbergeron> gholms! ;)
21:42:48 <gholms> :D
21:43:05 * gholms bursts through the door and takes a seat
21:43:33 <rbergeron> how goes it?
21:43:39 <jsmith> rbergeron: Two things... documentation for how to build the EC2 images, and getting them more spun up into rel-eng
21:43:57 <rbergeron> jsmith: yeah, that would be awesome to have integrated with the rel-eng process.
21:44:05 <jforbes> gholms: you might have some input on euca2ools issues mgoldmann is running into.  he asked that I brought up https://jira.jboss.org/browse/BGBUILD-55 to euca2ools people
21:44:28 <clalance> jforbes: Is that still in progress?
21:44:46 <clalance> Arg, yeah, I see that.
21:44:49 <clalance> That is unfortunate.
21:44:51 <jforbes> jsmith: yes, that is the biggy, we need to get a handoff to releng early in the F15 process so that testing images make it
21:44:53 <gholms> Oh yeah, that bug.  I wish I had some idea what the deal was.  :-\
21:44:55 <rbergeron> do you think it's something best sketched out during FUDCon (ie: here are 2-3 days worth of things the Cloud SIG thinks it could get accomplished at a FAD that are important outcomes from what we do at fudcon) ?
21:46:25 <rbergeron> jsmith: ^
21:46:36 <rbergeron> or jforbes, or gholms ;)
21:46:38 <jforbes> FUDcon would be a good place to really get the ball rolling on it, though it is fairly late to start scheduling
21:46:46 <rbergeron> (gholms: jsmith suggesed having a cloud FAD)
21:46:46 <jsmith> Yup
21:47:04 <jsmith> rbergeron: I'm afraid that people's attention will be split at FUDCon as well, to be honest
21:47:05 <gholms> FAD?
21:47:16 <rbergeron> jforbes: yeah, I'm going to be kind of, um, hectic during january.
21:47:23 <rbergeron> gholms: Fedora Activity Day(s)
21:47:29 <gholms> Sounds fun.
21:47:45 <rbergeron> ie: fly everyone to one spot for a few days and hack on $somethingthatgetsalotdoneinperson
21:47:54 <gholms> The hard part would be gathering all the right people at once.
21:47:59 <clalance> rbergeron: I have to bail (heading out to a hockey game).
21:48:00 * rbergeron apologies to tom for invoking his name
21:48:04 <jforbes> rbergeron: Yeah, I dont mean actually doing it in January, but doing the scheduling in earlier january would probably be better than early febuary
21:48:06 <rbergeron> clalance: i'm jealous. have fun ;)
21:48:20 <rbergeron> jforbes: I agree
21:48:21 <clalance> rbergeron: You probably don't need me for anything, but I'll try to keep you apprised of the situation with the aggregator.
21:48:24 <jforbes> clalance: thanks for coming in
21:48:28 <rbergeron> clalance: awesome. thank you
21:48:33 <clalance> (and I'll try to make this meeting more often)
21:48:35 * rbergeron bows
21:48:35 <clalance> Bye!
21:49:19 <rbergeron> jsmith: You don't think an hour session where we could throw out ideas and decide on a FAD time/place/topic would do the trick?
21:49:25 <gholms> How realistic do you suspect a productive cloud FAD would be?
21:49:40 <rbergeron> I think we're probably going to be practically our own track at times ;)
21:49:51 <rbergeron> with the # of cloud things being presented
21:49:57 <jsmith> rbergeron: The problem is -- if we wait until FUDCon to schedule the FAD, the FAD will be too close to F15 release.
21:50:05 <jforbes> gholms: depends on the goals of the FAD but if we define the goals ahead of time it could be very productive
21:50:07 <jsmith> rbergeron: I'd rather get things spun into rel-eng *early*
21:50:19 <jsmith> Maybe we'll get the work done early and have no need for a FAD
21:50:21 <jforbes> jsmith: I agree there
21:50:38 <gholms> Hmmm...
21:50:56 <rbergeron> so - what if we extended fudcon into a cloud FAD for a few days post-fudcon?
21:51:08 * rbergeron is just throwing ideas out - i realize it's complicated as we've already got people with plane tickets and such
21:51:25 <rbergeron> anhd a week of travel just sucks
21:51:25 <gholms> I have to be at work that Tuesday, so what I can do will depend on them.
21:51:29 * rbergeron nods
21:51:39 <jforbes> rbergeron: already purchased the tickets, not sure how difficult changing them is since it was through our travel people
21:51:42 <rbergeron> is it easier for you on a weekend?
21:51:56 <rbergeron> jforbes: I know you love calling axiom. admit it
21:52:14 <jforbes> there is nothing I love about axiom :(
21:52:19 <rbergeron> yeah....
21:52:59 <gholms> rbergeron: Was that question directed toward me?
21:53:02 * rbergeron notes the sig0 called axiom once and they triple charged him for the call and he spent the next 5 months fuming abou tit
21:53:09 <rbergeron> gholms: somewhat ;)
21:53:20 <gholms> rbergeron: ¯\(°_o)/¯
21:53:45 <gholms> Triple-charged him for the call?  Whaaa?
21:54:43 <rbergeron> yeah, they have some fee if you call about your reservation. They did it three times on his plane ticket bill.
21:54:46 <rbergeron> for one call
21:54:59 <gholms> That doesn't make sense.
21:54:59 * rbergeron doesn't bring it up because he can complain for an hour plus about it
21:55:03 * gholms shrugs
21:55:10 <rbergeron> anyway: gholms: is it easier for you to do something like that on a weekend?
21:55:26 <rbergeron> travel out of town and hack on something for two days + maybe one work/vacation day
21:55:27 <gholms> Can't say.  I have to move and start my new job first.  That's what ¯\(°_o)/¯ meant.
21:55:33 <rbergeron> ah.
21:55:38 <rbergeron> when are you starting?
21:55:44 <gholms> Jan 1/2
21:56:32 <rbergeron> cool.
21:56:39 <rbergeron> okay.
21:56:57 <rbergeron> jsmith: would you be interested in proposing the idea of a cloud FAD on the list (and maybe talking aobut "what is a FAD" also)?
21:57:11 <jsmith> rbergeron: Happy to do it... probably won't happen until tomorrow though
21:57:13 * rbergeron sees that Matahari has been added to the list of fudcon talks.
21:57:15 * jsmith is juggling three things at once
21:57:42 <rbergeron> innnnteresting
21:57:45 <rbergeron> jsmith: gotcha
21:57:58 <rbergeron> #action jsmith to propose FAD idea onlist when he gets a chance.
21:58:34 <rbergeron> #topic Any other business?
21:59:21 <gholms> Looks like I have another bugfix to work on.  That's about it for me.
21:59:32 <rbergeron> gholms: :\
22:00:07 <rbergeron> alrighty.
22:00:11 <rbergeron> thanks for coming everyone!
22:00:12 <gholms> https://bugzilla.redhat.com/show_bug.cgi?id=658560
22:00:17 <gholms> Bye!
22:00:19 <rbergeron> oh
22:00:22 * rbergeron looks at that real quicklike
22:00:31 <gholms> .bug 658560
22:00:33 <zodbot> gholms: Bug 658560 fail with a trailing slash - https://bugzilla.redhat.com/show_bug.cgi?id=658560
22:00:42 <gholms> Just a parsing error; that's all.
22:00:55 <rbergeron> ah
22:01:00 <rbergeron> :)
22:01:08 <rbergeron> okay. we'll try that again:
22:01:08 <jforbes> looks like a patch is even posted, gotta love those bugs :)
22:01:13 <rbergeron> thanks everyone for coming!
22:01:15 <rbergeron> :D
22:01:18 <gholms> :D
22:01:18 <rbergeron> #endmeeting