00:01:47 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:01:47 <zodbot> Meeting started Thu Dec  2 00:01:47 2010 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:01:49 <Sparks> #meetingname Fedora Docs
00:01:49 <zodbot> The meeting name has been set to 'fedora_docs'
00:01:51 <Sparks> #topic Roll Call
00:02:05 * Sparks is here
00:02:07 * jhradilek is here.
00:02:14 * nb here but leaving
00:02:17 * Gearoid is here.
00:02:24 * jjmcd_ 
00:02:26 <nb> Sparks, see, i did make the meeting! at least the first minute or two of it :)
00:02:39 <Sparks> nb: Only counts if you are here at the end.
00:02:45 <nb> true
00:02:49 <Sparks> jjmcd_: Thought you weren't going to make it.
00:03:05 <jjmcd_> For some inexplicable reason, XYL didn't have 100 places to stop on the way home
00:03:25 <Sparks> heh
00:05:27 <Sparks> Okay, lets get started.
00:05:40 <Sparks> #topic Follow up on last week's action items
00:06:04 <Sparks> jjmcd to try to draw more discussion on desktop publication on the list
00:06:12 <jjmcd_> First item, and also an agenda item
00:06:25 <jjmcd_> we had decided to delay until we saw new publican
00:06:37 <jjmcd_> Which is accused of solving the problem
00:07:25 * rudi is here
00:07:29 * Sparks thought the new Publican was supposed to be out
00:07:37 <rudi> We ran into some delays
00:07:47 <rudi> We're building right now :)
00:08:50 <Sparks> heh
00:08:55 <Sparks> Okay, we'll come back to that
00:09:02 <Sparks> jjmcd to follow up on fedora-bookmarks updates
00:09:09 <jjmcd_> OK, I studied the SRPM
00:09:18 <jjmcd_> so I finally understood the concern
00:09:34 <jjmcd_> I'm pretty sure I can build an RPM that fixes the problem
00:09:40 <jjmcd_> but I'm not sure it's kosher
00:09:50 <jjmcd_> Didn't draw any comment to my post :-(
00:09:59 <Sparks> Build it and send it to devel?
00:10:26 <jjmcd_> Maybe thats the thing to do
00:10:37 <jjmcd_> Its a tad on the ugly side
00:10:48 <Sparks> So are the rest of my SPEC files
00:10:50 <jjmcd_> And like I said, not entirely sure it will pass muster
00:11:06 <jjmcd_> heh
00:11:20 <jjmcd_> is sed part of LSB?
00:11:40 * bledroid is here
00:11:42 <rudi> http://jfearn.fedorapeople.org/en-US/Publican/2.4/html-single/Users_Guide/index.html#desktop_menus
00:11:59 * bledroid is bethlynn on android
00:12:04 <rudi> ^^^^ that's a description of the new desktop menuing mechanism
00:12:10 <jjmcd_> cool
00:12:34 <jjmcd_> Hi bethlynn ... recalled the nick, couldn't connect the dots tho!
00:13:29 <Sparks> Okay...  so the saga continues
00:13:38 <jjmcd_> Anyway
00:13:49 <jjmcd_> Basically this mysterious profile
00:13:54 <Sparks> rudi will update wiki page on publication to desktop
00:14:09 <jjmcd_> is two or fewer files with one line that needs to be edited
00:14:12 <rudi> ack
00:14:48 <rudi> I can do that now that 2.4 is out
00:14:58 <rudi> (well, getting out :) )
00:15:38 <Sparks> :)
00:15:39 <Sparks> Okay
00:15:42 <Sparks> Moving on
00:15:55 <Sparks> #topic Removing redirects on docs.fp.o
00:16:02 <Sparks> #info When Fedora 13 was released we had just upgraded to the latest version of Publican which changed all of our links on docs.fp.o. The search engines hadn't had enough time to catch up with the new URLs so we added links to act as redirects so the old URLs would still work.
00:16:28 <jjmcd_> Don't we need to wait until 13 EOLs?
00:16:28 <Sparks> So this must wait until we can figure out a way to get those links changed
00:16:43 <Sparks> jjmcd_: F14 is similarly affected
00:16:52 <jjmcd_> yeah, 13 works, 14 is broke
00:17:24 <jjmcd_> Has anyone spoken to the bookmarks owner?
00:17:37 * Sparks filed a bug
00:17:43 <Sparks> jjmcd_: they are both broken
00:17:55 <Sparks> They both point to the linked url instead of the actual URL
00:18:08 <jjmcd_> Oh, I thought 13 worked until we killed the redirect
00:18:36 <Sparks> Well... yeah... but everything should be changed so we can remove the redirects
00:18:57 <jjmcd_> But as far as the user is concerned, 13 is ok now
00:19:08 <jjmcd_> we just don't like it
00:19:16 <Sparks> Yes
00:20:41 <Sparks> jjmcd_: So if you can follow up on that bug and perhaps provide the solution you've worked maybe we can get everything fixed.
00:20:56 <jjmcd_> I'll do some testing
00:21:07 <Sparks> We will also need to communicate with the developer early so he knows where to point the RN link.
00:21:10 <jjmcd_> gotta love virt-manager !!!
00:21:59 <Sparks> heh
00:22:55 <Sparks> #action jjmcd_ to work with the fedora-bookmarks owner to see if we can get the links fixed in F13 and F14
00:23:03 <Sparks> Anything else?
00:23:58 <Sparks> #topic Publishing Documentation to the desktop
00:24:08 <Sparks> #info Create a package that will provide links to docs.fp.o based on the Publican db.
00:24:19 <Sparks> rudi: So Publican 2.4 should do this?
00:24:50 <rudi> Sparks -- not directly
00:25:19 <rudi> Publican 2.3 actually has that feature in it; it can generate a publically-accessible database dump (in XML)
00:25:29 <rudi> That's the feature we could use to create such a links package
00:26:00 <jjmcd_> The trick is doing it before the user clicks System
00:27:39 <Sparks> Okay...  so we still need to work on the development of this?
00:27:45 <rudi> yeah, it would have to try to regenerate its database of links at login time I would think
00:28:05 <rudi> (and have some sensibly timeouts if it can't get to teh Internetz)
00:28:23 <jjmcd_> rudi, that would be good, although it seems to me that the database is a better choice than XML - easier to parse
00:28:41 <jjmcd_> SELECT is darn handy and sqlite is quick
00:29:49 <Sparks> Okay...  I guess we can revisit this later.  We need to get a game plan together.
00:29:55 <rudi> yeah, I don't know about serving that up publicly
00:30:22 <rudi> (as in, I don't know about the issues involved)
00:30:52 <jjmcd_> Of course, when you think about it
00:31:07 <jjmcd_> The menus only need to be revreated when the website is updated
00:31:27 <Sparks> So it can check a date or something first
00:31:34 <jjmcd_> So maybe we get nb to run some script on db update that simply builds the necessary bit
00:31:49 <jjmcd_> Then the login task is to just d/l it
00:33:05 <Sparks> jjmcd_: Perhaps you and rudi can start a wiki page with a plan so we can look at it?
00:33:16 <rudi> Yeah; those dates are in the sqlite db (and the XML dump file)
00:33:18 <Sparks> jjmcd_: And that way everyone is on the same page
00:33:28 <jjmcd_> Yeah, there are a bunch of possible approaches, each has its own issues
00:34:24 <jjmcd_> nb, are we striving to be totally PHP/cgi - free on docs.fp.o?
00:35:12 <jjmcd_> maybe he's bailed
00:35:28 <Sparks> Oh....  yeah, nb is gone
00:36:05 <Sparks> Okay, anything else before we move on?
00:37:07 <Sparks> #topic Guide Status
00:37:25 <Sparks> Anyone have anything they want to discuss regarding a guide?
00:38:38 <Sparks> #topic Outstanding BZ Tickets
00:38:44 <Sparks> #link http://tinyurl.com/lbrq84
00:40:00 <Sparks> #info 99 Open Bugs
00:41:02 <Sparks> #info 51 New bugs
00:41:40 <Sparks> Everyone needs to take a look at the New bugs and see if there is any of them that can be easily fixed.
00:42:15 <Sparks> If the tickets are assigned to you then please start working them or ask for help
00:42:51 <Sparks> #topic Open floor discussion
00:43:03 <Sparks> Anyone have anything they want to discuss?
00:46:44 <Sparks> Okay...  Thanks, everyone, for coming out tonight
00:46:48 <rbergeron> ohhh, wait1
00:46:50 <rbergeron> !
00:46:50 <rbergeron> :)
00:46:53 * rbergeron pops in real quicklike.
00:47:07 <Sparks> rbergeron: Go ahead
00:47:33 <rbergeron> As y'all know, I'm poelcat 2.0 - I'll be hitting up your mailing list in the next day or two to see if there are any changes you'd like to make to the schedule. So just think about it ;)
00:48:12 <Sparks> jjmcd_: ^^^
00:48:23 <jjmcd_> R
00:48:40 <jjmcd_> just got a landline from my DEC NWS-DTX
00:49:22 <Sparks> rbergeron: Okay, just hit us up on the list and we'll work out the changes that I know are forthcoming.
00:50:09 <rbergeron> sparks: excellent! thanks.
00:50:17 <Sparks> Okay, anything else?
00:50:47 <Sparks> anyone?
00:51:29 <Sparks> Okay, thanks for coming out, everyone.
00:51:33 <Sparks> #endmeeting