21:04:18 <mcepl> #startmeeting bugzappers meeting
21:04:18 <zodbot> Meeting started Tue Dec  7 21:04:18 2010 UTC.  The chair is mcepl. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:04:46 <Southern_Gentlem> #chairs to add any others as chairs
21:04:58 <adamw> boingy boingy
21:05:06 * adamw watching the progress meter on ddrescue with crossed fingers
21:05:29 <mcepl> #chairs mcepl adamw fenrus02
21:05:35 * fenrus02 takes a seat
21:05:48 * fcami stands in the back
21:05:56 <Southern_Gentlem> op try #chair
21:05:57 <mcepl> http://piratepad.net/xVd9K5RamP is a tentative agenda, please add any items you think are worthy
21:05:58 * bsjones waves
21:06:17 * andrewjroth waves back!
21:06:21 <fenrus02> hello and welcome bsjones :)
21:06:34 * adamw decides not to allow javascript access to a site called 'piratepad'
21:06:48 <mcepl> does anybody know whether there is already Fedoraproject Etherpad?
21:06:50 <fenrus02> adamw, hehe!  it's neat though.  you can watch folks type
21:06:52 <adamw> what's wrong with fpaste, really? :P
21:07:05 <fenrus02> adamw, interactively add/update ... doesnt happen on fpaste
21:07:05 * fcami notes fenrus02 watches _others_ type
21:07:08 <jlaska> adamw: web-based gobby
21:07:15 <adamw> fenrus02: all the more reason not to. i've typed my root password into the wrong window more than once :P
21:07:16 <mcepl> adamw: that five people cannot edit in the same time ... we could use gobby, but this is faster
21:07:29 <mcepl> adamw: there is no password
21:07:34 <fenrus02> fcami, my typing skill is not measured in words-per-minute like most ... more like typos-per-second
21:07:36 <fcami> adamw: so you treat IRC as read-only then? :)
21:07:52 <adamw> fcami: you have to hit enter on irc
21:07:54 <fenrus02> adamw, ok, google-wave is dead though
21:08:05 <adamw> sorry to derail, anyway
21:08:07 <andrewjroth> fenrus02: Dead?  how so?
21:08:11 <mcepl> fenrus02: it isn't, but let's try to behave for a second
21:08:21 <mcepl> (today it was taken over by Apache Foundation)
21:09:53 <fcami> #topic Update https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers ... do we have it up to date?
21:10:10 * fcami would like a chair
21:10:14 <mcepl> I was showing it to andrewjroth but I am really not sure how accurate it is
21:10:23 <fcami> it's not, as far as I am concerned
21:10:33 <fenrus02> fcami, what would you have it updated with ?
21:10:34 <fcami> I'll remove myself, I can't make time.
21:10:55 <adamw> i'm still vaguely doing X triage but only infrequently
21:11:00 <adamw> i'm not really doing anything else atm
21:11:10 <fcami> I can go on triaging stuff but cannot commit to triage regularly for a component now
21:11:14 <mcepl> fcami: that's OK, when I see two comments from you in a month, you are on ;)
21:11:29 <fcami> mcepl :)
21:12:00 <fenrus02> speaking of, did the metrics script die again?
21:12:30 <adamw> what script?
21:12:57 <mcepl> did it ever work?
21:13:06 <fenrus02> oh, guess that answers that.
21:14:47 <adamw> we had two-threeish attempts at it
21:15:00 <adamw> the last one was someone who joined earlier this year, i forget who; he got a few basic things working but not much more
21:15:08 * fenrus02 nods
21:15:31 <adamw> https://fedoraproject.org/wiki/BugZappers/Metrics (and the talk page) is the stuff from that last effort
21:15:40 <adamw> the actual commands are on the talk page
21:16:39 <mcepl> interesting, but is there any hope we would fix it? does anybody volunteer?
21:17:00 <mcepl> if not, let's go back to https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers ... that should be more doable.
21:17:03 <adamw> i think he came up against inadequacies in the tooling
21:17:10 <adamw> like we needed something added to bugzilla or something
21:17:10 <mcepl> What to do with it? It would be nice to have something from incoming newbies.
21:17:32 * mcepl is backing up ... he doesn't want to interrupt
21:17:44 <fcami> first of all, alphabetical order is not really the way to go, but we would need to script something better, so...
21:17:45 * andrewjroth apparently missing things...
21:17:47 <fenrus02> are there any heat-maps for components?  like what receives the most bug reports?
21:18:00 <fcami> I mean, some components have 100+ NEW bugs, others have none
21:18:16 <fcami> and it's not readily apparent from the list. but yeah, we would need a script to auto-update the wiki.
21:18:30 <mcepl> fenrus02: I guess that would be part of results from these scripts ;)
21:18:41 <fcami> yeah, indeed.
21:18:57 <fenrus02> mcepl, well, that's what i really cared about :)
21:19:09 <mcepl> I agree it would be nice to have
21:19:12 <fenrus02> mcepl, if folks knew what was reported most, that could give some guidance to what is needed
21:19:27 * andrewjroth agrees with fenrus02
21:19:31 <mcepl> OTOH, we know the biggest hostspots ... they are same
21:19:53 <mcepl> (kernel, xorg*, firefox/thunderbird, some other desktop comoponents)
21:20:21 <fenrus02> mcepl, do each of those hotspots have a "how to debug ___" page ? (i know some do, but if they are heavy use, they should have a dedicated page)
21:20:32 <fcami> xorg hqs
21:20:35 <fcami> *has
21:20:37 <mcepl> Xorg has
21:20:48 <mcepl> Firefox doesn't ... you need to talk with me
21:20:51 <mcepl> kernel, I have no idea
21:21:32 <adamw> kernel is another thing that's been in the pipeline forever
21:21:37 <adamw> can't remember who was working on that last either
21:21:48 <fcami> do we really, really care?
21:21:53 <fcami> I mean does #fedora-kernel care?
21:21:56 <adamw> i care a bit!
21:22:05 <fcami> yeah, me too, that's not the idea
21:22:08 <adamw> they'd be happy to have help but aren't really likely to help us help them a whole lot
21:22:35 <fcami> the main thing is, they take kernel.org, hack on it, include their own development branches, etc, etc
21:22:47 * nirik was. ;)
21:22:49 <fcami> do they look at bugs for real except when we're composing beta or something?
21:22:58 <fenrus02> kernel bug reports should likely have a smolt url though for instance
21:23:05 <nirik> perhaps over the holidays I can get back to it, but it just dropped low on my list.
21:23:31 <nirik> https://fedoraproject.org/wiki/KernelTriage
21:23:38 * mcepl notes he just learned about https://fedoraproject.org/wiki/User:Fenris02/Firefox ... will talk with fenrus02 about it later
21:24:05 <nirik> if someone wants to take over spearheading kernel bugzapping, please feel free and I will support them as best I can.
21:25:08 <fenrus02> well, they should have a mention https://fedoraproject.org/wiki/Bugs_and_feature_requests#Information_required_for_bugs_in_specific_components -- kernel does, xorg a few others.
21:25:12 <mcepl> smolt is pain ... I don't know if it is actually useful for kernel folks, it is mostly useless for Xorg.
21:25:24 <fenrus02> triage should be able to look through that page and provide useful suggestions to the reporter
21:25:49 <mcepl> we definitively have https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm
21:26:02 * mcepl is getting back and concentrating
21:26:25 <mcepl> and https://fedoraproject.org/wiki/Xorg/Debugging
21:27:13 <fcami> I could sort the Debugging page a bit
21:27:20 <fcami> we're mostly using KMS now
21:27:27 <fcami> it should be more visible
21:27:31 <mcepl> yes
21:27:36 <mcepl> it needs to be updated
21:27:48 <fcami> I'll do that
21:27:50 <adamw> fcami: radeon's still ums-capable i think
21:27:58 <fcami> on R400 and below
21:28:01 <fcami> maybe R500 and below
21:28:12 <fcami> not on anything people consider current
21:28:20 <fcami> (IIRC)
21:28:29 <mcepl> #action mcepl talk with fenrus02 about Firefox triage page
21:28:42 <mcepl> #action mcepl talk with fcami about update of Xorg triage page
21:29:01 <bsjones> be good to link these component wikis to the Components_and_triagers page
21:29:14 <fcami> adamw: and basically the Xorg devs do not want to maintain UMS anymore, we're nearly on par feature-wise now even on older hw so...
21:29:41 <mcepl> bsjones: or somewhere, yes
21:30:40 <mcepl> moreover nomodeset is not supported much ... if it is broken and KMS works, then we don't care
21:30:46 <mcepl> but back to our meeting
21:30:54 <andrewjroth> yes.
21:31:34 <mcepl> so, how we will update https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers
21:31:51 <mcepl> should we go around developers and ask them about them about the current status?
21:32:01 <fcami> I would like us to remove all the packages, even critpath, that have no or nearly no bugs
21:32:12 <fcami> that would make the page clearer. example: openssh-server
21:32:32 <fenrus02> that goes back to the heat-map idea (above)
21:32:36 <fcami> indeed
21:32:44 <fenrus02> fcami, any idea how to pull those stats out?
21:32:47 <mcepl> yes, and I am quite sure that its maintainer (sits next to me) doesn't want and doesn't need bug triager
21:32:48 <mcepl> s
21:32:59 <fcami> script bz through the webservice. I think I can do it but -enotime for now.
21:33:28 <adamw> i think we can do it with python-bugzilla actually
21:33:32 <fenrus02> fcami, bugzilla cli panics if there are "too many bugs", and reports nothing at all.  101 appears to be "too many" fwiw.
21:33:49 <fcami> we'd have to see if pybz does too
21:34:23 <adamw> rather than lose them it'd be good to stick them in a subsidiary table at the bottom or something, but yeah, let's get them out of the way
21:34:41 <fcami> +1 yes
21:35:07 <fcami> mcepl, how do you feel about that in general?
21:35:31 <mcepl> fenrus02: I think before we have scripts, plan B would be to go around maintainers, or check number of current bugs manually
21:35:47 <mcepl> (in opposite order of steps)
21:36:03 <fenrus02> mcepl, *nod*  rather cumbersome if you want to look at more than say 5 or 10 packages.
21:37:11 <adamw> it should be easier to hack it up via a web query or python-bugzilla query than do it manually.
21:37:27 <adamw> it usually takes me about half an hour to bodge something up in python-bugzilla, it'd take a lot longer to go through each one of those manually, i think
21:37:36 <mcepl> if you add unpacked http://is.gd/imkDm to your firefox as keyword search (there is %s in the end) and name it something then you can searhc by componetns by one command
21:37:49 <mcepl> adamw: ^^^^
21:38:08 <mcepl> http://fpaste.org/J438/
21:38:26 <mcepl> so I just write
21:38:28 <mcepl> rhbz firefox
21:38:33 <mcepl> and I have all open bugs for firefox
21:39:25 <mcepl> and you don't have to go through them for assesing its importance ... just numbe rof bugs is enough
21:39:48 * fenrus02 nods
21:40:21 * nirik just has a shortcut for 'bugz %s' that does 'http://bugz.fedoraproject.org/%s'
21:40:28 <adamw> okay, anyway
21:40:33 <adamw> enough bikeshedding
21:40:40 <adamw> someone say they'll do it and let's move on
21:40:49 <mcepl> OK, so he is willing to do the work ... any eager newbies around?
21:40:52 * adamw is not going to take on any major tasks at this meeting cos he's already overloaded with qa stuff
21:41:10 * mcepl too ... and he wants other to do something
21:41:23 * andrewjroth can do it... but would need guidance
21:41:27 <fcami> I'm editing the kernel page
21:41:31 <fcami> I'll do the Xorg pages afterwards
21:41:33 <mcepl> andrewjroth: I'll help you
21:42:19 <andrewjroth> alright... I don't know python that well, but I could learn
21:42:30 <mcepl> #action andrewjroth helped by mcepl will make an assesment for importance of all bugs
21:42:44 <mcepl> andrewjroth: I don't plan to use python, we'll talk
21:42:49 <andrewjroth> we just want a script to take the number of bugs and put it in the wiki table
21:42:51 <andrewjroth> ?
21:42:52 <andrewjroth> alright
21:43:01 <andrewjroth> We can talk off irc
21:43:06 <fenrus02> well, make a table of it anyhow
21:43:15 <mcepl> fenrus02: yes
21:43:21 <fenrus02> i suspect the ordering of the wiki will be a manual effort
21:44:08 * mcepl doesn't like proprietary solutions, but maybe this is the time for Google Docs? or OOo Calc file somewhere.
21:45:04 <mcepl> OK, anything more to this item?
21:45:25 * andrewjroth thinks the current list is daunting for newbies
21:45:37 <mcepl> three
21:45:40 <mcepl> two
21:45:45 <mcepl> one
21:45:50 <mcepl> #item Formally affirm the date and time of meeting (just it is recorded)
21:46:02 <mcepl> #topic Formally affirm the date and time of meeting (just it is recorded)
21:46:14 * andrewjroth updated the meeting time on the Wiki to this current time
21:46:17 <fcami> andrewjroth: that's why we want to prioritize instead of showing a big list.
21:46:30 <andrewjroth> fcami: right!
21:46:50 <mcepl> andrewjroth: thanks
21:47:09 <andrewjroth> No problem!  I updated it when I showed up at 10am and no one was here.  :-P
21:47:10 <mcepl> anybody has anything against 21:00 UTC on Tuesday? Or do we want to meet biweekly?
21:47:39 <fcami> that time is perfect for me
21:47:46 <fenrus02> this time of day works well for me
21:48:09 <mcepl> I don't like it much, but it is doable ... better than no meeting at all
21:48:20 <bsjones> now is good
21:48:33 <andrewjroth> true... I would have prefered 10am, but I can understand not everyone is on Eastern time
21:48:41 <andrewjroth> I will settle for this time
21:48:59 <mcepl> adamw: ???
21:49:11 <fenrus02> mcepl, $work impacts my ability to make "early" meetings on most days.  *shrugs*  i'm sure everyone has a unique time that works best
21:49:29 <adamw> this time's fine for me
21:49:36 <mcepl> fenrus02: it's 22:00 here :(
21:49:45 <fcami> I'm supposed not to have IRC at $work so
21:49:55 <mcepl> OK, so no complaints? Speak now or hold your peace forever!
21:49:57 <fenrus02> mcepl, *nod*  understand
21:49:57 <fcami> mcepl: here too *grin*
21:49:58 <andrewjroth> Since this meeting is currently at this time... there is no reason anyone here would object.
21:50:21 <mcepl> weekly or biweekly?
21:50:38 <fenrus02> mcepl, tbh, we've been so long without a meeting at all - is there a need to have weekly?
21:51:11 * adamw is of the 'meet when we need to' school
21:51:37 <fenrus02> adamw, well, meetings tend to shake the dust off projects that have been forgotten
21:51:45 <andrewjroth> If we start off at bi-weekly (first and third Tuesday?) we can increase frequency if needed.
21:51:49 <bsjones> is their usually much to cover? (my first meeting)
21:51:51 <mcepl> adamw: that's lovely ... but we need something to keep us in order (kind of Alcoholics Anonymous style)
21:52:00 <mcepl> moreover it is not good for newbies
21:52:03 <andrewjroth> (also my first meeting) so I don't know
21:52:20 <adamw> heh, true
21:52:32 <fenrus02> andrewjroth, bsjones - the -bz channel is always around if you have questions.  no need to wait for a meeting
21:52:38 <mcepl> not much .... just what we are doing, how much we are doing on projects we took on, and of course there is more activity around release
21:52:48 <mcepl> fenrus02: +1000
21:52:55 <andrewjroth> fenrus02: I know... haven't waited... but wanted to see a meeting.
21:53:04 <mcepl> I am there every workday (CET time, but long into evening usually)
21:53:44 <andrewjroth> so votes?  Weekly vs. Biweekly?
21:53:45 <fenrus02> mcepl, every two weeks or 1st/3rd of each month as a start?  keep tabs on any action items from last meeting?
21:54:19 * fenrus02 notes again that it would be positively awesome to have an ical for -meeting events
21:54:41 <mcepl> fenrus02: make one ;)
21:54:46 * andrewjroth would find it ammusing if IRC meetings followed to Robert's Rules of Order.
21:55:05 <andrewjroth> I was considering makeing a Google Calendar that is public for Meeting times
21:55:05 <mcepl> and yes, whatever will be the conclusion, we probably won't meet until next year. Agreed?
21:55:12 <fenrus02> mcepl, wouldnt do much good if not all reservations took place on the cal that was exprterd
21:55:21 <fenrus02> 'exported' (erg!)
21:55:32 <fcami> andrewjroth: we refrain from using proprietary solutions :)
21:55:43 <andrewjroth> So I hear... but it is a good solution.
21:55:53 <fcami> for some definition of good. but anyway.
21:55:59 <mcepl> ical is not properietary, but whatever
21:55:59 <fcami> mcepl: I'm ok for once a month.
21:56:00 <mcepl> whatever ... let's vote ... who is for biweekly meeting?
21:56:09 <fenrus02> +1
21:56:21 <fcami> err, bimonthly? or biweekly?
21:56:22 <bsjones> monthly sounds reasonable
21:56:35 <mcepl> fcami: montly is too much far from each other ... even if it would be fifteen minutes, I would prefer more often
21:56:49 <fcami> every two weeks then.
21:56:52 <andrewjroth> biweekly then
21:56:54 <fcami> that works
21:57:11 <mcepl> any opposition?
21:57:38 <bsjones> biweekly then from me as well
21:57:40 <fenrus02> fcami, bi-weekly = every two weeks, bi-monthly = every two months ...  60 days between meetings is a bit high for any action items :P
21:58:06 <fcami> yeah, I had it backwards. :)
21:58:09 <mcepl> #agreed meeting here every two weeks (next time 11th January 2011), 21:00 UTC
21:58:47 <mcepl> #topic Matěj's announcement of about the status of Jetpacks
21:59:34 <mcepl> just that current Firefox addon (https://fedorahosted.org/released/bugzilla-triage-scripts/bugzilla-triage-latest.xpi) is supported on Firefox 3.6.* and it is now in the maintenance mode (bugfixes only).
21:59:56 <mcepl> Firefox 4.* will require almost complete rewrite and it won't be compatible with FF 3.6.*
22:00:11 <mcepl> s/almost complete rewrite/substantial changes/
22:00:12 <fenrus02> new zappers, if you've not tried the triage xpi yet - check it out.  very handy
22:00:15 <mcepl> working on it
22:00:53 <fenrus02> mcepl, requires it because of jetpack updates, or refactoring in new ideas?
22:01:01 <mcepl> if you have any complaints, feature requests, catch me on #fedora-bugzappers or file a ticket on https://fedorahosted.org/bugzilla-triage-scripts/newtplticket
22:01:28 <mcepl> fenrus02: API was completely changed because of every-tab-is-an-independent-process in FF4
22:01:47 <mcepl> much more complicated for me
22:02:39 <mcepl> currently already some things don't work with current addon in FF4 (all privileged operations like XMLHttpRequest are disallowed)
22:02:43 <fenrus02> mcepl, *nod* and thanks for doing it, very useful
22:03:17 <mcepl> any questions?
22:03:40 <mcepl> #topic fcami would like us to look at the tentative bodhi-updates-bz message he posted to test-list and bodhi last Saturday - http://lists.fedoraproject.org/pipermail/test/2010-December/095866.html
22:03:44 <mcepl> #chairs fcami
22:03:56 <mcepl> fcami: you have a mike
22:04:01 <fcami> err
22:04:09 <andrewjroth> *mic*
22:04:10 <mcepl> what is it about?
22:04:25 <fcami> so basically, when bodhi updates a bug because an update is pushed to testing
22:04:33 <fcami> or from testing to stable
22:04:34 <mcepl> andrewjroth: sorry, bad spelling ...
22:04:43 <fcami> it updates the bug with a very terse message
22:04:57 <andrewjroth> mcepl: It's cool... /me is a former audio tech.
22:05:00 <mcepl> yes, too terse
22:05:11 <mcepl> andrewjroth: me has Enlighs as second language ;)
22:05:15 <mcepl> *English
22:05:18 <fcami> I wanted to change that message and posted the patch to do so - nirik pointed me at https://fedorahosted.org/fedora-infrastructure/ticket/701
22:05:30 <fcami> I would like the bugzappers to have a look at what we want to see when a bug is updated
22:05:45 <fcami> because of course, if a bug is not fixed by an update, we're going to have other open bugs
22:06:09 <fcami> so if you guys could help me formulate something that works for us, I'll be grateful
22:06:26 * fcami gives the mic back to mcepl
22:06:59 <fenrus02> fcami, when a push is made to stable, it would save time adding the comments to the bug reports.  At least it can give the reporter a chance to update and retest
22:07:24 <fcami> "adding the comments" means?
22:07:30 <mcepl> just from the first look "number of hours" is not enough for mirrors to propagate a package to Europe (not mentioning Asia and New Zealand) ... couple of days is more in line with reality, isn't it?
22:07:46 <mcepl> however, big +1 for the rewrite of the message
22:07:52 <fcami> about a day I think, but yeah
22:08:05 <fcami> ty mcepl
22:08:34 <fenrus02> fcami, if the bug reports have comments indicating "package foo was updated from what you reported" then the reporter can update and retest
22:08:47 <fcami> ah.
22:09:04 <fenrus02> only problem is that when folks dont update, and then report bugs on version that have already been repaired ...
22:09:13 <bsjones> patch looks good to me
22:09:16 <mcepl> and instead of "Your feedback on this update would be much appreciated, and can be submitted via the above URL." I would just directly ask them to file change karma of the update
22:09:37 <mcepl> Please go to the above URL and ....
22:09:41 <mcepl> something of that kind
22:09:44 <fcami> indeed
22:10:18 * bsjones has to jump on his bike and go to work
22:10:32 * fcami waves to bsjones :)
22:10:32 <bsjones> will pick it up there if you are still around. thanks and seeya!
22:11:06 <fenrus02> bsjones, cheers
22:11:09 <mcepl> fcami: BTW, that's probably another ticket but https://admin.fedoraproject.org/updates/spectrum-1.4.4-1.fc14 would need some big button [DOWNLOAD PACKAGES HERE]
22:11:23 <fcami> "package $foo was updated and should fix your issue. Please update it with the updates-testing repository and then file karma (feedback) on this update at $url as soon as you are able to."
22:11:29 <mcepl> if it is supposed to be the main point of contact
22:11:40 <mcepl> fcami: yes, much better
22:12:00 <andrewjroth> What if the update is not designed to fix the issue at hand?  Or are we talking about a manual comment?
22:12:22 <fcami> andrewjroth: supposedly the maintainer lists the bz #s when he/she pushes the update through bodhi
22:12:23 <fenrus02> mcepl, you mean change "Builds:" to "Download:" ?
22:12:30 <mcepl> andrewjroth: when the package is filed to bodhi (update database) maintainer can say that this update fixes bug no. so-and-so
22:12:41 <mcepl> fenrus02: no I mean that bodhi should grow another feature
22:12:59 <mcepl> andrewjroth: then and only then this whole happens
22:13:01 <fcami> mcepl: you want the "download rpm directly from koji" link in there?
22:13:06 <mcepl> yes
22:13:13 <mcepl> because otherwise reporter won't find it
22:13:13 <fcami> I think it is discouraged
22:13:35 <mcepl> OK, then don't say ... "and manually download packages from"
22:13:50 <fcami> hmmm
22:13:54 <fenrus02> su -c 'yum update --enablerepo=updates-testing foo'
22:13:59 <fcami> that works
22:14:01 * nirik notes the packages from koji are not signed.
22:14:06 <fcami> yes
22:14:11 <mcepl> nirik: I agree
22:14:25 <mcepl> I don'ŧ want to promote downloading packages from koji
22:14:36 <mcepl> just that the text of messages did, IMHO
22:15:11 <fcami> Package $foo was pushed to the updates-testing repository and should fix your issue. Please update it with su -c 'yum update --enablerepo=updates-testing foo', then reboot, and then file karma (feedback) on this update at $url as soon as you are able to.
22:15:33 <fenrus02> mirror propagation delay is in the 1-2 days though. this may cause some questions
22:15:49 <fcami> we need a faster c
22:16:04 <mcepl> fcami: do we really send THREE messages for each update?
22:16:15 <fcami> I think
22:16:24 <mcepl> OMG :(
22:16:31 <fcami> yeah
22:16:31 <fenrus02> one send that has all three statements?
22:16:42 <fcami> no, it's not like that
22:17:03 <mcepl> I think we need to send just one message "here is the packge and here is the webpage for karma"
22:17:12 <mcepl> so send it only when it is ready
22:17:23 <fcami> yeah, but we don't know when the mirror is ready
22:17:25 <mcepl> but I would like to have comments from others ... adamw?
22:17:39 <fcami> indeed. jlaska, ping
22:17:47 <mcepl> well, OK, when we push it to mirros (and say a "few days")
22:17:48 <fcami> errr, too late
22:18:01 <adamw> sorry
22:18:08 <adamw> got distracted
22:18:10 <mcepl> OK, so the action item is that we should talk with these about better strategy?
22:18:11 <adamw> what are we commenting on?
22:18:25 <fcami> adamw: I'm trying to, err, make bodhi messages more useful
22:18:33 <mcepl> https://fedorahosted.org/fedora-infrastructure/ticket/701
22:18:42 <mcepl> last 20 minutes chat
22:19:05 * mcepl makes a cup of tea
22:19:11 <adamw> fcami: yay
22:19:16 <fcami> hehe :)
22:20:49 <mcepl> fcami: BTW, procedural complaint ... this is not much business of BugZappers. SHouldn't this whole be discussed by QA folks?
22:20:59 <fcami> yeah, that too.
22:21:03 <adamw> i agree with mcepl's original comments
22:21:10 <adamw> not so much with 'omg we send three messages' - we kind of have to
22:21:23 <mcepl> why?
22:21:30 <adamw> the only one we *could* skip is the submit-to-testing message (only send on push-to-testing)
22:21:40 <adamw> but we definitely need both push-to-testing and push-to-stable messages
22:21:47 <mcepl> yes
22:21:51 <adamw> the first to say 'hey, test this update' and the second to say 'hey, the bug's fixed'
22:22:00 <adamw> i think the submit-to-testing has value, though, as it lets you get the fix asap
22:22:20 <mcepl> yes, sorry .. we definitively need two messages
22:22:28 <adamw> if releng aren't pulling their fingers out, you could be waiting around two days for the push-to-testing notification, when the fix has been available from koji all along
22:22:42 <mcepl> push-to-testing and push-to-stable are valuable
22:22:52 <fcami> http://fpaste.org/Nu0B/
22:22:53 <adamw> but yeah, submit-to-testing is the one we can drop if we want to drop one.
22:23:07 <mcepl> I am all for not bothering reporters with useless stuff
22:23:14 <mcepl> but this should be really discussed by QA folks
22:23:29 <adamw> until bodhi has a better design, we could probably explain how to log in at bodhi before filing karma too
22:23:32 <fenrus02> adamw, is there historically a delay between push-to-testing and submit-to-testing?
22:23:32 <adamw> as that's my #1 bodhi faq
22:23:44 <fcami> hmmm. adamw, when is the QA meeting? I think there is a reason I cannot be there :/
22:23:55 <adamw> fenrus02: other way around, and yes, there always is *some* delay. it should be max 24 hours (should be one push per day), but sometimes they get slack.
22:24:14 <adamw> fcami: mondays at 8am PT, right now.
22:24:30 <fenrus02> adamw, right, pesky RTL
22:24:31 <mcepl> adamw: that's yesterday
22:24:36 <fenrus02> 8am pt ... ught.
22:24:38 <adamw> mcepl: yes it is.
22:24:41 <mcepl> ok
22:24:49 <fcami> yeah, and that's definitely in the impossible world for me
22:25:15 <nirik> adamw: I've been doing them every day for the last N weeks. ;) The only slack was one friday where bodhi went out to lunch and I had to do a bunch of things to get it pushing the next day. ;)
22:25:15 <fcami> mcepl: tbh the reason I asked here is that I posted to test-list and never got feedback
22:25:19 <mcepl> fcami: you should probably ask adamw to be your ambassador
22:25:36 <mcepl> then
22:25:36 <fcami> hmmm. that would work. :)
22:26:04 <adamw> nirik: shut up while i slag you off!
22:26:13 <nirik> :)
22:26:37 <adamw> fcami: also it would make me look like i'm doing something, so i'm all for that!
22:26:45 <fcami> rotfl. ok.
22:27:03 <fcami> adamw: I'm going to submit a better version of the patch, and I'll CC you
22:27:12 <mcepl> OK, so it an #action then?
22:27:18 <mcepl> *is it an
22:27:30 <fcami> for me yes
22:27:51 <fcami> thanks a lot adamw :)
22:28:09 <mcepl> #action fcami through adamw sends https://fedorahosted.org/fedora-infrastructure/ticket/701 to QA folks to comment on
22:28:10 <adamw> fcami: ok cool
22:28:17 <mcepl> anything else?
22:28:26 <mcepl> should we have open floor or is this enough?
22:29:13 <fcami> I'm done. others?
22:29:33 <mcepl> three
22:29:35 <mcepl> two
22:29:37 <mcepl> one
22:29:40 <mcepl> #endmeeting