21:01:28 <rbergeron> #startmeeting Cloud SIG
21:01:28 <zodbot> Meeting started Thu Jan 13 21:01:28 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:35 <rbergeron> #meetingname Cloud SIG
21:01:35 <zodbot> The meeting name has been set to 'cloud_sig'
21:02:17 * mmcgrath here
21:02:20 <gholms> WHARRGARBL
21:02:32 * rackerhacker lolwuts
21:02:42 * jsmith is here
21:02:44 * mmorsi says yo
21:02:45 * jforbes is here
21:02:48 * clalance is here now
21:02:56 <gholms> rackerhacker: This:  http://blogs.riverfronttimes.com/atoz/wharrgarbl.jpg
21:03:07 <rbergeron> oh hey folks.
21:03:14 <rackerhacker> that's one of my favorites, gholms
21:03:21 * rbergeron was just ramblin' on (apologies to led zeppelin) in #fedora-cloud
21:03:30 <gholms> We should start where the infrastructure topic left off.
21:03:31 <rbergeron> okeedokee.
21:03:51 <rbergeron> Agenda was more or less written out in mail today but if you have anything else to say pipe up come open floor time.
21:03:54 <rbergeron> #topic EC2
21:04:07 <rbergeron> jforbes: hi there! :)
21:04:10 * rackerhacker naps ;)
21:04:12 * jgreguske waves
21:04:21 <rbergeron> #chair jforbes gholms
21:04:21 <zodbot> Current chairs: gholms jforbes rbergeron
21:04:25 <rbergeron> heya rackerhacker ;)
21:04:25 <jforbes> heya
21:04:48 <jforbes> So I have a mostly working ks file, I had to make some changes, it is running through koji now, then needs the test cycle, etc...
21:05:11 * jsmith would be happy to help test images
21:05:57 <rbergeron> awesome.
21:06:23 <jforbes> Blah, I take that back... might need more work, just got a fail from koji... checking the logs :(
21:06:43 <rbergeron> are we going to attempt to try and test things on EC2 somehow to make sure some basic scenarios work, given the issues we've been having with their ... ahem... vintage xen stuff?
21:06:52 <jgreguske> jforbes: see appliance.log
21:07:10 <jforbes> rbergeron: yeah, this will go through the whole F15 release cycle
21:07:36 <dgilmore> jforbes: whats the task?
21:07:44 <jgreguske> jforbes: if you have any trouble with koji don't hesitate to ping me
21:07:48 <jgreguske> http://koji.fedoraproject.org/koji/taskinfo?taskID=2719998
21:08:00 <jforbes> jgreguske: yeah, looking at it now
21:08:21 <jgreguske> jforbes: feel free to yell at me at FUDCon :P
21:08:39 <rbergeron> YAY FUDCON oh.... sorry.
21:08:46 <jforbes> jgreguske: will do :)
21:09:21 * rbergeron looks around for any other jforbes questions
21:09:48 <rbergeron> #info jforbes is working on ks file, has a fail from koji, is continuing to be awesome and plugging away at it.
21:10:11 <dgilmore> jforbes: you need to define the disk in your kickstart
21:11:03 <jforbes> dgilmore: indeed I do
21:12:04 <rbergeron> jforbes: need anything else? :)
21:12:10 <dgilmore> jforbes: add --ondisk sda
21:12:13 <jforbes> rbergeron: nope
21:12:14 <dgilmore> to your line
21:12:49 <rbergeron> okay then.
21:12:52 <rbergeron> I shall move onwards.
21:13:08 <rbergeron> #topic Feature status updates - Deltacloud
21:13:20 <rbergeron> clalance, mmorsi: Hello.
21:13:26 <clalance> rbergeron: Howdy :).
21:13:28 <mmorsi> yo
21:13:36 <rbergeron> I saw a very nice email from clalance on the list about aeolus - I encourage everyone to check it out.
21:13:51 * rbergeron shall find a link, while clalance / mmorsi say if they have anything goin on.
21:14:19 <clalance> rbergeron: Other than the rename, nothing specifically to do with Fedora, no.
21:14:26 <mmorsi> ya not too much extra to report
21:14:31 <clalance> mmorsi has been working on rails 3 packages, which will benefit fedora in general.
21:14:36 <clalance> (and aeolus in particular)
21:14:58 <clalance> As far as deltacloud, the API, most of the additions to the API are being driven by aeolus (as may be expected).
21:15:03 * rbergeron nods
21:15:09 <clalance> rbergeron: We have a new person on the team working on packaging for the moment.
21:15:22 <clalance> So I suspect in the next couple of weeks we will have a few more review requests for dependencies.
21:15:26 <rbergeron> awesome. do they need help / pointers / etc?
21:15:43 <clalance> rbergeron: I don't think at the moment, they are mostly getting familiar with our (long) chain of dependencies.
21:15:49 <clalance> But if they do, I will surely send them your way :).
21:16:05 <rbergeron> And I will dutifully find someone who can be of more assistance than I. :)
21:16:13 <clalance> Haha.
21:16:28 * rbergeron has packaging experience limited to fedex and ups
21:16:32 <clalance> rbergeron: Luckily we have a number of people on the team (myself included) who have done some packaging for Fedora.
21:16:37 <clalance> So hopefully we can sort it out.
21:16:39 * rbergeron nods
21:16:58 <rbergeron> Cool. Well keep us posted. And see if that person can join the cloud sig list :)
21:17:13 <mmorsi> yeh shouldn't be a huge issue, tho always the more eyes on these packages the better
21:17:21 <clalance> Oh, the patches for condor are going to be accepted upstream.
21:17:21 * rbergeron nods
21:17:28 <gholms> clalance: If you think your dependency chain is bad, right now I'm looking at 49 packages just to build the core part of eucalyptus built.  :-\
21:17:31 <clalance> (at least, we've been promised by one of the maintainers that he will want to commit them)
21:17:43 <clalance> gholms: Ouch, yeah, that sucks.
21:18:01 <mmorsi> gholms: you should've seen what i went through (and still am) for jruby :-p
21:18:09 <gholms> We'll see how much that explodes to when I finally get it to build from source.
21:18:15 <clalance> gholms: I rebuilt the whole cloud engine on RHEL-6 (which has zero rubygems).
21:18:21 <clalance> I had to package up 98 packages.
21:18:26 <gholms> Nice
21:18:27 <rbergeron> gholms: unrelated, I saw this interview video yesterday with a certain dude who flies in space occasionally talking about openstack and eucalyptus in their upcoming releases. le sigh.
21:18:27 <clalance> (98 source packages, that is)
21:18:38 <clalance> Heh.\
21:19:17 <rbergeron> Okay. Anything else?
21:19:21 <gholms> The spec file for our biggest dependency is over 1900 lines long.  It's ridiculous.
21:19:21 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-January/000487.html
21:19:27 <clalance> gholms: Yuck!
21:19:31 <clalance> rbergeron: Not from me.
21:19:38 <rbergeron> #info Check out Aeolus! :)
21:19:39 <gholms> clalance: Welcome to the land of java packaging.
21:19:52 <clalance> rbergeron: Just that I will, indeed, try to keep cloud SIG updated via the mailing list with our progress.
21:20:02 <gholms> rbergeron: I can vent some more, but I suspect you would like to move on.
21:20:07 <mmorsi> gholms: which package is that?
21:20:08 <clalance> (man, my sentence construction sucks today)
21:20:10 <mmorsi> w/ the long spec file
21:20:19 <gholms> mmorsi: axis2
21:20:20 <mmorsi> you can roll extra long changelogs and what not into their own files
21:20:30 <rbergeron> clalance: cool. And you guys are slowing moving over your mailing lists to new names, I'm guessing?
21:20:34 <mmorsi> and remove em from the spec if thats whats causing the length
21:20:36 <rbergeron> or portions, anyhow?
21:20:40 <clalance> rbergeron: Yeah, that will be part of the cut-over on Monday.
21:21:26 <rbergeron> Cool.
21:21:28 <rbergeron> Onwards!
21:21:35 <gholms> mmorsi: I'm pretty sure it isn't the changelog, but I'm not positive.  Right now I'm just swiping the packages from jpackage.  >_>
21:21:41 <gholms> What's next?
21:21:45 <mmorsi> ah gotchya
21:21:54 * rbergeron looks at her list -
21:22:05 <rbergeron> I have boxgrinder here, and CloudFS.
21:22:30 <gholms> rbergeron: You'll have to copypaste your #fedora-cloud logs for BG.
21:22:31 <rbergeron> I don't see a jdarcy here, and I think mgoldmann is the sleeping portion of his day.
21:22:35 * rbergeron nods
21:22:43 <gholms> He mentioned a ton of stuff there earlier.
21:22:57 * rbergeron is just going to cut and paste, for everyone's benefit.
21:23:03 <rbergeron> #topic BoxGrinder
21:23:45 <rbergeron> #info Robyn is doing a copypasta to earlier today on #fedora-cloud, since mgoldmann couldn't be here.
21:23:53 <gholms> Pfft
21:23:54 <rbergeron> err, from earlier today... you get the picture.
21:24:03 <rbergeron> no? :)
21:24:33 <rbergeron> bugs: https://bugzilla.redhat.com/show_bug.cgi?id=664113  https://bugzilla.redhat.com/show_bug.cgi?id=664111  https://bugzilla.redhat.com/show_bug.cgi?id=652414
21:24:49 <rbergeron> #info Need some reviews. Please help.
21:25:22 <rbergeron> 13:06 < mgoldmann> BG development move forward pretty fast, before FUDCon expect big update - BG: 0.8.0
21:25:26 <rbergeron> 13:07 < gholms> What's new?
21:25:28 <rbergeron> 13:07 < mgoldmann> already fixed issues for 0.8.0:
21:25:31 <rbergeron> https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+BGBUILD+AND+fixVersion+%3D+%220.8.0%22+AND+status+%3D+Resolved+ORDER+BY+priority+DESC&mode=hide
21:25:35 <rbergeron> 13:07 -!- fabiand_ [~fabiand_@f055242088.adsl.alicedsl.de] has joined #fedora-cloud
21:25:38 <rbergeron> 13:07 < mgoldmann> gholms: support for all EC2 regions, RHEL 6 support, VirtualBox plugin
21:25:41 <rbergeron> 13:07 < mgoldmann> and BG will be really easy to use it as library
21:25:44 <rbergeron> 13:08 < mgoldmann> (in Ruby apps)
21:25:46 <rbergeron> 13:08 < gholms> Fancy
21:25:49 <rbergeron> 13:08 < mgoldmann> no more shell execution there
21:25:51 <rbergeron> 13:08 < gholms> That part is especially good news.
21:25:54 <rbergeron> 13:09 < mgoldmann> see this comment:
21:25:56 <rbergeron> https://issues.jboss.org/browse/BGBUILD-79?focusedCommentId=12573278&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12573278
21:25:59 <rbergeron> 13:09 < mgoldmann> in 0.8.0 there is also removed file requirement - you can use appliance definition as string  too
21:26:02 <rbergeron> 13:11 < mgoldmann> I think that's all from my side
21:26:05 <rbergeron> 13:11 < mgoldmann> If you have any questions feel free to ping me anytime!
21:26:08 <rbergeron> yeah, i'm just going to copy/paste.
21:26:11 <rbergeron> #info BoxGrinder 0.8.0 will have support for all EC2 regions, RHEL6 support, VirtualBox plugin, usable as a library in Ruby apps.
21:26:30 <rbergeron> #info Can also use appliance definition as string.
21:26:31 <gholms> It also comes with a free pony!
21:26:45 <rbergeron> OMG ponies?
21:26:56 <gholms> No, just one.
21:27:09 * jsmith worries about pony packaging
21:27:36 <rbergeron> Hopefully the pony licensing is kosher.
21:27:44 <skvidal> kosher ponies?
21:27:51 <skvidal> but they have hooves
21:27:52 <skvidal> I mean..
21:27:54 <skvidal> oh nevermind
21:29:01 <rbergeron> #link http://img27.imageshack.us/i/ponies.jpg/
21:29:04 <rbergeron> :)
21:29:22 <rbergeron> #topic OpenStack
21:29:26 <gholms> ...
21:29:42 <rbergeron> So - I sent out some email on this topic yesterday.
21:29:53 <rbergeron> Silas is still working on it, though I odn' tknow if we're going to have it in as a feature for F15.
21:30:17 <rbergeron> But we'll see what we can do.
21:30:33 <rbergeron> There's an outstanding review left on python-carrot, which needs to get moved along somehow.
21:30:50 <rbergeron> If anyone has thoughts, please, by all means, join into the mail thread.
21:32:11 <rbergeron> Okay.
21:32:16 <rbergeron> #topic Test Day stuff
21:32:52 <rbergeron> jforbes: we've been talking aobut this a bit every week, but I'm not seeing a lot of movement on the mailing list in terms of OMG INTEREST.
21:33:05 <rbergeron> do you have any thoughts on how we might prod this along?
21:33:10 * rbergeron is interested in anyone else's thoughts as well
21:33:24 <jforbes> rbergeron: I was thinking just schedule a day and start with ec2
21:33:47 <jforbes> rbergeron: then let people submit test plans as they want/need
21:33:54 <gholms> That's not a bad idea.
21:34:27 <clalance> Yeah, that is a good start.
21:34:28 <rbergeron> Okay. Should I just get it scheduled, and do the wiki business, and pass it off to you for further more specific action?
21:34:31 <rbergeron> does that work?
21:34:35 <clalance> At least it shows that *someone* is thinking about it.
21:35:15 <jforbes> rbergeron: sure
21:35:21 <rbergeron> okay. works for me.
21:35:36 * gholms would like to play with a relatively recent image  :)
21:35:38 <rbergeron> #action rbergeron to schedule an Cloud SIG test day and start with EC2.
21:35:55 <rbergeron> jforbes: how far out do you need it to be to get things sort of in order to have something to test?
21:36:35 <jforbes> rbergeron: well, we need after a release for EC2
21:36:43 <jforbes> maybe 2 weeks after alpha is scheduled
21:36:48 <clalance> rbergeron: I unfortunately have to run.  Do you need me for anything else?
21:36:56 <rbergeron> #info 2 weeks after alpha is scheduled is proably workable.
21:37:02 <rbergeron> clalance: no sir. thanks for your time :)
21:37:08 <clalance> rbergeron: Thanks, talk to you next week.
21:37:11 * rbergeron salutes
21:37:13 <clalance> (and see you the weekend after)
21:37:17 * rbergeron grins
21:37:18 <rbergeron> indeed.
21:37:23 <rbergeron> Okay.
21:37:35 <rbergeron> #info Everyone, please help out with some ideas about cloud test day if you can onlist!
21:37:45 * rbergeron looks around for any other cloud testing day thoughts
21:38:00 <sdake> need to recruit some testers :)
21:38:42 <rbergeron> OH LOOK
21:38:46 * rbergeron throws sdake under the bus
21:38:50 <rbergeron> I think you just volunteered :)
21:39:09 * gholms runs
21:39:11 <rbergeron> Anyway. :)
21:39:18 <sdake> too much on plate at m:)
21:39:38 <rbergeron> yeah, i know it.
21:39:43 <sdake> lol
21:39:55 <rbergeron> #topic FUDCon
21:40:15 <rbergeron> Hey gholms: planning on doing any eucalyptus-type stuff at fudcon? :)
21:40:42 <gholms> rbergeron: I would sure like to, but I will need obino there as well for moral support.  :)
21:41:06 <rbergeron> oh look.
21:41:18 <rbergeron> gholms: is he coming to fudcon? :)
21:41:21 <gholms> obino: I was just talking about you.  :)
21:41:36 <obino> should I wait to come in? :)
21:41:49 <rbergeron> NEVAR
21:41:55 <obino> :)
21:41:55 <rbergeron> obino: are you coming to fudcon?
21:42:00 <gholms> rbergeron and I want you to go to FUDcon and help talk about Eucalyptus.
21:42:02 <obino> rbergeron: I think so
21:42:12 <rbergeron> obino: awesome.
21:42:25 <obino> rbergeron: should we plan for some talk about eucalyptus? Does it make sense? is it useful?
21:42:48 <obino> what can we do to make FUDcon greater/better? :)
21:42:53 <rbergeron> I think even if it's a "Eucalyptus is awesome, here's what it does and it should be in Fedora and we know you want to help"
21:43:07 <rbergeron> or "here's what we plan on for the future and we'll be in fedora"
21:43:08 <rbergeron> or
21:43:17 <rbergeron> ....if anyone else has something they'd like to hear about....
21:43:44 <rbergeron> gholms: i saw you guys talking in the inf. meeting about eucalyptus a bit - was any of that something that is fudcon-material?
21:44:25 <gholms> rbergeron: They want to learn about hosting providers that they can put VMs on.  They would prefer someone with an open source platform.
21:44:30 <obino> rbergeron: sounds good: can I hit later on to coordinate about FUDCon? I am a newbie and I may need couching on it
21:44:52 <gholms> obino: Know of any hosting providers who use eucalyptus?
21:45:27 <obino> I think we should ask to rich or matt
21:45:40 <gholms> Okee dokee
21:45:41 <obino> I know of someone from the forum but I cannot tell their name
21:45:42 <rbergeron> obino: surely.
21:45:55 <gholms> Who else here is going to go?
21:46:03 <obino> rbergeron: thx will hit you on IRC then
21:46:24 <rbergeron> obino: sure. I'll be out a short bit after the meeting, but back fairly soon
21:46:31 <rbergeron> gholms: ummmm, I'm going.
21:46:45 <obino> rbergeron: no rush, I'll get you eventually :)
21:46:46 <gholms> rbergeron: kewl  :P
21:46:46 <rbergeron> clalance is going, jdarcy is going, mgoldmann is going
21:46:54 <gholms> jforbes?
21:46:55 <rbergeron> zaitcev is going
21:46:57 <rbergeron> jforbes is going
21:47:02 <gholms> :D
21:47:06 <jforbes> I am going :)
21:47:08 <rbergeron> gholms is going :)
21:47:30 <gholms> Anyone know if smooge or brianlamere will be there?
21:47:37 <rbergeron> smooge will be there.
21:47:45 <rbergeron> I haven't heard from brianlamere lately, but I know it was on his maybe list.
21:47:57 <rbergeron> there's a full list here: http://fedoraproject.org/wiki/FUDCon:Tempe_2011 in the preregistration section.
21:48:29 <rbergeron> rackerhacker is going. :)
21:49:01 <rbergeron> Anyway:
21:49:13 <rbergeron> There are a bunch of cloud-related sessions pitched.
21:49:19 <rbergeron> But feel free to add on on the wiki.
21:49:40 <gholms> #info Lots of people will be at FUDCon.  Everyone should go and attend cloud-related sessions.
21:49:55 <jgreguske> I'll be there too
21:50:11 <rbergeron> And if anyonhe has any ideas about less of a "here's my feature, whee" and more of a "Hey look, there will be lots of cloud stuff and we should talk about how they might all work together someday"
21:50:20 <rbergeron> ...... that would be awesome too. Plz post.
21:50:31 <rbergeron> jgreguske: Sorry. I knew I was going to miss someone on the list :)
21:50:52 <jgreguske> meh I'm usually a lurker anyway
21:51:08 * rbergeron grins
21:51:55 <rbergeron> Okayyyyy.
21:51:58 <rbergeron> #topic Open Floor
21:52:00 <rbergeron> Anyone? :)
21:52:35 <jgreguske> dgilmore: looks like the imgcreate change was reverted, so we're in the clear there for now?
21:52:47 <jgreguske> the one breaking koji image builds
21:53:07 <dgilmore> jgreguske: ok
21:53:14 <jgreguske> dgilmore: I'm asking :)
21:53:56 <dgilmore> jgreguske: http://koji.fedoraproject.org/koji/taskinfo?taskID=2720084
21:54:09 <dgilmore> thats a rawhide image i just made
21:54:15 <dgilmore> its still uploading
21:54:43 <dgilmore> so at least it seems that f15 images will be ok
21:54:43 <jgreguske> if it made it that far it should be ok then
21:54:57 <jgreguske> alrighty
21:55:05 <dgilmore> jgreguske: yeah. livecds will be ok also
21:56:25 <jgreguske> dgilmore: I'm working on a patch set to more tightly integrate images with build objects
21:56:35 <dgilmore> jgreguske: cool
21:56:36 <jgreguske> dgilmore: in koji that means images will have NVRs
21:56:44 <jgreguske> dgilmore: and uniqueness will be enforced
21:56:52 <jgreguske> dgilmore: you can also tag them and such
21:56:57 <gholms> That's kind of neat.
21:57:10 <dgilmore> jgreguske: im working on a patch to make scratch images get linked like scratch builds do
21:57:20 <jgreguske> dgilmore: nice
21:57:24 <jgreguske> gholms: :)
21:58:04 <jgreguske> dgilmore: not sure if this is useful to Fedora but I plan to add support to RPMify images as part of the build process if you want
21:58:28 <jgreguske> dgilmore: "koji spin-livecd --rpm" or something like that
21:58:50 <dgilmore> jgreguske: not sure  how usefult that would be
21:58:51 <jgreguske> that's all that is on my road map these days
21:59:09 <dgilmore> but it might be useful for those who help do the testing on nightly images
21:59:11 <jgreguske> dgilmore: yeah, I mentioned it for the sake of completeness :)
21:59:19 <dgilmore> that way that could be yum updated
21:59:21 <jgreguske> focus right now is the NVR stuff
21:59:23 <jgreguske> yeah
21:59:56 * rbergeron is stepping away for a momento but plz continue :)
22:00:04 * jgreguske is done babbling
22:00:12 <jgreguske> wait no I'm not
22:00:36 <jgreguske> dgilmore: another thing is on the effort to remove pykickstart from koji internals
22:00:43 <jgreguske> and use something laid down by pykickstart
22:01:08 <jgreguske> that's on the list too
22:01:10 <dgilmore> jgreguske: yep we need to do the flattening etc in the chroot
22:01:29 * jgreguske is really done now
22:01:45 <rbergeron> :)
22:02:10 <rbergeron> dgilmore: anything else you wanted to add?
22:02:27 <rbergeron> any other business from anyone?
22:02:45 <rbergeron> okaybthen.
22:02:59 * rbergeron counts backwards from 87 at her own pace
22:03:10 <rbergeron> 56..... 23::::
22:03:17 <gholms> lulwut?
22:03:26 <rbergeron> see y'all next week.
22:03:28 * gholms really hates Java packaging
22:03:39 <jgreguske> gholms: I'm confused too
22:03:40 <rbergeron> #endmeeting